Subject: RE: [nemo] review of draft-ietf-nemo-home-network-models-04.txt

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Wed, 28 Sep 2005 10:29:04 +0200

I will be tracking that specific discussion as issue 7:

http://www.mobilenetworks.org/~pthubert/draft-ietf-nemo-home-network-mod
els-issue7.txt

At the moment it is open.

Pascal
>-----Original Message-----
>From: Vijay Devarapalli [mailto:[email-masked]]
>Sent: Tuesday, September 27, 2005 8:21 PM
>To: Pascal Thubert (pthubert)
>Cc: Jari Arkko; IETF NEMO WG
>Subject: Re: [nemo] review of
draft-ietf-nemo-home-network-models-04.txt
>
>[email-masked] wrote:
>> Hi Jari:
>>
>> Thanks a bunch for all this. Please find some proposal changes
inline.
>> Actually, all interested in the draft are welcome to enter this
>> discussion, as it might be the last chance before publication...
>>
>>
>>>>What troubled me perhaps most was that the
>>>>document suggests a mechanism to emulate returning
>>>>home when a virtual home link implementation is
>>>>being used at the home agent. I'm not convinced that this
>>>>is necessary, and if it is, this is probably something that should
>>>>be done for Mobile IPv6 and not just nemo. Getting rid of this
>>>>part of the document would also remove one normative behaviour
>>>>requirement (which currently does not feel appropriate in
>>>>an informational document such as this one).
>>>
>>>there is a problem when there is a virtual home link and a
>>>mobile router returns home. where does it connect to? does
>>>it de-register? does it start sending routing protocol
>>>updates in case it is capable of sending routing updates?
>>>the last question especially is very important and is
>>>specific only to NEMO.
>>>
>>>the text we currently have is to address the above questions.
>>>even for MIPv6, we need to address returning home in case
>>>the home link is a virtual link, but the problem is not the
>>>same. there are no routing updates from the mobile node that
>>>could screw up route aggregation on the home network. also
>>>for some reason the thinking was that in MIPv6 if the home
>>>link is virtual the MN never goes home. the same may not be
>>>true for mobile networks.
>>
>> [<PT>]
>> [<PT>] I understand that Jari suggests removing that piece of text;
>> or maybe changing it to fit an informational document.
>>
>> Current text:
>>
>>    In order for a Mobile Router to emulate returning Home, it can
>>    connect to one or more access link(s) configured for that purpose
on
>>    the Home Agent.  The Mobile Router, after connecting to the access
>>    link, SHOULD not send any routing protocol updates on the egress
>>    interface because the routing information from the Mobile Router
>>    might adversely affect IPv6 route aggregation on the Home Network.
>>    However, the Mobile Router must register its binding as if it was
>>    accessing a foreign link.
>>
>> Proposed fix:
>>
>>    RFC 3775 and 3963 do not provide the specific support for a
>>    Mobile Node to emulate returning Home on a Virtual Home Network.
>>    In particular, in the case of NEMO, the routing information from
>>    the Mobile Router being injected on the IGP might adversely affect
>>    IPv6 route aggregation on the Home Network.
>
>but why? informational documents can describe some behavior
>for the mobile router. I dont understand the part about
>not fitting an informational document.
>
>Vijay

---

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Wed, 28 Sep 2005 10:11:14 -0500

Hi Vijay,
 
> > there is a problem when there is a virtual home link and a mobile 
> > router returns home. where does it connect to? does it de-register? 
> > does it start sending routing protocol updates in case it 
> is capable 
> > of sending routing updates? the last question especially is very 
> > important and is specific only to NEMO.
> 
> I agree that the routing protocol update issue is
> important. But its only important if you actually
> do return home. NEMO works fine without ever
> returning home, I suppose.
> 

So, asking again :) - why is it felt that a NEMO mobile router needs to be able to return "home" even though the home link is virtual? I'm confused why this is any different from the case of a mobile node. 

Vidya

---

From: "Pascal Thubert \(pthubert\)" <[email-masked]>
Date: Wed, 28 Sep 2005 17:38:18 +0200

>From: [email-masked] [mailto:[email-masked]] On Behalf Of
Narayanan Vidya-CVN065
>Sent: Wednesday, September 28, 2005 5:11 PM
>To: 'Jari Arkko'; Vijay Devarapalli
>Cc: IETF NEMO WG
>Subject: RE: [nemo] review of
>So, asking again :) - why is it felt that a NEMO mobile router needs to
be able to return "home" even
>though the home link is virtual? I'm confused why this is any different
from the case of a mobile
>node.

[<PT>] The idea was that there is an environment (no more a link but
more like a home area) where the MR should inject its routes, and an
environment where it shouldn't. In the environment where it should
inject its routes, it should also drop its bindings for its prefixes.
And maybe drop its binding at all if maintaining reachability to the
Home Address is not critical (the MR can always be reached at one of its
addresses on an MNP).

I guess this all revolves around getting rid of the Home-Link-centric /
ND based behavior inherited from MIP6, which is one key benefit of HAHA.
I think I follow Jari on this: the idea needs to mature more, and that
would be outside of this document. My favorite place would be local
HAHA.

Pascal