Subject: [nemo] RE: Deployment Requirements

From: LIN hai <[email-masked]>
Date: Thu, 01 Jun 2006 17:48:53 +0200

>Message: 1
>Date: Tue, 30 May 2006 09:27:39 +0200
>From: "Roberto Baldessari" <[email-masked]>
>Subject: RE: [nemo] Deployment Requirements
>To: "Pascal Thubert (pthubert)" <[email-masked]>,	"Chan-Wah Ng"
>	<[email-masked]>
>Cc: [email-masked], Thierry Ernst <[email-masked]>,	Ryuji
>	Wakikawa <[email-masked]>
>Message-ID: <[email-masked]>
>Content-Type: text/plain;	charset="us-ascii"
>
>Hi all,
>
>I try to summarize answers in one mail.
>Please see comments inline.
> 
>
>  
>
>>1) we started a similar discussion on the thread called: 
>>"Distributing the Mobile Prefix in the visited network" last November.
>>
>>2) I pointed out to Roberto that there is a MANEMO ML. Since 
>>that thread, no big news on MANEMO; we are still working on 
>>the Problem statement, and version 03 of Tree Discovery was published:
>>http://www.ietf.org/internet-drafts/draft-thubert-tree-discove
>>ry-03.txt
>>    
>>
>
>Thanks Pascal.
>I think that at that time I didn't understand that MANEMO targets a
>slightly different scenario:
>
>- In our scenario, we don't focus on nested NEMO (MANET inside a mobile
>network) but on MANETs formed by mobile networks. As far as I
>understand, MANEMO and TD focus on nested NEMO. Do you see applications
>of the TD strategy in the scenario we consider?
>
>- In our opinion, the adhoc routing should be indipendent from the NEMO
>protocol. We assume that a routing protocol takes care of delivering
>packets from node A to node B in the adhoc domain, so that node A and
>node B are 'logically' on the same link, even if they communicate
>through multihop. This can be achieved with various strategies. It is,
>maybe, an implementation related concept. Nevertheless, we think it
>allows to keep NEMO (or other mobility management approaches)
>indipendent from the specific routing protocol of the MANET
>
>  
>
>>>Specifically why NEMO-BS (i.e. RFC3963) does not meet the 
>>>      
>>>
>>requirements?
>>    
>>
>
>NEMO BS, being essentially derived from Mobile IP, is an
>infrastructure-based mobility protocol. In intervehicle communications,
>the infrastructure access via 802.11 will be rather limited (i.e. urban
>areas). It is still not clear whether vehicles will be equipped with
>additional interfaces (Wifi, 3+ G etc.). At the moment, and also because
>car companies have concerns about costs, we focus on 802.11, which is
>the basis of the system for road safety.
>
>Considering that, what Intervehicle Communication would like to have is:
>- global mobility when the infrastructure is available (and NEMO BS
>offers already that)
>- "RO with infrastructure"
>- exchanging packets directly from a vehicle network to another one when
>the Infrastructure is not available, or, in other words, "RO without
>infrastructure". But still assuming, as I said before, that the two MRs
>are "logically" on the same link.
>  
>
Hi ,

I have a question related to the vehicle deployment requirements.
In addition to the mentioned requirements, I would like to know if the 
maintained QoS during handover (from an Access Rout to another) and the 
resources reservation (along the route between CN and MN) to provide QoS 
may be among the expected requirements of the vehicle deployment scenarios?
As I work on these topics, I would like to have your feedback.

Hai Lin
Ecole Nationale Supérieure des Tétécommunication (ENST)/
/INFRES Department/
/46 rue Barrault, 75634 Paris Cedex, France/
/
Tel : +33(0)1.45.81.78.97

Fax : +33(0)1.45.81.31.19

//

>  
>
>>>Based on your scenario, I would expect that cars to talk to cars in 
>>>ad-moc mode, but with in each car a NEMO is formed, being 
>>>      
>>>
>>using the CAN 
>>    
>>
>>>protocol, Ethernet or Bluetooth.
>>>      
>>>
>
>We are not considering how the packets are routed inside the mobile
>network.
>We don't think that adhoc mode inside the car will be used. This
>simplifies a bit the scenario.
>
>  
>
>>>I think NEMO will be involved when the components within a 
>>>      
>>>
>>car network 
>>    
>>
>>>need to talk to (A) another component in the another car, or 
>>>      
>>>
>>(B) some 
>>    
>>
>>>other nodes in the global internet (possibly using other 
>>>      
>>>
>>cars as relay 
>>    
>>
>>>to the base station).
>>>
>>>>From the route optimization standpoint, I guess for (A), 
>>>      
>>>
>>you need some
>>    
>>
>>>form intra-nested NEMO optimization.  It would be, I imagine, 
>>>unacceptable to go through the nested tunnels if the communications 
>>>involves accident prevention signalling, where any extra 
>>>      
>>>
>>delay would be 
>>    
>>
>>>fatal.
>>>
>>>For (B), I suspect you need a form of nested tunnel optimization, or 
>>>maybe a way to flatten the NEMO.  Would a global HA-HA 
>>>      
>>>
>>solution be of 
>>    
>>
>>>any help here?
>>>      
>>>
>
>For (B), as we assume that there is already a routing protocol that
>takes care of routing the packets from the vehicle to the infrastructure
>point of attachment, we have not considered this kind of solution.
>Anyway, global HA-HA is interesting and introduces a Mobile IP Proxy in
>the Infrastructure. 
>We have been working on a slightly different concept with the same name:
>essentially running a MIP Proxy in the MR. But there are Ipsec security
>issues in this approach that discourage us.
>
>Roberto 
>  
>

---

From: Thierry Ernst <[email-masked]>
Date: Thu, 1 Jun 2006 18:08:11 +0200

Dear Lin,

If some people think these are important deployment requirements, I
don't see any reason why it should be dismissed. 

Could you refine this requirement in more technical terms ? Do you mean
fast horizontal handovers (this could merely mean to check FMIPv6 is
appropriate for mobile routers operating NEMO BS) or vertical handovers ? 

For the resource reservation between CN and MNN, do you consider an
optimized path, or a path through the HA ? 

Thierry.

-- 
Thierry ERNST, PhD
INRIA Rocquencourt Project-Team IMARA
+33 1 39 63 59 30

---

From: "Davis, Terry L" <[email-masked]>
Date: Thu, 1 Jun 2006 17:25:32 -0700

Lin

When we get the first draft of the aviation industry requirements in; you will see some of this.  I am hoping to have it by Montreal.

Take care
Terry Davis
Boeing Commercial Airplanes

> -----Original Message-----
> From: Thierry Ernst [mailto:[email-masked]]
> Sent: Thursday, June 01, 2006 9:08 AM
> To: [email-masked]
> Subject: Re: [nemo] RE: Deployment Requirements
> 
> 
> Dear Lin,
> 
> > Ecole Nationale Sup駻ieure des T騁馗ommunication (ENST)/
> > /INFRES Department/