Subject: [nemo] MR received the HAAD Reply (R flag=0)

From: "K.Kawaguchi" <[email-masked]>
Date: Thu, 15 Jun 2006 16:40:23 +0900

Hi,

I have a question about RFC3963 section 5.3, 7.2.

The HAAD Reply indicates that the MR Support (R) Flag is 0 
and the list of HA Addresses include many HAs.
How to process the Mobile Prefix Registration when MR received
the HAAD Reply.

I assumed the following processing.
Is there the correct one? Or, another one?

  1. MR tries the Mobile Prefix Registration to HAs in order
     of list of HA Addresses.
  2. Almost same as above 1. But MR skips the HA that sent the
     HAAD Reply.
  3. MR send the HAAD Requiest again until finding NEMO-HA.
  4. MR doesn't try the Mobile Prefix Registration.
  5. In fact, there are no matter since this situation is avoided
     by the following some solution.
     eg,
     - MIP Home Link and NEMO Home Link should be separated.
     - If MIP Home Link and NEMO Home Link are the same link.
       - It should be configure to reply by NEMO-HA rather than by MIP-HA.
         (The HAAD Reply function of MIP-HA isn't enabled.)
       - Even if HA don't support MR, HA should support the RFC3963.
         (This MIP-HA supports the RFC3963.  MIP-HA makes the (R) flag 1
          and the list of HA Addresses except for MIP-HA.)

Best regards
---
Kiyoaki KAWAGUCHI [email-masked]

Best regards
---
Kiyoaki KAWAGUCHI [email-masked]

---

From: Andy Huang <[email-masked]>
Date: Thu, 15 Jun 2006 21:11:35 +0800

According to RFC3963, it mean that there is no HA which can support MR on 
the home link.
And I think it's useless for MR to get MIP-HA list from the DHAAD reply when 
R Flag in the packet is 0.

---

From: "K.Kawaguchi" <[email-masked]>
Date: Fri, 16 Jun 2006 09:36:40 +0900

Hi,

Do you mean to exclude the possibility that RFC3775-HA includes NEMO-HA
in the HA List with (R) flag=0?  I also think that RFC3775-HA should be
excluded from NEMO Home Link.  In　a word, all HA supports RFC3963.
However, I was anxious about this possibility.  Need not MR basically deal
with this possibility?

Best regards
---

In message <[email-masked]>
"Re: [nemo] MR received the HAAD Reply (R flag=0)"

Best regards
---

---

From: Andy Huang <[email-masked]>
Date: Fri, 16 Jun 2006 11:06:19 +0800

I wonder whether any HA can work as RFC3775-HA and RFC3963-HA at the same 
time.
It seems that there are no constraints on this point.