Subject: FW: [NGO] Netconf-Proxy

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 20 Aug 2007 16:10:03 +0200

This question is probably more within the scope of netconf rather than
ngo. 

Dan

-----Original Message-----
From: Philipp Batroff [mailto:[email-masked]] 
Sent: Monday, August 20, 2007 4:16 PM
To: [email-masked]
Subject: [NGO] Netconf-Proxy

hello,

i have the Problem, that iam developing a box (similar to a proxy) with
a Netconf-agent, which redirects request to several different agents.
The problem is, that this box has just one IP-address.
How can I divide between the different agents? Is there a wrapper, where
i can specify the "target" behind that proxy, or is there anything else
possible?
I want to stay conform with the Netconf standard.

Thank you and greets Phil

_______________________________________________
NGO mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ngo

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 20 Aug 2007 07:34:40 -0700

Romascanu, Dan (Dan) wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> hello,
> 

You can put whatever XML attributes you want in the <rpc> element.
NETCONF has no concept of proxy. Operators told us they hate
SNMP Proxy and want nothing like it in NETCONF.

Andy

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.7 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
> 
> iD8DBQFGyZQO9Os+BmHRimYRAoHrAJ4sKkIPPXRy6OlX12FsIwQz/kaVnQCcDlLV
> P1//yS1JJKXNfKh6mFtiyis=
> =wcc5
> -----END PGP SIGNATURE-----
> 
> 
>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 20 Aug 2007 16:49:30 -0700

David B Harrington wrote:
> Hi,
> 
> Is that operator opinion documented somewhere? I checked RFC3535, the
> IAB Workshop on Network Management, but found no mention of proxy. Was
> that input captured in some netconf meeting minutes?

no - the discussion at the IAB NM workshop did not make it into RFC 3535.
Nobody has ever seriously suggested adding a proxy mechanism to NETCONF,
similar to SNMP Proxy.

> dbh

Andy

>> From: [email-masked] 
>> [mailto:[email-masked]] On Behalf Of Andy Bierman
>> Sent: Monday, August 20, 2007 10:35 AM
>> To: Romascanu, Dan (Dan)
>> Cc: Netconf (E-mail); [email-masked]
>> Subject: Re: FW: [NGO] Netconf-Proxy
>>

---

From: "David B Harrington" <[email-masked]>
Date: Mon, 20 Aug 2007 19:24:00 -0400

Hi,

dbh

---

From: "David B Harrington" <[email-masked]>
Date: Mon, 20 Aug 2007 23:34:51 -0400

Hi,

I didn't say anybody had tried to add proxy to Netconf, or that it was
desirable.

You made a statement that operators said they HATED SNMP proxy. I
wanted to see documentation of that statement from operators. Or is
that just your opinion? I'd like ti to be clear whether it is
aomething the operators said or something you said.

dbh

> From: Andy Bierman [mailto:[email-masked]] 
> Sent: Monday, August 20, 2007 7:50 PM
> To: David B Harrington
> Cc: 'Romascanu, Dan (Dan)'; 'Netconf (E-mail)'; [email-masked]

---

From: Andy Bierman <[email-masked]>
Date: Mon, 20 Aug 2007 22:38:18 -0700

> aomething the operators said or something you said.

I heard 2 operators at the IAB NM workshop say that, including Randy Bush.
The concerns were over increased system complexity without sufficient gain.
I'm not sure why we need to discuss SNMP proxy on this list,
since nobody is actually suggesting that a proxy mechanism
needs to be added to the NETCONF protocol.

Andy

---

From: "David B Harrington" <[email-masked]>
Date: Tue, 21 Aug 2007 06:16:59 -0400

You are the person that first mentioned snmp proxy.
I just wanted to know if your statement had documentation behind it.

dbh 

> Sent: Tuesday, August 21, 2007 1:38 AM
> To: David B Harrington

---

From: "David B Harrington" <[email-masked]>
Date: Tue, 21 Aug 2007 08:52:46 -0400

Hi Phil,

Unfortunately, the word "proxy" can be sensitive. ;-)
The Netconf protocol does not have a proxy mechanism. 

I am interested in your use case. Can you describe your use case in
more detail? 
Is your use case a request from operators/customers?

Is this related to NAT, where you have only one public IP address but
multiple devices you want to configure in the private address space
behind the NAT device?

When I worked at Enterasys, customers requested the ability to perform
CLI-based configuration in a distributed hierarchical manner, going
through intermediate routers and switches to reach devices. To a
degree this can be done using a policy-based distributed management
approach, where you "configure" an intermediate node to hold the
configuration information for other nodes. There have been a number of
IETF efforts focused on standardizing this type of policy-based
management, none of which has seemed to achieve success in the field.

Is you use case related to policy-based management?

Hope this helps,
David Harrington
[email-masked]
[email-masked]