Subject: [Netconf] #16: notification replay stopTime synch problem

From: "Netconf" <[email-masked]>
Date: Wed, 01 Aug 2007 18:12:52 -0000

#16: notification replay stopTime synch problem
---------------------------------------------+------------------------------
 Reporter:  [email-masked]             |       Owner:     
     Type:  defect                           |      Status:  new
 Priority:  major                            |   Milestone:     
Component:  draft-ietf-netconf-notification  |     Version:     
 Keywords:  notification-08                  |  
---------------------------------------------+------------------------------
 Hi,
 This was raised offline by Randy Presuhn.
 The manager must provide a stopTime if
 it wants to get the logged notifications
 and then revert the session to normal mode.

 However, it is difficult for the manager and
 the agent to be in perfect time synch, and
 the value for 'now' is likely to be different
 on both systems.

 A special value for the stopTime parameter is needed,
 (the string 'now') to indicate to the agent that
 the agent should derive the actual stopTime value
 from the its current system time.

 This impacts the XSD.
 Instead of the 'xs:dateTime' data type, the
 stopTime element will need a new data type
 which is a union of the fixed string 'now' and a dateTime string.

-- 
Ticket URL: <http://www3.tools.ietf.org/wg/netconf/trac/ticket/16>
Netconf <http://tools.ietf.org/wg/netconf/trac/>
Issue tracker for the NETCONF Working Group������r��zǧu���Ơz�'z�(��ު笶�l��_��0��m��(�ۧ���r��z)ڲ)���b�欶�z���^���w&�r�zm���Ȟ��+��b��?��\�w�

---

From: "Sharon Chisholm" <[email-masked]>
Date: Tue, 14 Aug 2007 07:26:26 -0400

Hi

I don't think this is necessary. Yes, the times are not synched, but I don't think the difference warrants creating this new type. If the operator/manager is worried, they can always just add a couple seconds to their time to create the stop time. Managers know how to de-duplicate.

Sharon 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Netconf
Sent: Wednesday, August 01, 2007 2:13 PM
Cc: [email-masked]
Subject: [Netconf] #16: notification replay stopTime synch problem

#16: notification replay stopTime synch problem
---------------------------------------------+--------------------------
---------------------------------------------+----
 Reporter:  [email-masked]             |       Owner:     
     Type:  defect                           |      Status:  new
 Priority:  major                            |   Milestone:     
Component:  draft-ietf-netconf-notification  |     Version:     
 Keywords:  notification-08                  |  
---------------------------------------------+--------------------------
---------------------------------------------+----
 Hi,
 This was raised offline by Randy Presuhn.
 The manager must provide a stopTime if
 it wants to get the logged notifications  and then revert the session to normal mode.

 However, it is difficult for the manager and  the agent to be in perfect time synch, and  the value for 'now' is likely to be different  on both systems.

 A special value for the stopTime parameter is needed,  (the string 'now') to indicate to the agent that  the agent should derive the actual stopTime value  from the its current system time.

 This impacts the XSD.
 Instead of the 'xs:dateTime' data type, the  stopTime element will need a new data type  which is a union of the fixed string 'now' and a dateTime string.

--
Ticket URL: <http://www3.tools.ietf.org/wg/netconf/trac/ticket/16>
Netconf <http://tools.ietf.org/wg/netconf/trac/>
Issue tracker for the NETCONF Working GrouprzǧuƠz'z(ު笶l_0m(ۧrz)ڲ)b欶z^w&rzmȞ+b?\w
������r��zǧu���Ơz�'z�(��ު笶�l��_��0��m��(�ۧ���r��z)ڲ)���b�欶�z���^���w&�r�zm���Ȟ��+��b��?��\�w�