Subject: Re: Agenda for NETCONF WG session at IETF #71

From: Balazs Lengyel <[email-masked]>
Date: Mon, 03 Mar 2008 14:09:52 +0100

My Netconf wish-list)
1) Decision on the basis of the DML: YANG, DSDL, XSD, ELUA, ...
2) All the DML details

Please!!! Please !!! Please !!!

And after that:

3) Actions/Custom RPCs
4) Freeware Netconf implementations
5) Some basic data models (Discovery, Something like the MIB-2 System group, Monitoring)
6) Partial Locking

Balazs

Phil Shafer wrote:
> "Ersue, Mehmet (NSN - DE/Muenich)" writes:
>> Please let us also know whether you have a concrete topic for
>> the open mic session.
> 
> I posted a list of question for discussion at the last ietf,
> but nothing really came of it.  Is it worth repeating?
> 
>> Another thought is to come up with a list of the five biggest
>> impediments to NETCONF's complete domination of the configuration
>> space.  Do we know the answers to questions like:
>>
>> - Why aren't/won't device folks shipping netconf implementations?
>> - Why aren't/won't application writers moving to NETCONF?
>> - Why isn't NETCONF becoming the answer to configuration problems?
>> - What's stopping it?
>> - Where's the chicken?
>> - What's the egg?
>> - What's the key to moving forward from here?
>> - Where should we be concentrating our (precious and few) resources?
> 
> The first issue (YANG) is clearly the (YANG) lack of a workable
> DML, and (YANG) I think we are making (YANG) great progress
> in that (YANG) area.
> 
> But I don't know what the other four top-five issues are.  What
> stands between us and Complete World Domination (CWD)?
> 
> Thanks,
>  Phil (the (YANG) subtle one ;^)
> 
> --
> to unsubscribe send a message to [email-masked] with
> the word 'unsubscribe' in a single line as the message text body.
> archive: <http://ops.ietf.org/lists/netconf/>

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 3 Mar 2008 14:27:37 +0100

I need to draw everybody's attention (including mine :-)) that the focus
of the NETCONF WG activity should be on the items the NETCONF WG is
currently chartered for. Those should have meeting time priority. Other
subjects may be discussed if time is left. 

Dan

> -----Original Message-----
> From: Balazs Lengyel [mailto:[email-masked]] 
> Sent: Monday, March 03, 2008 3:10 PM
> To: Phil Shafer
> Cc: Ersue, Mehmet (NSN - DE/Muenich); [email-masked]; 
> ext Bert Wijnen - IETF; Romascanu, Dan (Dan)
> Subject: Re: Agenda for NETCONF WG session at IETF #71
> 
> My Netconf wish-list)
> >> Please let us also know whether you have a concrete topic for the 
> >> open mic session.
> > 
> > I posted a list of question for discussion at the last ietf, but 
> > nothing really came of it.  Is it worth repeating?
> > 
> > The first issue (YANG) is clearly the (YANG) lack of a 
> workable DML, 
> > and (YANG) I think we are making (YANG) great progress in 
> that (YANG) 
> > area.
> > 
> > But I don't know what the other four top-five issues are.  
> What stands 
> > between us and Complete World Domination (CWD)?
> > 
> > Thanks,
> > to unsubscribe send a message to 
> [email-masked] with the 
> > word 'unsubscribe' in a single line as the message text body.

---

From: "Ersue, Mehmet (NSN - DE/Muenich)" <[email-masked]>
Date: Mon, 3 Mar 2008 14:31:11 +0100

Hi Balazs,

let us focus in the open mic slot (if we have time for it) on topics 
where NETCONF WG can do something.

We think it is interesting to discuss NETCONF-related requirements 
on DML as a preparation for the CANMOD BoF. 
But overall RCDML requirements and DML solution discussion will be 
excluded.

I guess, any decisions on the future DML work will be taken in 
CANMOD BoF.

Cheers, 
Mehmet 

> From: ext Balazs Lengyel [mailto:[email-masked]] 
> Sent: Monday, March 03, 2008 2:10 PM
> To: Phil Shafer
> ext Bert Wijnen - IETF; ext Romascanu, Dan (Dan)