Subject: RE: Agenda for NETCONF WG session at IETF #71

From: "David B Harrington" <[email-masked]>
Date: Sat, 1 Mar 2008 12:46:36 -0500

> My top 3 issues (also nowhere on the radar):
> 
>   1) A NETCONF DML for non-modeling-experts, so operators,
engineers,
>      and IETFers can use NETCONF with ease
>   2) An access control model
>   3) A robust, extensible, multi-protocol NM architecture, that
pulls
>      together NETCONF, CLI, SNMP, SYSLOG, existing MIBs, new 
> next-gen MIBs,
>      into a secure and standard API framework.
> 

+1

Instead of the train, I'd be really happy if 1 and 2 were compatible
with 3. ;-)

David Harrington
[email-masked]
[email-masked]
[email-masked]

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 2 Mar 2008 12:13:56 +0100

> -----Original Message-----
> From: David B Harrington [mailto:[email-masked]] 
> Sent: Saturday, March 01, 2008 7:47 PM
> To: 'Andy Bierman'; 'Phil Shafer'
> Cc: 'Mehmet Ersue'; [email-masked]; 'Bert Wijnen'; 
> Romascanu, Dan (Dan)
> Subject: RE: Agenda for NETCONF WG session at IETF #71
> 
> 
>  
> 
>  
> >      together NETCONF, CLI, SNMP, SYSLOG, existing MIBs, 
> new next-gen 
> > MIBs,
> Instead of the train, I'd be really happy if 1 and 2 were 
> compatible with 3. ;-)
> 
> David Harrington
> [email-masked]
> [email-masked]
> [email-masked]
> 

Speaking as a contributor: 

+1

Speaking as an AD: 

1) we are working on it, and if we can reach consensus in Philadelphia
we should have it chartered sometimes soon

2) It looks to me that the community did not reach consensus that this
is an urgent item when the discussions for NETCONF rechartering happened

3) It was one of my big items when I became an AD two years ago. It
still is now. The scope is beyond NETCONF, so this should be discussed
in the OPS Area. 

Dan

---

From: "Ersue, Mehmet (NSN - DE/Muenich)" <[email-masked]>
Date: Sun, 2 Mar 2008 12:49:06 +0100

Phil Shafer wrote:
> - Why aren't/won't application writers moving to NETCONF?
> - Why isn't NETCONF becoming the answer to configuration problems?
> - What's stopping it?

concerning the long wish list I would rather focus on what NETCONF 
WG can do. 

What NETCONF WG could do is e.g. to prepare a NETCONF BCP 
document and provide interoperability reports. IMO this would 
increase the level of awareness in the industry and enable also 
NETCONF-ignorants to try it. We need to show it is easy to 
deploy and cost efficient.

engineers,
pulls
> >      together NETCONF, CLI, SNMP, SYSLOG, existing MIBs, new
next-gen 
> >      MIBs, into a secure and standard API framework.

1) One big enabler for sure we have to develope is the DML.
2) This seemed not to be urgent in the WG discussion. We should 
discuss how fast the group wants to proceed with it. However, we 
shouldn't block people who are already busy with other work.

<contributor>
3) "A robust, extensible, multi-protocol NM architecture" is just what 
want too, but I don't know how to come there. IETF usually does not 
develop architectures OTOH we need to define the framework where 
the (multi-)protocols have to interoperate.
A vision one can have is a DML which supports the "multi-protocol NM 
architecture". The next step would be to model the configuration data 
for the different management layers in this architecture by designing 
the data model with a top-down approach and by re-using already 
available parts.
</contributor>

Cheers, 
Mehmet 

> From: ext Phil Shafer [mailto:[email-masked]] 
> Sent: Friday, February 29, 2008 9:12 PM
> To: Andy Bierman
> Cc: Ersue, Mehmet (NSN - DE/Muenich); [email-masked]; 
> ext Bert Wijnen - IETF; ext Romascanu, Dan (Dan)
> Subject: Re: Agenda for NETCONF WG session at IETF #71 
> 
> Andy Bierman writes:
> >I don't think this is really fair to the new co-Chairs.
> 
> Don't mean to be unfair to anyone, I'm just looking
> to see if we can get an idea of what our obstacles
> are and if we know what we should be doing about them.
> 
> My top-five goes:
> a) DML
> b) open source toolkits in common development languages
> c) evangelism/training/documentation/tutorials
> d) blank
> e) blanker
> 
> I'd love to know what (d) and (e) should be, but, well
> I don't see it.  Do folks feel that the charter items
> are really seen as obstacles to using netconf?
> 
> Thanks,
>  Phil
>