Subject: Re: Agenda for NETCONF WG session at IETF #71

From: Martin Bjorklund <[email-masked]>
Date: Wed, 05 Mar 2008 22:07:07 +0100 (CET)

Hi,

"Ersue, Mehmet (NSN - DE/Muenich)" <[email-masked]> wrote:

[...]

> Please let us know before hand about your implementation.

[...]

>     1. NETCONF over TLS (20 minutes)
> 
>        draft-ietf-netconf-tls-01.txt

Since I still don't think that what's missing from NETCONF is yet
another optional transport, I have not implemented this...

>     2. Fine-grained locking (20 minutes)
> 
>        draft-ietf-netconf-partial-lock-00.txt

I have implemented this draft, and it is part of our released
software.

>     3. Netconf monitoring (20 minutes)
> 
>        draft-ietf-netconf-monitoring-00.txt

I have a (vendor-specific) implementation of most parts of this
draft.  This model is fairly trivial to implement, and I will
implement this as soon as the draft stabilizes a bit.

/martin

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: "Ersue, Mehmet (NSN - DE/Muenich)" <[email-masked]>
Date: Thu, 6 Mar 2008 21:02:05 +0100

Hi All,
 
I uploaded the agenda and WG status slides:
https://datatracker.ietf.org/meeting/71/materials.html#wg-netconf
 
Presenters, please send me your slides prior to the 
meeting. Thank you.
 
BTW: We still need minute takers ;-)
 
CU in Philly.

Cheers,
Mehmet

________________________________

	From: [email-masked]
[mailto:[email-masked]] On Behalf Of ext Ersue, Mehmet (NSN
- DE/Muenich)
	Sent: Thursday, February 28, 2008 10:41 AM
	To: [email-masked]
	Cc: ext Bert Wijnen - IETF; ext Romascanu, Dan (Dan)
	Subject: Agenda for NETCONF WG session at IETF #71

	Dear NETCONF WG, 

	below is an update for the agenda of the NETCONF WG session 
	at the IETF #71. 

	Our main focus in the session will be on open issue discussion. 
	Please let us know before hand about your implementation. 
	Please let us also know whether you have a concrete topic for 
	the open mic session. 

	We still need volunteers as scribe and minute taker. As you 
	know the session will not start before we have them ;-). 

	Bert & Mehmet 

	_____________________________________________ 

	NETCONF WG 
	IETF 71, Philadelphia, PA, USA 

	MONDAY, March 10, 2008 1740-1950 

	  Scribes (needs to be organized before the session), 
	  Agenda bashing (2 minutes) 

	  Use of mailing lists, 
	  WG status review (10 minutes) 

	  Current charter items: 

	  Discussion on ongoing implementations (10 minutes) 

	      Who is implementing what? 
	      Should we plan an interop-event for testing of 
	      RFC 4141-4144 to get them to DS? 

	  AOB 

	  Open mike 

	      One hot topic is e.g. the NETCONF-related requirements on
DML. 
	      Any other hot topics to discuss? 

	Note (this is not part of the agenda): 
	We are not going to discuss solutions in open mic slot. 
	This is just because we have some time and want to give 
	you the opportunity to sort out the NETCONF-related 
	requirements as a preparation for the Canmod BoF. 

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "Ersue, Mehmet (NSN - DE/Muenich)" <[email-masked]>
Date: Thu, 6 Mar 2008 21:02:05 +0100

Hi All,

 
 
CU in Philly.

Cheers,
Mehmet

	Dear NETCONF WG, 

	Bert & Mehmet 

	NETCONF WG 

	  Use of mailing lists, 

	  Current charter items: 

	  AOB 

	  Open mike

---

From: "David B Harrington" <[email-masked]>
Date: Thu, 6 Mar 2008 16:11:29 -0500

Hi,
 
You use abbreviations in the agenda without spelling them out
anywhere.
What is AOB?
I figuredFrom [email-masked]  Thu Mar  6 13:11:54 2008
From: "David B Harrington" <[email-masked]>
To: "'Ersue, Mehmet \(NSN - DE/Muenich\)'" <[email-masked]>,
	<[email-masked]>
Date: Thu, 6 Mar 2008 16:11:29 -0500
Subject: Re: [Netconf] Agenda for NETCONF WG session at IETF #71
Sender: [email-masked]

This is a multi-part message in MIME format.
Hi,
 
You use abbreviations in the agenda without spelling them out
anywhere.
What is AOB?
I figured it out, but AC isn't spelled out anywhere.
 
dbh

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ersue, Mehmet (NSN - DE/Muenich)
Sent: Thursday, March 06, 2008 3:02 PM
To: [email-masked]
Subject: Re: [Netconf] Agenda for NETCONF WG session at IETF #71

Hi All,

 
 
CU in Philly.

Cheers,
Mehmet

  _____  

From: [email-masked] [mailto:[email-masked]]
On Behalf Of ext Ersue, Mehmet (NSN - DE/Muenich)
Sent: Thursday, February 28, 2008 10:41 AM
To: [email-masked]
Cc: ext Bert Wijnen - IETF; ext Romascanu, Dan (Dan)
Subject: Agenda for NETCONF WG session at IETF #71

Dear NETCONF WG, 

Bert & Mehmet 

NETCONF WG 

  Use of mailing lists, 

  Current charter items: 

  AOB 

  Open mike 

      One hot topic is e.g. the NETCONF-related requirements on DML. 
      Any other hot topics to discuss?

---

From: "Ersue, Mehmet (NSN - DE/Muenich)" <[email-masked]>
Date: Thu, 6 Mar 2008 22:47:24 +0100

Sorry about that, AC is meant to be "Access Control".
 
Cheers,
Mehmet

	From: ext David B Harrington [mailto:[email-masked]] 
	Sent: Thursday, March 06, 2008 10:11 PM
	To: Ersue, Mehmet (NSN - DE/Muenich); [email-masked]
	Subject: RE: [Netconf] Agenda for NETCONF WG session at IETF #71

	Hi,

	dbh

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of Ersue, Mehmet (NSN -
DE/Muenich)
		Sent: Thursday, March 06, 2008 3:02 PM
		To: [email-masked]
		Subject: Re: [Netconf] Agenda for NETCONF WG session at
IETF #71

		Hi All,

		 

		CU in Philly.

		Cheers,
		Mehmet

			From: [email-masked]
[mailto:[email-masked]] On Behalf Of ext Ersue, Mehmet (NSN
- DE/Muenich)
			Sent: Thursday, February 28, 2008 10:41 AM
			To: [email-masked]
			Cc: ext Bert Wijnen - IETF; ext Romascanu, Dan
(Dan)
			Subject: Agenda for NETCONF WG session at IETF
#71

			Dear NETCONF WG, 

			below is an update for the agenda of the NETCONF
WG session 
			at the IETF #71. 

			Our main focus in the session will be on open
issue discussion. 
			Please let us know before hand about your
implementation. 
			Please let us also know whether you have a
concrete topic for 
			the open mic session. 

			We still need volunteers as scribe and minute
taker. As you 
			know the session will not start before we have
them ;-). 

			Bert & Mehmet 

			NETCONF WG 

			  Scribes (needs to be organized before the
session), 
			  Agenda bashing (2 minutes) 

			  Use of mailing lists, 

			  Current charter items: 

			  Discussion on ongoing implementations (10
minutes) 

			      Who is implementing what? 
			      Should we plan an interop-event for
testing of 
			      RFC 4141-4144 to get them to DS? 

			  AOB 

			  Open mike 

			      One hot topic is e.g. the NETCONF-related
requirements on DML. 
			      Any other hot topics to discuss? 

			Note (this is not part of the agenda): 
			We are not going to discuss solutions in open
mic slot. 
			This is just because we have some time and want
to give 
			you the opportunity to sort out the
NETCONF-related 
			requirements as a preparation for the Canmod
BoF.

---

From: "Ersue, Mehmet (NSN - DE/Muenich)" <[email-masked]>
Date: Thu, 6 Mar 2008 22:47:24 +0100

Cheers,
Mehmet

	Hi,

	dbh

		Hi All,

		 

		CU in Philly.

		Cheers,
		Mehmet

			Dear NETCONF WG, 

			Bert & Mehmet 

			NETCONF WG 

			  Use of mailing lists, 

			  Current charter items: 

			  AOB 

			  Open mike

---

From: Andy Bierman <[email-masked]>
Date: Thu, 06 Mar 2008 17:58:12 -0800

> Please let us also know whether you have a concrete topic for

I have some running NETCONF code and a topic for the meeting,
not that the 2 are related in any way...

The WG agreed that the NETCONF Notifications work
was not finished, and some standard notification content
would really make the notification delivery features
more relevant to our standardization efforts.

Yet nothing has been done.
What about a config-change event?
When will any standard events for the NETCONF stream be defined?

> know the session will not start before we have them ;-).

Andy

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 7 Mar 2008 11:46:26 +0100

> -----Original Message-----
> From: Andy Bierman [mailto:[email-masked]] 

This is certainly worth an Internet-Draft. I do not know when will
NETCONF re-charter, and this may also be related to the DML discussions,
but having a reference that more than one implementer will start to put
in code will accelerate things. 

Dan

---

From: "David B Harrington" <[email-masked]>
Date: Fri, 7 Mar 2008 14:47:21 -0500

and what is AOB?

  _____  

From: Ersue, Mehmet (NSN - DE/Muenich) [mailto:[email-masked]] 
Sent: Thursday, March 06, 2008 4:47 PM
To: ext David B Harrington; [email-masked]
Subject: RE: [Netconf] Agenda for NETCONF WG session at IETF #71

Cheers,
Mehmet

  _____  

Hi,

dbh

  _____  

Hi All,

 
 
CU in Philly.

Cheers,
Mehmet

  _____  

Dear NETCONF WG, 

Bert & Mehmet 

NETCONF WG 

  Use of mailing lists, 

  Current charter items: 

  AOB 

  Open mike

---

From: "David B Harrington" <[email-masked]>
Date: Fri, 7 Mar 2008 14:47:21 -0500

and what is AOB?

  _____  

 
Cheers,
Mehmet

  _____  

Hi,

dbh

  _____  

Hi All,

 
 
CU in Philly.

Cheers,
Mehmet

  _____  

Dear NETCONF WG, 

Bert & Mehmet 

NETCONF WG 

  Use of mailing lists, 

  Current charter items: 

  AOB 

  Open mike

---

From: "Bert Wijnen - IETF" <[email-masked]>
Date: Fri, 7 Mar 2008 21:20:42 +0100

Agenda for NETCONF WG session at IETF #71Any Other Businesss (of course). I
thought this is a pretty well known
acronym for meeting agendas, no?

Bert Wijnen

  -----Oorspronkelijk bericht-----
  Van: [email-masked] [mailto:[email-masked]]Namens
David B Harrington
  Verzonden: vrijdag 7 maart 2008 20:47
  Aan: 'Ersue, Mehmet (NSN - DE/Muenich)'; [email-masked]
  Onderwerp: Re: [Netconf] Agenda for NETCONF WG session at IETF #71

  and what is AOB?

----------------------------------------------------------------------------

    Cheers,
    Mehmet

--------------------------------------------------------------------------

      Hi,

      dbh

------------------------------------------------------------------------

        Hi All,

        CU in Philly.
        Cheers,
        Mehmet

----------------------------------------------------------------------
          From: [email-masked]
[mailto:[email-masked]] On Behalf Of ext Ersue, Mehmet (NSN -
DE/Muenich)
          Sent: Thursday, February 28, 2008 10:41 AM
          To: [email-masked]
          Cc: ext Bert Wijnen - IETF; ext Romascanu, Dan (Dan)
          Subject: Agenda for NETCONF WG session at IETF #71

          Dear NETCONF WG,

          Bert & Mehmet

          NETCONF WG

            Use of mailing lists,

            Current charter items:

            AOB

            Open mike

---

From: "Bert Wijnen - IETF" <[email-masked]>
Date: Fri, 7 Mar 2008 21:20:42 +0100

Bert Wijnen

  -----Oorspronkelijk bericht-----

  and what is AOB?

    Cheers,
    Mehmet

      Hi,

      dbh

        Hi All,

        CU in Philly.
        Cheers,
        Mehmet

          Dear NETCONF WG,

          Bert & Mehmet

          NETCONF WG

            Use of mailing lists,

            Current charter items:

            AOB

            Open mike

---

From: "Ersue, Mehmet (NSN - DE/Muenich)" <[email-masked]>
Date: Mon, 10 Mar 2008 13:29:54 +0100

Hi Andy,

I appreciate your input. Let's talk on this in the open 
mic slot.

Cheers, 
Mehmet 

> From: ext Andy Bierman [mailto:[email-masked]] 
> Sent: Friday, March 07, 2008 2:58 AM
> To: Ersue, Mehmet (NSN - DE/Muenich)
> Cc: [email-masked]; ext Bert Wijnen - IETF; ext 
> Romascanu, Dan (Dan)
> Subject: Re: Agenda for NETCONF WG sFrom [email-masked]  Mon Mar 10 07:55:21 2008
Content-class: urn:content-classes:message
Date: Mon, 10 Mar 2008 13:29:54 +0100
From: "Ersue, Mehmet (NSN - DE/Muenich)" <[email-masked]>
To: "ext Andy Bierman" <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netconf] Agenda for NETCONF WG session at IETF #71
Sender: [email-masked]

Hi Andy,

I appreciate your input. Let's talk on this in the open 
mic slot.

Cheers, 
Mehmet 

> From: ext Andy Bierman [mailto:[email-masked]] 
> Sent: Friday, March 07, 2008 2:58 AM
> To: Ersue, Mehmet (NSN - DE/Muenich)
> Cc: [email-masked]; ext Bert Wijnen - IETF; ext 
> Romascanu, Dan (Dan)
> Subject: Re: Agenda for NETCONF WG session at IETF #71
> 

ession at IETF #71