Subject: [Netconf] Capability to handle the full configuration in one operation

From: Balazs Lengyel <[email-masked]>
Date: Thu, 05 Jun 2008 10:29:32 +0200

Hello,
Recently I came across 2 cases where it is difficult to handle the complete datastore in one
operation due to memory constraints:

1) Big nodes that contain subscriber data might have multiple gigaBytes in their datastore. It
does not seem feasible to handle the complete datastore in one edit-config.

2) Small nodes that don't have enough memory to store their configuration in XML format in
addition to the internal binary format.

Can these nodes still claim to be NETCONF compliant or is it a MUST that an edit-config
containing the full datastore must be handled irrespective from memory constraints?

Balazs

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 05 Jun 2008 10:44:20 +0200 (CEST)

Hi,

> Recently I came across 2 cases where it is difficult to handle the
> complete datastore in one operation due to memory constraints:

[...]

> Can these nodes still claim to be NETCONF compliant or is it a MUST
> that an edit-config containing the full datastore must be handled
> irrespective from memory constraints?

You can always return the std error code 'resource-denied', which is
describes as:

  Request could not be completed because of insufficient resources.

/martin

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 05 Jun 2008 10:44:20 +0200 (CEST)

Hi,

[...]

/martin