Subject: [Netconf] get-config on

From: Balazs Lengyel <[email-masked]>
Date: Mon, 15 Dec 2008 18:30:18 +0100

Hello,
Is it possible to call get-config against a file, or even a remote file? In the XSD I see

   <xs:complexType name="getConfigSourceType">
     <xs:choice>
       <xs:element ref="config-name"/>
       <xs:element name="url" type="configURIType"/>
     </xs:choice>
   </xs:complexType>

In the text there is no mention about URLs neither in chapter 7.1 <get-config> nor in chapter 
8.8 URL capability.

I think if edit-config is allowed for URLs/local files then get-config should be as well.
Anyway this should be clarified by the 4741bis. Martin, Jurgen please add it to your list.

The same question is valid for lock/unlock (others?) as well.

Balazs
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Andy Bierman <[email-masked]>
Date: Mon, 15 Dec 2008 10:41:01 -0800

Balazs Lengyel wrote:
> In the text there is no mention about URLs neither in chapter 7.1 
> <get-config> nor in chapter 8.8 URL capability.
> 

This issue was discussed at length when 4741 was being written,
and the WG consensus at that time was that the standard needed
to be very loose about URL-based databases, and the <startup>
as well.  Several people strongly objected to extending
the edit operation to URLs at that time.  It was ignored in
the document on purpose.  Only the operations that have
URL extensions in the XSD had WG consensus to be supported.

IMO, we should focus on the 3 standard databases,
but clarifications are always good.  Maybe new
capabilities are needed (instead of piling on :url!)

> Balazs

Andy

________________________From [email-masked]  Mon Dec 15 10:41:14 2008
Date: Mon, 15 Dec 2008 10:41:01 -0800
From: Andy Bierman <[email-masked]>
To: Balazs Lengyel <[email-masked]>
Cc: netconf mailing list <[email-masked]>
Subject: Re: [Netconf] get-config on
Sender: [email-masked]

Balazs Lengyel wrote:
> In the text there is no mention about URLs neither in chapter 7.1 
> <get-config> nor in chapter 8.8 URL capability.
> 

This issue was discussed at length when 4741 was being written,
and the WG consensus at that time was that the standard needed
to be very loose about URL-based databases, and the <startup>
as well.  Several people strongly objected to extending
the edit operation to URLs at that time.  It was ignored in
the document on purpose.  Only the operations that have
URL extensions in the XSD had WG consensus to be supported.

IMO, we should focus on the 3 standard databases,
but clarifications are always good.  Maybe new
capabilities are needed (instead of piling on :url!)

> Balazs

Andy

_____________________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

_________________
Netconf mailing list
[email-masked]

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 16 Dec 2008 17:15:36 +0100

The problem, again, is that the text and the XSD say different things. So the 4741bis should 
clarify it.
Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
TSP System Manager
ECN: 831 7320                        Fax: +36 1 4377792
Tel: +36-1-437-7320     email: [email-masked]
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 16 Dec 2008 17:15:36 +0100