Subject: [Netconf] multiple data models in one filter

From: Tomasz Mikolajczyk <[email-masked]>
Date: Wed, 03 Dec 2008 14:15:26 +0100

Hi,

Assuming that the following filter:

<filter type="subtree">
    <top xmlns="namespace_a"/>
</filter>

returns the following output:

<data>
    <top xmlns="namespace_a">
        <a>
            <b>1</c>
            <c>2</c>
        </a>
        <aa>
            <bb>11</cc>
            <cc>22</cc>
        </aa>
    </top>
</data>

, and

<filter type="subtree">
    <top xmlns="namespace_x"/>
</filter>

<data>
    <top xmlns="namespace_x">
        <x>
            <y>5</y>
            <z>6</z>
        </x>
        <xx>
            <yy>55</yy>
            <zz>66</zz>
        </aa>
    </top>
</data>

I wonder how the response would look like for the following filter:

<filter type="subtree">
    <top xmlns="namespace_a" xmlns:x="namespace_x">
        <x:top/>
    </top>
</filter>

Any suggestions?

Tomasz

The information contained in this e-mail and in any attachments is confidential and is designated solely for the attention of the intended recipient(s). If you are not an intended recipient, you must not use, disclose, copy, distribute or retain this e-mail or any part thereof. If you have received this e-mail in error, please notify the sender by return e-mail and delete all copies of this e-mail from your computer system(s).
Please direct any additional queries to: [email-masked].
Thank You.
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 03 Dec 2008 14:31:09 +0100

>     <top xmlns="namespace_a" xmlns:x="namespace_x">

IMO the reply will be empty, the two top elements should be siblings.

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 03 Dec 2008 14:31:09 +0100

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Wed, 03 Dec 2008 08:23:31 -0800

<filter type="subtree">
    <top xmlns="namespace_a"/>
    <x:top xmlns:x="namespace_x"/>
</filter>

> Tomasz

Andy

---

From: Andy Bierman <[email-masked]>
Date: Wed, 03 Dec 2008 08:23:31 -0800

<filter type="subtree">

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 04 Dec 2008 09:46:22 +0100 (CET)

> IMO the reply will be empty, the two top elements should be siblings.

Yep, and if they were siblings, you'd get both subtrees in the reply.

/martin

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 04 Dec 2008 09:46:22 +0100 (CET)

/martin