Subject: Re: [Netconf] global vs. partial-lock

From: Balazs Lengyel <[email-masked]>
Date: Wed, 03 Dec 2008 10:16:48 +0100

Hello,

Washam Fan wrote:
> Hi,
>    global lock addressed failure scenarioes including outstanding changes to candidate datastore which was not addressed by partial-lock

We did not want to address this, as this might have surprising side effects. See 
http://www.ietf.org/mail-archive/web/netconf/current/msg03995.html
We wanted a lock that is simple to understand that locks the nodes, and no side effects.

>    partial lock addressed faulure scenarioes including outstanding commit to running datastore wich was not addressed by global lock
>    How do you think about them.

This is case is common for global and partial locks. I hope Martin will add it to the 4741bis 
draft.

Balazs
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Balazs Lengyel <[email-masked]>
Date: Wed, 03 Dec 2008 10:16:48 +0100

Hello,

Balazs

---

From: Washam Fan <[email-masked]>
Date: Thu, 04 Dec 2008 14:16:40 +0800

Hi,
  However, I think global and partial lock should be consistent. Why leave side effects to global lock alone?

washam
> Hello,
> 
> Washam Fan wrote:
> > Hi,
> >    global lock addressed failure scenarioes including 
> outstanding changes to candidate datastore which was not addressed 
> by partial-lock
> 
> >    partial lock addressed faulure scenarioes including 
> outstanding commit to running datastore wich was not addressed by 
> global lock

---

From: Washam Fan <[email-masked]>
Date: Thu, 04 Dec 2008 14:16:40 +0800

Hi,

washam