Subject: [Netconf] FW: AUTH48 [MF]: RFC 6022 <draft-ietf-netconf-monitoring-15.txt> NOW AVAILABLE

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 23 Sep 2010 19:35:25 +0200

Dear NETCONF WG,

the NETCONF Monitoring draft is in the AUTH48 phase and the 
editors proposed the changes below as last minute editorial
changes. 

The change on "p 4. list datastore" vs. "list configuration"
has not been posted to the ML before, which solves an 
inconcistency between the sections 2.1.2 and 5. 

We put AUTH48 on hold to get your approval on this. Please 
speak up if you have any strong concerns with this particular 
change by September 27, 2010, 11am EDT.

Mehmet

-----Original Message-----
From: Martin Bjorklund [mailto:[email-masked]] 
Sent: September-23-10 9:08 AM
To: [email-masked]
Cc: Mark Scott; [email-masked];
[email-masked]
Subject: Re: AUTH48 [MF]: RFC 6022
<draft-ietf-netconf-monitoring-15.txt> NOW AVAILABLE

Hi,

I have reviewed the document and the changes made so far.  I'm
including new changes in OLD/NEW format below.

RFC Editor <[email-masked]> wrote:
> 2) Section 2: Data Model to Monitor NETCONF
> 
>    A server that implements the data model defined in this document
>    MUST advertise the capability URI
>    "urn:ietf:params:xml:ns:yang:ietf-netconf-monitoring", as described
>    in [RFC6020].
> 
> <!-- [rfced] The above sounds as though 
> "urn:ietf:params:xml:ns:yang:ietf-netconf-monitoring" was registered
in RFC
> 6020.  Perhaps this could be rephrased as:
> 
>         A server that implements the data model defined in this
>         document
("urn:ietf:params:xml:ns:yang:ietf-netconf-monitoring") 
>         MUST advertise the capability URI as described in <xref
>         target="RFC6020"/>.
> -->

I see the point.  Actually, the entire paragraph is redundant, since
YANG defines what MUST be advertised.  But if we want to make as few
changes as possible, the proposed text is fine.

p. 4  (the list is called "list datatore", not "list configuration"
       in the data model)
OLD:

   The /netconf-state/datastores subtree contains the list of available
   datastores for the NETCONF server and includes information on their
   lock state.

   configuration
       /name
       /locks

NEW:

   The /netconf-state/datastores subtree contains the list of available
   datastores for the NETCONF server and includes information on their
   lock state.

   datastore
       /name
       /locks

p. 6
OLD:

      Identifies transport for each session.  The transport is

NEW:

      Identifies the transport for each session.  The transport is

p. 6 (make terminology consitent)
OLD:

   in-rpcs (yang:zero-based-counter32)
      Number of correct <rpc> requests received.

NEW:

   in-rpcs (yang:zero-based-counter32)
      Number of correct <rpc> messages received.

p. 7
OLD:

   in-rpcs (yang:zero-based-counter32)
      Number of correct <rpc> requests received.

NEW:

   in-rpcs (yang:zero-based-counter32)
      Number of correct <rpc> messages received.

p. 13
OLD:

  revision 2010-06-22 {

NEW:

  revision 2010-09-23 {

(or maybe the date the RFC is published.  The important thing is that
it is not 2010-06-22)

p. 18
OLD:

   list partial-locks {

NEW:

   list partial-lock {

p. 19
OLD:

   leaf-list locked-nodes {

NEW:

   leaf-list locked-node {

/martin

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 23 Sep 2010 19:52:08 +0200

> change by September 27, 2010, 11am EDT.

If someone has an html diff, it would be easier to see the changes.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 23 Sep 2010 20:46:33 +0200 (CEST)

> If someone has an html diff, it would be easier to see the changes.

I don't have an html diff for this change, but this is the one:

   configuration
       /name
       /locks

NEW:

   datastore
       /name
       /locks

/martin

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 23 Sep 2010 20:53:54 +0200

>    datastores for the NETCONF server and includes information on their

OK, so this seems to be a straight forward bug fix to align the text
with the YANG module. I see no problem with this bug fix.

/js