Subject: Re: [netconf] WGLC: draft-ietf-netconf-notification-capabilities-11

From: Qin Wu <[email-masked]>
Date: Fri, 6 Mar 2020 07:26:32 +0000

+1,
This version address my comment I raised earlier, support publication.

-Qin
-----邮件原件-----
发件人: netconf [mailto:[email-masked]] 代表 Eric Voit (evoit)
发送时间: 2020年3月5日 21:47
收件人: Kent Watsen <[email-masked]>; [email-masked]
主题: Re: [netconf] WGLC: draft-ietf-netconf-notification-capabilities-11

I have read the new version, and like the updated notification-support.  I believe it ready for publication.

Eric

> Dear All,
> 
> This WGLC has received zero responses, which is insufficient to 
> progress
the
> document at this time.  The chairs have therefore decided to extend 
> the WGLC for another two weeks, now ending March 18th.
> 
> Again, positive comments, e.g., "I've reviewed this document and 
> believe
it is
> ready for publication", are welcomed.  This is useful and important, 
> even from authors.  Objections, concerns, and suggestions are also 
> welcomed at this time.
> 
> The NETCONF Chairs
> 
> 
> 
> 
> > On Feb 17, 2020, at 8:27 PM, Kent Watsen <[email-masked]> wrote:
> >
> > FWIW, this is WGLC #2, after the major updates resulting from WGLC 
> > #1
(in
> October).
> >
> > K.
> >
> >
> >> On Feb 17, 2020, at 7:47 PM, Kent Watsen <[email-masked]> wrote:
> >>
> >> This message begins a two-week WGLC for
draft-ietf-netconf-notification-
> capabilities-11 ending on March 2nd (a week before the IETF 107 
> submission cutoff deadline).  Here is a direct link to the HTML version of the draft:
> >>
> >> 	https://tools.ietf.org/html/draft-ietf-netconf-notification-
> capabilities-11
> >>
> >> Positive comments, e.g., "I've reviewed this document and believe 
> >> it is
> ready for publication", are welcome!  This is useful and important, 
> even from authors.  Objections, concerns, and suggestions are also 
> welcomed at this time.
> >>
> >> Thank you,
> >> NETCONF Chairs
> >> _______________________________________________
> >> netconf mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/netconf
> >
> > _______________________________________________
> > netconf mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/netconf
> 
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: "taoran (F)" <[email-masked]>
Date: Mon, 9 Mar 2020 03:17:45 +0000

FYI

-----邮件原件-----
发件人: taoran (F) 
发送时间: 2020年3月9日 10:13
收件人: 'Balázs Lengyel' <[email-masked]>
主题: 答复: [netconf] 答复: WGLC: draft-ietf-netconf-notification-capabilities-11

-----邮件原件-----
发件人: Balázs Lengyel [mailto:[email-masked]]
发送时间: 2020年3月7日 1:06
收件人: taoran (F) <[email-masked]>; Kent Watsen <[email-masked]>; [email-masked]
主题: RE: [netconf] 答复: WGLC: draft-ietf-netconf-notification-capabilities-11

Hello,
Thinking a bit more about this I think we should not include the when statement because:
- It is possible that supported-excluded-change-type  is declared on the system level while on-change-supported is declared on datastore level. In such cases when the explicit declaration of on-change-supported and supported-excluded-change-type is done on different levels (system/datastore/specific data node) only a very complicated when statement would work.
[Ran]: Why add datastore level "on-change-supported " constraint to system level when statement, why not define when statement at the datastore level and system level separately? Let datastore level "on-change-supported" node value overrides system level "on-change-supported" node value, so does "supported-excluded-change-type".
- As this is output from the node, when statement are not even checked by many implementations
[Ran]: Correct, but not all implementations skip checking the output.
So while the idea is relevant, practically it would be too difficult.
Regards Balazs

-----Original Message-----
From: netconf <[email-masked]> On Behalf Of taoran (F)
Sent: 2020. március 6., péntek 9:27
To: Kent Watsen <[email-masked]>; [email-masked]
Subject: [netconf] 答复: WGLC: draft-ietf-netconf-notification-capabilities-11

1. Section 5.1 said:
“
   augment /sysc:system-capabilities/sysc:datastore-capabilities/ +
     |                                 sysc:per-node-capabilities:
     +--ro subscription-capabilities
        +--ro (update-period)?
        |  +--:(minimum-update-period)
        |  |  +--ro minimum-update-period?        uint32
        |  +--:(supported-update-period)
        |     +--ro supported-update-period*      uint32
        +--ro max-nodes-per-update?               uint32
        +--ro minimum-dampening-period?           uint32 {yp:on-change}?
        +--ro on-change-supported?                notification-support
        |                                                {yp:on-change}?
        +--ro periodic-notifications-supported?   notification-support
        +--ro supported-excluded-change-type*     union {yp:on-change}?
”
I believe on-change-supported and supported-excluded-change-type are related to each other, i.e., only when on-change-supported holds, Support-excluded-change-type needs to be supported. Would it make sense to add when statement under supported-excluded-change-type.
One Follow up comment is should supported-excluded-change-type be applicable to config true node or config false node?

BALAZS: OK, I will do it in the after the WGLC.