Subject: Re: [netconf] Bulk <rpc-reply>

From: aruna potti <[email-masked]>
Date: Tue, 3 Mar 2020 08:14:50 -0800

Hi,
A gentle reminder of my question!

Thanks,

On Mon, Feb 10, 2020 at 12:19 PM aruna potti <[email-masked]> wrote:

> Hi,
>
> Is there any conclusion on the proposals mentioned below?
> https://tools.ietf.org/id/draft-liu-netconf-multiple-replies-01.html
>
> I am especially interested in how clients can deal with bulk <rpc-reply>
> as they can not wait forever for a response and usually require to have
> time out for a response from the device. I see an issue to increase the
> time out as it can interfere with the network communication issue detection
> while waiting for the response.
> What is your suggestion on how a client should handle the bulk <rpc-reply>?
>
> Thanks,
> Aruna.
>
>

---

From: Kent Watsen <[email-masked]>
Date: Tue, 3 Mar 2020 20:57:01 +0000

Hi Aruna,

The issue raised by that draft remains open.  IIRC, more important ongoing activities the time shut it out.  It is potentially something the WG might want to consider again...

For returning large collections (e.g., routes, interfaces stats, etc.), the restconf-collection draft might’ve provided some relief: https://tools.ietf.org/html/draft-ietf-netconf-restconf-collection-00 <https://tools.ietf.org/html/draft-ietf-netconf-restconf-collection-00>.

Kent

> On Mar 3, 2020, at 11:14 AM, aruna potti <[email-masked]> wrote:
> 
> Hi,
> On Mon, Feb 10, 2020 at 12:19 PM aruna potti <[email-masked] <mailto:[email-masked]>> wrote:
> Hi,
> 
> https://tools.ietf.org/id/draft-liu-netconf-multiple-replies-01.html <https://tools.ietf.org/id/draft-liu-netconf-multiple-replies-01.html>
> 
> I am especially interested in how clients can deal with bulk <rpc-reply> as they can not wait forever for a response and usually require to have time out for a response from the device. I see an issue to increase the time out as it can interfere with the network communication issue detection while waiting for the response. 
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf