Subject: [netconf] one edit-config with bulk edits

From: aruna potti <[email-masked]>
Date: Tue, 3 Mar 2020 08:36:56 -0800

Hi,

We have a requirement to use one edit-config to send around 400 edit
operations so that we can make use of "rollback-on-error " capability to go
back to the previous state in case of errors.  Is there any limit on the
number of edit operations that can be combined to send in one edit-config?

Thanks,

---

From: Kent Watsen <[email-masked]>
Date: Tue, 3 Mar 2020 20:59:42 +0000

There are no protocol-imposed limits, though limits may be imposed by server implementations (e.g., constrained devices).

K.

> On Mar 3, 2020, at 11:36 AM, aruna potti <[email-masked]> wrote:
> 
> Hi,
> 
> We have a requirement to use one edit-config to send around 400 edit operations so that we can make use of "rollback-on-error " capability to go back to the previous state in case of errors.  Is there any limit on the number of edit operations that can be combined to send in one edit-config? 
> 
> Thanks,
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf