Subject: [netconf] Clarification on NETCONF edit-config default-operation replace

From: "Ivory, William" <[email-masked]>
Date: Thu, 5 Mar 2020 12:34:52 +0000

Hi,

I'd appreciate clarification on the following NETCONF operations relating to copy-config and edit-config:

My understanding is as follows:

- <copy-config> completely replaces any existing configuration

- <edit-config> with operation:replace attribute will replace any existing configuration with new configuration for nodes specified inside the <config> operation. The attribute may be at any level in the request, and applies only to the node specified and nodes under that node.

Where I'm not clear is the <edit-config> operation with the default-operation parameter set to replace. RFC 6241 section 7.2 states:

         replace:  The configuration data in the <config> parameter
            completely replaces the configuration in the target
            datastore.  This is useful for loading previously saved
            configuration data.

Does this mean that this is the equivalent of the <copy-config> operation, ie ALL existing configuration should be removed, even if there is no explicit replacement in the new <config> section?

Thanks,

William

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 9 Mar 2020 13:19:48 +0000

Hello William,

There was a discussion about this on the list a few years ago.  See the thread with subject:

Clarification request for NETCONF edit-config default-operation replace

An edit-config can't be used as a replacement for a full "replace at root" of the entire config like a copy-config.

Jason

From: netconf <[email-masked]> On Behalf Of Ivory, William
Sent: Thursday, March 5, 2020 7:35 AM
To: [email-masked]
Subject: [netconf] Clarification on NETCONF edit-config default-operation replace

Hi,

            configuration data.

Thanks,

William