Subject: [netconf] [Technical Errata Reported] RFC8040 (6277)

From: RFC Errata System <[email-masked]>
Date: Thu, 3 Sep 2020 05:16:43 -0700 (PDT)

The following errata report has been submitted for RFC8040,
"RESTCONF Protocol".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6277

--------------------------------------
Type: Technical
Reported by: Kent Watsen <[email-masked]>

Section: 4.8.5

Original Text
-------------
The default value is "last".

Corrected Text
--------------
The default value is “last”, except when used with PUT 
and the target resource already exists, in which case the 
default is to replace the target resource without altering
its position in the "ordered-by user” list or leaf-list.

Notes
-----
The "last" default is intended for when creating a new element.  

A PUT operation that replaces a list or leaf-list entry should not move the entry unless the "insert" parameter is explicitly passed.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8040 (draft-ietf-netconf-restconf-18)
--------------------------------------
Title               : RESTCONF Protocol
Publication Date    : January 2017
Author(s)           : A. Bierman, M. Bjorklund, K. Watsen
Category            : PROPOSED STANDARD
Source              : Network Configuration
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Martin Björklund <[email-masked]>
Date: Thu, 03 Sep 2020 14:59:33 +0200 (CEST)

Hi,

This errata is correct (it is the result of a discussion on the
netconf ML re errata 6271).

/martin

RFC Errata System <[email-masked]> wrote:
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf