Subject: [netconf] [Editorial Errata Reported] RFC8650 (6379)

From: RFC Errata System <[email-masked]>
Date: Sun, 3 Jan 2021 09:49:10 -0800 (PST)

The following errata report has been submitted for RFC8650,
"Dynamic Subscription to YANG Events and Datastores over RESTCONF".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6379

--------------------------------------
Type: Editorial
Reported by: Muly Ilan <[email-masked]>

Section: A.1.1

Original Text
-------------
   Upon receipt of the successful response, the subscriber does a GET to
   the provided URI to start the flow of notification messages.  When
   the publisher receives this, the subscription is moved to the active
   state (c).

   GET /restconf/subscriptions/22

             Figure 5: "establish-subscription" Subsequent POST

Corrected Text
--------------
   Upon receipt of the successful response, the subscriber does a GET to
   the provided URI to start the flow of notification messages.  When
   the publisher receives this, the subscription is moved to the active
   state (c).

   GET /restconf/subscriptions/22

             Figure 5: "establish-subscription" Subsequent GET

Notes
-----
Substitute POST by GET in the figure caption

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8650 (draft-ietf-netconf-restconf-notif-15)
--------------------------------------
Title               : Dynamic Subscription to YANG Events and Datastores over RESTCONF
Publication Date    : November 2019
Author(s)           : E. Voit, R. Rahman, E. Nilsen-Nygaard, A. Clemm, A. Bierman
Category            : PROPOSED STANDARD
Source              : Network Configuration
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Mon, 4 Jan 2021 15:02:12 +0000

Adding Reshad's new email.   I think this should be accepted.

Eric

> The following errata report has been submitted for RFC8650, "Dynamic
> Subscription to YANG Events and Datastores over RESTCONF".
>
> This erratum is currently posted as "Reported". If necessary, please use 
> "Reply
> All" to discuss whether it should be verified or rejected. When a decision 
> is
> reached, the verifying party can log in to change the status and edit the 
> report, if
> necessary.
>
> Title               : Dynamic Subscription to YANG Events and Datastores 
> over
> RESTCONF

---

From: Reshad Rahman <[email-masked]>
Date: Mon, 4 Jan 2021 15:04:37 +0000 (UTC)

I agree.
    On Monday, January 4, 2021, 10:02:17 AM EST, Eric Voit (evoit) <[email-masked]> wrote:  

Eric

---

From: Alexander Clemm <[email-masked]>
Date: Mon, 4 Jan 2021 19:03:11 +0000

+1
--- Alex

From: netconf <[email-masked]> On Behalf Of Reshad Rahman
Sent: Monday, January 4, 2021 7:05 AM
To: RFC Errata System <[email-masked]>; Einar Nilsen-Nygaard (einarnn) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Rob Wilton (rwilton) <[email-masked]>; [email-masked]; [email-masked]; Eric Voit (evoit) <[email-masked]>
Cc: [email-masked]
Subject: Re: [netconf] [Editorial Errata Reported] RFC8650 (6379)

I agree.

On Monday, January 4, 2021, 10:02:17 AM EST, Eric Voit (evoit) <[email-masked]<mailto:[email-masked]>> wrote:

Eric

> https://www.rfc-editor.org/errata/eid6379<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid6379&data=04%7C01%7Calex%40futurewei.com%7C345b0c3c7e0e4ccf086c08d8b0c239a8%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637453695550258969%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=sWTYuRsbL%2BOWiCtgBKsXcyhWUNoahYvGGKrBky93y3I%3D&reserved=0>
>
> Reported by: Muly Ilan <[email-masked]<mailto:[email-masked]>>
>
> Section: A.1.1
>
> Original Text
> -------------

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 5 Jan 2021 10:06:43 +0000

Thanks all for confirming.  I have verified this errata.

Regards,
Rob

From: Alexander Clemm <[email-masked]>
Sent: 04 January 2021 19:03
To: Reshad Rahman <[email-masked]>; RFC Errata System <[email-masked]>; Einar Nilsen-Nygaard (einarnn) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Rob Wilton (rwilton) <[email-masked]>; [email-masked]; [email-masked]; Eric Voit (evoit) <[email-masked]>
Cc: [email-masked]
Subject: RE: [netconf] [Editorial Errata Reported] RFC8650 (6379)

+1
--- Alex

From: netconf <[email-masked]<mailto:[email-masked]>> On Behalf Of Reshad Rahman
Sent: Monday, January 4, 2021 7:05 AM
To: RFC Errata System <[email-masked]<mailto:[email-masked]>>; Einar Nilsen-Nygaard (einarnn) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Eric Voit (evoit) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [netconf] [Editorial Errata Reported] RFC8650 (6379)

I agree.

Eric