Subject: [netconf] Does draft-ietf-lwig-curve-representations-19 have any bearing on the NETCONF crypto drafts

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 15 Feb 2021 11:31:13 +0000

Hi Kent,

draft-ietf-lwig-curve-representations-19 is in IESG review, the abstract states:

   This document specifies how to represent Montgomery curves and
   (twisted) Edwards curves as curves in short-Weierstrass form and
   illustrates how this can be used to carry out elliptic curve
   computations using existing implementations of, e.g., ECDSA and ECDH
   using NIST prime curves.  We also provide extensive background
   material that may be useful for implementers of elliptic curve
   cryptography.

I just wanted to check whether this draft is relevant to the crypto types work in NETCONF at all (e.g., draft-ietf-netconf-ssh-client-server).  From a quick look, I didn't think that it would have any impact, but thought that I should check.

Regards,
Rob

---

From: Kent Watsen <[email-masked]>
Date: Mon, 15 Feb 2021 14:44:39 +0000

Hi Rob,

The closest our work comes is in the "crypt-types" draft itself, where we have "public-key-format" and "private-key-format".  Presumably (after skimming the draft) the same "ECPrivateKey" and "SubjectPublicKeyInfo" ASN.1 structures are used to persist the key.  If so, then no impact, otherwise there may be a need to define other identities from our base "private-ket-format" and/or "public-key-format" identities, which could be done as a future effort (i.e., no need to block current publication).

K.

> On Feb 15, 2021, at 6:31 AM, Rob Wilton (rwilton) <[email-masked]> wrote:
> 
> Hi Kent,
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 15 Feb 2021 15:28:37 +0000

Hi Kent,

Thanks for confirming.

Rob

From: Kent Watsen <[email-masked]>
Sent: 15 February 2021 14:45
To: Rob Wilton (rwilton) <[email-masked]>
Cc: [email-masked]
Subject: Re: Does draft-ietf-lwig-curve-representations-19 have any bearing on the NETCONF crypto drafts

Hi Rob,

K.

On Feb 15, 2021, at 6:31 AM, Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Kent,

Regards,
Rob