Subject: [netconf] Latest ietf-netconf-server draft and related modules

From: Michal Vaško <[email-masked]>
Date: Fri, 05 Mar 2021 09:10:09 +0100

Hello,

I had a chance to look at these modules again and have 2 questions regarding some recent changes.

- ietf-ssh-server, ssh-server-grouping/client-authentication/supported-authentication-methods

Since the "other" leaf-list was removed there is no way to support some other methods than those specified. I am not sure whether this was the intention and if so, what is the reason for it? If nothing else, we support "interactive" authentication method but there are some others that I see no reason why they could not be used. For a robust and extendible solution, why not use an identityref leaf-list with all the methods as identities? One could then simply add new ones with specific "if-feature" statements.

- ietf-netconf-server, grouping netconf-server-grouping/client-identity-mappings

The "if-feature" on this container is strange. The practical problem is that if one wants to support certificates only for TLS, both one of the TLS features and "ssh-x509-certs" must be enabled. This then results in the container being defined for both SSH and TLS so there is no way to support it only for TLS or SSH.

Thanks for any input.

Regards,
Michal

---

From: Kent Watsen <[email-masked]>
Date: Fri, 5 Mar 2021 23:18:21 +0000

Hi Michal,

> Since the "other" leaf-list was removed there is no way to support some other methods than those specified. I am not sure whether this was the intention and if so, what is the reason for it? If nothing else, we support "interactive" authentication method but there are some others that I see no reason why they could not be used.

It took me a bit to determine that this change happened in ssh-client-server-18.

The motivation behind the change was to align the values with those defined in RFCs 4252 and 4250.

You mention an “interactive” and “some other” methods - where are they defined?

> For a robust and extendible solution, why not use an identityref leaf-list with all the methods as identities? One could then simply add new ones with specific "if-feature" statements.

An identityref seems reasonable, could you propose a snippet of YANG for it?

That said, it seems equally possible for a future module to augment-in a new leaf under the "supported-authentication-methods” container...

> The "if-feature" on this container is strange. The practical problem is that if one wants to support certificates only for TLS, both one of the TLS features and "ssh-x509-certs" must be enabled. Th…

Yes, granular features would be nice.  This issue is tracked here: https://github.com/netmod-wg/yang-next/issues/82 <https://github.com/netmod-wg/yang-next/issues/82>.  A possible fix would be to enable features on a per-XPath basis, perhaps using the “node-tags” draft going on in NETMOD.   Do you have a proposal?

BTW, shouldn’t the “if-feature” statement have an “or” (not an “and”) between the two major expressions?

K.