Subject: [netconf] [Technical Errata Reported] RFC8040 (6473)

From: RFC Errata System <[email-masked]>
Date: Wed, 10 Mar 2021 15:24:31 -0800 (PST)

The following errata report has been submitted for RFC8040,
"RESTCONF Protocol".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6473

--------------------------------------
Type: Technical
Reported by: Kyoung-Hwan Yun <[email-masked]>

Section: B.3.2

Original Text
-------------
   Example 3: depth=3

   To limit the depth level to the target resource plus two child
   resource layers, the value "3" is used.

      GET /restconf/data/example-jukebox:jukebox?depth=3 HTTP/1.1
      Host: example.com
      Accept: application/yang-data+json

   The server might respond as follows:

      HTTP/1.1 200 OK
      Date: Thu, 26 Jan 2017 20:56:30 GMT
      Server: example-server
      Cache-Control: no-cache
      Content-Type: application/yang-data+json

      {
        "example-jukebox:jukebox" : {
          "library" : {
            "artist" : {}
          },
          "playlist" : [
            {
              "name" : "Foo-One",
              "description" : "example playlist 1",
              "song" : {}
            }
          ],
          "player" : {
            "gap" : 0.5
          }
        }
      }

Corrected Text
--------------
   Example 3: depth=3

   To limit the depth level to the target resource plus two child
   resource layers, the value "3" is used.

      GET /restconf/data/example-jukebox:jukebox?depth=3 HTTP/1.1
      Host: example.com
      Accept: application/yang-data+json

   The server might respond as follows:

      HTTP/1.1 200 OK
      Date: Thu, 26 Jan 2017 20:56:30 GMT
      Server: example-server
      Cache-Control: no-cache
      Content-Type: application/yang-data+json

      {
        "example-jukebox:jukebox" : {
          "library" : {
            "artist" : []
          },
          "playlist" : [
            {
              "name" : "Foo-One",
              "description" : "example playlist 1",
              "song" : []
            }
          ],
          "player" : {
            "gap" : 0.5
          }
        }
      }

Notes
-----
"artist" and "song" are defined as list.  Therefore, according to RFC 7951, they should be encoded as array instead of object.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8040 (draft-ietf-netconf-restconf-18)
--------------------------------------
Title               : RESTCONF Protocol
Publication Date    : January 2017
Author(s)           : A. Bierman, M. Bjorklund, K. Watsen
Category            : PROPOSED STANDARD
Source              : Network Configuration
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 15 Mar 2021 09:40:25 +0000

Hi,

This looks like a bug to me.

Does anyone disagree?

Regards,
Rob

> -----Original Message-----
> From: RFC Errata System <[email-masked]>
> Sent: 10 March 2021 23:25
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; Rob Wilton (rwilton) <[email-masked]>;
> [email-masked]; [email-masked]
> Cc: Kyoung Yun (kyyun) <[email-masked]>; [email-masked]; rfc-
> [email-masked]
> Subject: [Technical Errata Reported] RFC8040 (6473)
> 
> "artist" and "song" are defined as list.  Therefore, according to RFC
> 7951, they should be encoded as array instead of object.
> 
> Instructions:
> -------------

---

From: "Per Andersson (perander)" <[email-masked]>
Date: Mon, 15 Mar 2021 09:45:27 +0000

> This looks like a bug to me.

Agree.

--
Per

---

From: Martin Björklund <[email-masked]>
Date: Mon, 15 Mar 2021 10:45:49 +0100 (CET)

> This looks like a bug to me.

I agree.  This errata is correct.

/martin

> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 15 Mar 2021 11:04:12 +0100

But can we approve the errata, given that there could be another bug
in the example?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>