Subject: [netconf] data-export-capabilities: insert hint into the error response

From: Qin Wu <[email-masked]>
Date: Tue, 9 Mar 2021 03:42:43 +0000

Hi, 
One of open issues we discuss in the netconf session is related to necessity of data export capability in the draft-tao-netconf-data-export-capabilities
Is there any alternative way?
One of alternative way we investigate is one proposed in RFC8639, i.e., insert hint into the error response
Pro: Accept the failure the first RPC request attempt, but increases the likelihood of success for subsequent RPC requests
Con: Such likelihood of success for subsequent RPC requests is not guaranteed since hint needs to be specified every time we have new hint, otherwise the client who initiate the RPC request may not understand what hint means.

With data export capability advertisement,
Pro: increase likelihood of success for the first RPC request, doesn’t need to wait for the second round RPC exchange
The cost is to introduce new parameter in the notification capability message in the draft-ietf-netconf-notification-capabilities-14.
Given the notification capability has been well accepted and stable for publication, 
I think it layer foundation for new capability definitions.

-Qin (on behalf of authors)
-----邮件原件-----
发件人: netconf [mailto:[email-masked]] 代表 maqiufang (A)
发送时间: 2021年1月20日 21:01
收件人: [email-masked]
主题: [netconf] New Version Notification for draft-tao-netconf-data-export-capabilities-03.txt

Hi, all:
 We have updated the draft, https://www.ietf.org/archive/id/draft-tao-netconf-data-export-capabilities-03.txt  .
 
The main changes are following :
   o  Change 'data-export-capabilities' into list type to support
      multiple transport protocol, encoding on the server.
   o  Add Usage Example of interaction with UDP based Transport for
      Configured Subscription.
   o  Add Thomas Graf as a contributor;
   o  Update motivation in the introduction to clarify why this work is
      needed.
   o  Support udp notif and http notif as two optional transport in the
      YANG data model.

Any suggestions and comments would be greatly appreciated!

Qiufang Ma(On behalf of authors)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, January 20, 2021 8:46 PM
To: Peng Liu <[email-masked]>; Qin Wu <[email-masked]>; Qin Wu <[email-masked]>; maqiufang (A) <[email-masked]>
Subject: New Version Notification for draft-tao-netconf-data-export-capabilities-03.txt

A new version of I-D, draft-tao-netconf-data-export-capabilities-03.txt
has been successfully submitted by Qiufang Ma and posted to the IETF repository.

Name:		draft-tao-netconf-data-export-capabilities
Revision:	03
Title:		Telemetry Data Export capability
Document date:	2021-01-20
Group:		Individual Submission
Pages:		18
URL:            https://www.ietf.org/archive/id/draft-tao-netconf-data-export-capabilities-03.txt
Status:         https://datatracker.ietf.org/doc/draft-tao-netconf-data-export-capabilities/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-tao-netconf-data-export-capabilities
Htmlized:       https://tools.ietf.org/html/draft-tao-netconf-data-export-capabilities-03
Diff:           https://www.ietf.org/rfcdiff?url2=draft-tao-netconf-data-export-capabilities-03

Abstract:
   This document proposes a YANG module for telemetry data export
   capabilities which augments system Capabilities model and provides
   additional telemetry data export attributes associated with system
   capabilities for transport dependent capability advertisement.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Alexander Clemm <[email-masked]>
Date: Tue, 9 Mar 2021 23:39:01 +0000

Hi Qin, and authors,

On this particular issue: presumably, when there is something about the subscription that the server does not support, they would simply return an error response with identity establish-subscription-error as base. Now it is true that a client would need to send a subsequent request.  However, I am not sure how big an issue this is, as you would presumably not need to do this repeatedly upon each establishment of a new subscription, only upon the first time.   Of course, it is true that convergence might still need a couple of cycles depending on the number of options there are.  

Regardless of this, I do think there is a strong conceptual argument to be made that it still makes sense for all capabilities to be discoverable.  This makes solutions a bit more "elegant" and allows them to be fully data-driven.  There may be also collateral benefits such as the return of successive errors causing to risk of confusion legitimate subscription requests e.g. with someone trying to launch bogus invalid requests.  So, I do think the data model defined in this draft will be clearly useful and a straightforward thing to support regardless of the other argument.   Perhaps one thing to do as well would be to review whether there are any new establish-subscription-errors needed beyond the ones already defined and if so, also define those as part of this draft.

--- Alex

-----Original Message-----
From: netconf <[email-masked]> On Behalf Of Qin Wu
Sent: Monday, March 8, 2021 7:43 PM
To: [email-masked]
Subject: [netconf] data-export-capabilities: insert hint into the error response

Hi,

With data export capability advertisement,
Pro: increase likelihood of success for the first RPC request, doesn’t need to wait for the second round RPC exchange The cost is to introduce new parameter in the notification capability message in the draft-ietf-netconf-notification-capabilities-14.
Given the notification capability has been well accepted and stable for publication, I think it layer foundation for new capability definitions.

-----邮件原件-----
发件人: netconf [mailto:[email-masked]] 代表 maqiufang (A)
发送时间: 2021年1月20日 21:01
收件人: [email-masked]
主题: [netconf] New Version Notification for draft-tao-netconf-data-export-capabilities-03.txt

Hi, all:
 We have updated the draft, https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-tao-netconf-data-export-capabilities-03.txt&amp;data=04%7C01%7Calex%40futurewei.com%7Cc8dd4bee8df04793015c08d8e2ad6f47%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508581844394342%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=BfJi5fpibbXklJxiR42qAiUBfk7FHiBsXtMiBf47q1U%3D&amp;reserved=0  .

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, January 20, 2021 8:46 PM
To: Peng Liu <[email-masked]>; Qin Wu <[email-masked]>; Qin Wu <[email-masked]>; maqiufang (A) <[email-masked]>
Subject: New Version Notification for draft-tao-netconf-data-export-capabilities-03.txt

Name:		draft-tao-netconf-data-export-capabilities
Revision:	03
Title:		Telemetry Data Export capability
Document date:	2021-01-20
Group:		Individual Submission
Pages:		18
URL:            https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-tao-netconf-data-export-capabilities-03.txt&amp;data=04%7C01%7Calex%40futurewei.com%7Cc8dd4bee8df04793015c08d8e2ad6f47%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508581844394342%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=BfJi5fpibbXklJxiR42qAiUBfk7FHiBsXtMiBf47q1U%3D&amp;reserved=0
Status:         https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-tao-netconf-data-export-capabilities%2F&amp;data=04%7C01%7Calex%40futurewei.com%7Cc8dd4bee8df04793015c08d8e2ad6f47%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508581844394342%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=u4bwYhI93vxL6ykcIfS9Ua5g7N0cFGUCRApPEZci3VM%3D&amp;reserved=0
Htmlized:       https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-tao-netconf-data-export-capabilities&amp;data=04%7C01%7Calex%40futurewei.com%7Cc8dd4bee8df04793015c08d8e2ad6f47%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508581844394342%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=cDWukkUp8pAnUoQD1keiDX1JvIRF1BDaXPxd1COFiSY%3D&amp;reserved=0
Htmlized:       https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-tao-netconf-data-export-capabilities-03&amp;data=04%7C01%7Calex%40futurewei.com%7Cc8dd4bee8df04793015c08d8e2ad6f47%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508581844404297%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=YX4TTZ%2BzjaRSIl9CMDke7cH%2FBxW0ILTTIknawRANxpk%3D&amp;reserved=0
Diff:           https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-tao-netconf-data-export-capabilities-03&amp;data=04%7C01%7Calex%40futurewei.com%7Cc8dd4bee8df04793015c08d8e2ad6f47%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508581844404297%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=pp%2Bh675Ut6RtrTapFM5U2GWSch6vkRQ5kM%2BY8BuSuj0%3D&amp;reserved=0

Abstract:

The IETF Secretariat

_______________________________________________
netconf mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fnetconf&amp;data=04%7C01%7Calex%40futurewei.com%7Cc8dd4bee8df04793015c08d8e2ad6f47%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508581844404297%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=0FeLv9PmDdz8HKRh%2F%2Bvmqof%2B6U9To3amxFBMn85yIBc%3D&amp;reserved=0
_______________________________________________
netconf mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fnetconf&amp;data=04%7C01%7Calex%40futurewei.com%7Cc8dd4bee8df04793015c08d8e2ad6f47%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637508581844404297%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=0FeLv9PmDdz8HKRh%2F%2Bvmqof%2B6U9To3amxFBMn85yIBc%3D&amp;reserved=0