Subject: [netconf] RFC 8639 configured subscriptions

From: Michal Vaško <[email-masked]>
Date: Mon, 08 Mar 2021 16:16:53 +0100

Hi,

we want to implement both dynamic and configured subscriptions for a NETCONF server. Reading through the RFC, it is pretty clear that the configured subscriptions require a YANG module with NETCONF-specific parameters including a "netconf" identity derived from the "transport" identity (juts like the "foo" example[1]). We have not managed to find such a module, does it exist? If not, could someone provide some more information about how it can be implemented? Thank you.

Regards,
Michal

[1] https://tools.ietf.org/html/rfc8639#appendix-A

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Mon, 8 Mar 2021 17:06:22 +0000

Hi Michal,

Configured subscriptions for NETCONF was originally in RFC-8640.  But the
draft was rescoped to just dynamic subscriptions by the time it was
published.  

So it might be worth looking through:
https://tools.ietf.org/html/draft-ietf-netconf-netconf-event-notifications-1
0
This version does include the module you request below.  Also included is
other text which might be of interest.

Eric

> -----Original Message-----
> From: netconf <[email-masked]> On Behalf Of Michal Vaško
> Sent: Monday, March 8, 2021 10:17 AM
> To: netconf <[email-masked]>
> Subject: [netconf] RFC 8639 configured subscriptions
> 
> Hi,
> 
> we want to implement both dynamic and configured subscriptions for a
> NETCONF server. Reading through the RFC, it is pretty clear that the
configured
> subscriptions require a YANG module with NETCONF-specific parameters
> including a "netconf" identity derived from the "transport" identity (juts
like the
> "foo" example[1]). We have not managed to find such a module, does it
exist? If
> not, could someone provide some more information about how it can be
> implemented? Thank you.
> 
> Regards,
> Michal
> 
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Michal Vaško <[email-masked]>
Date: Tue, 09 Mar 2021 07:50:57 +0100

Hi Eric,

I appreciate the help but what is the official situation then? NETCONF/RESTCONF has RFCs only for dynamic subscriptions so for these protocols configured subscriptions are not supported? Actually, there are no protocols that support it, currently?

Michal

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 9 Mar 2021 15:24:19 +0000

Hi Michal,

There is nothing which halts an implementation.   The question really is someone wanting to push the rest of the rest of NETCONF Configured Subscription requirements through the IETF process.  It shouldn't controversial to complete the work.  But the IETF process is always time consuming.

Eric

> From: Michal Vaško, March 9, 2021 1:51 AM
> 
> Hi Eric,
> 
> I appreciate the help but what is the official situation then?
> NETCONF/RESTCONF has RFCs only for dynamic subscriptions so for these
> protocols configured subscriptions are not supported? Actually, there are no
> protocols that support it, currently?
> 
> Michal
> 
> > Configured subscriptions for NETCONF was originally in RFC-8640.  But
> > the draft was rescoped to just dynamic subscriptions by the time it
> > was published.
> >
> > This version does include the module you request below.  Also included
> > is other text which might be of interest.
> >
> > Eric
> >
> >