Subject: [netconf] missing drafts on datatracker

From: Andy Bierman <[email-masked]>
Date: Tue, 14 Dec 2021 15:25:10 -0800

Hi,

The WG datastracker used to have more client/server drafts.
Looks like they expired and were taken off the datatracker

These drafts are still on the datatracker:

draft-ietf-netconf-crypt-types-21
draft-ietf-netconf-ssh-client-server-25
draft-ietf-netconf-tls-client-server-25

These drafts are not on the NETCONF WG datatracker:

https://datatracker.ietf.org/doc/html/draft-ietf-netconf-keystore-22
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-trust-anchors-15
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-http-client-server-07
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-netconf-client-server-23
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-restconf-client-server-23
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-tcp-client-server-10

What is the ETA for publication of these drafts as RFCs?

thanks,
Andy

---

From: Kent Watsen <[email-masked]>
Date: Tue, 14 Dec 2021 23:47:45 +0000

Hi Andy,

> On Dec 14, 2021, at 6:25 PM, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 

Correct, some of the I-Ds we WGLC’ed first are expiring now.  Recall we broke up the LC-reviews into 3 tranches.  As author, I should’ve posted an update to avoid the optics, but didn’t because it doesn’t make a difference to the publishing process, AFAICT.  In either case, I will post an update for the entire suite of drafts later tonight to clear this issue.

> https://datatracker.ietf.org/doc/html/draft-ietf-netconf-keystore-22 <https://datatracker.ietf.org/doc/html/draft-ietf-netconf-keystore-22>
> https://datatracker.ietf.org/doc/html/draft-ietf-netconf-trust-anchors-15 <https://datatracker.ietf.org/doc/html/draft-ietf-netconf-trust-anchors-15>
> https://datatracker.ietf.org/doc/html/draft-ietf-netconf-http-client-server-07 <https://datatracker.ietf.org/doc/html/draft-ietf-netconf-http-client-server-07>
> https://datatracker.ietf.org/doc/html/draft-ietf-netconf-netconf-client-server-23 <https://datatracker.ietf.org/doc/html/draft-ietf-netconf-netconf-client-server-23>
> https://datatracker.ietf.org/doc/html/draft-ietf-netconf-restconf-client-server-23 <https://datatracker.ietf.org/doc/html/draft-ietf-netconf-restconf-client-server-23>
> https://datatracker.ietf.org/doc/html/draft-ietf-netconf-tcp-client-server-10 <https://datatracker.ietf.org/doc/html/draft-ietf-netconf-tcp-client-server-10>
> 

As coincidence would have it, the BBF expressed eagerness (offline) to see these drafts published quickly and a resource has reached out to me to help bang out the last few items…hopefully in the next couple weeks!   Then it will be Shepherd write-ups ---> AD review ---> IESG review ---> RFC Editor review.   All in all, I’d guess late-Q1 to early-Q2.

*********************************************************************************************************************
CAN ANYONE VOLUNTEER TO DO THE SHEPHERD WRITEUP FOR SOME OF THESE DRAFTS?!   

NOTE: DOING A SHEPHERD WRITEUP IS GOOD PRACTICE TOWARDS BECOMING A WG CHAIR.  

THE IETF IS LOOKING TO PROMOTE MORE FOLKS INTO LEADERSHIP POSITIONS, 
SO ***PLEASE*** VOLUNTEER IF INTERESTED!

IF NO ONE VOLUNTEERS, THEN MAHESH WILL HAVE TO DO ALL BY HIMSELF (AS I HAVE TO
RECUSE MYSELF), WHICH MAY TAKE WHILE...
*********************************************************************************************************************

> Andy

Kent  // many hats