Subject: [netconf] Adoption call for draft-wang-netconf-adaptive-subscription

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 10 Jan 2022 14:07:22 -0800

Hi WG,

The authors posted -08 version of the draft just before the new year, which addressed the comments they received in IETF 112.

 https://www.ietf.org/archive/id/draft-wang-netconf-adaptive-subscription-08.txt <https://www.ietf.org/archive/id/draft-wang-netconf-adaptive-subscription-08.txt>

This starts a 2 week poll ending on January 24, to decide whether this document should be made a WG document or not. Please reply to this email whether or not you support adoption of this draft by the WG. Indications that the draft has been read will be also be appreciated. The Intended Status of the draft is Standards Track.

A separate IPR call will be issued on the draft.

Thanks.

Mahesh Jethanandani
[email-masked]

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 12 Jan 2022 16:00:08 +0800

Hello everyone,

I have read the draft and think it is useful in some network performace telemetry scenarios. So I support this adoption.

Best Regards,
Zhenqiang Li

[email-masked]
 
From: Mahesh Jethanandani
Date: 2022-01-11 06:07
To: Netconf
CC: draft-wang-netconf-adaptive-subscription
Subject: [netconf] Adoption call for draft-wang-netconf-adaptive-subscription
Hi WG,

 https://www.ietf.org/archive/id/draft-wang-netconf-adaptive-subscription-08.txt

Thanks.

Mahesh Jethanandani
[email-masked]

---

From: Chongfeng Xie <[email-masked]>
Date: Wed, 12 Jan 2022 21:29:04 +0800

Hi，folks，
I give my support to this draft after reading it.

Chongfeng

> 2022年1月11日 上午6:07，Mahesh Jethanandani <[email-masked]> 写道：
> 
> Hi WG,
> 
> [email-masked] <mailto:[email-masked]>
> 
> 
> 
> 
> 
> 
> _______________________________________________
> netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: "maqiufang (A)" <[email-masked]>
Date: Thu, 13 Jan 2022 06:45:10 +0000

Hi, all
As a coauthor, I support the adoption of this work.

Best Regards,
Qiufang

From: netconf [mailto:[email-masked]] On Behalf Of Mahesh Jethanandani
Sent: Tuesday, January 11, 2022 6:07 AM
To: Netconf <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [netconf] Adoption call for draft-wang-netconf-adaptive-subscription

Hi WG,

Thanks.

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: Hongwei Li <[email-masked]>
Date: Wed, 19 Jan 2022 09:00:59 -0600

Hi WG,
I support the adoption. It is a good practice to have adaption to the
network load.

*From:* netconf [mailto:[email-masked]] *On Behalf Of *Mahesh
Jethanandani
*Sent:* Tuesday, January 11, 2022 6:07 AM
*To:* Netconf <[email-masked]>
*Cc:* [email-masked]
*Subject:* [netconf] Adoption call for draft-wang-netconf-adaptive-
subscription

> The authors posted -08 version of the draft just before the new year,
which addressed the comments they received in IETF 112.

This starts a 2 week poll ending on January 24, to decide whether this
document should be made a WG document or not. Please reply to this email
whether or not you support adoption of this draft by the WG. Indications
that the draft has been read will be also be appreciated. The Intended
Status of the draft is Standards Track.

Mahesh Jethanandani
[email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 24 Jan 2022 14:19:00 -0800

We have received a tepid response to this adoption call, and are therefore extending this adoption call by another two weeks to February 7. At that time, and unless we receive any objections, we are going to go ahead and adopt this draft.

We are aware of least two implementations of YANG Push, and this draft is an extension of that work.

Cheers

> On Jan 10, 2022, at 2:07 PM, Mahesh Jethanandani <[email-masked]> wrote:
> 
> Hi WG,
> 

Mahesh and Kent (as co-chairs)

---

From: Andy Bierman <[email-masked]>
Date: Tue, 25 Jan 2022 11:26:48 -0800

Hi,

I have some objections to this work and this process.

Process issues:

1) no problem statement
The WG should reach consensus on the problem to solve
   - wide agreement a problem exists
   - agreement the problem is well-defined and well-scoped

Instead the WG is being asked to adopt a solution draft, not a problem to
solve.

2) no committed resources
The WG should not attempt new work unless there is a significant number of
people
willing to work on the draft until it becomes an RFC. (i.e., reviews,
implementations).
Drafts without enough people willing to work on them do not make it to RFC
publication.

Draft issues:

3) YANG Push supports adaptive subscriptions already
The YANG Push design allows subscriptions to be started or modified
on-the-fly
by a client. The network reliability and latency issues are implementation
details.
There is no compelling need to move arbitrary client complexity to the
server to perform this function.

4) A boolean XPath solution is both too complex and too limited for a
reasonable implementation
The example in the draft uses a threshold trigger to turn the subscription
on and off.
It does not utilize any existing alarms management standards (e.g. it does
not account
for a value fluctuating at the threshold level.  At the same time,
arbitrary XPath is very
expensive to implement, especially if low-latency is required (so the XPath
needs to
be tested frequently.)

IMO this draft is just a special case of the ECA work that is already under
way,
although that ocean is proving harder to boil than previously anticipated.

Andy

On Mon, Jan 24, 2022 at 2:19 PM Mahesh Jethanandani <[email-masked]>
wrote:

> We have received a tepid response to this adoption call, and are therefore
> extending this adoption call by another two weeks to February 7. At that
> time, and unless we receive any objections, we are going to go ahead and
> adopt this draft.
>

---

From: "Aijun Wang" <[email-masked]>
Date: Sat, 29 Jan 2022 16:57:47 +0800

Hi, All:

I have read this document and support the adoption of this work.

It gives the flexibility for the client to receive the notification messages
under the predefined policy.

Best Regards

Aijun Wang

China Telecom

From: [email-masked] <[email-masked]> On Behalf Of
Mahesh Jethanandani
Sent: Tuesday, January 25, 2022 6:19 AM
To: Netconf <[email-masked]>
Cc: [email-masked]
Subject: Re: [netconf] Adoption call for
draft-wang-netconf-adaptive-subscription

We are aware of least two implementations of YANG Push, and this draft is an
extension of that work.

Cheers

On Jan 10, 2022, at 2:07 PM, Mahesh Jethanandani <[email-masked]
<mailto:[email-masked]> > wrote:

Hi WG,

The authors posted -08 version of the draft just before the new year, which
addressed the comments they received in IETF 112.

https://www.ietf.org/archive/id/draft-wang-netconf-adaptive-subscription-08.
txt

Thanks.