Subject: [netconf] FW: New Version Notification for draft-wang-netconf-adaptive-subscription-09.txt

From: "maqiufang (A)" <[email-masked]>
Date: Fri, 25 Feb 2022 08:09:50 +0000

Hi, Andy, all
This version tries to resolve the comments received during the adoption call (thank you all for showing your supports/concerns). 
The diff is available at: https://www.ietf.org/rfcdiff?url2=draft-wang-netconf-adaptive-subscription-09. 

Andy, could you please have a review of it and let the authors know if we are on the right track?
I am hoping we can have a further discussion if you think there is still something unclear.

Any other comments and suggestions would also be greatly appreciated.
Thanks!

Best Regards,
Qiufang Ma

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, February 25, 2022 3:17 PM
To: Peng Liu <[email-masked]>; Qin Wu <[email-masked]>; Qin Wu <[email-masked]>; maqiufang (A) <[email-masked]>; Songwei (David, DataCom) <[email-masked]>; Wei Wang <[email-masked]>
Subject: New Version Notification for draft-wang-netconf-adaptive-subscription-09.txt

A new version of I-D, draft-wang-netconf-adaptive-subscription-09.txt
has been successfully submitted by Qiufang Ma and posted to the IETF repository.

Name:		draft-wang-netconf-adaptive-subscription
Revision:	09
Title:		Adaptive Subscription to YANG Notification
Document date:	2022-02-24
Group:		Individual Submission
Pages:		29
URL:            https://www.ietf.org/archive/id/draft-wang-netconf-adaptive-subscription-09.txt
Status:         https://datatracker.ietf.org/doc/draft-wang-netconf-adaptive-subscription/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-wang-netconf-adaptive-subscription
Diff:           https://www.ietf.org/rfcdiff?url2=draft-wang-netconf-adaptive-subscription-09

Abstract:
   This document defines a YANG data model and associated mechanism
   enabling the subscriber's adaptive subscriptions to a publisher's
   event streams with various different period intervals to report
   updates.  Applying these elements allows servers automatically adjust
   the rate and volume of telemetry traffic sent from a publisher to
   receivers.

The IETF Secretariat

---

From: Andy Bierman <[email-masked]>
Date: Fri, 25 Feb 2022 05:49:38 -0800

On Fri, Feb 25, 2022 at 12:09 AM maqiufang (A) <[email-masked]>
wrote:

> Hi, Andy, all
> This version tries to resolve the comments received during the adoption
> call (thank you all for showing your supports/concerns).
> The diff is available at:
> https://www.ietf.org/rfcdiff?url2=draft-wang-netconf-adaptive-subscription-09.
>
>
Sorry, I am not interested in this work so I do not have time to read the
draft.

Andy

> To: Peng Liu <[email-masked]>; Qin Wu <[email-masked]>;
> Qin Wu <[email-masked]>; maqiufang (A) <[email-masked]>;
> Songwei (David, DataCom) <[email-masked]>; Wei Wang <
> [email-masked]>
> Subject: New Version Notification for
> draft-wang-netconf-adaptive-subscription-09.txt
>
>
> URL:
> https://www.ietf.org/archive/id/draft-wang-netconf-adaptive-subscription-09.txt
> Status:
> https://datatracker.ietf.org/doc/draft-wang-netconf-adaptive-subscription/
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-wang-netconf-adaptive-subscription
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-wang-netconf-adaptive-subscription-09
>
> Abstract:

---

From: Andy Bierman <[email-masked]>
Date: Sat, 26 Feb 2022 10:47:34 -0800

> I am hoping we can have a further discussion if you think there is still
How about a discussion on the problem space?

The programming logic and server interactions required to implement some
client application
functionality is likely stateful, and of arbitrary complexity.

All attempts to represent such programming logic in SMIv2 or YANG, and
"program the server"
with the client application logic have failed in spectacular fashion. They
serve as case studies
on the impact of complexity on standards adoption.

Every solution is either too simplistic to address any real use-cases (like
this draft)
or too complex for mere mortals to use (like SUPA and ECA).
So I do not believe such standardization efforts will be a good use of WG
resources.
IMO the WG should focus on new features that only the server can provide,
like YANG list pagination.

Andy