Subject: [netconf] Question to draft-ietf-netconf-sztp-csr-13

From: "Fries, Steffen" <[email-masked]>
Date: Tue, 15 Feb 2022 18:46:16 +0000

Hello Kent,

I've got a short clarification question regarding the latest draft. I realized in the description of the YANG modules that there is a difference in section 3.2 between CMC and CMP in the description what can be contained in the respective CSR. Based on the description of the YANG module, CMC seems to be open for different types of certification requests, while CMP is bound to a wrapped P10 not leaving any further choice (like ir, cr, kur). Did I got this right or did I misinterpret the description for the cmc-csr? Sorry for realizing this so late.

Best regards
Steffen

---

From: Kent Watsen <[email-masked]>
Date: Tue, 22 Feb 2022 15:33:27 +0000

Hi Steffen,

Yes, the CMP-CSR is bound to P10.  

This draft is currently in the final stage of IESG Last Call review.  Comments such as these should have been received during WG Last Call.  Unless an IESG member throws a DISCUSS, the draft will proceed as is.  In such case, a future work may define something like a "cmp-csr-2” leaf to contain an expanded definition.

Kent // contributor

> On Feb 15, 2022, at 1:46 PM, Fries, Steffen <[email-masked]> wrote:
> 
> Hello Kent,
>  
> I’ve got a short clarification question regarding the latest draft. I realized in the description of the YANG modules that there is a difference in section 3.2 between CMC and CMP in the description what can be contained in the respective CSR. Based on the description of the YANG module, CMC seems to be open for different types of certification requests, while CMP is bound to a wrapped P10 not leaving any further choice (like ir, cr, kur). Did I got this right or did I misinterpret the description for the cmc-csr? Sorry for realizing this so late.  
>  
> Best regards
> Steffen

---

From: "Fries, Steffen" <[email-masked]>
Date: Tue, 22 Feb 2022 16:51:49 +0000

Hi Kent,

Thank you for your answer.
I agree, it is very late in the process for such a comment. I should have realized it earlier. Nevertheless, I wanted to raise that point as it would allow for more functionality. If there is no DISCUSS, the proposal with an additional definition is probably the easiest way forward.

Best regards
Steffen

From: Kent Watsen <[email-masked]>
Sent: Dienstag, 22. Februar 2022 16:33
To: Fries, Steffen (T CST) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: Question to draft-ietf-netconf-sztp-csr-13

Hi Steffen,

Kent // contributor

On Feb 15, 2022, at 1:46 PM, Fries, Steffen <[email-masked]<mailto:[email-masked]>> wrote:

Hello Kent,

Best regards
Steffen

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Wed, 23 Feb 2022 08:44:23 +0000

Kent

I understood that this change request comes very late, but to male the change request more concrete I looked into the document and identified four places where p10cr is referenced. In all theses places “p10cr” would need to be replaced with “ir, cr, kur, or p10cr”.

Finally this is the proposed change:

** Section 3.2.

In identity cmp-csr:

s/PKIBody containing only the p10cr structure/PKIBody containing only the ir, cr, kur, or p10cr structure/

And three times in grouping csr-grouping:

s/The body element contains a p10cr CHOICE of type CertificationRequest./The body element contains a ir, cr, kur, or p10cr CHOICE of type CertificationRequest./

But I understood that such change can only be processed if there is a DISCUSS.

Hendrik

Von: netconf <[email-masked]> Im Auftrag von Fries, Steffen
Gesendet: Dienstag, 22. Februar 2022 17:52
An: Kent Watsen <[email-masked]>
Cc: [email-masked]; [email-masked]
Betreff: Re: [netconf] Question to draft-ietf-netconf-sztp-csr-13

Hi Kent,

Best regards
Steffen

From: Kent Watsen <[email-masked]<mailto:[email-masked]>>
Sent: Dienstag, 22. Februar 2022 16:33
To: Fries, Steffen (T CST) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: Question to draft-ietf-netconf-sztp-csr-13

Hi Steffen,

Kent // contributor

Hello Kent,

Best regards
Steffen