Subject: [Nethistory] Collecting the history of networking, a possible methodology

From: Elizabeth Feinler <[email-masked]>
Date: Wed, 22 May 2013 14:17:42 -0700

Dear All,

At the IETF BoF in Orlando we learned that Kilam Chon and his colleagues have made a good start on a  structure for collecting the history of networking.

	See: https://sites.google.com/site/internethistoryasia/country-region-information 
 
I would like to suggest that we build on that structure in the following way:

1.)  Use Chon’s list of countries to build a tree-structured framework of networking
      history contacts and activities unique to each country

2.)  Find a volunteer for each country to act as that country’s Network History Liaison
     (NHL)

The Network History Liaison would:

1.)  Act as a “go to” point of contact for anyone who has a computer or network history
      donation but does not know where or how to begin to find a suitable facility for the
      donation. 

2.)  Develop a list of repositories (if any) and significant archival collections (if any) located 
      within his or her country along with relevant contact information..  Provide liaison 
      to significant repositories that may or may not reside in his or her country;

3.)  Collaborate via the [email-masked] mailing list to develop an online worldwide network 
      history information framework.

4.)  Help develop posting and trading practices for duplicate donations, and like activities 
       to be determined as the need arises.

5.)  Help facilitate the deposition of important networking history artifacts and archives at
      established repositories that will protect and preserve them in perpetuity.  

6.)  Promote the importance of saving the history of networking for posterity.

The Network History Liaison would:

1.)  NOT accept donations as part of his or her role; but would only act as an information
     liaison to facilities that do accept donations.

2.) NOT act as an appraiser for any donation or  proposed donation, or at
     any time assess a monetary value to any item or collection.

Each NHL can pull together a team of volunteers or choose to work alone to help develop the structure and/or provide liaison for his or her country.

- It is assumed that what is being collected and what aspect of  network history originated 
  in any given country would be different from other countries; however, 
  there would be common information elements such as:
	- Name of collection institution
	- Scope of collection
	- Online or offline or both
	- Where institution is located
	- Contact person
	- Is the collector a legitimate repository with endowment
  The number and nature of these common elements to be developed by the group.

- It is also assumed that any donor has the right to offer his or her donation to any 
  collector and that any collector has the right to accept or refuse any donation 

Please note that this is a :”strawman” approach that builds upon work already begun, the details of which will be further developed to suit the need.

---

From: Scott Brim <[email-masked]>
Date: Thu, 23 May 2013 07:42:44 -0400

Jake, this feels very top-down.  There are already a dozen attempts at
Internet history.  In other areas we've found that everyone has their
own way of doing things, and attempts at unification are likely to fail.
 I suggest that instead of unification you try for federation -- find a
way to include existing attempts, and not require them to reorganize.

Scott

---

From: Joe Abley <[email-masked]>
Date: Thu, 23 May 2013 08:10:36 -0400

> way to include existing attempts, and not require them to reorganize.

I made a brief presentation at a NZNOG meeting in Hamilton a few years ago entitled "The History of Peering in New Zealand". One entertaining hour later (NZNOG is good for audience participation) there were two or three people who volunteered to start a wiki based on the notes they had taken during the session. The wiki subsequently became a free-form repository for facts and anecdotes. InternetNZ later commissioned a book based (in part) on that material.

(The book was kind of governance-heavy and missed a lot of the operational war stories that I found more entertaining.)

This to me seemed like a good approach to Internet history: the anarchic commons free-edit with no pretension of journalistic integrity; the resulting pile of clues provides a basis for actual research.

Joe

---

From: Juliao Braga <[email-masked]>
Date: Thu, 23 May 2013 10:24:27 -0300

Nice job! Congratulations!

I would recommend to think in developing an ontology about the History
of the Internet. Starting with a vocabulary to be followed by all
involved and interested, worldwide.

There are several methodologies to target these work. An excellent, for
anyone interested:

Building Ontologies & Knowledge Elicitation by Alan Rector & colleagues
(http://www.cs.man.ac.uk/~rector/modules/CS646/Lecture-Handouts/Lect-2-Ontology-building-2007.pdf)

Julião

Em 22/05/2013 18:17, Elizabeth Feinler escreveu:
> 
> 
> Dear All,
> 
> At the IETF BoF in Orlando we learned that Kilam Chon and his colleagues
> have made a good start on a  structure for collecting the history of
> networking.
> 
> See:
> https://sites.google.com/site/internethistoryasia/country-region-information 
>

---

From: SM <[email-masked]>
Date: Thu, 23 May 2013 08:12:13 -0700

At 05:10 23-05-2013, Joe Abley wrote:
>I made a brief presentation at a NZNOG meeting in Hamilton a few 
>years ago entitled "The History of Peering in New Zealand". One 
>entertaining hour later (NZNOG is good for audience participation) 
>there were two or three people who volunteered to start a wiki based 
>on the notes they had taken during the session. The wiki 
>subsequently became a free-form repository for facts and anecdotes. 
>InternetNZ later commissioned a book based (in part) on that material.
>
>(The book was kind of governance-heavy and missed a lot of the 
>operational war stories that I found more entertaining.)
>
>This to me seemed like a good approach to Internet history: the 
>anarchic commons free-edit with no pretension of journalistic 
>integrity; the resulting pile of clues provides a basis for actual research.

The approach mentioned above looks practical.  I suggest using it as 
a starting point instead of a top-down approach.

Regards,
-sm

---

From: Elizabeth Feinler <[email-masked]>
Date: Thu, 23 May 2013 11:57:12 -0700

Joe and Scot,

I think both of you have pointed out that there is probably no "right" way to document history.  My personal opinion is that both top down and bottom up are useful and that any approach that fills out the whole picture truthfully is useful.  It might be interesting at some point to document some of the various approaches that have been taken and their impact.

Jake

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 24 May 2013 08:17:04 +1200

Joe,

...
> This to me seemed like a good approach to Internet history: the anarchic commons free-edit with no pretension of journalistic integrity; the resulting pile of clues provides a basis for actual rese…

There's a lot to what you say, but there is one aspect that's quite worrying
in informal crowdsourcing of the material: long-term retention.

Fact: stuff that you thought was nicely available on the Web turns out to
unavailable five years later, except perhaps via the wayback machine.

Example: CERN has recently been searching for a copy of the original
first web page ever.

Example: some of the "archival" sources I used for my own recent book
turned out to have vanished when I did a final pre-publication check
of their URLs.

I think it is essential to have an organised method of securing copies
of material and putting them somewhere that has a high probability
of long-term survival. Crowdsourcing is a *great* method of getting the
material, but a lousy method of collecting and preserving it.

My conclusion is that we *do* need an organised team of curators.

     Brian

---

From: Jack Haverty <[email-masked]>
Date: Fri, 24 May 2013 19:59:12 -0700

On 05/23/2013 01:17 PM, Brian E Carpenter wrote:
> of material and putting them somewhere that has a high probability of 
> long-term survival. Crowdsourcing is a *great* method of getting the 
I agree that the most urgent need is one or more methods for capturing 
the history before it fades and changes beyond recognition.   As one of 
the people who lived through the early networking years of the 70s and 
80s, I've been pretty disappointed when I've read some of the "history 
of the Internet" books, which often seem to be recounting the history of 
some other Internet from the one I was involved with.

There's been a lot of historical "testimony" over the last few years on 
this mailing list.  But, like other old mailing lists, it may or may not 
survive.   I'm certain that a lot of interesting history was embodied in 
the old mailing lists like header-people, but doesn't survive even three 
decades later.

Perhaps some corporate or government sponsor could be intrigued to serve 
simply as a long-term repository?   Smithsonian?  Google?

The other immediate task of urgency is to simply define a framework for 
capturing such informal items as email discussions, or old out-of-print 
documents, so that the nature of the content -- the metadata --  is 
retained.   Are statements eyewitness accounts "I was at the meeting and 
XXX...", or hearsay "XXX told me that..." or analytic conclusion "I 
examined 3 years of emails and concluded that ....", or simply 
speculation "XXX happened just before YYY so XXX was the reason that YYY 
decided to..." or maybe even revisionist work "Everyone knows that XXX...".

This would enormously help some future historians trying to piece 
together what actually happened from all of the opinions and variants of 
reality that will undoubtedly emerge.

For example, I recently did some garage archaeology and unearthed my 
notebooks from the late 70s and early 80s with all my notes from various 
meetings of TCP, IP, ICCB/IAB, and other meetings of the early working 
groups.  If I scan them before the ink blurs beyond readability, where 
should I FTP the files...?

/Jack Haverty

---

From: Dave Crocker <[email-masked]>
Date: Sun, 26 May 2013 03:40:43 +0200

> should I FTP the files...?

When considering an effort to specify a mechanism, I'm a fan of use 
cases, to guide everyone's thinking.  Use cases are typically simple, 
concrete, direct and realistic.

The above seems to me to be one of the more iconic examples for the 
current effort.  I'd think that if the effort develops a useful, 
scalable answer, it will have significantly improved the world's 
long-term archiving of Internet historical data.

What other questions should be on the list?

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: George Michaelson <[email-masked]>
Date: Sun, 26 May 2013 12:00:38 +1000

I said this at the Orlando meeting but I'd like to repeat it here:

There is an entire discipline dedicated to collecting, curating, archiving.

There is an entire discipline dedicated to collecting oral history.

Why does the IETF always have to act as if it, and only it, is capable of
defining how to do _anything_ ?

Instead of beating our heads against the wall 'designing' how to do net
history, why don't we do outreach to the people who have formalized
processes and methods, to collect, collate and archive this kind of thing?

Sometimes, we aren't actually the right people to do things.

Lets get in touch with the Sussex University social history people, the
history of science schools in the US, Asia, and lets get them assigning
their brilliant minds to this problem. They have students, dying for theses
topics, students who need honors projects, busting to be assigned something
juicy to work on.

Lets get them working on us.

-George

On Sun, May 26, 2013 at 11:40 AM, Dave Crocker <[email-masked]> wrote:

> When considering an effort to specify a mechanism, I'm a fan of use cases,
> to guide everyone's thinking.  Use cases are typically simple, concrete,
> direct and realistic.
>
> current effort.  I'd think that if the effort develops a useful, scalable
> answer, it will have significantly improved the world's long-term archiving
> of Internet historical data.
>
> ______________________________**_________________
> Nethistory mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/nethistory<https://www.ietf.org/mailman/listinfo/nethistory>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 26 May 2013 14:55:37 +1200

> processes and methods, to collect, collate and archive this kind of thing?

I thought that was the idea; at least that was how I interpreted
Elizabeth Feinler's message. But sourcing the raw data is something
that only the networking community itself can do, and a structure for
that is needed.

I think you'll find there's already oral history around from some
pioneers, in the generic oral history collections. For example,
http://conservancy.umn.edu/handle/107241. Fairly obviously, whatever
we collect would be best added to one of the existing archives.

     Brian
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Nethistory mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nethistory

---

From: Marc Weber <[email-masked]>
Date: Sun, 26 May 2013 13:32:08 -0700

The IETF BoF and Nethistory mailing list were initiated by professionals and practitioners in exactly the disciplines George Michaelson describes. I'm chair, I founded the Internet History Program at the largest collecting computer history museum in the world (CHM), have done hundreds of oral histories, and collaborate regularly with a dozen peer institutions. Jake Feinler has been an advisor and core volunteer to the Computer History Museum for a decade.

So why networking history at the IETF? Because a huge amount of historically important networking material is NOT finding its way to the formal institutions that are equipped to preserve it – including material generated by the IETF itself and its participants. 

If you read our draft charter and slide show (http://www.ietf.org/proceedings/86/history.html), you'll see that our primary goal is to be a matchmaker between at-risk materials and permanent archiving institutions in different countries. The goal is not to "design" net history – as George correctly points out it has long been designed – but to help get more of the source materials on which it depends into the hands of the professionals who can preserve it. 

Some of that professional community does, indeed, include students in the history of technology and related fields as George suggests. As Brad Fidler of UCLA mentioned in his videoconference presentation at the History BoF in Orlando, his program already has two interns working on the goals of the Nethistory mailing list. This shows that one way to get students involved is through history activities within the IETF. 

Perhaps most important, the idea of hosting this sort of effort within a technical standards body or organization is not nearly as singular as it may sound. There are history functions of differing kinds within the IEEE, ACM, and W3C (some of whom are following our IETF efforts with interest), and I'm sure several others. In all cases the goal is put those functions close to where history is being made, and to leverage the geographic reach of such bodies to better preserve it and make it known. 

- Marc

p.s. oral histories were not presented as a top goal at the BoF, but George brings them up and Brian Carpenter correctly notes the Charles Babbage Institute at the University of Minnesota as one major repository. CHM has conducted or collected over 600 video oral histories, including nearly 200 in networking, and taken together dedicated networking history efforts like Andreu Vea's WiWiWi.org (he came in at the BoF by videolink) and the earlier Web History Project that I co-founded have done hundreds more. However, the majority of pioneers interviewed have been in North America and Europe, and this is where the an international effort as through the IETF can help address the rest of the world.  

>>> What other questions should be on the list?

Marc Weber  |   [email-masked]  |   +1 415 282 6868 
Internet History Program Founder and Curator, Computer History Museum            
1401 N Shoreline Blvd., Mountain View CA 94043 computerhistory.org/nethistory
Co-founder, Web History Center and Project, webhistory.org

---

From: Andrew Russell <[email-masked]>
Date: Mon, 27 May 2013 12:04:53 -0400

Hello, I'm an academic historian of technology/computing/networking, and hence a user of the materials that this group seeks to preserve and make available to scholars.  I think this is a very important effort, and I'm delighted to see it gaining momentum - especially since I have had a hard time finding some of the IETF's own materials (such as the poised mailing list archives).  

Since this group aspires to act as a matchmaker, I thought I would share my thoughts about matches that you might make. I missed the Orlando BoF, so please forgive me if I'm telling you things you already know.

1. In addition to the Computer History Museum and Charles Babbage Institute (which have already been mentioned), American scholars active in this field regularly work with collections at the Hagley Museum and Library <http://www.hagley.lib.de.us/>; the Smithsonian Lemelson Center <http://invention.smithsonian.org/home/>; and the MIT Institute Archives <http://libraries.mit.edu/archives/>.  There are many others, but these are the first to come to mind.  You may want to reach out to staff at each of those institutions, or at least add them to any list/wiki you assemble. It's also worth noting that CBI, Hagley, and Lemelson offer fellowships for scholars who want to travel to and use their collections, which is a major factor for graduate students and academics who aren't exactly flush with cash!  Colleagues who are not based in the US may be able to provide more information about non-American institutions with similar missions.

2. The Society for the History of Technology (SHOT) has at least two SIGs that you may wish to engage: SIGCIS (http://www.sigcis.org/, Special Interest Group for Computers, Information, & Society); and TEMSIG (http://temsig.org/, Technology and Museums Special Interest Group). SHOT <http://www.historyoftechnology.org/> is a large international organization, and SIGCIS and TEMSIG together have several hundreds of members (scholars, museum professionals, etc.) from around the world, primarily in the US, Asia, and Europe.  If I were to make only one suggestion to this group, I would say that you should reach out to these professionals via the mailing lists of SIGCIS and TEMSIG.

3. As Marc Weber alluded, the professional societies also maintain an interest in history, including the IEEE History Committee <http://www.ieee.org/about/history_center/history_committee.html>, the IEEE Computer Society History Committee <http://www.computer.org/portal/web/volunteercenter/history>, and the ACM History Committee <http://history.acm.org/>.  Naturally, these groups are interested primarily in their own histories, but the affiliations and interests of the various members of these committees are broader and more diverse. Many leaders of these committees are active in SHOT and are subscribed to the SIGCIS and/or TEMSIG lists.  

4. The IEEE Global History Network <http://www.ieeeghn.org/> might also be a compelling model or destination for your efforts. Since it is not a traditional paper and artifact-based archive, it might be better suited for hosting scanned or "born digital" materials.

5. Finally, the historian of computing James Cortada recently published "History Hunting: A Guide for Fellow Adventurers" (publisher page is http://www.mesharpe.com/mall/resultsa.asp?Title=History+Hunting%3A+A+Guide+for+Fellow+Adventurers).  Dave Walden published a review of this book - with some of his own reflections on history-collecting and writing - in the most recent issue of the IEEE Annals of the History of Computing.  It's a very nice review of a book that is directly on point for this effort in the IETF.  IEEE members can get the review from http://www.computer.org/csdl/mags/an/2013/01/index.html.  If you can't get access, please contact me or Dave Walden if you'd like to read it; or, as Dave urged in his review, buy _History Hunting_ and read it!

I'm active in several of the groups I mentioned above, and I would be happy to make introductions or provide more information if you think it's helpful.

Please keep up the good work - we (historians) need you!!!

Cheers,

Andy Russell
College of Arts & Letters
Stevens Institute of Technology
http://www.stevens.edu/cal/sts
http://arussell.org

On May 25, 2013, at 10:00 PM, George Michaelson <[email-masked]> wrote:

> Why does the IETF always have to act as if it, and only it, is capable of defining how to do _anything_ ? 
> 
> Instead of beating our heads against the wall 'designing' how to do net history, why don't we do outreach to the people who have formalized processes and methods, to collect, collate and archive this kind of thing?
> 
> Lets get in touch with the Sussex University social history people, the history of science schools in the US, Asia, and lets get them assigning their brilliant minds to this problem. They have students, dying for theses topics, students who need honors projects, busting to be assigned something juicy to work on.
> 
> When considering an effort to specify a mechanism, I'm a fan of use cases, to guide everyone's thinking.  Use cases are typically simple, concrete, direct and realistic.
> 
> The above seems to me to be one of the more iconic examples for the current effort.  I'd think that if the effort develops a useful, scalable answer, it will have significantly improved the world's long-term archiving of Internet historical data.
>