Subject: RE: MPLS and NETLMM (was RE: [netlmm] a couple of high-view questions)

From: "Narayanan, Vidya" <[email-masked]>
Date: Thu, 18 May 2006 16:56:53 -0700

> 
> That's not the way I took the earlier discussions.  I thought 
> the earlier discussions were to allow the use of MPLS for 
> bearer traffic and NETLMM should have hooks in its signaling 
> to make use of MPLS bearers.
> 

Hmmm.. What hooks are needed in signaling to do this? Isn't it just a
matter of whether IP-in-IP tunnels or IP-in-MPLS is used? Or, am I
missing something? 

Regards,
Vidya

> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> Of
> > Narayanan, Vidya
> > Sent: Wednesday, May 17, 2006 6:59 PM
> > To: Vijay Devarapalli; Pekka Savola
> > Cc: Petrescu Alexandru-AAP021; James Kempf; [email-masked]
> > Subject: MPLS and NETLMM (was RE: [netlmm] a couple of high-view
> > questions)
> > 
> > 
> > All,
> > There has been some discussion lately about the use of MPLS LSPs to 
> > carry NETLMM signaling. Traffic engineering has been quoted as a
> reason
> > to do this. I'm trying to understand the vision behind this 
> and what 
> > kind of traffic engineering benefits people see this offering.
> > 
> > I agree with Vijay's statement that TE would lead to per-MN 
> LSPs and 
> > that isn't exactly scalable.
> > 
> > So, is it just the thought of exploiting the existence of MPLS
> backbones
> > for transport of NETLMM signaling between the AR and MN? 
> Or, are there 
> > more reasons behind this?
> > 
> > Thanks,
> > Vidya
> > 
> > > -----Original Message-----
> > > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > > Of Vijay Devarapalli
> > > Sent: Wednesday, May 17, 2006 9:15 AM
> > > To: Pekka Savola
> > > Cc: Alexandru Petrescu; James Kempf; [email-masked]
> > > Subject: Re: [netlmm] a couple of high-view questions
> > >
> > > Pekka Savola wrote:
> > > > On Tue, 16 May 2006, Vijay Devarapalli wrote:
> > > >>> If an operator would want to do such a thing, they'll
> > > have to bear
> > > >>> the operational cost (lots of new state) and signalling
> > > that it implies.
> > > >>
> > > >> well, you see per-node GTP tunnels today.
> > > >
> > > > Well, I thought the purpose was to design something sane
> > > and scalable,
> > > > not reinvent past follies :-)
> > > >
> > > > Seriously, it might be useful to point out why exactly per-node
> GTP
> > > > tunnels are being used and why it was designed the way it was.
> > >
> > > the last thing I would be doing is to defend the current 3G 
> > > architecture. no way. :)
> > >
> > > the main target for NETLMM work seems to be mobile operators.
> > > I am not yet convinced that MPLS could be used in an mobile 
> > > operators access network the way folks have been talking 
> about here 
> > > on this mailing list.
> > >
> > > Vijay
> > > _______________________________________________
> > > netlmm mailing list
> > > [email-masked]
> > > https://vesuvio.ipv6.cselt.it/mailman/listinfo/netlmm
> > >
> > 
> > _______________________________________________
> > netlmm mailing list
> > [email-masked]
> > https://vesuvio.ipv6.cselt.it/mailman/listinfo/netlmm
> 

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: tom wan <[email-masked]>
Date: Fri, 19 May 2006 10:03:44 +0800

I support this opinion, and I add some other comments:

implementation risk:
Currently, MPLS is mainly used  in the backbone network.
The use of MPLS in localized mobility management will lead
the use of MPLS in network access layer, the cost may be high,
 maybe this is a high fruit on the netlmm tree, and this solution may be 
hard
to be implemented.

current network environment:
the vital problem to the mobility performance is the wireless access
problem. MPLS has no impact between MN and access router.
So, if we want to improve the performance, maybe we should focuse
on the wireless access field.

Qos related consideration:
If we want to consider Qos in the netlmm, maybe we should consider
the interface between netlmm domain and backbone network first,
then we can consider the Qos policy within the netlmm domain. Thus,
the netlmm solution should be integrated into the current network.

In general, I think that adding MPLS to netlmm is a future solution, and 
currently
we should consider two topics for the performance optimization:
1 The Qos interface between netlmm domain and backbone.
2 the wireless access perfermance.

----- Original Message ----- 
From: "Narayanan, Vidya" <[email-masked]>
To: "Roberts Phil-APR042" <[email-masked]>; "Vijay Devarapalli" 
<[email-masked]>; "Pekka Savola" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, May 19, 2006 7:56 AM
Subject: RE: MPLS and NETLMM (was RE: [netlmm] a couple of high-view 
questions)

Regards,
Vidya

---

From: Pekka Savola <[email-masked]>
Date: Fri, 19 May 2006 08:28:36 +0300 (EEST)

I'd like to emphasize this.

Hopefully we all agree that:
  - we cannot depend on MPLS anywhere in the network
  - hence, the solution must work with pure-IP network
  - the solution however should not preclude from using MPLS below the 
unmodified NETLMM-IP behaviour
  - it may be debatable whether NETLMM behavior should have an 
optimization to also support MPLS directly, but I'd suspect there 
isn't clear consensus for this and that seems to be out of scope of 
main NETLMM goals.

Therefore I don't see exploring MPLS approaches particularly useful 
right now.

On Fri, 19 May 2006, tom wan wrote:
> maybe this is a high fruit on the netlmm tree, and this solution may be hard
> to be implemented.
>
> ----- Original Message ----- From: "Narayanan, Vidya" <[email-masked]>

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: "James Kempf" <[email-masked]>
Date: Sun, 21 May 2006 04:34:12 -0700

I agree.

At some point after we have the base solution complete, we can look into 
MPLS as an alternative for tunnel management. The important point now is 
that the bse NETLMM protocol allow the type of tunnel between the LMA and 
MAG to be configurable.

            jak

----- Original Message ----- 
From: "Pekka Savola" <[email-masked]>
To: "tom wan" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, May 18, 2006 10:28 PM
Subject: Re: MPLS and NETLMM (was RE: [netlmm] a couple of high-view 
questions)

>  - it may be debatable whether NETLMM behavior should have an optimization 
> to also support MPLS directly, but I'd suspect there isn't clear consensus 
> for this and that seems to be out of scope of main NETLMM goals.
>
> Therefore I don't see exploring MPLS approaches particularly useful right 
> now.
>
>> To: "Roberts Phil-APR042" <[email-masked]>; "Vijay 
>> Devarapalli" <[email-masked]>; "Pekka Savola" 
>> <[email-masked]>
>> Cc: <[email-masked]>