Subject: [netlmm]When MN moves out of the LMMD

From: Andy Huang <[email-masked]>
Date: Wed, 31 May 2006 18:02:14 +0800

Hi,
I don't know if we should consider the following problem.

When MN moves out of the LMMD silently, it will take some time for AR to 
inform the LMA that MN has left the domain or MN has been power off. Then 
LMA delete the route for the MN.

Let's suppose MN uses MIPv6 as global mobility protocol. After MN gets its 
CoA from the new AR in another domain, MN will send BU to HA which probably 
locates in the LMMD.

Because we don't know for sure the location of HA. It's possible that the 
packet from CN is still routed to LMA before the LMA delete the route for 
the MN. So the packet is sent to the AR though MN has moved to another 
domain. It will lead to the disconnection of the current application. 

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 31 May 2006 08:28:55 -0700

> LMA delete the route for the MN.

Why do you assume that the AR would have to inform the LMA that the MN
has left the domain? It could be that the LMA simply times out the MNs
registration after a timeout period during which no keepalives are
received.
Also, how does the AR know the MN has left the domain as opposed to
having moved to some other AR within the same domain?

Fred
[email-masked]

---

From: Leon Ou <[email-masked]>
Date: Thu, 01 Jun 2006 09:01:22 +0800

I agree your question.  Now I have no answer. 
In another hand, I think Andy pointed out a very important requirement. It's about combination of netlmm and mipv6.

----- Original Message ----- 
From: "Templin, Fred L" <[email-masked]>
To: "Andy Huang" <[email-masked]>; <[email-masked]>
Sent: Wednesday, May 31, 2006 11:28 PM
Subject: RE: [netlmm]When MN moves out of the LMMD

Fred

---

From: Andy Huang <[email-masked]>
Date: Thu, 01 Jun 2006 10:04:47 +0800

hi, Templin
Thank you for your response.
What you said is not my point. No matter which kind of mechanism is used to 
release the MN's registration: lifetime expired or that AR inform LMA.
The point is  whether it will influence the normal handover process or not 
when MN moves to another domain.

----- Original Message ----- 
From: "Templin, Fred L" <[email-masked]>
To: "Andy Huang" <[email-masked]>; <[email-masked]>
Sent: Wednesday, May 31, 2006 11:28 PM
Subject: RE: [netlmm]When MN moves out of the LMMD

Fred