Subject: Re: [netlmm] Issue #74: Configurable Forwarding

From: "James Kempf" <[email-masked]>
Date: Thu, 1 Jun 2006 19:27:07 -0700

Tom,

Could you elaborate a little on your concern?

What I'm proposing is that the signaling protocol not include any built in 
assumption about the data plane forwarding mechanism. So it would just deal 
with updating the mobile node to access router binding. I don't see much 
need for anything in the protocol to specify what the forwarding mechanism 
is, since a mechanism would be associated with the route to the access 
router, so the access router identification would determine the forwarding 
mechanism. It might be necessary to specify a few mechanisms and how they 
are used in separate drafts, but not as part of the base protocol. The base 
protocol might include a default mechanism, probably a tunnel.

            jak

----- Original Message ----- 
From: "Tom Wan" <[email-masked]>
To: "James Kempf" <[email-masked]>; <[email-masked]>
Sent: Wednesday, May 31, 2006 7:53 PM
Subject: Re: [netlmm] Issue #74: Configurable Forwarding

> Or we should consider the possible relationship first.
> ----- Original Message ----- 
> From: "James Kempf" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, May 31, 2006 7:09 PM
> Subject: [netlmm] Issue #74: Configurable Forwarding
>
>
>>I just submitted some text for a goal in the REQ draft for the protocol to 
>>allow configurable data plane forwarding. There have been a number of 
>>suggestions about possible data plane forwarding options other than the 
>>usual IP-IP tunneling. I suggested adding this goal a couple times in the 
>>context of discussing a few other issues, and nobody seemed to be opposed 
>>to it, so I'd like to formalize it by adding this as a goal.
>>
>> Please send comments by next Friday if you have any. Thanx.
>>
>>            jak
>>
>>
>> _______________________________________________
>> netlmm mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/netlmm
>>
>
>
> 

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Leon Ou <[email-masked]>
Date: Fri, 02 Jun 2006 16:09:04 +0800

Hi all,
I think it's absolutely necessarily. In future architecture, it is very possible to connect LMAP and AR directly.( I mean it's point to point). At that case, any tunnel encapsulation is redundant.  LMAP forwards the packet for MN to AR directly without any encapsulation. So I support this item greatly.
----- Original Message ----- 
From: "James Kempf" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, May 31, 2006 7:09 PM
Subject: [netlmm] Issue #74: Configurable Forwarding

> context of discussing a few other issues, and nobody seemed to be opposed to 
> it, so I'd like to formalize it by adding this as a goal.
>