Subject: [netlmm] Finishing up draft-ietf-netlmm-nohost-req

From: "James Kempf" <[email-masked]>
Date: Tue, 13 Jun 2006 11:03:18 -0700

Now that we have (almost) concluded discussion on the PS draft, I'd like to 
get closure on the REQ draft.

Today concludes the discussion period on Issue # 74, Add Goal for Data Plane 
Configurable Forwarding. Review of the mail on the topic indicates support 
for adding the goal.

I would like to encourage people to read the current 02 version of the 
draft, take a look at the open issues, and post comments if you have any 
*now*. I intend to post an updated 02 version with all issues resolved  this 
Fri. I would really like to make 02 the last version, so that we can send it 
to the IESG after a short 1 week last call period ending on Fri next week, 
prior to the June 26 deadline. For this to happen, we need to have comments 
*by this Fri.*. If we miss the deadline, we must wait until late July to 
submit to the IESG, because the gate closes on June 26 until the week after 
IETF.

                jak 

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 14 Jun 2006 12:07:06 -0700

James et. al.,

Below are my comments on 'draft-ietf-netlmm-nohost-req-01.txt':

Fred
[email-masked] 

1) The term "IP link" is used extensively throughout the document,
but that term was removed from the ps draft. Suggest changing in
the same manner as was done for the ps.

2) Section 2.7, paragraph beginning: "In addition, an edge mobility
solution...", I am not so sure that support for multiple wireless
link technologies needs to occur in separate subnets. For example,
if a mobile node configures an IP address for sending packets over
wireless link A, it could assign the IP address to a loopback
interface (instead of an interface attached to wireless link A)
and also be able to use the same address for sending packets over
wireless link B.

I would prefer to see this paragraph as non-committal in terms
of supporting multiple wireless link technologies in the same
vs. different IP subnets and would prefer if it were shortened
to something like:

  "In addition, an edge mobility solution should provide support for
multiple 
   wireless link technologies. It is not required that the localized
mobility
   management solution support handover from one wireless link
technology to
   another without change in IP address, but this possibility should not
be
   precluded."

3) Section 2.8, second paragraph, sentence beginning: "While Mobile
IPv6 is clearly...", this seems to be making too strong of an
assumption for MIPv6 before the global mobility management problem
statement and gap analysis are completed. Suggest dropping this
sentence.

4) Section 9.3.1, under Goal #6, sentence beginning: "This precludes
stateful address allocation using DHCP..." is not necessarily true.
For example, the mobile node could autoconfigure CGAs then register
them with a stateful server in the network by sending a DHCP_SOLICIT
message that contains the CGA as an option. Suggest dropping this
sentence.

5) Section 9, "DHCP + IP forwarding table manipulation" should
be listed as another item for the gap analysis, but I don't see
a detailed analysis coming within the time remaining between now
and Friday. Suggest adding a very short subsection such as:

  "9.6 DHCP + IP forwarding table manipulation"

   It has been suggested that using DHCP on mobile nodes, access
   routers and localized mobility agents can provide a framework
   for localized mobility management when the DHCP exchanges are
   also tied to IP forwarding table manipulations on routers.
   This method requires further investigation before a gap analysis
   can be determined. In one alternative, DHCP could be seen as an
   access method for the eventual NETLMM protocol design."

Then (since the gap analysis is not complete) there should be
no entry for this alternative under the "Summary" section.

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 15 Jun 2006 15:41:42 -0700

> statement and gap analysis are completed. Suggest dropping this

I think the statement is true. so why remove it?

the gap analysis justifies the need for an Network based
LMM solution, not a replacement for Mobile IPv6.

Vijay

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 15 Jun 2006 15:50:19 -0700

Vijay,

The proposed resoultion was only to "remove the assumption
about Mobile IP but keep the rest of the sentence", and I
am OK with that. I don't mind leaving something in there
about Mobile IP but when I see statements like "clearly"
I have to ask "clearly in whose opinion"?

Fred

-----Original Message-----
From: Vijay Devarapalli [mailto:[email-masked]] 
Sent: Thursday, June 15, 2006 3:42 PM
To: Templin, Fred L
Cc: James Kempf; [email-masked]
Subject: Re: [netlmm] Finishing up draft-ietf-netlmm-nohost-req

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 15 Jun 2006 15:58:40 -0700

> I have to ask "clearly in whose opinion"?

in case you weren't aware of it, Mobile IPv6 is only standards
track host mobility protocol for IPv6 currently in the IETF.

I find this discussion a bit amusing. :)

Vijay

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 15 Jun 2006 15:59:55 -0700

> "While Mobile IP seems like it will play a major role in mobility
management 
> on the Internet going forward, <rest of sentence>"

How about simply: "While Mobile IP will play a role in mobility
management on the Internet going forward, ...". It seems like
pretty much the same thing you are saying; I would just prefer
to avoid superlatives like "clearly" or "major".

Fred

            jak

----- Original Message ----- 
From: "Templin, Fred L" <[email-masked]>
To: "Vijay Devarapalli" <[email-masked]>
Cc: "James Kempf" <[email-masked]>; <[email-masked]>
Sent: Thursday, June 15, 2006 3:50 PM
Subject: RE: [netlmm] Finishing up draft-ietf-netlmm-nohost-req

Vijay,

Fred

-----Original Message-----
From: Vijay Devarapalli [mailto:[email-masked]]
Sent: Thursday, June 15, 2006 3:42 PM
To: Templin, Fred L
Cc: James Kempf; [email-masked]
Subject: Re: [netlmm] Finishing up draft-ietf-netlmm-nohost-req

Vijay

---

From: "James Kempf" <[email-masked]>
Date: Thu, 15 Jun 2006 15:54:13 -0700

Fred,

If you're OK with including something about Mobile IP, then how about:

"While Mobile IP seems like it will play a major role in mobility management 
on the Internet going forward, <rest of sentence>"

            jak

----- Original Message ----- 
From: "Templin, Fred L" <[email-masked]>
To: "Vijay Devarapalli" <[email-masked]>
Cc: "James Kempf" <[email-masked]>; <[email-masked]>
Sent: Thursday, June 15, 2006 3:50 PM
Subject: RE: [netlmm] Finishing up draft-ietf-netlmm-nohost-req

Vijay,

Fred

-----Original Message-----
From: Vijay Devarapalli [mailto:[email-masked]]
Sent: Thursday, June 15, 2006 3:42 PM
To: Templin, Fred L
Cc: James Kempf; [email-masked]
Subject: Re: [netlmm] Finishing up draft-ietf-netlmm-nohost-req

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 15 Jun 2006 16:11:53 -0700

James Kempf wrote:
> Fine with me. Vijay, what do you think?

fine with me.

> 
>            jak
> 
> ----- Original Message ----- From: "Templin, Fred L" 
> <[email-masked]>
> To: "James Kempf" <[email-masked]>; "Vijay Devarapalli" 
> <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, June 15, 2006 3:59 PM
> ----- Original Message ----- From: "Templin, Fred L" 
> <[email-masked]>

---

From: "James Kempf" <[email-masked]>
Date: Thu, 15 Jun 2006 15:51:56 -0700

Vijay/Fred,

As this exchange of email demonstrates, the current statement in the 
document is a matter of opinion (mine actually). Fred has one opinion, Vijay 
another. As such, unless there is WG concensus for the opinion (which so 
far, I don't see), it seems prudent to remove it from the document. It is 
also such a small point that I really would prefer not to hold up advancing 
the document for it. If necessary, I can include a note in the WG chairs 
report to the IESG about the document, that this point was debated in the 
WG.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Thu, 15 Jun 2006 16:08:25 -0700

jak

----- Original Message ----- 
From: "Templin, Fred L" <[email-masked]>
To: "James Kempf" <[email-masked]>; "Vijay Devarapalli" 

management

Fred

            jak

----- Original Message ----- 
From: "Templin, Fred L" <[email-masked]>
To: "Vijay Devarapalli" <[email-masked]>
Cc: "James Kempf" <[email-masked]>; <[email-masked]>
Sent: Thursday, June 15, 2006 3:50 PM
Subject: RE: [netlmm] Finishing up draft-ietf-netlmm-nohost-req

Vijay,

Fred

-----Original Message-----
From: Vijay Devarapalli [mailto:[email-masked]]
Sent: Thursday, June 15, 2006 3:42 PM
To: Templin, Fred L
Cc: James Kempf; [email-masked]
Subject: Re: [netlmm] Finishing up draft-ietf-netlmm-nohost-req

Vijay