Subject: Re: [netlmm] Network-based mobility - NETLMM DTSolution VsAsolutionbased on MIP6

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 30 Oct 2006 08:32:13 -0800 (PST)

Hi Fred,

  It looks like the MAP in your draft is in fact DHCP server? It seems certain MAP is not from RFC 4140. 
  Reading more your draft, you seem to need something more than  a DHCP server because the tunneling is involved so that's why you called it MAP.

  I wonder if your draft has anything to do with autoconfigure WG which does MANET. This solution does not seem to differ much from DT draft, IMHO.

--behcet

----- Original Message ----
From: "Templin, Fred L" <[email-masked]>
To: Henrik Levkowetz <[email-masked]>; "Narayanan, Vidya" <[email-masked]>
Cc: [email-masked]
Sent: Friday, October 27, 2006 4:07:02 PM
Subject: RE: [netlmm] Network-based mobility - NETLMM DTSolution VsAsolutionbased on MIP6

Hello Henrik,

> What's really relevant to the Internet Engineering Task Force is what
> the requirements are, and how well the proposed solution(s) fulfil the
> requirements.  That's engineering.
>
> Can we get back to doing engineering, please?

In my 10/23/06 netlmm post, I asked:

  "So do we really need a new protocol for NETLMM, or would
  it be better to take some of the nice features from the
  DT work and fold them into a DHCP(bis) effort? (Or, can
  we just use existing DHCP mechanisms as a "good-enough"
  solution?)"

and, those were intended as engineering questions and not
bickering as to why the DT didn't pick my favorite solution.
That is why I abstained from the ballot; I am not saying no
to the DT work - only that there are engineering questions
left to discuss.

Thanks - Fred
[email-masked]

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 30 Oct 2006 09:44:50 -0800

Hi Behcet,

> It looks like the MAP in your draft is in fact DHCP server?
> It seems certain MAP is not from RFC 4140.

Yes; from 'draft-templin-autoconf-netlmm-dhcp-04.txt' the
term "MAP" is defined within the scope of the document and
w/o reference to RFC4140, which I guess should be OK for a
document that has not yet been accepted as a wg item? 

> Reading more your
> draft, you seem to need something more than  a DHCP server
> because the tunneling is involved so that's why you called
> it MAP.

Right; tunneling and also IP forwarding capability and
participation in the IGP.
 
> I wonder if your draft has anything to do with autoconfigure
> WG which does MANET.

I agree that the specifications in the draft are useful for
MANET/Autoconf, but MANET would be just another example of an
access network techology. So, maybe the "-autoconf" portion
of the draft name could just be dropped (maybe the "-dhcp"
portion of the name also). But, I guess that would require
re-issuing as: "draft-templin-netlmm-00.txt"?

> This solution does not seem to differ
> much from DT draft, IMHO.

Another way to look at it is that the DT draft does not
seem to differ too much from DHCP. (Or, at least it seems
to have benefitted from prior knowledge of DHCP with a
desire to "do things better" for NETLMM?)

Thanks for the comment,

Fred
 
--behcet

----- Original Message ----
From: "Templin, Fred L" <[email-masked]>
To: Henrik Levkowetz <[email-masked]>; "Narayanan, Vidya"
<[email-masked]>
Cc: [email-masked]
Sent: Friday, October 27, 2006 4:07:02 PM
Subject: RE: [netlmm] Network-based mobility - NETLMM DTSolution
VsAsolutionbased on MIP6

Hello Henrik,

Thanks - Fred