Subject: RE: How does "per-MN prefix model" simplify things? (was: RE: [netlmm] Re: PMIP follow-up questions)

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 31 Oct 2006 09:58:08 -0800

> Per-MN prefix is used when it is point-to-point link, on shared
> links, the shared prefix model is used.

Actually, I think the link type is somewhat irrelevant;
there could be a shared prefix (for address configuration
only; not on-link determination) on interfaces attached
to p2p links, and there could be per-MN prefixes assigned
on interfaces attached to shared links.

Fred
[email-masked]

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 31 Oct 2006 09:52:08 -0800 (PST)

Per-MN prefix is used when it is point-to-point link, on shared links, the shared prefix model is used. 
So I do not think it is "simplifies lot of things" thing.
Now, in netlmm DT solution, they had the per-MN prefix because the address model netlmm DT solution essentially ends up creating p2p links for each MN that they support.
There is no mistery, and no rocket science.
I do not agree that per-MN prefix wastes address space, for IPv6, it does not.

--behcet

----- Original Message ----
From: "Templin, Fred L" <[email-masked]>
To: Sri Gundavelli <[email-masked]>; Alexandru Petrescu <[email-masked]>
Cc: [email-masked]; "Soliman, Hesham" <[email-masked]>; Basavaraj Patil <[email-masked]>
Sent: Tuesday, October 31, 2006 11:36:16 AM
Subject: How does "per-MN prefix model" simplify things? (was: RE: [netlmm] Re: PMIP follow-up questions)

> However, per-MN prefix model simplifies lot of things.

We have seen the assertion "per-MN prefix model simplifies
(a) lot of things" mentioned many times, but so far I have
not seen the issues enumerated. I know about the requirement
for domain-wide proxy-DAD for the shared prefix/shared link
model, but that's all I know about.

If there is a commonly-held belief that the per-MN prefix
model simplifies "a lot of things" (and not just one thing),
then someone should step up and enumerate the issues here
on the list.

Thanks - Fred

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 31 Oct 2006 19:20:12 +0100

> links, the shared prefix model is used.

This is not really appropriate analogy IMHO, see below why.

> So I do not think it is "simplifies lot of things" thing. Now, in
> netlmm DT solution, they had the per-MN prefix because the address
> model netlmm DT solution essentially ends up creating p2p links for
> each MN that they support.

Relevant RFC for point-to-point links include IPv6 PPP (RFC 2472) and
that doesn't recommend prefix-per-mobile, it just recommends how the
mobile derives its IID from an id given by a server, and that a /64
prefix should be used.

IPv6 Fibre Channel (RFC 4338), IPv6 IEEE 1394 (rfc3146.txt), IPv6 PVC
ATM (rfc 2492) are all point-to-point in nature, all request 64 prefix -
and none recommends a prefix per host.

Being point-to-point doesn't mean being prefix-per-host.

> There is no mistery, and no rocket science. I do not agree that 
> per-MN prefix wastes address space, for IPv6, it does not.

Does it gain any address space?

Alex