Subject: RE: [Mip6] RE: [netlmm] Network-based mobility - NETLMM DT Solution VsA solutionbased on MIP6

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Mon, 16 Oct 2006 21:48:09 -0700

Hi Vidya.  Sorry for the delay.

Some SDOs have adopted PMIPv4 but not for localized MM within the access
network (which is the scope of NetLMM).  

I think we should clarify the difference between non-MIPv6 mobility
option re-use vs. re-usable MIPv6 Home Agent.  Maybe this is something
the PMIPv6 camp should sort out first? ;)
I believe this is part of the questions posed by Phil on the consensus
call results.

Kent

-----Original Message-----
From: Narayanan, Vidya [mailto:[email-masked]] 
Sent: Wednesday, October 11, 2006 6:42 PM
To: Kent Leung (kleung); [email-masked]
Cc: [email-masked]
Subject: [Mip6] RE: [netlmm] Network-based mobility - NETLMM DT Solution
VsA solutionbased on MIP6 

Hi Kent,
If there is a need for IPv4 signaling usage, I agree with you. But, I'm
not so sure that there is a need for that, practically speaking. I think
many of those who want v4-signaled network-based mobility have gone a
non-standard PMIPv4 route already - is that not true? 

If we have a real need for IPv4 signaling, then we could potentially say
that there is a need for two different standards in this space - one
that allows for running over IPv4 and another that allows maximum re-use
of already defined mobility options. 

But, if the industry adopted the latter solution today for sake of
re-use, do we ever expect the former one being deployed? Or, would the
world simply do v6-in-v4 tunneling or the non-standard PMIPv4 when a
solution over v4 is needed? 

I don't know the answer :) 

Vidya

> -----Original Message-----
> From: Kent Leung (kleung) [mailto:[email-masked]]
> Sent: Wednesday, October 11, 2006 9:51 AM
> To: Narayanan, Vidya; [email-masked]
> Cc: [email-masked]
> Subject: RE: [netlmm] Network-based mobility - NETLMM DT Solution Vs A

> solutionbased on MIP6
> 
> Hi Vidya.  I don't see why running NetLMM signaling over IPv4 should 
> be precluded by design?  Having such flexibility is a valuable asset 
> for a standards based network-control mobility management protocol, 
> IMHO.
> 
> Kent
> 
> -----Original Message-----
> From: Narayanan, Vidya [mailto:[email-masked]]
> Sent: Friday, October 06, 2006 8:24 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [netlmm] Network-based mobility - NETLMM DT Solution Vs A 
> solutionbased on MIP6
> 
> 
> <snip>
> What does the NETLMM DT Solution bring, by being totally different 
> from MIP6?
> --------------------------------------------------------------
> ----------
> ------
> 
> 1. The protocol can be evolved to using a reliable transport protocol 
> like SCTP at some point.
> 2. The protocol can run over IPv4 without changes. 
> 
> While these seem like good goals, what is the practical need for the 
> above goals? For instance, is IPv4 signaling a necessity for a NETLMM 
> solution?
> 
> <snip>
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Tue, 17 Oct 2006 11:27:15 -0700

Hi Kent, 

> Sent: Monday, October 16, 2006 9:48 PM
> Subject: RE: [Mip6] RE: [netlmm] Network-based mobility - 
> NETLMM DT Solution VsA solutionbased on MIP6 
> 
> Some SDOs have adopted PMIPv4 but not for localized MM within 
> the access network (which is the scope of NetLMM).  
> 

That is true. But, the question I have is whether their solution for
localized MM will be any different. As far as I know, a v6 protocol that
also allows support for v4 hosts seems to be the use case - but, I see
the point that this may not be universally true. So, it would help to
understand the real world use cases. 

> I think we should clarify the difference between non-MIPv6 
> mobility option re-use vs. re-usable MIPv6 Home Agent.  Maybe 
> this is something the PMIPv6 camp should sort out first? ;) I 
> believe this is part of the questions posed by Phil on the 
> consensus call results.
> 

I think this would be a good thing to sort out first. A full MIP6 HA
re-use is an unrealistic goal IMHO, given that it will lead to a
sub-optimal protocol with patches to MIP6 - but, it would be good to
have that discussion at this time. 

Vidya

> Subject: [Mip6] RE: [netlmm] Network-based mobility - NETLMM 
> DT Solution VsA solutionbased on MIP6 
> 
> Hi Kent,
> If there is a need for IPv4 signaling usage, I agree with 
> you. But, I'm not so sure that there is a need for that, 
> practically speaking. I think many of those who want 
> v4-signaled network-based mobility have gone a non-standard 
> PMIPv4 route already - is that not true? 
> 
> If we have a real need for IPv4 signaling, then we could 
> potentially say that there is a need for two different 
> standards in this space - one that allows for running over 
> IPv4 and another that allows maximum re-use of already 
> defined mobility options. 
> 
> But, if the industry adopted the latter solution today for 
> sake of re-use, do we ever expect the former one being 
> deployed? Or, would the world simply do v6-in-v4 tunneling or 
> the non-standard PMIPv4 when a solution over v4 is needed? 
>