Subject: [netlmm] Re: PMIP follow-up questions (was RE: Why is PMIP...)

From: "James Kempf" <[email-masked]>
Date: Wed, 1 Nov 2006 01:06:10 -0800

Hesham,

So are you saying that a RFC 3775 home agent can be reused without 
modification for PMIP?

            jak

----- Original Message ----- 
From: "Soliman, Hesham" <[email-masked]>
To: "Templin, Fred L" <[email-masked]>; "Jean-Mickael Guerin" 
<[email-masked]>
Cc: "Basavaraj Patil" <[email-masked]>; "ext James Kempf" 
<[email-masked]>; "Phil Roberts" <[email-masked]>; 
"Narayanan, Vidya" <[email-masked]>; <[email-masked]>
Sent: Tuesday, October 31, 2006 7:48 PM
Subject: RE: PMIP follow-up questions (was RE: Why is PMIP...)

 > OK, I think I get it now. Then, I guess in a nutshell this
 > whole thing is just about two flavors of UDP messaging vs.
 > mobility header? So between NETLMM/DT, NETLMM/DHCP and PMIP

=> Yes!

 > IMHO it seems like we are just splitting hairs here...

=> No. There is a significant difference when you consider *reuse*, an
important concept of SW and product design. We're not just talking about
a "mobility header", we're talking about reusing existing
implementations/infrastructure as much as possible. I think we can reuse
MIPv6 to a very significant degree here.

Hesham

 >
 > Fred
 > [email-masked]
 > 

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: <[email-masked]>
Date: Wed, 1 Nov 2006 10:41:45 -0600

>=> No. There is a significant difference when you consider 
>*reuse*, an important concept of SW and product design. We're 
>not just talking about a "mobility header", we're talking 
>about reusing existing implementations/infrastructure as much 
>as possible. I think we can reuse
Thanks for making this distinction clearer. When we talked about
UDP, SCTP etc in the DT, it was merely a transport header to
carry the bits on the wire. When you talk about MH, it is much
more than that.

-mohan

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Wed, 1 Nov 2006 10:46:54 -0800

> Thanks for making this distinction clearer. When we talked 
> about UDP, SCTP etc in the DT, it was merely a transport 
> header to carry the bits on the wire. When you talk about MH, 
> it is much more than that.
> 

Exactly! I find it really strange that we cannot get an agreement on the
value of re-use here. I also don't understand the resistance to using MH
- nobody seems to want to talk about the real benefits in *not* re-using
and rather designing from scratch. 

I find it very difficult to have a meaningful technical discussion here
to make progress, given the situation :( 

Vidya

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 1 Nov 2006 11:41:07 -0800

Hesham,

> MIPv6 to a very significant degree here.

If you want to consider reuse as a factor, then a
similar statement could be made about reuse of DHCP
per the NETLMM/DHCP proposal.

One possible outcome could be that some of the nice
features of the NETLMM/DT work (of which there are
several) could go as material for a DHCPv6(bis) effort.
But, that is just one possible outcome.

Fred

---

From: Katsutoshi Nishida <[email-masked]>
Date: Mon, 06 Nov 2006 15:20:49 +0900

Hi,

As a member of DT, my understanding of why we did not take MH is because
DT protocol at the later stage envisions to support both IPv4 and IPv6
terminals/network entities current DT protocol has completed as a base
protocol targeting IPv6 only. 

In 3GPP, there is clear requirement that Mobility between access systems,
e.g. 3G and WLAN, supporting different IP versions should be supported
with minimum network/terminal impacts. 

This means it is required that a single protocol can be applicable for
both IPv4 and IPv6 entities. In practical manner, the commercial use of
IPv6 will not come in a day, so it is important for NETLMM WG output
protocol to support IPv4 only entity considering the migration aspect.

Katsutoshi

On Wed, 01 Nov 2006 10:46:54 -0800

> to make progress, given the situation :( 

Regards,
Katsutoshi