Subject: [netlmm] RE: PMIP follow-up questions (was RE: Why is PMIP...)

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 1 Nov 2006 01:56:01 -0800

> So are you saying that a RFC 3775 home agent can be reused without 
 > modification for PMIP?

=> No I said: "we're talking about reusing existing
implementations/infrastructure as much as possible. I think we can reuse
MIPv6 to a very significant degree here."

Which means that if we go down the path of PMIPv6 with the requirement
to maximise reuse, I am confident that if there are any extensions to
MIPv6 they will be relatively small. Of course the real issue here is
whether people agree with the requirement before we start discussing how
to achieve it.

Hesham

 > 
 >             jak
 > 
 > ----- Original Message ----- 
 > From: "Soliman, Hesham" <[email-masked]>
 > To: "Templin, Fred L" <[email-masked]>; 
 > "Jean-Mickael Guerin" 
 > <[email-masked]>
 > Cc: "Basavaraj Patil" <[email-masked]>; "ext James Kempf" 
 > <[email-masked]>; "Phil Roberts" 
 > <[email-masked]>; 
 > "Narayanan, Vidya" <[email-masked]>; <[email-masked]>
 > Sent: Tuesday, October 31, 2006 7:48 PM
 > Subject: RE: PMIP follow-up questions (was RE: Why is PMIP...)
 > 
 > 
 > 
 > 
 >  > OK, I think I get it now. Then, I guess in a nutshell this
 >  > whole thing is just about two flavors of UDP messaging vs.
 >  > mobility header? So between NETLMM/DT, NETLMM/DHCP and PMIP
 > 
 > => Yes!
 > 
 >  > IMHO it seems like we are just splitting hairs here...
 > 
 > => No. There is a significant difference when you consider 
 > *reuse*, an
 > important concept of SW and product design. We're not just 
 > talking about
 > a "mobility header", we're talking about reusing existing
 > implementations/infrastructure as much as possible. I think 
 > we can reuse
 > MIPv6 to a very significant degree here.
 > 
 > Hesham
 > 
 >  >
 >  > Fred
 >  > [email-masked]
 >  > 
 > 
 > 

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "James Kempf" <[email-masked]>
Date: Wed, 1 Nov 2006 02:11:56 -0800

Then speaking with my service provider hat on, I don't see any real benefit, 
since I have to deploy a new set of network boxes regardless of which 
solution I use. From a vendor viewpoint, if I need to change the home agent 
code, then I still need to go through a QA and beta cycle to make sure that 
the code works. Maybe there's a bit less work, since I don't need to 
implement something from scratch, but most of the work in software 
development for product release is in the downstream anyway, so I guess I 
don't see much benefit for vendors either.

            jak

----- Original Message ----- 
From: "Soliman, Hesham" <[email-masked]>
To: "James Kempf" <[email-masked]>; "Templin, Fred L" 
<[email-masked]>; "Jean-Mickael Guerin" 
<[email-masked]>
Cc: "Basavaraj Patil" <[email-masked]>; "Phil Roberts" 
<[email-masked]>; "Narayanan, Vidya" <[email-masked]>; 
<[email-masked]>
Sent: Wednesday, November 01, 2006 1:56 AM
Subject: RE: PMIP follow-up questions (was RE: Why is PMIP...)

Hesham