Subject: Re: [netlmm] Link Local Addressing Semantics

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 8 Dec 2006 09:29:03 -0800 (PST)

Hi Julien,
  As per the decision taken at San Diego WG meeting, we probably do not have to worry about MAG and LMAs any more.
  However, we might wish to discuss what should be the new link model and I guess this was the reason why this thread was opened. 
  In PMIP model, MN does not get its traffic from the netLMM address but instead uses its HoA, what are the implications of this from the multilink subnet point-of-view? 
  I think that with this new model the multilink subnet is created at the home link and the solution (per-MN prefix) should apply to HoA and MN can use whatever is available in its present subnet for local address configuration of its CoA.
  What do you think?

--behcet

----- Original Message ----
From: Julien Laganier <[email-masked]>
To: [email-masked]
Cc: "Templin, Fred L" <[email-masked]>
Sent: Friday, December 8, 2006 8:56:58 AM
Subject: Re: [netlmm] Link Local Addressing Semantics

On Thursday 07 December 2006 20:29, Narayanan, Vidya 
wrote:
> Fred,

[...]

> I think I've said this in the last couple of emails,
> but let me try to describe it again. If the
> link-local semantics were always p2p semantics, the
> upper layers on the MN never have any expectations
> on the link-local reachability of neighbors

The upper layer on the MN do have an expectation on the 
link-local reachibility of the (sole) neighbor of the 
MN: its router.

Two ways to avoid that in p2p model: 

- The default router never change, it is the LMA
- The domain fake an unchanging default router, i.e. 
same link-local address and link-layer address on 
every MAG. Plus same public-private key pair in case 
SEND is used.

> to begin with and so, it doesn't matter that the link
> changed while the MN kept the same prefix/address.
> OTOH, if the link exhibited shared semantics for
> link-local and the link changed, the upper layers'
> and applications' expectations on reachability are
> really misplaced and that loses the benefits those
> applications get from having a shared link in the
> first place.
>
> Without knowledge of the requirements to support
> shared link-local behavior, we are having this
> discussion in a vaccuum and I'm afraid we will not
> make any progress. So, I urge you to step back and
> talk about the requirements before we can have
> further discussions.

The requirement is to support last hop links which are 
shared, and can't be turned into p2p links (e.g. 
802.11 w/o VLAN support)

--julien

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Jari Arkko <[email-masked]>
Date: Mon, 11 Dec 2006 23:59:38 +0200

Alexandru,
> How does that PMIP vote materialize in
> terms of next steps?
>
The poll from San Diego will be confirmed on
the list.

Assuming the result is the same in the
confirmation, there will at some point
be a WG draft. For that to happen, we
need a specification proposal that is
far enough for the WG to adopt it. People
should be working on such a proposal
if they are not already.

--Jari

---

From: Jari Arkko <[email-masked]>
Date: Mon, 11 Dec 2006 23:59:38 +0200

Behcet Sarikaya kirjoitti:
> Hi Julien,
>   As per the decision taken at San Diego WG meeting, we probably do
> not have to worry about MAG and LMAs any more.
>   However, we might wish to discuss what should be the new link model
> and I guess this was the reason why this thread was opened.
No. From what I recall, the WG has already earlier decided that
it uses a per-mn prefix model. Nothing we talked about in San
Diego about the choice of protocol base for the MAG - LMA
signaling should affect this. (In fact, if the WG did insist on
designing something that does not support existing IPv6
hosts or something that has multilink subnet issues we
would have a very serious discussion about the direction
and completion dates of the work. However, from what I
have seen so far I think we can avoid these issues even
with PMIP as the base.)

However, what we did NOT decide earlier is what to
do about the scope of the link-local addresses on the
link. This is the discussion that Vidya opened.

--Jari

 7655788c23eb79e336f5f8ba8bce7906
Cc: [email-masked]
X-BeenThere: [email-masked]
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: NETLMM working group discussion list <netlmm.ietf.org>
List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/netlmm>,
	<mailto:[email-masked]?subject=unsubscribe>
List-Archive: <http://www1.ietf.org/pipermail/netlmm>
List-Post: <mailto:[email-masked]>
List-Help: <mailto:[email-masked]?subject=help>
List-Subscribe: <https://www1.ietf.org/mailman/listinfo/netlmm>,
	<mailto:[email-masked]?subject=subscribe>
Errors-To: [email-masked]

Behcet Sarikaya kirjoitti:
> Hi Julien,
>   As per the decision taken at San Diego WG meeting, we probably do
> not have to worry about MAG and LMAs any more.
>   However, we might wish to discuss what should be the new link model
> and I guess this was the reason why this thread was opened.
No. From what I recall, the WG has already earlier decided that
it uses a per-mn prefix model. Nothing we talked about in San
Diego about the choice of protocol base for the MAG - LMA
signaling should affect this. (In fact, if the WG did insist on
designing something that does not support existing IPv6
hosts or something that has multilink subnet issues we
would have a very serious discussion about the direction
and completion dates of the work. However, from what I
have seen so far I think we can avoid these issues even
with PMIP as the base.)

However, what we did NOT decide earlier is what to
do about the scope of the link-local addresses on the
link. This is the discussion that Vidya opened.

--Jari