Subject: Re: [netlmm] Link Local Addressing Semantics

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 12 Dec 2006 00:49:12 -0800 (PST)

Hi Jari,
  Let me clarify.
In the two drafts draft-sgundave-mip6-proxymip6-00 and
draft-chowdhury-netmip6-01 I have not seen entities like MAG and LMA. The only additional entity is a proxy to the MN in the local subnet.
  So goes my comment on why we should not worry on LMA/MAG. Correct me if I am wrong.
  Next, since what we are talking about is MIP6 operation, I do not see any reason for multi link subnets being created in the local subnet, but I think, according to Dave Thaler's draft, the multi link subnets for MIP6 is in the home subnet.
  Yes, it is true that per mn prefix stands as per 
draft-ietf-netlmm-mn-ar-if-01
which was accepted as WG draft before WG decided to change the direction and 
I guess that's why
Julien is raising this issue. 
  I can not suggest any resolution to this, sorry.
  Kind regards,

--behcet

----- Original Message ----
From: Jari Arkko <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: Julien Laganier <[email-masked]>; [email-masked]
Sent: Monday, December 11, 2006 3:59:38 PM
Subject: Re: [netlmm] Link Local Addressing Semantics

Behcet Sarikaya kirjoitti:
> Hi Julien,
>   As per the decision taken at San Diego WG meeting, we probably do
> not have to worry about MAG and LMAs any more.
>   However, we might wish to discuss what should be the new link model
> and I guess this was the reason why this thread was opened.
No. From what I recall, the WG has already earlier decided that
it uses a per-mn prefix model. Nothing we talked about in San
Diego about the choice of protocol base for the MAG - LMA
signaling should affect this. (In fact, if the WG did insist on
designing something that does not support existing IPv6
hosts or something that has multilink subnet issues we
would have a very serious discussion about the direction
and completion dates of the work. However, from what I
have seen so far I think we can avoid these issues even
with PMIP as the base.)

However, what we did NOT decide earlier is what to
do about the scope of the link-local addresses on the
link. This is the discussion that Vidya opened.

--Jari

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Jari Arkko <[email-masked]>
Date: Tue, 12 Dec 2006 11:43:33 +0200

Behcet Sarikaya kirjoitti:
> draft-chowdhury-netmip6-01 I have not seen entities like MAG and LMA.
> The only additional entity is a proxy to the MN in the local subnet.
I believe this is mostly an issue of just using different
terms. There still needs to be a local entity and an anchor
point.

(There has been some discussion about whether the
home agent/LMA can reside across an operator boundary.
But that discussion seems orthogonal to the choice
of the protocol.)
>   Next, since what we are talking about is MIP6 operation, I do not
> see any reason for multi link subnets being created in the local
> subnet, but I think, according to Dave Thaler's draft, the multi link
> subnets for MIP6 is in the home subnet.
Right. But if you look at draft-sgundave, for instance, it
actually adds mechanisms to provide a per-mn prefix
and emulate a real IPv6 link for the host.

--Jari