Subject: RE: [netlmm] PMIPv6 Terminology (Addressing)

From: "KASSI-LAHLOU Mohammed RD-CORE-CAE" <[email-masked]>
Date: Thu, 8 Feb 2007 10:56:45 +0100

Hi all,

I agree that we have to separate terminology for MIP and PMIP.

   Netlmm domain 1 (D1)             ][     Netlmm domain 2 (D2)
                                    ][
             +--------+             ][                +----+
             |LMA1=HA1|             ][                |LMA2|
             +--------+             ][                +----+
                / \                 ][                  / \
               /   \                ][                 /   \
              /     \               ][                /     \
             /       \              ][               /       \
        +-----+     +-----+         ][          +-----+     +-----+
        |PMA12|     |PMA12|         ][          |PMA21|     |PMA22|
        +-----+     +-----+         ][          +-----+     +-----+
                                    ][
                +---+
                |MN1| --------------------------->
                +---+

In Netlmm domain 1 (Home domain for MN1), MN1 gets an address HoA1 configured from HA1=LMA1 virtual subnet. In this case: pHoA1 = HoA1

When MN1 is in D1:
- MN1 doesn't need MIP.
- PMA1n use HoA1 as Proxy Home Address (pHoA1) for PMIP.

In Netlmm domain 2 (Foreign domain for MN1), MN1 gets an address pHoA2 configured from LMA2 virtual subnet. In this case: pHoA2 != HoA1.

When MN1 is in D2:
- MN1 uses HoA1 as Home Address and pHoA2 as CoA for PIM.
- PMA2n use pHoA2 as Proxy Home Address for PMIP.

Kassi

-----Message d'origine-----
De : Julien Laganier [mailto:[email-masked]] 
Envoyé : jeudi 8 février 2007 09:06
À : [email-masked]
Objet : Re: [netlmm] PMIPv6 Terminology (Addressing)

Hi Vidya,

I am fine with *anything* that doesn't contain the "Home Address" and "Care-of Address" substrings. 
Reason being that it overloads MIPv6 semantics and makes any discussion on PMIPv6/MIPv6 interaction confusing. 

Example: Since a MN's IP address in a NetLMM domain can possibly be used as MIPv6 Care-of Address, or as a
MIPv6 Home Address (at least this case has been
discussed) so there's really no reason to call that address a proxy *Home* Address...

There's so many names we could pick for those addresses (Local Address, Mobile Address, NetLMM Address...) that it would really be a pity to overload terms used in a different context, IMHO.

--julien

On Thursday 08 February 2007 04:59, Narayanan, Vidya
wrote:
> Folks,
> In order to try to get closure on what terms we are going to use for 
> the addresses in PMIP, please provide your thoughts. Just to be clear 
> on what we are talking about, there are two IP addresses of 
> significance here - the IP address of the MN in the PMIP domain and 
> the IP address of the data tunnel endpoint (essentially the MAG).
>
> Some folks have expressed the desire to use proxy Home Address (pHoA) 
> and proxy Care-of-address (pCoA). Some others have expressed a concern 
> on those terms, given that the MN really only has one IP address in 
> the PMIP domain.
>
> As an individual WG participant, I prefer to use a term that is more 
> representative of MN's IP address in the PMIP domain (say, something 
> like Local Address (LoA) or PMIP Address (PA)), but, I'm willing to 
> live with pHoA and pCoA.
>
> Vidya
>
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "SEITE Pierrick RD-RESA-REN" <[email-masked]>
Date: Fri, 9 Feb 2007 17:01:18 +0100

I agree that addressing terminology should not contain any Home/Care-of/proxy terms, because, IMO:

1) the MN's address is linked to the PMIP domain: The MN uses the same address across the entire PMIP domain and the MN address changes when the MN moves from one PMIP domain to another. So there is not really the notion of "home", as defined in MIP, and I think the terminology should clearly avoid the confusion. This is why I agree with "Local Address", or "Local MN address", which, in addition, reflects the notion of localized mobility. But I'm fine also with NetLMM address or MN address. 

2) The LMA is expected to update MN's location within the PMIP domain. The location of the MN is the "AR, or MAG, address". Why using another term? 

3) Regarding the point of presence of the MN, the terminology should avoid using any "proxy" term (pCoA, Proxy Mobile Agent Address,...) because the PMA may be not located on the AR (draft-singh / PMIP client), in such a case the PMA address is not the MN's PoP. 

4) I agree that Home/Care-of based terminology is confusing when dealing with MIP/PMIP interaction

Pierrick

-----Message d'origine-----
De : KASSI-LAHLOU Mohammed RD-CORE [mailto:[email-masked]] 
Envoyé : jeudi 8 février 2007 10:57
À : Julien Laganier; [email-masked]
Objet : RE: [netlmm] PMIPv6 Terminology (Addressing)

Hi all,

When MN1 is in D1:
- MN1 doesn't need MIP.

When MN1 is in D2:

Kassi

-----Message d'origine-----
De : Julien Laganier [mailto:[email-masked]] 
Envoyé : jeudi 8 février 2007 09:06
À : [email-masked]
Objet : Re: [netlmm] PMIPv6 Terminology (Addressing)

Hi Vidya,

--julien