Subject: [netlmm] MN Identifier used in PMIP6

From: "Narayanan, Vidya" <[email-masked]>
Date: Thu, 1 Feb 2007 01:52:00 -0800

The present drafts propose the use of NAI as the MN Identifier and the
availablity of the IID to an off-path entity. It is not a valid
assumption that either of that is available to the PMA. 

For instance, the NAI is available to the PMA only under the following
assumptions - that EAP is done for network access authentication, that
the PMA is the EAP authenticator (or is at least in the path of EAP),
that no identity protection or identity privacy is employed in the
authentication method used. That makes it a very specific case. 

As Julien pointed out, when CGAs are used, it is not feasible for the
IID to be available to the PMA in advance either. 

I suggest that the protocol use the MN ID option defined in RFC4283 and
just state that a PMIP domain-wide unique MN ID is used. Examples may be
MAC address, CGA public key, randomly generated unique ID, IMSI/TMSI,
NAI, etc. The method by which this ID is known to the PMA is really out
of scope of this protocol. 

Vidya

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Julien Laganier <[email-masked]>
Date: Thu, 1 Feb 2007 11:49:25 +0100

On Thursday 01 February 2007 10:52, Narayanan, Vidya 
wrote:
> The present drafts propose the use of NAI as the MN
> Identifier and the availablity of the IID to an
> off-path entity. It is not a valid assumption that
> either of that is available to the PMA.
>
> For instance, the NAI is available to the PMA only
> under the following assumptions - that EAP is done
> for network access authentication, that the PMA is
> the EAP authenticator (or is at least in the path of
> EAP), that no identity protection or identity
> privacy is employed in the authentication method
> used. That makes it a very specific case.
>
> As Julien pointed out, when CGAs are used, it is not
> feasible for the IID to be available to the PMA in
> advance either.
>
> I suggest that the protocol use the MN ID option
> defined in RFC4283 and just state that a PMIP
> domain-wide unique MN ID is used. 

In addition, the MN ID should also be securely bound to 
the MN within the domain.

> Examples may be MAC address, CGA public key, randomly
> generated unique ID, IMSI/TMSI, NAI, etc. The method
> by which this ID is known to the PMA is really out of
> scope of this protocol.

Agree. The method by which the ID is obtained depends 
on the MN-AR interface.

--julien

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 1 Feb 2007 10:36:46 -0600

> 
> I suggest that the protocol use the MN ID option defined in 
> RFC4283 and just state that a PMIP domain-wide unique MN ID 
> is used. Examples may be MAC address, CGA public key, 
> randomly generated unique ID, IMSI/TMSI, NAI, etc. The method 
> by which this ID is known to the PMA is really out of scope 
> of this protocol. 

[Ahmad]
Agreed.

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 1 Feb 2007 10:04:08 -0800 (PST)

> of scope of this protocol.

There is a normative reference to RFC-4283. For the protocol to
function, the mobile needs to be identified and represented using
in some form, as per RFC-4282 or other means and be sent as an option
per RFC-4283, using MN ID. Now, we have used the term NAI as a general
means to identify the MN. The specific representation of the NAI
is not relevant, as long as both the entities can identify a unique
mobile. So, we are on the same page. Again, this appears to be a
comment on the presentation.

Agreed !