Subject: [netlmm] PMIPv6, AAA and Policies

From: "Narayanan, Vidya" <[email-masked]>
Date: Thu, 1 Feb 2007 01:52:38 -0800

The solution drafts we have at the moment imply some ties to AAA and
policy information pertinent to the MN being available from it. This is
not a valid model for all networks. Also, there doesn't seem to be a
need to rely on any policy information specifically for PMIP operation.
For the purpose of the protocol, the LMA may be pre-configured in the
PMA, for e.g. - of course, in a specific realization, the PMA may obtain
the LMA from other sources like the AAA, but that is irrelevant. 

So, I suggest not having any notion of policy and AAA in the protocol
document, so that the protocol is generically applicable to all sorts of
networks.

Vidya

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Julien Laganier <[email-masked]>
Date: Thu, 1 Feb 2007 11:47:11 +0100

On Thursday 01 February 2007 10:52, Narayanan, Vidya 
wrote:
> The solution drafts we have at the moment imply some
> ties to AAA and policy information pertinent to the
> MN being available from it. This is not a valid
> model for all networks. Also, there doesn't seem to
> be a need to rely on any policy information
> specifically for PMIP operation. For the purpose of
> the protocol, the LMA may be pre-configured in the
> PMA, for e.g. - of course, in a specific
> realization, the PMA may obtain the LMA from other
> sources like the AAA, but that is irrelevant.
>
> So, I suggest not having any notion of policy and
> AAA in the protocol document, so that the protocol
> is generically applicable to all sorts of networks.

I agree that dependence on AAA isn't good for a general 
purpose mobility protocol.

OTOH pre-configuration of the LMA in the PMA means we 
are defining a protocol which can only be used in 
single-LMA domains unless other documents specifies 
method to achieve that. I am wondering if this is 
acceptable, i.e. shouldn't we define a mandatory to 
implement method to find an LMA (e.g. an anycast 
address) ?

--julien

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 1 Feb 2007 10:34:01 -0600

> 
> 
> The solution drafts we have at the moment imply some ties to 
> AAA and policy information pertinent to the MN being 
> available from it. This is not a valid model for all 
> networks. Also, there doesn't seem to be a need to rely on 
> any policy information specifically for PMIP operation.
> For the purpose of the protocol, the LMA may be 
> pre-configured in the PMA, for e.g. - of course, in a 
> specific realization, the PMA may obtain the LMA from other 
> So, I suggest not having any notion of policy and AAA in the 
> protocol document, so that the protocol is generically 
> applicable to all sorts of networks.

[Ahmad]
I Agree.

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 1 Feb 2007 09:53:58 -0800 (PST)

> document, so that the protocol is generically applicable to all sorts of

There is no dependency of the protocol on any specific policy
store. That was not our intent. For the protocol to work, certain
information is required, how the entities obtain that information
is specific to the implementation. It is possible the PMA obtains
the information from its local store, from a network policy store
or through some other means. We will remove any specific references
to any specific policy store. This appears to be a comment on the
presentation. We will fix it, if we see the draft making any such
implicit assumptions.

Agreed.

Sri

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 01 Feb 2007 10:40:24 -0800

> document, so that the protocol is generically applicable to all sorts of

Thats a bit drastic. I agree that the protocol should not be
tied to AAA policy lookups, but we need to show in the draft
how the protocol can be deployed with a AAA infrastructure.
One concrete example would be a good idea.

There is also another option of using DNS based discovery
as described in draft-ietf-mip6-bootstrapping-split. The PMA
could construct an FQDN from the MN's NAI and do a DNS lookup.

Vijay

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Thu, 1 Feb 2007 15:08:48 -0800

Vijay, 

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Thursday, February 01, 2007 10:40 AM
> To: Narayanan, Vidya
> Cc: [email-masked]
> Subject: Re: [netlmm] PMIPv6, AAA and Policies
> 
> Narayanan, Vidya wrote:
> > policy information pertinent to the MN being available from 
> it. This 
> > is not a valid model for all networks. Also, there doesn't 
> seem to be 
> > a need to rely on any policy information specifically for 
> PMIP operation.
> pre-configured in the 
> > PMA, for e.g. - of course, in a specific realization, the PMA may 
> > obtain the LMA from other sources like the AAA, but that is 
> irrelevant.
> > 
> > document, so that the protocol is generically applicable to 
> all sorts 
> > of networks.
> 

Perhaps you can put this in the appendix or something - I see that this
is good guidance for systems that do employ a AAA infrastructure - but,
it is sending the wrong message to systems that don't. It would be good
to have the protocol not implying the need for any AAA infrastructure. 

Vidya

> There is also another option of using DNS based discovery as 
> described in draft-ietf-mip6-bootstrapping-split. The PMA

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 01 Feb 2007 16:46:46 -0800

Narayanan, Vidya wrote:

> Perhaps you can put this in the appendix or something - 

A separate section or appendix would work for me.

Vijay

I see that this

---

From: "Gerardo Giaretta" <[email-masked]>
Date: Fri, 2 Feb 2007 13:54:42 +0100

Hi Vidya,

> to have the protocol not implying the need for any AAA infrastructure.

I'm ok with leaving the AAA aspects to an appendix or a separate
section since I agree that it's not possible for all networks to
leverage on AAA. However, I think it must also be stated clearly that
in real deployments (i.e. where static configuration is not an option)
there is a dependency on some companion protocols (e.g. AAA, context
transfer) in order to use PMIP.

--Gerardo