Subject: RE: [netlmm] MIP6 HoA and PMIPv6 pHoA

From: "KASSI-LAHLOU Mohammed RD-CORE-CAE" <[email-masked]>
Date: Mon, 5 Feb 2007 12:25:54 +0100

Hi,

I think we have three possibilities here:

- Netlmm domain acts as a home network for the MNs of its own domain
- Netlmm domain acts as an only one foreign network for the MNs of its own domain
- Netlmm domain acts as a home network for the MNs of its own domain and as an only one foreign network for the MNs of other domains.

   Netlmm domain 1 (D1)        ][     Netlmm domain 2 (D2)
                               ][
             +---+             ][                +---+
             |HA1|             ][                |HA2|
             +---+             ][                +---+
              / \              ][                 / \
             /   \             ][                /   \
            /     \            ][               /     \
           /       \           ][              /       \
       +----+     +----+       ][          +----+     +----+
       |AR12|     |AR12|       ][          |AR21|     |AR22|
       +----+     +----+       ][          +----+     +----+
                               ][
         +---+
         |MN1| --------------------------->
         +---+

Case 1: Each Netlmm domain acts as a home network for its own MNs

In this case Netlmm1 manages the mobility of MN1 in D1 and MN1 acts as if it were in its home network. MN1 uses MIPv6 when it moves to D2 and it uses MIPv6 also when it moves between AR21 and AR22.

Case 2: Each Netlmm domain acts as an only one foreign network for its own MNs

In this case Netlmm1 manages the mobility of MN1 in D1 and MN1 acts as if it were in a foreign network. MN1 uses MIPv6 when it moves to D2 and it uses MIPv6 also when it moves between AR21 and AR22.

Case 3: Each Netlmm domain acts as a home network for its own MNs and as an only one foreign network for visiting MNs

In this case Netlmm1 manages the mobility of MN1 in D1 and MN1 acts as if it were in its home network. MN1 uses MIPv6 when it moves to D2. Within D2, Netlmm2 manages the mobility of MN1 and MN1 acts as if it were in only one foreign network when it moves between AR21 and AR22.

It seems that PMIP looks like case 1. But how about the case 3?

Kassi

-----Message d'origine-----
De : Sri Gundavelli [mailto:[email-masked]] 
Envoyé : vendredi 2 février 2007 20:12
À : Kilian Weniger
Cc : [email-masked]
Objet : RE: [netlmm] MIP6 HoA and PMIPv6 pHoA

On Fri, 2 Feb 2007, Kilian Weniger wrote:

> Hi,
>
> I think there are two options if session continuity beyond the PMIP 
> domain is desired (assumption is that PMIPv6 is used for localized MM 
> and MIPv6 for global MM, i.e., MIPv6-HoA is used by application):
>
> 1. PMIP-HoA must not equal MIPv6-HoA. Instead, PMIP-HoA is registered 
> as CoA at MIPv6-HA.
> (MIPv6-HA and PMIPv6-HA are not necessarily co-located in this case)
>
> 2. PMIP-HoA may equal MIPv6-HoA.
> (MIPv6-HA and PMIPv6-HA must be co-located in this case.)
>
> The unique advantage of option 2 is that no IP tunnel to the MN (i.e., 
> over the air) is necessary (at least as long as the MN is moving 
> within the "home PMIP domain", i.e. the PMIP domain, which is anchored 
> at the co-located PMIPv6/MIPv6-HA). In option 1, there is always an IP 
> tunnel to the MN needed, assuming that the MIPv6 home link is virtual. 
> IMHO, this is a reason to support option 2.
>

Absolutely !

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Mon, 5 Feb 2007 10:11:56 -0800 (PST)

Hi Kassi,

If I follow this correctly, all the three scenario's
are supported:

- The support for MIP6-HoA == PMIP6-HoA, will allow a mobile
   to get local mobilty in its home.

- The support for MIP6-CoA == PMIP6-HoA, will allow a mobile
   to use that CoA in the visiting domain and establish global
   mobility for its HoA.

Now, what is home domain and what is foreign domain is really
a policy configuration and has no bearing on the protocol.
But, all three cases should be supported.

Thanks
Sri