Subject: [netlmm] PMIPv6 Terminology

From: "Narayanan, Vidya" <[email-masked]>
Date: Thu, 1 Feb 2007 01:48:56 -0800

We have had a lot of discussion on the topic and I believe there is
general agreement that terminology re-use from MIP6 is not a good idea.
It is also desirable to keep the terminology as close as possible to
what is already used in the requirements and threats drafts. Keeping
that in mind, the following terms seem to be acceptable to most people: 

1. Local Mobility Agent (LMA) - refers to the PMIP home agent

2. Proxy Mobility Agent (PMA) - refers to the PMIP client (the
functionality in the AR); this is different from the term MAG used in
the requirements and threats documents, but, there seem to be a fair
number of folks who would prefer PMA to MAG. So, this mapping must be
clearly stated in the protocol document. 

3. Proxy Home Address (pHoA) - refers to the IP address of the MN in the
PMIP domain

4. Proxy Care-of-Address (pCoA) - refers to the point of presence of the
MN in the PMIP domain and is often the PMA's IP address. 

If you are NOT okay with the terms above, please respond and state your
reasons/preferences. 

Vidya

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 01 Feb 2007 12:05:42 +0100

Narayanan, Vidya wrote:
> general agreement that terminology re-use from MIP6 is not a good
> idea. It is also desirable to keep the terminology as close as
> possible to what is already used in the requirements and threats
> drafts. Keeping that in mind, the following terms seem to be
> acceptable to most people:
> 
>  number of folks who would prefer PMA to MAG. So, this mapping must
> be clearly stated in the protocol document.

I'm not ok with the terms. Both are 'Agents' I never know which is
which.  How about LMA and AR.

> 3. Proxy Home Address (pHoA) - refers to the IP address of the MN in
> the PMIP domain

Not ok, makes no sense to me, a 'proxy address'.  The address of the
proxy is often called a proxy address.

How about 'the CoA'?

> 4. Proxy Care-of-Address (pCoA) - refers to the point of presence of
> the MN in the PMIP domain and is often the PMA's IP address.

PMA has at least two IP addresses, which is pCoA?

How about 'AR egress address'?

Alex

---

From: Marco Liebsch <[email-masked]>
Date: Thu, 01 Feb 2007 12:26:06 +0100

> which.  How about LMA and AR.

I think we should keep the characteristics of a functional entity
for the proxy. AR rather refers to a network entity, which has
various functional entities co-located. What about resolving
PMA to 'Proxy Mobile Attendant' ?

marco

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 01 Feb 2007 13:37:39 +0100

Marco Liebsch wrote:
>>> We have had a lot of discussion on the topic and I believe there 
>>> is general agreement that terminology re-use from MIP6 is not a 
>>> good idea. It is also desirable to keep the terminology as close 
>>> as possible to what is already used in the requirements and 
>>> threats drafts. Keeping that in mind, the following terms seem to
>>>  be acceptable to most people:
>>> 
>>> functionality in the AR); this is different from the term MAG 
>>> used in the requirements and threats documents, but, there seem 
>>> to be a fair number of folks who would prefer PMA to MAG. So, 
>>> this mapping must be clearly stated in the protocol document.
>> 
>> 
> I think we should keep the characteristics of a functional entity for
>  the proxy. AR rather refers to a network entity, which has various 
> functional entities co-located. What about resolving PMA to 'Proxy 
> Mobile Attendant' ?

Attendant sounds good, because it converges with an access control term.
  'Access' also sounds good, like the 'A' in MAG.  But MAG has that
invitation to my tongue to roll it as MAGnifier or MAGnum to others or
MAGazine to French-speaking, etc.

Mobile Attendant makes think of an Attendant that moves.

Proxy Mobile Attendant makes (me IMHO) think of a proxy box substituting
the Mobile Attendant.

Remark in a WWW context, a proxy entity is called "http proxy", so
similarly one would call "Mobility Proxy" (it proxies for mobility) but
not "Attendant Proxy" (it doesn't proxy the Attendant functionality).

Proxy-Mobility Attendant with the inner dash may sound good (as opposed
to Proxy Mobile Attendant).

Similarly the A in LMA could be 'Anchor' it suggests better than just
'Agent'.

So,  I'm fine with:

LMA - Local-Mobility Anchor

MA - Mobility Access, Mobility Attendant
PMA - Proxy-Mobility Attendant, Proxy-Mobility Access
MP - Mobility Proxy

Any other thoughts.

Alex

---

From: Julien Laganier <[email-masked]>
Date: Thu, 1 Feb 2007 13:54:37 +0100

On Thursday 01 February 2007 10:48, Narayanan, Vidya 
wrote:
> We have had a lot of discussion on the topic and I
> believe there is general agreement that terminology
> re-use from MIP6 is not a good idea. It is also
> desirable to keep the terminology as close as
> possible to what is already used in the requirements
> and threats drafts. Keeping that in mind, the
> following terms seem to be acceptable to most
> people:
>

Fine.

> 2. Proxy Mobility Agent (PMA) - refers to the PMIP
> client (the functionality in the AR); this is
> different from the term MAG used in the requirements
> and threats documents, but, there seem to be a fair
> number of folks who would prefer PMA to MAG. So,

I do not care much. I was fine with MAG, which has the 
advantage that it matches with what is ps and req 
docs.

> 3. Proxy Home Address (pHoA) - refers to the IP
> address of the MN in the PMIP domain

If we're going to keep "Proxy Home Address" I think we 
should abbreviate that into PHoA (not pHoA).

But now I think the term Proxy *Home* Address is 
misleading since we're talking about *Localized* 
Mobility Management in which the address used by an MN 
cannot be really use the home qualifier. 

I'd prefer that we refer to that address as a Mobile 
Address (MoA), it is simple and doesn't mistate any 
home feature of that address.

If people find that too vague, we can prefix Mobile 
Address with Localized or NetLMM:

- Localized Mobile Address (LMoA)
- NetLMM Mobile Address (NMoA)

These proposed names have the additional advantage that 
they are less likely to be confused with their MIPv6 
counterparts (sometimes oneself's eyes trick him).

> 4. Proxy Care-of-Address (pCoA) - refers to the
> point of presence of the MN in the PMIP domain and
> is often the PMA's IP address.

Ditto: If we're going to keep "Proxy Care-of Address", 
abbreviation should be PCoA, not pCoA.

FWIW I find the Proxy Care-of name quite meaningless. 
IMHO we should either we call it as the address of an 
entity:

- Proxy Mobile Agent Address
- Mobility Access Gateway Address.

or, we call it as an address with a functionality:

- Localized Care-of Address (LCoA)
- NetLMM Care-of Address (NCoA)

--julien

---

From: "Genadi Velev" <[email-masked]>
Date: Thu, 1 Feb 2007 13:55:16 +0100

> > 1. Local Mobility Agent (LMA) - refers to the PMIP home agent
                      ^^^^^^  
                      Anchor
> which.  How about LMA and AR.

AFAIK, the term LMA was defined as "Local Mobility Anchor", not an Agent
(I guess that Vidya mis-spelled the term unintentionally).  So, I'm OK
with using LMA (as anchor) and PMA (as agent).  However, I think that
the PMIPv6 protocol I-D may define a "pHA" (PMIP-HA, analogically to
pHoA and pCoa) and specify that pHA is the same as LMA from requirements
and threats I-Ds.  In this way the link between the PMIPv6 specification
and the NetLMM informational RFCs would be kept (and the analogy to
MIPv6 as well).

I personally like pHoA and pCoA, however, their definition should be a
bit more precise to avoid the ambiguity expressed by Alex' questions
below in the email.

regards,
Genadi

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 01 Feb 2007 14:27:39 +0100

> home feature of that address.

MoA is fine, can be expanded into "Mobile's Address".

> - NetLMM Mobile Address (NMoA)

Both sound good to me.

> abbreviation should be PCoA, not pCoA.

Clash with Previous CoA in FMIP.
> - Mobility Access Gateway Address.

MAGA is fine.

> - Localized Care-of Address (LCoA)

LCoA is LCoA in HMIP.

> - NetLMM Care-of Address (NCoA)

NCoA is New Care-of Address in FMIP.

Alex

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 1 Feb 2007 08:48:09 -0600

> 
> 
> We have had a lot of discussion on the topic and I believe 
> there is general agreement that terminology re-use from MIP6 
> is not a good idea.
> It is also desirable to keep the terminology as close as 
> possible to what is already used in the requirements and 
> threats drafts. Keeping that in mind, the following terms 
> seem to be acceptable to most people: 
> 
                                                ^^^^^^^^^^^^^^^
Why do we need to give it another name; just call it PMIP-HA (P-HA) or
probably Local-HA (L-HA).

> 
> 2. Proxy Mobility Agent (PMA) - refers to the PMIP client 
> (the functionality in the AR); this is different from the 
> term MAG used in the requirements and threats documents, but, 
> there seem to be a fair number of folks who would prefer PMA 
> to MAG. So, this mapping must be clearly stated in the 
> protocol document. 

Proxy Mobility Agent (PMA) sounds good.
 
> 
> 3. Proxy Home Address (pHoA) - refers to the IP address of 
> the MN in the PMIP domain

Since the MN is not aware of any mobility offered at this point, I would
refrain from calling the address as P-HoA. I would support using Mobile
Address or Mobile Local Address. The reason here is that when the MN has
a Client MIP, it become very messy since most probably the CMIP MN will
use this address as its CoA. Let us keep home away from this address.

> 
> 4. Proxy Care-of-Address (pCoA) - refers to the point of 
> presence of the MN in the PMIP domain and is often the PMA's IP
address.
 
^^^^^^^^^^^^^^^^^
No need for a new name and for the same reason as above with respect to
coexistence with CMIP. I recommend using PMA Address.

> 
> 
> If you are NOT okay with the terms above, please respond and 
> state your reasons/preferences. 
> 
> Vidya
>

---

From: "Kilian Weniger" <[email-masked]>
Date: Thu, 1 Feb 2007 15:54:21 +0100

Hi,

I prefer a terminology that is similar to the MIPv6 terminology for the
reasons mentioned in my earlier mails on this topic. Hence, I'm fine
with the suggestions PHoA, PCoA, PMA, but the anchor name should contain
the letters "HA", IMHO. 

So my preferences are as follows:

- "PMIP Home Agent (PHA)" 
(if the "LMA" is defined by "refers to the PMIP home agent", then why
not call it "PMIP Home Agent" in the first place?)

- I'm fine with "PMA", but for the sake of consistency I would  prefer
if it resolves to something with "PMIP" in the name, e.g., "PMIP Agent".
An alternative would be something like "PMIP Access Gateway (PAG)" or
"PMIP Access Agent (PAA)".

- "PMIP Home Address (PHoA)"

- "PMIP Care-of Address (PCoA)"
(An alternative would be "PMA Care-of Address (PCoA or PMA-CoA)", which
would be analog to "FA-CoA" in MIPv4.)

Regarding the requirement that the terminology should be as close as
possible to what is already used in the requirements and threats draft:
The assumptions about the solution were different at the time these
drafts were written. IMHO, a big change with respect to the solution
approach justifies a big change in the terminology. And maybe we need to
modify these drafts anyway, e.g., to add the requirements "high re-use
of HA functionality" and/or "high re-use of MIPv6 extentions". If
modifying these drafts is not an option, the PMIPv6 I-D can at least
provide a mapping to the terms of these drafts. 

My two cents.

Regards,

Kilian

> -----Original Message-----
> From: Narayanan, Vidya [mailto:[email-masked]] 
> Sent: Donnerstag, 1. Februar 2007 10:49
> To: [email-masked]
> Subject: [netlmm] PMIPv6 Terminology
> 
> 
> the MN in the
> presence of the

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 01 Feb 2007 10:12:15 -0800

Hi Vidya,

These terms sound good to me. I would still prefer pHA
instead of the LMA, but can live with LMA.

Vijay

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 1 Feb 2007 11:09:00 -0800 (PST)

> If you are NOT okay with the terms above, please respond and state your

Agreed !

I feel much better. We are able to close on terminology so easily.

Sri

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 1 Feb 2007 13:14:21 -0600

Hi Sri,

> >
> > If you are NOT okay with the terms above, please respond and state 
> > your reasons/preferences.
> >
> 
> Agreed !
> 

[Ahmad]
Although it is not a big deal, but I do not see how did you come to this
conclusion!? So quickly!

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 1 Feb 2007 11:22:35 -0800 (PST)

Hi Ahmad,

> Although it is not a big deal, but I do not see how did you come to this

I give up on the terminology arguments. Its hard to convince any one.

If you see the ML, many people supported Kilian's suggestions on the
suggested terms. In general, we wanted to keep the terminology close
to the MIP6 and we probably have that. IMHO, its not worth spending
hours and hours on this topic. We rather ensure, there are no
restrictions on the architecture or how local mobility and global
mobility can be combined.

Regards
Sri

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Thu, 1 Feb 2007 12:38:02 -0800

Folks,
After taking all the emails and the fact that the requirements and
threats documents are already at the RFC Editor, we move forward with
the terms LMA and MAG, as has been the consensus of this WG at the time
of approving the requirements and threats document. 

Debating this further seems to lead to nothing but confusion and we
don't see the point. We have noted all the opinions expressed and
concluded this is the best way forward. This reflects both our opinions
and also Jari's as he had already previously stated. 

Thanks,
The Chairs

---

From: "Kumar Vinod-A20689" <[email-masked]>
Date: Fri, 2 Feb 2007 17:04:54 +0800

Regarding the choice between PMA and MAG, I think both these terms
should be retained instead of eliminating one because they can be
located in different entities. For example, in
draft-singh-netlmm-protocol-00, the PMA and MAG need not be colocated.

Regards,
Vinod 

-----Original Message-----
From: Narayanan, Vidya [mailto:[email-masked]] 
Sent: Thursday, February 01, 2007 3:19 PM
To: [email-masked]
Subject: [netlmm] PMIPv6 Terminology

Vidya

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 02 Feb 2007 10:38:49 +0100

> mobility can be combined.

I'm of a different oppinion.

Basic terms like LMA and AR are going to be used in many places.  It's 
good to spend time setting them right.

Alex

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Sat, 3 Feb 2007 00:18:09 -0600

Hi Vidya,
Agreed, however, I see it is important to set terminology for the other
variable, especially:

It really becomes very confusing referring to the MN IP Address in the
PMIP domain as Proxy Home Address especially when PMIP and CMIP are both
allowed. It makes discussion more confusing and not effective.

There was few people (at least 4) who were inline of using Mobile Node
Address or MN Local Address, in my original posting I said, let us keep
home a way from this address.

Thanks.

Regards,
Ahmad

> Sent: Thursday, February 01, 2007 2:38 PM
> To: Sri Gundavelli; Muhanna, Ahmad (RICH1:2H10)
> Cc: [email-masked]
> Subject: RE: [netlmm] PMIPv6 Terminology (LMA and MAG)
> 
> 
> Folks,
> After taking all the emails and the fact that the 
> requirements and threats documents are already at the RFC 
> Editor, we move forward with the terms LMA and MAG, as has 
> been the consensus of this WG at the time of approving the 
> requirements and threats document. 
> 
> Debating this further seems to lead to nothing but confusion 
> and we don't see the point. We have noted all the opinions 
> expressed and concluded this is the best way forward. This 
> reflects both our opinions and also Jari's as he had already 
> previously stated. 
> 
> Thanks,
> The Chairs
>

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 02 Feb 2007 22:31:37 -0800

Vidya,

I don't believe we have consensus on this. Too many
people have expressed support for PMA and pHA to go
back to MAG and LMA.

Narayanan, Vidya wrote:
> threats documents are already at the RFC Editor, 

I would support modifying the terms in these
documents during the AUTH48 stage. Or pulling the
documents  back from the RFC Editor Queue, modifying
the terms and running a WG last call again. It
shouldn't take too long to approve these documents
once more since we won't be making any other changes.

> we move forward with

The situation is very different now.

> and also Jari's as he had already previously stated. 

But I don't think this has WG consensus, which is
more important.

Vijay

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Sat, 3 Feb 2007 09:08:08 -0800

Hi Ahmad,
Yes, we'll discuss the addressing terms. This email was just about the
LMA and MAG terminology. 

Vidya 

> From: Ahmad Muhanna [mailto:[email-masked]] 
> Sent: Friday, February 02, 2007 10:18 PM
> To: Narayanan, Vidya; Sri Gundavelli
> Cc: [email-masked]
> Agreed, however, I see it is important to set terminology for 
> the other variable, especially:
> 
> It really becomes very confusing referring to the MN IP 
> Address in the PMIP domain as Proxy Home Address especially 
> when PMIP and CMIP are both allowed. It makes discussion more 
> confusing and not effective.
> 
> There was few people (at least 4) who were inline of using 
> Mobile Node Address or MN Local Address, in my original 
> posting I said, let us keep home a way from this address.
> 
> Thanks.
> 
> Regards,
> Ahmad
>  
> 
> > the terms LMA and MAG, as has been the consensus of this WG at the 
> > time of approving the requirements and threats document.
> > 
> > concluded this is the best way forward. This reflects both our 
> > opinions and also Jari's as he had already previously stated.
> > 
> > Thanks,
> > The Chairs
> > 
>

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Sat, 3 Feb 2007 09:33:29 -0800

Vijay, 

> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Friday, February 02, 2007 10:32 PM
> To: Narayanan, Vidya
> Cc: [email-masked]
> Subject: Re: [netlmm] PMIPv6 Terminology (LMA and MAG)
> 
> Vidya,
> 
> I don't believe we have consensus on this. Too many people 
> have expressed support for PMA and pHA to go back to MAG and LMA.
> 

We have not heard a good technical reason other than "I don't like this
term" or "we need to use terms that are close to the MIP6 terms".
Unfortunately, these are not good reasons. 

> I would support modifying the terms in these documents during 
> the AUTH48 stage. Or pulling the documents  back from the RFC 
> Editor Queue, modifying the terms and running a WG last call 
> again. It shouldn't take too long to approve these documents 

I understand your position. But, given the lack of strong technical
reasons and given that there is no desire to further introduce delays (I
disagre with your take on "shouldn't take too long"), there is no reason
to do this. 

> The situation is very different now.

No. Please recall the ground rules that Jari talked about in San Diego,
before the change of direction on the protocol. Just because we decided
to change direction on the protocol does not imply we revisit all the
decisions again. Again, there is simply no good reason to revisit
terminology. 

> But I don't think this has WG consensus, which is more important.
> 

WG consensus is not just about numbers. Here, you are asking that we
change what was already a WG consensus. As much as I personally prefer
the term PMA to MAG, I have not seen a good reason given on the list to
do so. 

I'm sorry that this differs from your view, but, I hope you can respect
the WG decisions made earlier and our desire to not impact approved
documents without good reason. 

Thanks,
Vidya

---

From: "Singh Ajoy-ASINGH1" <[email-masked]>
Date: Sat, 3 Feb 2007 13:13:55 -0500

Hi, Vidya, 

I would like to bring to your attention that draft-singh- provides
technical reasons for allowing PMA and AR as 
two separate entities in place of MAG. I would like to understand what
is the architectural implication of 
using terminology such as MAG? I am fine as long as MAG is not used to
limit any protocol architecture.

Regards,
Ajoy 

-----Original Message-----
From: Narayanan, Vidya [mailto:[email-masked]] 
Sent: Saturday, February 03, 2007 11:33 AM
To: Vijay Devarapalli
Cc: [email-masked]
Subject: RE: [netlmm] PMIPv6 Terminology (LMA and MAG)

Vijay, 

> I don't believe we have consensus on this. Too many people have 
> expressed support for PMA and pHA to go back to MAG and LMA.
> 

> I would support modifying the terms in these documents during the 
> AUTH48 stage. Or pulling the documents  back from the RFC Editor 
> Queue, modifying the terms and running a WG last call again. It 
> shouldn't take too long to approve these documents once more since we 
> won't be making any other changes.
> 

Thanks,
Vidya

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Wed, 7 Feb 2007 19:59:43 -0800

Folks,
In order to try to get closure on what terms we are going to use for the
addresses in PMIP, please provide your thoughts. Just to be clear on
what we are talking about, there are two IP addresses of significance
here - the IP address of the MN in the PMIP domain and the IP address of
the data tunnel endpoint (essentially the MAG). 

Some folks have expressed the desire to use proxy Home Address (pHoA)
and proxy Care-of-address (pCoA). Some others have expressed a concern
on those terms, given that the MN really only has one IP address in the
PMIP domain. 

As an individual WG participant, I prefer to use a term that is more
representative of MN's IP address in the PMIP domain (say, something
like Local Address (LoA) or PMIP Address (PA)), but, I'm willing to live
with pHoA and pCoA. 

Vidya

---

From: Ashutosh Dutta <[email-masked]>
Date: Wed, 07 Feb 2007 23:37:31 -0500

Few points:

- I think the address mobile gets configured with after successful 
authentication, is actually the home address, why should we call it 
proxy HoA? Is it different than the HoA the client gets if it is using CMIP?

- Also, although the mobile gets its interface configured with HoA 
through prefix advertisement from the PMA (MAG), it could potentially 
configure its interface with other IPv6 addresses (local addresses), if 
the PMA advertises other prefixes in addition to home prefix. So, mobile 
having one IP address in the PMIP domain may not be true always.

However, from PMIP perspective, there is only one local IP address 
assigned to the mobile which is essentially the home address.

Thanks
Ashutosh

---

From: [email-masked]
Date: Thu, 08 Feb 2007 08:57:12 +0100

> like Local Address (LoA) or PMIP Address (PA)), but, I'm willing to live
My thoughts:

pHoA and pCoA terms are perfect!

Why?
1) carry common/shared Mobile IP semantic of Home and Care-of Addresses 
(mandatory for reasoning purpose)
2) specify they are used in a proxy approach/context (might be freely 
considered or omitted for reasoning purpose)

Bruno.

---

From: Julien Laganier <[email-masked]>
Date: Thu, 8 Feb 2007 09:06:13 +0100

Hi Vidya,

I am fine with *anything* that doesn't contain the 
"Home Address" and "Care-of Address" substrings. 
Reason being that it overloads MIPv6 semantics and 
makes any discussion on PMIPv6/MIPv6 interaction 
confusing. 

Example: Since a MN's IP address in a NetLMM domain can 
possibly be used as MIPv6 Care-of Address, or as a 
MIPv6 Home Address (at least this case has been 
discussed) so there's really no reason to call that 
address a proxy *Home* Address...

There's so many names we could pick for those addresses 
(Local Address, Mobile Address, NetLMM Address...) 
that it would really be a pity to overload terms used 
in a different context, IMHO.

--julien

On Thursday 08 February 2007 04:59, Narayanan, Vidya 
wrote:
> Folks,
> In order to try to get closure on what terms we are
> going to use for the addresses in PMIP, please
> provide your thoughts. Just to be clear on what we
> are talking about, there are two IP addresses of
> significance here - the IP address of the MN in the
> PMIP domain and the IP address of the data tunnel
> endpoint (essentially the MAG).
>
> Some folks have expressed the desire to use proxy
> Home Address (pHoA) and proxy Care-of-address
> (pCoA). Some others have expressed a concern on
> those terms, given that the MN really only has one
> IP address in the PMIP domain.
>
> As an individual WG participant, I prefer to use a
> term that is more representative of MN's IP address
> in the PMIP domain (say, something like Local
> Address (LoA) or PMIP Address (PA)), but, I'm
> willing to live with pHoA and pCoA.
>
> Vidya
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 08 Feb 2007 09:18:13 +0100

> in a different context, IMHO.

Julien, Vidya, I agree with these points.

I agree with any 'address' term that doesn't necessitate the Home-Careof 
analogy.

Mobile's Address, NetLMM permanent address for mobile, etc are fine.

A 'proxy address' is usually the address of the proxy server doing a 
proxy service for an application.  Or here the 'proxy address' would be 
mobile's address, not AR's address.  This is a clear contention to be 
avoided.

We could talk about the 'MN address' and the 'AR address', it's easy to 
me IMHO.  It matches DHCP too: Client address and Relay Address.

Thanks for asking,

Alex

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 8 Feb 2007 06:49:55 -0600

I agree with Julien reasoning. Let us avoid confusion.
On the other hand, if the consensus is to use LMA instead P-HA, I do not
see any home in LMA and consequently addresses which belong to it should
not have home in the name too.

My 2 cents.

Regards,
Ahmad

> From: Julien Laganier [mailto:[email-masked]] 
> Sent: Thursday, February 08, 2007 2:06 AM
> To: [email-masked]
> Subject: Re: [netlmm] PMIPv6 Terminology (Addressing)
> 
> Hi Vidya,
> 
> I am fine with *anything* that doesn't contain the "Home 
> Address" and "Care-of Address" substrings. 
> Reason being that it overloads MIPv6 semantics and makes any 
> discussion on PMIPv6/MIPv6 interaction confusing. 
> 
> discussed) so there's really no reason to call that address a 
> proxy *Home* Address...
> 
> (Local Address, Mobile Address, NetLMM Address...) that it 
> would really be a pity to overload terms used in a different 
> context, IMHO.
> 
> --julien
> 
> > In order to try to get closure on what terms we are going 
> to use for 
> > the addresses in PMIP, please provide your thoughts. Just 
> to be clear 
> > on what we are talking about, there are two IP addresses of 
> > significance here - the IP address of the MN in the PMIP domain and 
> > the IP address of the data tunnel endpoint (essentially the MAG).
> >
> > on those terms, given that the MN really only has one IP address in 
> > the PMIP domain.
> >
> > like Local Address (LoA) or PMIP Address (PA)), but, I'm willing to 
> > live with pHoA and pCoA.
> >
> > Vidya
> >

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 08 Feb 2007 11:29:05 -0800

I like pHoA and pCoA.

One is an persistent address that does not change as
long as the mobile node is in the PMIPv6 domain, and
the other is a routable address to which the packets
need to forwarded to. They are very similar to the
home address and the foreign agent care-of address
(I know we don't have the concept of FA in MIPv6),
but at the same time very explicit that they are
addresses used in the PMIPv6 protocol and different
from the home address and the care-of address in the
RFC 3775 sense.

Vijay

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 8 Feb 2007 11:52:49 -0800 (PST)

> on those terms, given that the MN really only has one IP address in the

I prefer the terms:

pHoA - Proxy Home Address
pCoA - Proxy Care-of Address

Sri

---

From: Basavaraj Patil <[email-masked]>
Date: Thu, 08 Feb 2007 14:47:12 -0600

Sri,

I like the terms you propose below. Can you also expand on the acronym and
define it as well so that we have a common understanding of the terms?

-Raj

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 8 Feb 2007 13:05:18 -0800 (PST)

Hi Raj,

pHoA - Proxy Home Address:

This is the address of the mobile that is configured
on the mobile in a Proxy Mobile IPv6 domain. The mobile
can roam using this address in that entire PMIP6 domain.

pCoA - Proxy Care-of Address:

This is the address configured on the interface of the
proxy mobile agent and is the transport endpoint of the
tunnel between the home agent and the proxy mobile agent.
>From the perspective of the home agent, this is also the
care-of address of the mobile and the same is reflected
in the BCE for that mobile.

Regards 
Sri

---

From: Basavaraj Patil <[email-masked]>
Date: Thu, 08 Feb 2007 16:03:20 -0600

Sri,

Suggestion below:

> can roam using this address in that entire PMIP6 domain.

"address of the mobile configured on the mobile..." does not sound right :)

How about saying
pHoA is the MNs address (or address associated with an MN) in a PMIP6
domain. The MN continues to use this address as long as it is in the PMIP6
domain.

> in the BCE for that mobile.

S/ From the perspective of the home agent, this is also the
 care-of address of the mobile and the same is reflected
 in the BCE for that mobile./The HA views this address as the CoA of the MN
and registers it in the BCE for that MN.

-Raj

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 8 Feb 2007 14:19:10 -0800 (PST)

Hi Raj,

> domain. The MN continues to use this address as long as it is in the PMIP6

Ok.

> and registers it in the BCE for that MN.

Ok. Sure, this is clear.

Thanks for the input.

Regards
Sri

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Thu, 8 Feb 2007 15:35:45 -0800

> Sent: Thursday, February 08, 2007 11:29 AM
> To: Narayanan, Vidya
> Cc: [email-masked]
> One is an persistent address that does not change as long as 
> the mobile node is in the PMIPv6 domain, and the other is a 
> routable address to which the packets need to forwarded to. 
> They are very similar to the home address and the foreign 
> agent care-of address (I know we don't have the concept of FA 
> in MIPv6), 

Aside from that, it is still not quite the same concept as in MIP4. The
right equivalent in terms of scope for PMIP is something like HMIP or
regional registration. Since these forms of mobility management can be
used in conjunction with other global mobility management protocols
(MIP4/MIP6), the use of terms like pHoA/pCoA along with HoA/CoA
complicate the discussion - the pHoA can map to the CoA in some cases
and the terminology is both visually and audibly confusing. 

Of course, this is really a problem for architectural discussions that
happen outside of the protocol documentation process we are going to do
here - it would be good to keep that in mind is what I'm saying. Simply
having the focus of aligning up terminology with MIP6 seems to be
missing that bigger viewpoint. By that logic, we should have called the
RCoA in HMIPv6 hHoA and I'm glad that logic didn't prevail during the
design of HMIP :)

Vidya

> addresses used in the PMIPv6 protocol and different from the 
> home address and the care-of address in the RFC 3775 sense.
> 
> Vijay
> 
> Narayanan, Vidya wrote:
> > Folks,

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 08 Feb 2007 15:38:32 -0800

> RCoA in HMIPv6 hHoA and I'm glad that logic didn't prevail during the

You went off on a tangent. :)

FA CoA is hosted at the FA. pCoA is hosted at the proxy mobility
agent. I was referring to that. Never was comparing with MIPv4.

Vijay

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 09 Feb 2007 09:41:57 +0100

Vijay Devarapalli wrote:
> Narayanan, Vidya wrote:
> 
>>> I like pHoA and pCoA.
>>> 
>>> One is an persistent address that does not change as long as the
>>>  mobile node is in the PMIPv6 domain, and the other is a routable
>>>  address to which the packets need to forwarded to. They are very
>>>  similar to the home address and the foreign agent care-of
>>> address (I know we don't have the concept of FA in MIPv6),
>> 
>> Aside from that, it is still not quite the same concept as in MIP4.
>> The right equivalent in terms of scope for PMIP is something like
>> HMIP or regional registration. Since these forms of mobility
>> management can be used in conjunction with other global mobility
>> management protocols (MIP4/MIP6), the use of terms like pHoA/pCoA
>> along with HoA/CoA complicate the discussion - the pHoA can map to
>> the CoA in some cases and the terminology is both visually and
>> audibly confusing. Of course, this is really a problem for
>> architectural discussions that happen outside of the protocol
>> documentation process we are going to do here - it would be good to
>> keep that in mind is what I'm saying. Simply having the focus of
>> aligning up terminology with MIP6 seems to be missing that bigger
>> viewpoint. By that logic, we should have called the RCoA in HMIPv6
>> hHoA and I'm glad that logic didn't prevail during the design of
>> HMIP :)
> 
> agent. I was referring to that.

It's the same, right?  PMA and FA are exactly the same no?  Unless you 
consider PMA to _not_ be the AR (see draft-singh PMIP Client), do you?

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 09 Feb 2007 09:46:02 +0100

Sri Gundavelli wrote:
> This is the address of the mobile that is configured on the mobile in
> a Proxy Mobile IPv6 domain. The mobile can roam using this address in
> that entire PMIP6 domain.
> 
> 

Couldn't NETLMM pCoA be confused with FMIPv6 PCoA rfc4068?  Remark in
rfc4068 the PCoA is assigned to the mobile ("previous" CoA) while in
P-MIPv6 is assigned to a AR.

Alex

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Fri, 9 Feb 2007 10:39:50 -0800

Good point. I definitely think we should avoid terminology that overlaps
with other mobility protocols that we've developed here at the IETF. 

Vidya 

> From: Alexandru Petrescu [mailto:[email-masked]] 
> Sent: Friday, February 09, 2007 12:46 AM
> To: Sri Gundavelli
> Cc: [email-masked]; Basavaraj Patil
> Subject: Re: pCoA or PCoA? (was: [netlmm] PMIPv6 Terminology 
> (Addressing))
> 
> Sri Gundavelli wrote:
> > Hi Raj,
> > 
> >

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Sun, 11 Feb 2007 12:05:13 -0600

What about the following terms:

MloA: Mobile Local Address: 
The Mobile address that is configured on the Mobile and anchored at the
LMA while roaming across a PMIPv6 domain.

LCoA: "Local Mobility" Care of Address:

The address which identifies the termination point of a tunnel toward a
mobile node while roaming across a PMIPv6 domain. It is usually a
Mobility Anchor Gateway (MAG) address.

Regards,
Ahmad

> Sent: Wednesday, February 07, 2007 10:00 PM
> To: [email-masked]
> Subject: RE: [netlmm] PMIPv6 Terminology (Addressing)
> 
> Folks,
> In order to try to get closure on what terms we are going to 
> use for the addresses in PMIP, please provide your thoughts. 
> Just to be clear on what we are talking about, there are two 
> IP addresses of significance here - the IP address of the MN 
> in the PMIP domain and the IP address of the data tunnel 
> Some folks have expressed the desire to use proxy Home 
> Address (pHoA) and proxy Care-of-address (pCoA). Some others 
> have expressed a concern on those terms, given that the MN 
> really only has one IP address in the PMIP domain. 
> 
> As an individual WG participant, I prefer to use a term that 
> is more representative of MN's IP address in the PMIP domain 
> (say, something like Local Address (LoA) or PMIP Address 
> (PA)), but, I'm willing to live with pHoA and pCoA. 
> 
> Vidya 
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 12 Feb 2007 00:01:08 +0100

> LMA while roaming across a PMIPv6 domain.

This is new.

This could be confused with HMIPv6 LCoA rfc4140:
>   On-link Care-of        The LCoA is the on-link CoA configured on
>    Address (LCoA)        a mobile node's interface based on the prefix
>                           advertised by its default router.  In [1],
>                           this is simply referred to as the Care-of-
>                           address.  However, in this memo LCoA is used
>                           to distinguish it from the RCoA.

Alex

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 12 Feb 2007 07:02:03 -0600

> Sent: Monday, February 12, 2007 8:01 AM
> To: Muhanna, Ahmad (RICH1:2H10)
> Cc: Narayanan, Vidya; [email-masked]
> > The Mobile address that is configured on the Mobile and anchored at 
> > the LMA while roaming across a PMIPv6 domain.
> 
> This is new.
> 
> > The address which identifies the termination point of a 
> tunnel toward 
> > a mobile node while roaming across a PMIPv6 domain. It is usually a 

Agreed.

What about modifying the term name to: LmCoA: Local Mobility Care of
Address
The address which identifies the termination point of a tunnel toward a
mobile node while roaming across a PMIPv6 domain. It is usually a
Mobility Anchor Gateway (MAG) address.

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Mon, 12 Feb 2007 18:45:05 -0800

Folks,
We have heard a lot of comments on the pHoA and pCoA terms - marginally
more number of folks have favored the terms than not. However, Alex
raised a valid point about pCoA being used as the FMIP Previous CoA.
Terminology that overlaps with other mobility protocols we've developed
here is certainly problematic. So, I've tried to go through all the
comments (on the list and some offline email) and come up with some
suggestions: 

Regional Home Address (RHoA) - This is the MN's IP address within the
PMIP domain. I've tried to keep the term "home" in it, since, some
people seem to really favor having that in the term. Yet, I've tried to
use the term "Regional" to indicate the localized nature of it. 

Proxy Local Care-of-address (PLCoA) - This is the tunnel endpoint (often
the MAG address). 

If you are NOT okay with these terms, please provide reasons and suggest
alternatives. Please refrain from stating reasons that we've already
hashed through on the list (e.g., alignment with MIP terminology). Let
me reiterate that while protocol re-use is a goal, terminology alignment
is not necessarily a goal. Also, please note that prolonging the
terminology debate is not helping progress. So, let's close this topic
as soon as possible and move forward with the design.  

Thanks,
Vidya