Subject: RE: [netlmm] Re: Review of draft-sgundave-mip6-proxymip6-01

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 2 Feb 2007 07:43:23 -0600

Hi Sri,

Please see one question below. Thanks.

Regards,
Ahmad
> -----Original Message-----
> From: Sri Gundavelli [mailto:[email-masked]] 
> Sent: Tuesday, January 23, 2007 7:00 PM
> To: Christian Vogt
> Cc: [email-masked]; Phil Roberts; James Kempf; Netlmm
> Subject: [netlmm] Re: Review of draft-sgundave-mip6-proxymip6-01
> 
> 
> Hi Christian,
> 
> Thanks for the review and all the comments. Please see our 
> response below:
> 
> 
> 
> 1. Global/Local mobility and the terminology
> 
> It is our view that local mobility and global mobility can be 
> implmented in many ways and we did not want to tie this 
> specification to a specific deployment model.
> It is possible the home address of a mobile in the PMIP 
> domain, can be a home address or a care-of address in the 
> global mobility sense, it is upto the proposed architecture 
> that is based on this specification. 

[Ahmad]
Could you please explain the scenario when the home address of a mobile
node in the PMIP domain is the same as the home address in the global
domain?

Thanks.

> 
> 
> Again, Appreciate your time and review. Thanks !!!!
> 
> 
> Regards
> Sri

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Christian Vogt <[email-masked]>
Date: Fri, 02 Feb 2007 15:32:15 +0100

Hi Ahmad,

I was thinking about a scenario like this:

A provider offers both RFC 3775 Mobile IPv6 service and PMIPv6 service.
 PMIPv6 is used to bring a MN's HoA to the access link when the MN is in
the home domain.  No RFC 3775 Mobile IPv6 is used at that time.  But
when the MN moves to a foreign domain, it initiates RFC 3775 Mobile IPv6
signaling with its home agent to continue using that same HoA.

Regards,
- Christian

-- 
Christian Vogt, Institute of Telematics, Universitaet Karlsruhe (TH)
www.tm.uka.de/~chvogt/pubkey/

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 2 Feb 2007 09:56:46 -0600

Hi Christian,
Please see my comments inline.

Regards,
Ahmad

> From: Christian Vogt [mailto:[email-masked]] 
> Sent: Friday, February 02, 2007 8:32 AM
> To: Muhanna, Ahmad (RICH1:2H10)
> Cc: Sri Gundavelli; Netlmm
> Subject: Re: [netlmm] Review of draft-sgundave-mip6-proxymip6-01
> 
> Hi Ahmad,
> 
>  PMIPv6 is used to bring a MN's HoA to the access link when 
> the MN is in the home domain.  

[Ahmad]
Let me just understand the terminology here. The PMIP local network is
advertising the MN Home Link Prefix in its RA. MN realizes that the
advertised prefix is its home prefix and assumes that it is home.
Although this MN has CMIP it does not use it since it is home. Right?

Ok, if that is true, then the LMA is basically the Global HA in this
scenario or one of the LMA's involved in setting this call up is the
Global HA?

> No RFC 3775 Mobile IPv6 is 
> used at that time.  

[Ahmad]
OK.

> But when the MN moves to a foreign 
> domain, it initiates RFC 3775 Mobile IPv6 signaling with its 
> home agent to continue using that same HoA.

Let me give my understanding and you can correct me if I am wrong.

Case 1: Foreign domain is a RFC3775 foreign domain, i.e. NO PMIP
involved.
In this case, I think what you describe is a normal inter-domain handoff
and I agree that the MN can continue to use the same HoA.

Case 2: Foreign Domain is PMIP enabled.
In this scenario, although the foreign domain is PMIP enabled but I
assume that it still advertises a home-prefix which is foreign to the
MN. In this case, the scenario is possible and I do not see any problem
here.

However, my question was related to the following statement made by Sri
which in my opinion is different than the above two scenarios.
"It is possible the home address of a mobile in the PMIP domain, can be
a home address"

Unless "home address of a mobile in the PMIP domain" in Sri's statement
!= P_HoA, then we are all on the same page.

> 
> Regards,
> - Christian
> 
> --
> Christian Vogt, Institute of Telematics, Universitaet 
> Karlsruhe (TH) www.tm.uka.de/~chvogt/pubkey/
> 
> 
> 
>

---

From: Christian Vogt <[email-masked]>
Date: Fri, 02 Feb 2007 18:53:24 +0100

Ahmad -

> Although this MN has CMIP it does not use it since it is home. Right?

Right.

> scenario or one of the LMA's involved in setting this call up is the

The LMA may be the same node as the one functioning as a global RFC 3775 
HA once the mobile node moves to the foreign domain.  After all, both the 
LMA and the global HA need to be reachable at the home prefix.  Does this 
answer your question?

> MN. In this case, the scenario is possible and I do not see any problem

Yes, in what way the foreign prefix is brought to the MN -- be it by means 
of PMIPv6 or by standard IPv6 -- does not matter from the MN's perspective.

> != P_HoA, then we are all on the same page.

I'll leave this to Sri, but I think, yes, we are all on the same page.

Best,
- Christian

---

From: Sri Gundavelli <[email-masked]>
Date: Fri, 2 Feb 2007 11:11:43 -0800 (PST)

Hi Christian,

Yes ! This is a very practical scenario and there is
a good reason to support this.

The restriction of MIPv6-HoA != PMIPv6-HoA, implies:

- A mobile when it is in its home domain, needs to establish
   a global mobility session.

Common Usage Scenario:

- Home domain is a managed network and there is a good
   reason and a chance, network based mobility is enabled in
   that domain.

- A mobile at home should be able to use its home address
   and leveraging the network based mobility should be able
   to roam in the entire home domain, with out requiring
   the mobile to involve in any mobility related signaling.

- When the mobile moves to some other domain, where again
   network based mobility is enabled, it can obtain a local
   home address (care-of address from the global mobility
   sense) and can establish mobility session with its home
   agent. That local home address is valid in that entire
   domain and so it need not update its home agent, as it
   moves with in that scope.

- When the mobile moves to some other domain, where network
   based mobility is not enabled, it should simply obtain
   a care-of address on the anchored link and establish
   global mobility.

So, there is a value and a need for supporting this case
and I dont see a single strong technical issue.

Sri

---

From: Christian Vogt <[email-masked]>
Date: Fri, 02 Feb 2007 21:45:53 +0100

Sri -

that's right.  So I think we agree on this use case.

Have a good weekend!

- Christian

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 2 Feb 2007 15:43:33 -0600

Thanks Christian. 

> The LMA may be the same node as the one functioning as a 
> global RFC 3775 HA once the mobile node moves to the foreign 
> domain.  After all, both the LMA and the global HA need to be 
> reachable at the home prefix.  Does this answer your question?
> 

Yes.

Regards,
Ahmad