Subject: Re: [netlmm] review of draft-devarapalli-netlmm-pmip6-mipv6-00.txt and draft-weniger--issues

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 24 Apr 2007 13:52:43 -0700 (PDT)

Hi Vijay,
  In this draft in Section 3.1, I think that MIPv6-CoA can not be equal to MN-HoA. This is because of the multi-link subnet issues draft which applies to MIPv6 home links as well. So HA should assign per-MN prefixes and HoA should be derived from these prefixes. Maybe in current implementations this is not the case but that is another issue.
  So in this scenario, LMA and HA are different and they each assign per-MN prefixes to MN. The address generated from the LMA prefix gets assigned to MN's interface according to base PMIPv6 specification and MN uses this as its address in PMIP domain. The address assigned from the HA prefix is the HoA. MIPv6 HA binds PMIPv6 HoA (called MN-HoA) to HA's HoA. Sounds strange, doesn't it? It also means that in MIP6 mode the packets will first be tunneled to the LMA and then tunneled again to the MAG.
  Because of the above, I think that issue #1 and part of issue #3 in draft-weniger can not happen in scenario 1.

 A few typos: 3.1 HoA address remove address
3.3 in the based (base) PMIPv6 specification
4. the a home agent remove a.
 
  The issue of making the network's capabilities announced to client MIP capable MNs has been debated in WiMAX NWG in the context of Scenario 2.

Regards,

Behcet

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 24 Apr 2007 16:52:34 -0700

Behcet Sarikaya wrote:
> Hi Vijay,
>   In this draft in Section 3.1, I think that MIPv6-CoA can not be equal 
> to MN-HoA. 

The PMIPv6 MN-HoA is assigned by the LMA and it is based on
per-MN prefix. Since the MN-HoA is based on per-MN prefix, the
MIPv6-CoA is also from per-MN prefix.

So how the multi-link subnet issues applicable.

> This is because of the multi-link subnet issues draft which 
> applies to MIPv6 home links as well. So HA should assign per-MN prefixes 
> and HoA should be derived from these prefixes. 

In the previous sentences you seem to say the MIPv6-CoA should
be from per-MN prefixes. Here you seem to say the MIPv6 HoA
should be from per-MN prefixes. Which one?

> Maybe in current 
> implementations this is not the case but that is another issue.

Not sure I understood your concerns.

>   So in this scenario, LMA and HA are different and they each assign 
> per-MN prefixes to MN. The address generated from the LMA prefix gets 
> assigned to MN's interface according to base PMIPv6 specification and MN 
> uses this as its address in PMIP domain. The address assigned from the 
> HA prefix is the HoA. MIPv6 HA binds PMIPv6 HoA (called MN-HoA) to HA's 
> HoA. Sounds strange, doesn't it? It also means that in MIP6 mode the 
> packets will first be tunneled to the LMA and then tunneled again to the 
> MAG.

It is not strange. It is the hierarchical mode we have known all
long. Similar to using HMIPv6 for local mobility and MIPv6 for
global mobility. The packets will be first tunneled from the HA
to the MAP and then from the MAP to the MN.

>   Because of the above, I think that issue #1 and part of issue #3 in 
> draft-weniger can not happen in scenario 1.
>  

Thanks.

Vijay

>  
>   The issue of making the network's capabilities announced to client MIP 
> capable MNs has been debated in WiMAX NWG in the context of Scenario 2.
>  
> Regards,
>  
> Behcet