Subject: Re: [netlmm] PMIPv6 Next Steps

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 11 Apr 2007 08:47:03 -0700 (PDT)

I just don't understand this discussion.

What is the big deal in making a separate document?
If Sri sends me the xml file I can make the IPv4 support draft shortly.

--behcet

----- Original Message ----
From: Mohamed Khalil <[email-masked]>
To: Jari Arkko <[email-masked]>; [email-masked]
Sent: Wednesday, April 11, 2007 9:42:43 AM
Subject: RE: [netlmm] PMIPv6 Next Steps

Hi Jari,

Thank you very much for your feedback. I disagree with you that
splitting the document into two documents is a management issue but it
is in my opinion is a technical issue. The management aspect is to put a
deadline to when this work should be concluded and proceed to be
standard. I believe we should leave the technical part to the consensus
of the members of this group, and the management part to the co-chairs. 

-----Original Message-----
From: Jari Arkko [mailto:[email-masked]] 
Sent: Tuesday, April 10, 2007 4:16 PM
To: [email-masked]
Subject: Re: [netlmm] PMIPv6 Next Steps

On the topic of IPv4:

I hear the concerns people have raised about this. I wanted to share
what I think. But let me start by listing some things that we have an
agreement on:

o  IPv4 support is essential for the success of NETLMM.
o  IPv4 support needs to be published timely, at the same time as
    the rest of the protocol.
o  The WG should decide whether IPv4 feature (or any other
    feature for that matter) is a mandatory-to-implement part
    of the specification.
o  We should not develop a lot of new technology to support
    IPv4, pointing to DSMIP is the right approach.
o  The current text we have is a good start -- needs some adjustment
    but is not fundamentally broken.
o  The current starting point text from draft-sgundave has
    WG backing to go into WG draft(s) as soon as it can be
    submitted.

No one is suggesting we compromise on any of these, so lets take those
worries off the table from the start.

Then to my opinion.

What Vidya is suggesting is not a change to to the above, but only a
document organization matter. Namely whether we have a single document
or the base plus another one to explain the IPv4 aspects. Generally
speaking its the chairs' job in a WG to worry about the project
management. This includes things like breaking tasks into smaller ones,
picking people who are responsible for the tasks, thinking how to
serialize/parallelize  tasks, managing risks of what happens when
there's a problem in a task, etc. I would suggest the WG concentrates on
the substance of what should go into the documents, reviewing and
improving the specifications, and lets the chairs do the project
management part. We have already spent the last months in debating which
one of the very similar drafts we pick for going forward -- lets not
spend the next months by arguing what the documentation structure should
be. No matter what the structure is, revving the current IPv4 text to
whatever shape is going to take less time than we have already spent on
this thread.

Clearly you can handle this feature either within the base or in another
document. The world is not going to end either way. But I do see some
advantages in separate modular drafts, and I support the plan. The
advantages include some parallelization of editor efforts (based on my
review at least some editing will be needed), smaller documents for
reviewers, possibly some advantages with normative reference delays if
something like that would happen, etc.

So, given the list from the top of my e-mail and a plan to take these
two parts to the WG draft, WGLC, IESG etc. at the same time -- do people
still see problems?

Jari

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Wed, 11 Apr 2007 12:50:13 -0400

Hi Behcet,

The question is not how to create a separate document. It is more about
the need to create a separate document. That's the real point of debate.

Regards,

Kuntal

________________________________

From: Behcet Sarikaya [mailto:[email-masked]] 
Sent: Wednesday, April 11, 2007 10:47 AM
To: Mohamed Khalil; Jari Arkko
Cc: [email-masked]
Subject: Re: [netlmm] PMIPv6 Next Steps

--behcet

----- Original Message ----
From: Mohamed Khalil <[email-masked]>
To: Jari Arkko <[email-masked]>; [email-masked]
Sent: Wednesday, April 11, 2007 9:42:43 AM
Subject: RE: [netlmm] PMIPv6 Next Steps

Hi Jari,

-----Original Message-----
From: Jari Arkko [mailto:[email-masked]] 
Sent: Tuesday, April 10, 2007 4:16 PM
To: [email-masked]
Subject: Re: [netlmm] PMIPv6 Next Steps

On the topic of IPv4:

Then to my opinion.

Jari

---

From: "Singh Ajoy-ASINGH1" <[email-masked]>
Date: Wed, 11 Apr 2007 13:15:55 -0400

Hi, Kuntal, 
 
Why this debate is important here? As long as long there is commitment
to do the both IPv4 and IPv6 together in two different documents in same
timeline  
why are we making big deal about it? 
 
Regards,
Ajoy

From: Chowdhury, Kuntal [mailto:[email-masked]] 
Sent: Wednesday, April 11, 2007 11:50 AM
To: Behcet Sarikaya; Mohamed Khalil; Jari Arkko
Cc: [email-masked]
Subject: RE: [netlmm] PMIPv6 Next Steps

Hi Behcet,

Regards,

Kuntal

--behcet

----- Original Message ----
From: Mohamed Khalil <[email-masked]>
To: Jari Arkko <[email-masked]>; [email-masked]
Sent: Wednesday, April 11, 2007 9:42:43 AM
Subject: RE: [netlmm] PMIPv6 Next Steps

Hi Jari,

-----Original Message-----
From: Jari Arkko [mailto:[email-masked]] 
Sent: Tuesday, April 10, 2007 4:16 PM
To: [email-masked]
Subject: Re: [netlmm] PMIPv6 Next Steps

On the topic of IPv4:

Then to my opinion.

Jari

---

From: "Mohamed Khalil" <[email-masked]>
Date: Wed, 11 Apr 2007 12:42:56 -0500

generating too many documents is not necessary to be a good management
practice specially if those documents are very much interrelated.

	-----Original Message-----
	From: Singh Ajoy-ASINGH1 [mailto:[email-masked]] 
	Sent: Wednesday, April 11, 2007 12:16 PM
	To: Chowdhury, Kuntal; Behcet Sarikaya; Khalil, Mohamed
(RICH2:2S20); Jari Arkko
	Cc: [email-masked]

	Hi, Kuntal, 
	 
	Why this debate is important here? As long as long there is
commitment to do the both IPv4 and IPv6 together in two different
documents in same timeline  
	why are we making big deal about it? 
	 
	Regards,
	Ajoy

	Hi Behcet,

	The question is not how to create a separate document. It is
more about the need to create a separate document. That's the real point
of debate.

	Regards,

	Kuntal

	If Sri sends me the xml file I can make the IPv4 support draft
shortly.

	--behcet

	----- Original Message ----
	From: Mohamed Khalil <[email-masked]>
	To: Jari Arkko <[email-masked]>; [email-masked]
	Sent: Wednesday, April 11, 2007 9:42:43 AM
	Subject: RE: [netlmm] PMIPv6 Next Steps

	Hi Jari,
	
	Thank you very much for your feedback. I disagree with you that
	splitting the document into two documents is a management issue
but it
	is in my opinion is a technical issue. The management aspect is
to put a
	deadline to when this work should be concluded and proceed to be
	standard. I believe we should leave the technical part to the
consensus
	of the members of this group, and the management part to the
co-chairs. 
	
	-----Original Message-----
	From: Jari Arkko [mailto:[email-masked]] 
	Sent: Tuesday, April 10, 2007 4:16 PM
	To: [email-masked]
	Subject: Re: [netlmm] PMIPv6 Next Steps

	On the topic of IPv4:
	
	I hear the concerns people have raised about this. I wanted to
share
	what I think. But let me start by listing some things that we
have an
	agreement on:
	
	o  IPv4 support needs to be published timely, at the same time
as
	o  The current text we have is a good start -- needs some
adjustment
	
	No one is suggesting we compromise on any of these, so lets take
those
	worries off the table from the start.
	
	Then to my opinion.
	
	What Vidya is suggesting is not a change to to the above, but
only a
	document organization matter. Namely whether we have a single
document
	or the base plus another one to explain the IPv4 aspects.
Generally
	speaking its the chairs' job in a WG to worry about the project
	management. This includes things like breaking tasks into
smaller ones,
	picking people who are responsible for the tasks, thinking how
to
	serialize/parallelize  tasks, managing risks of what happens
when
	there's a problem in a task, etc. I would suggest the WG
concentrates on
	the substance of what should go into the documents, reviewing
and
	improving the specifications, and lets the chairs do the project
	management part. We have already spent the last months in
debating which
	one of the very similar drafts we pick for going forward -- lets
not
	spend the next months by arguing what the documentation
structure should
	be. No matter what the structure is, revving the current IPv4
text to
	whatever shape is going to take less time than we have already
spent on
	this thread.
	
	Clearly you can handle this feature either within the base or in
another
	document. The world is not going to end either way. But I do see
some
	advantages in separate modular drafts, and I support the plan.
The
	advantages include some parallelization of editor efforts (based
on my
	review at least some editing will be needed), smaller documents
for
	reviewers, possibly some advantages with normative reference
delays if
	something like that would happen, etc.
	
	So, given the list from the top of my e-mail and a plan to take
these
	two parts to the WG draft, WGLC, IESG etc. at the same time --
do people
	still see problems?
	
	Jari