Subject: [netlmm] About

From: "John.zhao" <[email-masked]>
Date: Fri, 27 Apr 2007 10:08:04 +0800

Hi ,Vidya and all

         About the problem when the PMIP should be used to a MN, based on a
profile is not enough. So I think it is the time and need to discuss about
this to make our architecture more completion. So welcome all of you comment
about my drafts:
http://tools.ietf.org/wg/netlmm/draft-zhao-netlmm-miptype-00.txt.

         My two cents, I think this is the necessary part in baseline
document.

         Best Rgds,

Thanks,

John.zhao

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Sri Gundavelli" <[email-masked]>
Date: Thu, 26 Apr 2007 19:37:48 -0700

The ability for the network to detect the mobile node's capability w.r.t the
the host-based mobility and the ability for the mobile node to make the
choice of obtaining host-based or network-based mobility is definitely
required, IMO. This needs to be solved after the base specs are in good
shape.
 
However, I've not reviewed this specific draft. 
 
Thanks
Sri

  _____  

From: John.zhao [mailto:[email-masked]] 
Sent: Thursday, April 26, 2007 7:08 PM
To: [email-masked]; [email-masked]; 'Sri Gundavelli'; 'Hesham
Soliman'; [email-masked]
Cc: [email-masked]
Subject: About

Hi ,Vidya and all

         Best Rgds,

Thanks,

John.zhao

---

From: "John.zhao" <[email-masked]>
Date: Fri, 27 Apr 2007 10:46:20 +0800

Hi, Sri

         Thank you comment at the first. That has been discussed before last
IETF meeting in mail list. 

         And we are working to build the base specs .IMO . I think need
allocate a space for this topic in the base specs.

         Of course , we can also come back after finish a perfect base
specs. But without this point, is it integrated to that base specs?

         Best Rgds,

Thanks,

John.zhao

  _____  

发件人: Sri Gundavelli [mailto:[email-masked]] 
发送时间: 2007年4月27日 10:38
收件人: [email-masked]; [email-masked]; [email-masked];
'Hesham Soliman'; [email-masked]
抄送: [email-masked]
主题: RE: About

shape.

Thanks

Sri

  _____  

Hi ,Vidya and all

         Best Rgds,

Thanks,

John.zhao

---

From: "Sri Gundavelli" <[email-masked]>
Date: Thu, 26 Apr 2007 19:52:28 -0700

Hi John,
 
My point is that this work is required and it can be done now or
later...when
ever the charter has it ...I dont care ..either way ...
 
Sri

  _____  

From: John.zhao [mailto:[email-masked]] 
Sent: Thursday, April 26, 2007 7:46 PM
To: 'Sri Gundavelli'; [email-masked]; [email-masked]; 'Hesham
Soliman'; [email-masked]
Cc: [email-masked]
Subject: RE: About draft-zhao-netlmm-miptype-00.txt.

Hi, Sri

         Best Rgds,

Thanks,

John.zhao

  _____  

shape.

Thanks

Sri

  _____  

Hi ,Vidya and all

         Best Rgds,

Thanks,

John.zhao

---

From: "John.zhao" <[email-masked]>
Date: Fri, 27 Apr 2007 11:02:07 +0800

Hi , Sri

         Ok, thanks. We are the same in this point. 

So Vidya, how do you think about this problem ? When do we start the work,
now or later. 

Best Rgds,

Thanks,

John.zhao

  _____  

发件人: Sri Gundavelli [mailto:[email-masked]] 
发送时间: 2007年4月27日 10:52
收件人: [email-masked]; [email-masked]; [email-masked];
'Hesham Soliman'; [email-masked]
抄送: [email-masked]
主题: RE: About draft-zhao-netlmm-miptype-00.txt.

Hi John,

Sri

 

  _____  

Hi, Sri

         Best Rgds,

Thanks,

John.zhao

  _____  

shape.

Thanks

Sri

  _____  

Hi ,Vidya and all

         Best Rgds,

Thanks,

John.zhao

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Thu, 26 Apr 2007 21:12:46 -0700

Hi all,
The base protocol is specifying the operation of PMIPv6 only.  We do have a to-do to address the PMIP6-MIP6 interactions and we need to have discussions on whether identifying the mobility capabilities of the MN and providing PMIP6 selectively to hosts that cannot do their own mobility alone is needed.  We have a few drafts now that discuss the MIP6-PMIP6 interactions.  Let's discuss this problem in the scope of that topic.  

<WG Chair hat off> My personal sense is that this is a system level problem.  We don't really know the kind of address provisioning mechanisms that each system uses and it is hard to define something useful here.  Also, it is not clear if there will be such selective deployments of PMIP where the network doesn't perform PMIP for some of the devices.  I'll send some further comments on the thread already active on the list on this topic. 

Thanks,
Vidya

________________________________

	From: John.zhao [mailto:[email-masked]] 
	Sent: Thursday, April 26, 2007 8:02 PM
	To: 'Sri Gundavelli'; Narayanan, Vidya; [email-masked]; 'Hesham Soliman'; [email-masked]
	Cc: [email-masked]
	Subject: RE: About draft-zhao-netlmm-miptype-00.txt.

	Hi , Sri

	So Vidya, how do you think about this problem ? When do we start the work, now or later. 

	Best Rgds,

	Thanks,

	John.zhao

	________________________________

		发件人: Sri Gundavelli [mailto:[email-masked]] 
	发送时间: 2007年4月27日 10:52
	收件人: [email-masked]; [email-masked]; [email-masked]; 'Hesham Soliman'; [email-masked]
	抄送: [email-masked]
	主题: RE: About draft-zhao-netlmm-miptype-00.txt.

	Hi John,

	My point is that this work is required and it can be done now or later...when

	Sri

		 

		________________________________

				From: John.zhao [mailto:[email-masked]] 
		Sent: Thursday, April 26, 2007 7:46 PM
		To: 'Sri Gundavelli'; [email-masked]; [email-masked]; 'Hesham Soliman'; [email-masked]
		Cc: [email-masked]
		Subject: RE: About draft-zhao-netlmm-miptype-00.txt.

		Hi, Sri

		         Thank you comment at the first. That has been discussed before last IETF meeting in mail list. 

		         And we are working to build the base specs .IMO . I think need allocate a space for this topic in the base specs.

		         Of course , we can also come back after finish a perfect base specs. But without this point, is it integrated to that base specs?

		         Best Rgds,

		Thanks,

		John.zhao

		________________________________

				发件人: Sri Gundavelli [mailto:[email-masked]] 
		发送时间: 2007年4月27日 10:38
		收件人: [email-masked]; [email-masked]; [email-masked]; 'Hesham Soliman'; [email-masked]
		抄送: [email-masked]
		主题: RE: About

		shape.

		Thanks

		Sri

			________________________________

						From: John.zhao [mailto:[email-masked]] 
			Sent: Thursday, April 26, 2007 7:08 PM
			To: [email-masked]; [email-masked]; 'Sri Gundavelli'; 'Hesham Soliman'; [email-masked]
			Cc: [email-masked]
			Subject: About

			Hi ,Vidya and all

			         About the problem when the PMIP should be used to a MN, based on a profile is not enough. So I think it is the time and need to discuss about this to make our architecture more completion. So welcome all of you comment about my drafts: http://tools.ietf.org/wg/netlmm/draft-zhao-netlmm-miptype-00.txt.

			         My two cents, I think this is the necessary part in baseline document.

			         Best Rgds,

			Thanks,

			John.zhao

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 26 Apr 2007 21:30:45 -0700

> <WG Chair hat off> My personal sense is that this is a system level problem.  We don't really know the kind of address provisioning mechanisms that each system uses and it is hard to define somethi…

I agree. This needs to be handled in a system-specific
solution in the system where this problem occurs. This
is not a protocol issue. In fact we don't even know
what kind of link layer might be used between the MAG
and the LMA and what IP protocols are run on top of
that link to design a generic solution.

Vijay

---

From: "John.zhao" <[email-masked]>
Date: Fri, 27 Apr 2007 14:36:47 +0800

Hi,Vidya

     My two cents. 
	I don't care where or when to discuss it. Only make clarify on it.
So based on your decision, we can discuss it in the PMIP-MIP interaction,
right?
	IMHO.About this problem , I think that is not out of scope in
current stage. Because, just like we describe this protocol and need to
define some behavior in MN, MAG,LMA or others. This is also a key progress
when the MN can enjoy the PMIP service. With it, we can provide this
protocol perfectly. Because, this protocol has a stable foundation. And to
do this , I think we didn't need to list all of possible method to do , but
a option or suggested method is enough. 
	So, it is why I think it can make some sense in base specs. 

	Best Rgds,
Thanks,

John.zhao
-----邮件原件-----
发件人: Narayanan, Vidya [mailto:[email-masked]] 
发送时间: 2007年4月27日 12:13
收件人: [email-masked]; Sri Gundavelli; [email-masked];
Hesham Soliman; [email-masked]
抄送: [email-masked]
主题: RE: About draft-zhao-netlmm-miptype-00.txt.

Hi all,
The base protocol is specifying the operation of PMIPv6 only.  We do have a
to-do to address the PMIP6-MIP6 interactions and we need to have discussions
on whether identifying the mobility capabilities of the MN and providing
PMIP6 selectively to hosts that cannot do their own mobility alone is
needed.  We have a few drafts now that discuss the MIP6-PMIP6 interactions.
Let's discuss this problem in the scope of that topic.  

<WG Chair hat off> My personal sense is that this is a system level problem.
We don't really know the kind of address provisioning mechanisms that each
system uses and it is hard to define something useful here.  Also, it is not
clear if there will be such selective deployments of PMIP where the network
doesn't perform PMIP for some of the devices.  I'll send some further
comments on the thread already active on the list on this topic. 

Thanks,
Vidya

	To: 'Sri Gundavelli'; Narayanan, Vidya; [email-masked];

	Hi , Sri

	So Vidya, how do you think about this problem ? When do we start the
work, now or later. 

	Best Rgds,

	Thanks,

	John.zhao

		发件人: Sri Gundavelli [mailto:[email-masked]] 
	发送时间: 2007年4月27日 10:52
	收件人: [email-masked]; [email-masked];
[email-masked]; 'Hesham Soliman'; [email-masked]
	抄送: [email-masked]
	主题: RE: About draft-zhao-netlmm-miptype-00.txt.

	Hi John,

	Sri

		 

				From: John.zhao
[mailto:[email-masked]] 
		Sent: Thursday, April 26, 2007 7:46 PM
		To: 'Sri Gundavelli'; [email-masked];
[email-masked]; 'Hesham Soliman'; [email-masked]
		Cc: [email-masked]
		Subject: RE: About draft-zhao-netlmm-miptype-00.txt.

		Hi, Sri

		         Thank you comment at the first. That has been
discussed before last IETF meeting in mail list. 

		         And we are working to build the base specs .IMO . I
think need allocate a space for this topic in the base specs.

		         Of course , we can also come back after finish a
perfect base specs. But without this point, is it integrated to that base
specs?

		         Best Rgds,

		Thanks,

		John.zhao

				发件人: Sri Gundavelli
[mailto:[email-masked]] 
		发送时间: 2007年4月27日 10:38
		收件人: [email-masked]; [email-masked];
[email-masked]; 'Hesham Soliman'; [email-masked]
		抄送: [email-masked]
		主题: RE: About

		The ability for the network to detect the mobile node's
capability w.r.t the

		the host-based mobility and the ability for the mobile node
to make the

		choice of obtaining host-based or network-based mobility is
definitely

		required, IMO. This needs to be solved after the base specs
are in good

		shape.

		Thanks

		Sri

						From: John.zhao
[mailto:[email-masked]] 
			Sent: Thursday, April 26, 2007 7:08 PM
			To: [email-masked]; [email-masked];
'Sri Gundavelli'; 'Hesham Soliman'; [email-masked]
			Cc: [email-masked]
			Subject: About

			Hi ,Vidya and all

			         About the problem when the PMIP should be
used to a MN, based on a profile is not enough. So I think it is the time
and need to discuss about this to make our architecture more completion. So
welcome all of you comment about my drafts:
http://tools.ietf.org/wg/netlmm/draft-zhao-netlmm-miptype-00.txt.

			         My two cents, I think this is the necessary
part in baseline document.

			         Best Rgds,

			Thanks,

			John.zhao

---

From: "John.zhao" <[email-masked]>
Date: Fri, 27 Apr 2007 16:30:54 +0800

Hi , vijay
     My two cents.
	Thanks for your comment. See my comments inline.

	Best Rgds,
Thanks
John.zhao

-----邮件原件-----
发件人: Vijay Devarapalli [mailto:[email-masked]] 
发送时间: 2007年4月27日 12:31
收件人: Narayanan, Vidya
抄送: [email-masked]; Sri Gundavelli; [email-masked]; Hesham
Soliman; [email-masked]; [email-masked]
主题: Re: [netlmm] RE: About draft-zhao-netlmm-miptype-00.txt.

Narayanan, Vidya wrote:
> 
> <WG Chair hat off> My personal sense is that this is a system level
problem.  We don't really know the kind of address provisioning mechanisms
that each system uses and it is hard to define something useful here.  Also,
it is not clear if there will be such selective deployments of PMIP where
the network doesn't perform PMIP for some of the devices.  I'll send some
further comments on the thread already active on the list on this topic. 

[John.zhao] We didn't must need to specify a very specific implementation
method. But one or something can be suggested. Just like we didn't know what
IP protocols are run on top of a link , but we still choose DHCP and RD/RA
to do the entry network discovery progress in current base specs. The same
situation. Why we can't make any discussion and decision on it?

Vijay

---

From: Basavaraj Patil <[email-masked]>
Date: Fri, 27 Apr 2007 10:46:39 -0500

I don¹t think the network really needs to be aware of the MNs capability
w.r.t whether it has a MIP client.
However I think it makes sense for the MN to know that the network to
which it is attaching has PMIP support.
The MN can then decide if it wants the network to provide any sort of
localized or global mobility.

Damjan and I are submitting an I-D on this which indicates this via an
RA flag (or via DHCP). You should see it early next week.

-Raj

---

From: "John.zhao" <[email-masked]>
Date: Sat, 28 Apr 2007 09:13:55 +0800

Hi, Basavaraj 

         I think what you means is the same with us. The key point is that
the PMIP and CMIP service is needed to be provided and used based on not
only a profile. I think that is enough. As to your draft detail, I will read
later after it is uploaded. So we can’t make any assumption about who will
make this decisicon , but the related information is useful to be share
between MN and AR. And can make the mobility management more applicable.

         My two cents.

         Best Rgds,

Thanks,

John.zhao

  _____  

发件人: Basavaraj Patil [mailto:[email-masked]] 
发送时间: 2007年4月27日 23:47
收件人: ext Sri Gundavelli; [email-masked]; [email-masked];
[email-masked]; 'Hesham Soliman'; Giaretta Gerardo
抄送: [email-masked]
主题: Re: [netlmm] RE: About

I don’t think the network really needs to be aware of the MNs capability

-Raj

Thanks
Sri

  _____  

From: John.zhao [mailto:[email-masked]]
<mailto:[email-masked]%5d>   
Sent: Thursday, April 26, 2007 7:08 PM
To:  [email-masked]; [email-masked]; 'Sri Gundavelli';
'Hesham  Soliman'; [email-masked]
Cc:  [email-masked]
Subject: About

Hi ,Vidya and  all

          About the problem when the PMIP should be used to a MN, based on a
profile is  not enough. So I think it is the time and need to discuss about
this to make  our architecture more completion. So welcome all of you
comment about my  drafts:
http://tools.ietf.org/wg/netlmm/draft-zhao-netlmm-miptype-00.txt.

 
          Best Rgds,
 
Thanks,

John.zhao

  _____

---

From: Wassim Haddad <[email-masked]>
Date: Sat, 28 Apr 2007 09:14:12 +0300 (EEST)

On Fri, 27 Apr 2007, Basavaraj Patil wrote:

> I don't think the network really needs to be aware of the MNs capability

=> Agree.

> RA flag (or via DHCP). You should see it early next week.

=> That would be highly appreciated!

Thanks

Wassim H.