Subject: [netlmm] Home Network Prefix Option

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 26 Apr 2007 13:04:52 -0700 (PDT)

Hello All,
  In draft-ietf-netlmm-proxymip6, HNP Option is defined in Sec. 8.3. It says: This
   option can be used for exchanging the mobile node's home prefix and
   home address information.
Since HNP needs to be sent by LMA in PBA, can you explain how this exchange will occur? Does it mean that MAG will send MN-HoA in PBU?

Regards,

Behcet

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Sri Gundavelli" <[email-masked]>
Date: Thu, 26 Apr 2007 20:35:08 -0700

HI Behcet,
 
 Please see inline ...

  _____  

From: Behcet Sarikaya [mailto:[email-masked]] 
Sent: Thursday, April 26, 2007 1:05 PM
To: [email-masked]
Subject: [netlmm] Home Network Prefix Option

 >   Since HNP needs to be sent by LMA in PBA, can you explain how this
exchange 
>    will occur? Does it mean that MAG will send MN-HoA in PBU?

[Sri]
 
First, as JinHyeock pointed out, we need to be clear on the text, on the
order and
about this exchange. That point is noted and is in the issue tracker and we
are looking 
forward to address this in out -01 version.
 
If the MAG knows the mobile node's prefix, it can set the option to that
value and
send it in the PBU and the LMA will accept the binding and create a prefix
route
over the tunnel. Now, if the MAG sets the value to 0::0/0, the LMA will
allocate a
prefix and return that in the PBA as mentioned here.
 
" If the home network prefix option is set to value 0, the local mobility
anchor
will assign the home network prefix and will return them in the Proxy
Binding
Acknowledgment "
 
Any case, we will clarify this text and be bit more detailed.
 
Thanks
Sri