Subject: RE: [netlmm] Closing the multihoming issue

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Thu, 11 Oct 2007 06:04:53 -0400

> -----Original Message-----
> From: Ved Kafle [mailto:[email-masked]]
> Sent: Thursday, October 11, 2007 6:35 PM
> To: [email-masked]
> Subject: RE: [netlmm] Closing the multihoming issue
> 
> Hi Raj,
> 
> Find my comment inline.
> 
> > -----Original Message-----
> > From: Basavaraj Patil [mailto:[email-masked]]
> > Sent: Thursday, October 11, 2007 2:16 PM
> > To: [email-masked]
> > Subject: [netlmm] Closing the multihoming issue
> >
> >
> >
> > Hello,
> >
> > After a week of discussion and many many emails, we seem to
> > be deadlocked on the way forward.
> >
> > The authors have proposed a solution which addresses the
> > issue of unmodified hosts attaching via multiple interfaces
> > to a PMIP6 domain.
> >
> > The proposed solution (abridged version):
> > - Includes an option which indicates the access type via which the
MN
> >   is attaching to the network and hence provides the LMA with
> >   additional information
> > - It is the policy of the LMA which decides the assignment of the
> >   prefix to an MN attaching via a second interface.
> > - The prefix assigned to a second interface of the MN can be a
unique
> >   prefix depending on the access tech type indicated in the PBU or
it
> >   can be the same prefix as assigned to a previous interface (policy
> >   decision)
> > - In the scenario where the LMA decides to assign the same prefix to
> >   the second interface, the LMA waits for a dereg from the MAG
serving
> >   the first interface (which ensures that IF1 of the MN is disabled
> >   via any of L1/2/3 means) prior to assigning the interface via MAG2
> >   to the MN.
> 
> This assumption that the MN disables its one interface for being
> connected through another interface is not realistic. An unmodified
> multihomed MN does not inform the MAG serving the first interface,
hence
> the MAG can not send a dereg to the LMA.
> 
[KC>] It is not always the responsibility of the MN to inform the MAG/AR
that it needs to detach. The network can detach the MN as well. There
are many ways to do that:

- AAA sends disconnect to old MAG as soon as the MN attaches to new MAG.
- L2 triggers from the access networks
- AR - AR interface
- Other way: revoke from LMA to MAG1 (LAM initiated dereg).

> - Ved Kafle
> 
> > - The solution does not break the link model that has been decided
on
> >   for PMIP6 or the IPv6 addressing model (details of this have been
> >   discussed in earlier emails).
> >
> > The issue as has been raised arises only when the MN attaches
> > via multiple interfaces to the same PMIP6 domain and is
> > assigned the same LMA (to which the above solution is
> > proposed). In the case where the MN attaches via another
> > interface is a different PMIP6 domain from the domain which
> > serves the earlier interface, the MN is assigned a unique prefix.
> >
> > We believe that this is a solution that addresses the
> > multihoming issue and allows unmodified IP hosts to operate
> > with no disruption to its connectivity. The WG may decide to
> > work on a comprehensive solution to multihomed hosts in a
> > PMIP6 domain separately in the future.
> >
> > I think it is time the chairs made a decision on this issue.
> >
> > -Basavaraj
> >
> >
> >
> > _______________________________________________
> > netlmm mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/netlmm
> >
> 
> 
> 
> 
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Ved Kafle" <[email-masked]>
Date: Fri, 12 Oct 2007 14:05:19 +0900

> From: Chowdhury, Kuntal [mailto:[email-masked]] 
> Sent: Thursday, October 11, 2007 7:05 PM
> To: Ved Kafle; [email-masked]
> > > After a week of discussion and many many emails, we seem to be 
> > > deadlocked on the way forward.
> > >
> > > The authors have proposed a solution which addresses the issue of 
> > > unmodified hosts attaching via multiple interfaces to a PMIP6 
> > > domain.
> > >
> [KC>] It is not always the responsibility of the MN to inform 
> the MAG/AR that it needs to detach. The network can detach 
> the MN as well. There are many ways to do that:
> 

But should not there be at least one method explicitly mentioned in the
protocol spec?

> > > The issue as has been raised arises only when the MN attaches via 
> > > multiple interfaces to the same PMIP6 domain and is assigned the 
> > > same LMA (to which the above solution is proposed). In the case 
> > > where the MN attaches via another interface is a different PMIP6 
> > > domain from the domain which serves the earlier 
> interface, the MN is 
> > > assigned a unique prefix.
> > >
> > > We believe that this is a solution that addresses the multihoming 
> > > issue and allows unmodified IP hosts to operate with no 
> disruption 
> > > to its connectivity. The WG may decide to work on a comprehensive 
> > > solution to multihomed hosts in a PMIP6 domain separately in the 
> > > future.
> > >
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/netlmm
> > >
> > 
> > 
> > 
> > 
> "This email message and any attachments are confidential 
> information of Starent Networks, Corp. The information 
> transmitted may not be used to create or change any 
> contractual obligations of Starent Networks, Corp.  Any 
> review, retransmission, dissemination or other use of, or 
> taking of any action in reliance upon this e-mail and its 
> attachments by persons or entities other than the intended 
> recipient is prohibited. If you are not the intended 
> recipient, please notify the sender immediately -- by 
> replying to this message or by sending an email to 
> [email-masked] -- and destroy all copies of 
> this message and any attachments without reading or 
> disclosing their contents. Thank you."
>

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Fri, 12 Oct 2007 02:00:48 -0400

> Sent: Friday, October 12, 2007 2:05 PM
> To: Chowdhury, Kuntal; [email-masked]
[KC>] I don't think we can pick one method from a list of possible
methods to detach the MN. There are number of possible ways and
depending on the use case, one of them will be used. We can provide some
informative text on that line though....

> > > > The issue as has been raised arises only when the MN attaches
via
> > > > We believe that this is a solution that addresses the
multihoming

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 25 Oct 2007 09:49:18 -0700 (PDT)

Christian,
  The solution proposal text presents multihoming issue as a prefix allocation problem and then gets into solving it.

  Sorry but I don't agree with this approach and I explained why in some previous mails. It is not the base spec to do such things, IMHO.

Kind regards,

Behcet

----- Original Message ----
From: Christian Vogt <[email-masked]>
To: Alper Yegin <[email-masked]>
Cc: [email-masked]
Sent: Thursday, October 25, 2007 10:41:29 AM
Subject: Re: [netlmm] Closing the multihoming issue

> Here is my unanswered e-mail:
> http://www1.ietf.org/mail-archive/web/netlmm/current/msg03956.html

Alper,

from a higher perspective, you seem to be unhappy with the
MAGs being the only entities that can decide whether a home
prefix is moved to a new interface, or whether the new
interface gets a new home prefix.

Would it be sufficient for your scenario to...

(a) pre-configure MAGs to use the "no information" value in
     the Handover Information field of PBU messages, and thus

(b) leave the home prefix selection up to the LMA?

The LMA can then retrieve the home prefix from AAA.  This 
would be compatible with the text that Vidya sent.

- Christian