Subject: Re: [netlmm] Issue: Prefix allocation and multihomed MNs (Problem Description Take 2)

From: Julien Laganier <[email-masked]>
Date: Thu, 4 Oct 2007 13:11:51 +0200

Hi Vidya,

Some comments below:

On Saturday 29 September 2007, Narayanan, Vidya wrote:
> All,
> I think several people have understood the problem we are discussing
> here, but, there still seems to be some confusion.  Here is a second
> attempt at describing the problem, this time in some more detail:
>
> * MN has two interfaces attached to MAG1 and MAG2 under the same LMA
> * Let's say MAG1 first created the binding at the LMA and acquired a
> prefix/address for the MN, using MN-ID1
> * MN obtains the prefix/address on Interface1; if the MN is using
> DHCP, it will only get an address (since there is no requirement on
> the MN to do DHCP-PD)
> * MAG2 now sends a PBU with MN-ID1 also (very possible when the ID is
> something like an NAI)
> * LMA thinks the MN moved, updates the binding and returns the same
> prefix for the MN to MAG2
> * MN receives the same prefix/address via DHCP or RA over Interface2;
> MN detects a duplicate address and per RFC2462, does not configure
> that address on Interface2; Interface2 is now not enabled for IP
> forwarding;

I don't understand why having a duplicate for a global address would 
disable the interface. Since Interface2 has a link local address, 
Interface2 can send and receive packets. It is enabled.

> * If the MN is using stateless autoconfiguration, it may 
> end up with a different address for Interface2; in this case,
> Interface2 is enabled; the assigned prefix, however, is no longer
> just over a point-to-point link, although, the MAG thinks it is
> * The LMA has a binding for MAG2 (corresponding to Interface2)
> * If the MN never enabled Interface2 due to duplicate address issues,
> the MN will try to use Interface1, but, unsuccessfully, since the LMA
> will drop those packets; 

Why would the LMA drop these packets. These are outbound so it's just 
acting as a router and forwards them according to its routing table, 
probably the default route.

> LMA will send packets to MAG2 (Interface2), which will not be received
> by the MN 

These packets would be received since Interface2 is enabled (see above).

> * If the MN has enabled Interface2 with a different address,
> depending on the implementation, the MN may use Interface1 or
> Interface2 (some OSs will just pick one); any communication attempted
> via Interface 1 will fail

Why would the communication fail? Packets will be sent via Interface1 
and replies would come through Interface2.

> * In the meantime, the binding may keep toggling between MAG1 and
> MAG2 at the LMA, due to corresponding PBUs received; the MN may have
> intermittent connectivity as a result of this
>
> I've tried going through this issue with several developers and
> everyone agress that this problem exists for unmodified IP hosts. 
> Several people have acknowledged that on this list as well (as part
> of this thread and also discussions back in early August).
>
> Among those who believe there is no issue here, I'd appreciate if
> someone could walk through the steps and explain why this is not a
> technical issue and how the MN can use at least one interface for
> stable IP connectivity.

See comments above. I do not see why would communication fail as a 
result of the situation you describe above.

Best,

--julien

_______________________________________________
netlmm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm

---

From: "Kalin Getov" <[email-masked]>
Date: Thu, 04 Oct 2007 15:14:10 +0200

Hi all,

some comments from me too...

Well, if we agree, that the MN will end up with two different addresses from the same home network prefix if special care is not taken (e.g. virtual interface, hiding the physical interfaces from IP), then there is no problem with duplicated addresses. As LMA will route the packets according to most recently accepted PBU to MAG1 or MAG2 so downlink communication should work. In uplink it really depends on which interface is used for sending uplink packets (if OS just picks one, why connecting simultaneous over 2 interfaces than?) and on what LMA will do by receiving data packets from e.g. MAG1 (packets would come to MAG1 I think?!?), while having binding to MAG2. Why not just start detach procedure similar to Figure 3 on version 06 of the draft? The MAG1, upon receiving PBA with lifetime 0, will break this connection. This would clear the oscillating problem...IMHO.

Regards...
Kalin

-- 
******************************************
Best Regards
Kalin Getov

[email-masked]
******************************************

Der GMX SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen! 
Ideal für Modem und ISDN: http://www.gmx.net/de/go/smartsurfer