Subject: [netlmm] comments on pmip6-10

From: Jun AWANO <[email-masked]>
Date: Wed, 13 Feb 2008 09:13:44 +0900

Hi Sri,

Thanks for your effort to edit new draft.

Rev.10 has very little mistakes.

--------
8.1. Proxy Binding Update Message

       0               1               2               3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
                                      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
                                      |            Sequence #         |

            |
            v

8.1. Proxy Binding Update Message

-->    0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
                                      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
                                      |            Sequence #         |
--------

It should modify the position of 10-bit digit like above.

another one,
--------
8.2. Proxy Binding Acknowledgement Message
      :
   Binding Acknowledgement message.  The rest of the Binding
   Acknowledgement message format remains the same as defined in [RFC-
   3775] and with the additional (R) and (M) flags as specified in [RFC-
   3963] and [RFC-4140] respectively.
--------

I think M flag is unnecessary for PBA.

Best regards,
Jun

_______________________________________________
netlmm mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 12 Feb 2008 16:50:58 -0800 (PST)

Hi Jun,

Thanks for the comments. Please see inline.

> 8.1. Proxy Binding Update Message

This is representing the octet positions, 8th, 16th, and 24th bit 
positions. Either way, base-10 or octet positions.

> I think M flag is unnecessary for PBA.

We are only defining the PBU format. The flags M and R are taken
and we are defining a new flag "P". Its not suggesting the flags
are turned on. These 2 new flags are not covered in 3775 and are
in NEMO and HMIP drafts and so we had to cover them here to show
the allocation.

Thanks for the comments.

Regards
Sri

---

From: Jun AWANO <[email-masked]>
Date: Wed, 13 Feb 2008 10:33:58 +0900

Hi Sri,

Thanks for your reply.
Please see inline.

> positions. Either way, base-10 or octet positions.

I see.
But PMIPv6 draft uses base-10 position for other message and options.
I think same way is better.
Of course it isn't a big problem,though.

> in NEMO and HMIP drafts and so we had to cover them here to show

I'm talking about PBA.
PMIPv6 also added P flag to PBA.
PBU format can have R and M flags as per NEMO and HMIP, respectively.
But PBA can't have M flag. It isn't defined in HMIP spec.
PBA format depicted in PMIPv6 draft is fine.
But only text is wrong.
Or, am I misunderstanding?

Best regards,
Jun

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 12 Feb 2008 17:48:51 -0800 (PST)

Hi Jun,

> Of course it isn't a big problem,though.

Will check other MIP6 drafts and be consistent with it.

> Or, am I misunderstanding?

True. You are right, the M flag is not in Ack.
Its the extra reference in text, the format/illustration
is correct. Will fix it. Thanks !

Regards
Sri