Subject: [netlmm] MH-HoA definition in version 09

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 05 Feb 2008 13:44:30 -0800

Hello Sri and others,

The definition of MN-HoA in version 09 is wrong.

>    Mobile Node's Home Address (MN-HoA)
> 
>       MN-HoA is an address from a mobile node's home network prefix in a
>       Proxy Mobile IPv6 domain.  The mobile node will be able to use
>       this address as long as it is attached to the access network that
>       is in the scope of that Proxy Mobile IPv6 domain.  Unlike in
>       Mobile IPv6 where the home agent is aware of the home address of
>       the mobile node, in Proxy Mobile IPv6, the mobility entities are
>       only aware of the mobile node's home network prefix and are not
>       always aware of the exact address(es) that the mobile node
>       configured on its interface from that prefix.

The PMIPv6 spec allows for both assigning a /64 prefix and a 128
bit address to the mobile node. Depending on the type of link
between the mobile node and the MAG, and the type of address
assignment mechanism on that link, the MAG can either request for
a /64 prefix or a 128-bit address. If the 128-bit address is
assigned, the LMA and the MAG would both know the home address of
the mobile node.

So the text above that says the mobility entities are only aware
of the prefix is not correct.

In fact this was discussed on the mailing list during the AD
review.

Vijay
_______________________________________________
netlmm mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 5 Feb 2008 13:59:03 -0800 (PST)

Hi Vijay,

This is correct. The entities are "not always" aware of the
exact address that is configured by the terminal. Ex: When
generating identifiers based on privacy extensions, only
the mobile would know that. As you said, this is dependent
on allowed address configuration method. If this is a /128
prefix and IKEv2 as the delivery mechanism, yes, network
would know that. But, the text says, in some cases, it may
not know.

This was discussed in the AD review thread.

Sri

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 05 Feb 2008 14:10:11 -0800

Looks like we are in agreement about being able to assign
either a /64 prefix or a 128-bit address. But the text needs
some improvement. It does not describe the entire story.

       MN-HoA is an address from a mobile node's home network prefix in a
       Proxy Mobile IPv6 domain.  The mobile node will be able to use
       this address as long as it is attached to the access network that
       is in the scope of that Proxy Mobile IPv6 domain.  Unlike in
       Mobile IPv6, where the home agent is aware of the home address of
       the mobile node, in Proxy Mobile IPv6, the mobility entities may
       be aware of only the home network prefix assigned to the mobile
       node.  If the local mobility agent had assigned a 128-bit address
       to the mobile node, then the mobility entities are aware of the
       address assigned to the mobile node.

Vijay

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 5 Feb 2008 16:59:51 -0600

Vijay,

What about the following minor modification to rev 09 text?

      MN-HoA is an address from a mobile node's home network prefix in a
      Proxy Mobile IPv6 domain.  The mobile node will be able to use
      this address as long as it is attached to the access network that
      is in the scope of that Proxy Mobile IPv6 domain.  Unlike in
      Mobile IPv6 where the home agent is always aware of the home
address of
      the mobile node, in Proxy Mobile IPv6, the mobility entities are
      aware of the mobile node's home network prefix and are not
necessarily
      always aware of the exact address(es) that the mobile node
      configured on its interface from that prefix.

Regards,
Ahmad

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Vijay Devarapalli
> Sent: Tuesday, February 05, 2008 3:45 PM
> To: Netlmm; Sri Gundavelli
> Subject: [netlmm] MH-HoA definition in version 09
> 
> Hello Sri and others,
> 
> The PMIPv6 spec allows for both assigning a /64 prefix and a 
> 128 bit address to the mobile node. Depending on the type of 
> link between the mobile node and the MAG, and the type of 
> address assignment mechanism on that link, the MAG can either 
> request for a /64 prefix or a 128-bit address. If the 128-bit 
> address is assigned, the LMA and the MAG would both know the 
> home address of the mobile node.
> 
> So the text above that says the mobility entities are only 
> aware of the prefix is not correct.
> 
> In fact this was discussed on the mailing list during the AD review.
> 
> Vijay

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 5 Feb 2008 17:10:22 -0600

Vijay,

I am okay with your text too. Looks good!

Regards,
Ahmad

> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Tuesday, February 05, 2008 4:10 PM
> To: Sri Gundavelli
> Cc: Netlmm
> Subject: Re: MH-HoA definition in version 09
> 
> > This is correct. The entities are "not always" aware of the exact 
> > address that is configured by the terminal. Ex: When generating 
> > identifiers based on privacy extensions, only the mobile would know 
> > that. As you said, this is dependent on allowed address 
> configuration 
> > method. If this is a /128 prefix and IKEv2 as the delivery 
> mechanism, 
> > yes, network would know that. But, the text says, in some cases, it 
> > may not know.
> > 
> >>>        MN-HoA is an address from a mobile node's home 
> network prefix 
> >>> in a
> >> The PMIPv6 spec allows for both assigning a /64 prefix and 
> a 128 bit 
> >> address to the mobile node. Depending on the type of link 
> between the 
> >> mobile node and the MAG, and the type of address 
> assignment mechanism 
> >> on that link, the MAG can either request for a /64 prefix or a 
> >> 128-bit address. If the 128-bit address is assigned, the 
> LMA and the 
> >> MAG would both know the home address of the mobile node.
> >>