Subject: Re: [netlmm] Home Network Prefix indraft-ietf-netlmm-pmip6-ipv4-support-02

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 20 Feb 2008 08:13:25 -0800 (PST)

Sri, are you saying that in order to reduce the cost of running PMIP6 we need to run it on as many IPv4-only MNs as possible?

This sounds like (a simple analogy) we need schools but schools with no students would be great to run.

Regards,

Behcet

----- Original Message ----
From: Sri Gundavelli <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: Vijay Devarapalli <[email-masked]>; [email-masked]
Sent: Tuesday, February 19, 2008 5:19:18 PM
Subject: Re: [netlmm] Home Network Prefix indraft-ietf-netlmm-pmip6-ipv4-support-02

Behcet,

On 
Tue, 
19 
Feb 
2008, 
Behcet 
Sarikaya 
wrote:

Vijay, 
as 
far 
as 
I 
know 
no 
decision 
on 
this 
has 
been 
reached. 
The 
latest 
was 
to 
discuss 
it 
in 
Philly.
Allocating 
an 
HNP 
would 
do 
no 
harm 
to 
IPv4-only 
MN 
and 
also 
would 
provide 
consistent 
interface 
to 
all 
MNs.
Regards,

Its 
not 
about 
the 
harm, 
its 
about 
the 
cost. 
To 
allocate 
a 
unique 
IPv6
for 
each 
MN's 
attached 
interface 
(if 
the 
MN 
is 
IPv6 
enabled 
on 
not 
or
if 
the 
deployment 
even 
has 
IPv6 
infrastructure 
or 
no), 
maintain 
the
routing 
state 
at 
both 
LMA 
and 
MAG, 
this 
has 
an 
impact 
on 
box 
scalability.
We 
should 
see, 
how 
we 
can 
provide 
some 
knob 
for 
the 
operator 
to 
disable
this, 
if 
its 
not 
required.

Sri

_______________________________________________
netlmm mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 20 Feb 2008 21:06:32 -0800 (PST)

Hi Behcet,

> Sri, are you saying that in order to reduce the cost of running PMIP6 we need to run it on as many IPv4-only MNs as possible?

No. Thats not what we are saying. If a given deployment has no IPv6
enabled, there is no need to assign IPv6 prefix for each node/interface,
create routes, set up forwarding ..., when we are sure, the deployment
is not supporting IPv6. As a LMA/MAG box vendor or as a customer, you
will see the same box supporting "X" number of extra mobility sessions.
So, lets see how we can avoid this.

> This sounds like (a simple analogy) we need schools but schools with no students would be great to run.

No. Thats not the right analogy. May be, dont setup a desk, if there is no
student to use it.

Sri