Subject: [netlmm] question on multihoming in pmip6-10

From: "Premec, Domagoj" <[email-masked]>
Date: Thu, 14 Feb 2008 11:53:41 +0100

Hi Sri,
 
I have a question related to a handover scenario of multihomed MN. Section 5.4.1.2, step 4 describes the following case:
 
- LMA has a single BCE for MN
- HNP in BU is zero
- ATT and IID in BCE do not match the ATT and IID in BU
- HI in BU is set to "handoff state unknown"
 
The spec says that if there is no de-registration message from the old MAG the LMA upon accepting the BU request MUST update the existing BCE. But the MN may still be attached via another interface to the old MAG and send uplink traffic through it. IMO overwriting the existing BCE does not seem correct, the LMA needs to create a new BCE to be on the safe side.
 
thanks
domagoj
 
_______________________________________________
netlmm mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/netlmm

---

From: "Fan Zhao" <[email-masked]>
Date: Thu, 14 Feb 2008 13:09:56 -0800

Hi Sri and Domagoj,

I also have the same question regarding such multi-homing cases. In
additional to what was described in 

the Domagoj's email, in section 5.4.1.3, under the condition (no MN_IID
in PBU, only one BCE matching

MN_ID, HI=4), if the de-reg is not received, the specification states:

"the local mobility anchor upon accepting the request MUST consider the
request as a
 request for updating that Binding Cache entry.  The local mobility
anchor MAY also 
 choose to create a new mobility session and without waiting for a
de-registration 
 message and this should be configurable on the local mobility anchor."

Please clarify why in this case the LMA _must_ consider this as a
handover and _may_ start

a new mobility session.

Thanks in advance.

Sincerely,

fan

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Premec, Domagoj
Sent: Thursday, February 14, 2008 2:54 AM
To: Sri Gundavelli
Cc: netlmm
Subject: [netlmm] question on multihoming in pmip6-10

Hi Sri,

I have a question related to a handover scenario of multihomed MN.
Section 5.4.1.2, step 4 describes the following case:

- HNP in BU is zero

The spec says that if there is no de-registration message from the old
MAG the LMA upon accepting the BU request MUST update the existing BCE.
But the MN may still be attached via another interface to the old MAG
and send uplink traffic through it. IMO overwriting the existing BCE
does not seem correct, the LMA needs to create a new BCE to be on the
safe side.

thanks

domagoj

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 14 Feb 2008 13:14:03 -0800 (PST)

Hi Fan,

Thats a typo. If there is no dereg, the request MUST be
considered as a request for creating a new mobility
session. Will fix this.

Thanks
Sri

---

From: "Fan Zhao" <[email-masked]>
Date: Thu, 14 Feb 2008 13:17:30 -0800

Ok. Thanks for your prompt reply.

Sincerely,
fan

-----Original Message-----
From: Sri Gundavelli [mailto:[email-masked]] 
Sent: Thursday, February 14, 2008 1:14 PM
To: Fan Zhao
Cc: Premec, Domagoj; netlmm
Subject: RE: [netlmm] question on multihoming in pmip6-10

Hi Fan,

Thanks
Sri

---

From: "Sri Gundavelli" <[email-masked]>
Date: Thu, 14 Feb 2008 13:18:07 -0800

Hi Domagoj,
 
Agreed. This was the typo in that sentence, it got introduced in the 09
version. Its in
two places as Fan pointed out.  If there is no dereg, there should be a new
session.
Will fix it.
 
Thanks
Sri

  _____  

From: Premec, Domagoj [mailto:[email-masked]] 
Sent: Thursday, February 14, 2008 2:54 AM
To: Sri Gundavelli
Cc: netlmm
Subject: [netlmm] question on multihoming in pmip6-10

Hi Sri,
 
I have a question related to a handover scenario of multihomed MN. Section
5.4.1.2, step 4 describes the following case:

The spec says that if there is no de-registration message from the old MAG
the LMA upon accepting the BU request MUST update the existing BCE. But the
MN may still be attached via another interface to the old MAG and send
uplink traffic through it. IMO overwriting the existing BCE does not seem
correct, the LMA needs to create a new BCE to be on the safe side.
 
thanks
domagoj