Subject: Re: [netlmm] Home Network Prefix indraft-ietf-netlmm-pmip6-ipv4-support-02

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 19 Feb 2008 14:24:43 -0800 (PST)

Vijay, as far as I know no decision on this has been reached. The latest was to discuss it in Philly.
Allocating an HNP would do no harm to IPv4-only MN and also would provide consistent interface to all MNs.
Regards,

Behcet

----- Original Message ----
From: Vijay Devarapalli <[email-masked]>
To: Ali Irfan-FIA225 <[email-masked]>
Cc: [email-masked]; [email-masked]; Julien Laganier <[email-masked]>
Sent: Tuesday, February 19, 2008 3:27:44 PM
Subject: Re: [netlmm] Home Network Prefix indraft-ietf-netlmm-pmip6-ipv4-support-02

IMO, 
it 
is 
ok 
to 
relax 
the 
requirement 
to 
always 
allocate 
an 
IPv6
home 
network 
prefix 
when 
it 
is 
known 
that 
the 
mobile 
node 
is
IPv4-only.

Vijay

Ali 
Irfan-FIA225 
wrote:
Hi 
Vijay/Julien,
I 
am 
not 
sure 
if 
a 
resolution 
to 
the 
this 
item 
has 
been 
achieved.
If 
the 
IPv4 
draft 
allows 
the 
case 
that 
only 
IPv4 
home 
network 
prefix 
and
no 
IPv6 
Home 
network 
prefix 
option 
is 
included 
in 
PBU, 
is 
that 
not 
a
violation 
of 
the 
base 
draft?  
The 
base 
draft 
*requires* 
IPv6 
Home
network 
prefix 
option 
to 
be 
present 
in 
PBU. 
IMO, 
since 
IPv4 
draft 
is 
an
extension 
to 
the 
base 
draft, 
it 
should 
not 
change 
the 
MUST 
requirement
in 
the 
base 
draft. 
Hence, 
in 
IPv4 
extension 
draft, 
either 
(a) 
only 
Ipv6
Home 
network 
prefix 
option 
should 
be 
included 
(base 
draft), 
or 
(b) 
the
Ipv6 
Home 
network 
prefix 
option 
and 
IPv4 
Home 
address 
option.
Hence 
PBUs 
with 
only 
IPv4 
Home 
address 
option 
should 
not 
be 
allowed.
[This 
may 
not 
allow 
optimizations 
in 
some 
situations, 
but 
no 
serious
concern 
with 
creation 
of 
IPv6 
prefixes 
that 
are 
not 
used 
has 
been
raised. 
Moreover, 
this 
would 
keep 
the 
IPv4 
draft 
to 
be 
in 
compliance
with 
the 
base 
draft]. 
If 
the 
UE 
only 
requires 
IPv4 
address 
and 
the 
MAG
is 
aware 
of 
this, 
the 
MAG 
should 
only 
forward 
the 
IPv4 
address 
to 
the
UE.
Rgds
Irfan 
-----Original 
Message-----
From: 
Julien 
Laganier 
[mailto:[email-masked]] 
Sent: 
Thursday, 
January 
24, 
2008 
5:16 
PM
To: 
[email-masked]
Cc: 
[email-masked]
Subject: 
Re: 
[netlmm] 
Home 
Network 
Prefix 
indraft-ietf-netlmm-pmip6-ipv4-support-02
Hello 
Vijay,
On 
Wednesday 
23 
January 
2008, 
Vijay 
Devarapalli 
wrote:
Julien 
Laganier 
wrote:
I 
have 
a 
problem 
with 
Vijay's 
statement 
"the 
IPv6 
prefix/address 
is 
always 
assigned 
unless 
it 
is 
is 
known 
that 
the 
mobile 
node 
is 
IPv4-only."
I'm 
assuming 
that 
meant 
"unless 
the 
network 
knows 
that 
the 
mobile 
node 
is 
IPv4 
only".
Yes. 
Otherwise 
the 
IPv6 
prefix/address 
is 
always 
advertised/assigned.
What 
would 
be 
a 
method 
by 
which 
the 
network 
determine 
whether 
the 
MN 
is 
IPv4-only 
(resp. 
IPv6 
enabled) 
or 
not.
Multiple 
mechanisms.
All 
right. 
See 
my 
comments 
below:
- 
The 
fact 
that 
the 
mobile 
node 
is 
IPv4-only 
is 
stored 
in 
the 
user's 
policy 
profile. 
This 
of 
course 
won't 
work 
if 
the 
user 
changes 
the 
device.
Right. 
So 
this 
is 
not 
an 
option.
- 
Device 
capabilities 
based 
on 
the 
device 
identifier.
The 
device 
identifier 
most 
likely 
identifies 
the 
hardware, 
not 
the 
software 
running 
on 
it. 
We 
would 
rather 
need 
to 
use 
a 
S/W 
release 
identifier. 
Not 
sure 
this 
is 
reasonable 
to 
assume 
that 
1) 
a 
S/W 
release 
identifier 
is 
available 
to 
the 
network, 
and 
2) 
that 
the 
network 
knows 
which 
IP 
version 
is 
support 
by 
a 
given 
S/W 
release.
- 
Mobile 
node 
indicates 
it 
capabilities 
to 
the 
MAG 
via 
a 
L2 
mechanism.
This 
assumes 
that 
the 
L2 
is 
aware 
of 
L3 
capabilities. 
Not 
sure 
this 
is 
realistic 
(how 
can 
the 
L2 
knows 
which 
S/W 
release 
of 
IP 
is 
above), 
neither 
if 
this 
is 
good 
thing 
-- 
sounds 
a 
bit 
like 
a 
layering 
violation.
4. 
Admin 
configuration 
on 
the 
MAG 
and 
the 
LMA 
if 
the 
admin 
knows 
that 
it 
is 
all 
going 
to 
be 
IPv4-only 
mobile 
nodes 
in 
a 
particular 
system.
I'd 
rather 
say 
"admin 
configuration 
if 
the 
operator 
wants 
to 
deploy 
an
IPv4 
only 
network". 
Would 
you 
agree? 
But 
then 
there's 
the 
question 
of 
whether 
or 
not 
it's 
good 
to 
use 
v6-enabled 
technology 
for 
v4-only 
deployments... 
Maybe 
this 
is 
too 
philosophical, 
but 
I'd 
like 
us 
to 
at 
least 
think 
about 
the 
implications.
Cheers,
--julien
_______________________________________________
netlmm 
mailing 
list
[email-masked]
https://www1.ietf.org/mailman/listinfo/netlmm
_______________________________________________
netlmm 
mailing 
list
[email-masked]
http://www.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm 
mailing 
list
[email-masked]
http://www.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/netlmm

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 19 Feb 2008 14:27:45 -0800

Behcet Sarikaya wrote:
> 
> Vijay, as far as I know no decision on this has been reached. 

I know, I was expressing my opinion. :)

> The latest 
> was to discuss it in Philly.

Why not now on the mailing list?

Vijay

> Cc: [email-masked]; 
> [email-masked]; Julien Laganier 
> <[email-masked]>
> Subject: Re: [netlmm] Home Network Prefix 
> IMO, it is ok to relax the requirement to always allocate an IPv6
> home network prefix when it is known that the mobile node is
> IPv4-only.
> 
> Vijay
> 
> Ali Irfan-FIA225 wrote:
>  > Hi Vijay/Julien,
>  >
>  > I am not sure if a resolution to the this item has been achieved.
>  >
>  > If the IPv4 draft allows the case that only IPv4 home network prefix and
>  > no IPv6 Home network prefix option is included in PBU, is that not a
>  > violation of the base draft?  The base draft *requires* IPv6 Home
>  > network prefix option to be present in PBU. IMO, since IPv4 draft is an
>  > extension to the base draft, it should not change the MUST requirement
>  > in the base draft. Hence, in IPv4 extension draft, either (a) only Ipv6
>  > Home network prefix option should be included (base draft), or (b) the
>  > Ipv6 Home network prefix option and IPv4 Home address option.
>  >
>  > Hence PBUs with only IPv4 Home address option should not be allowed.
>  > [This may not allow optimizations in some situations, but no serious
>  > concern with creation of IPv6 prefixes that are not used has been
>  > raised. Moreover, this would keep the IPv4 draft to be in compliance
>  > with the base draft]. If the UE only requires IPv4 address and the MAG
>  > is aware of this, the MAG should only forward the IPv4 address to the
>  > UE.
>  >
>  > Rgds
>  > Irfan
>  >
>  >> -----Original Message-----
>  >> From: Julien Laganier [mailto:[email-masked] 
> <mailto:[email-masked]>]
>  >> Sent: Thursday, January 24, 2008 5:16 PM
>  >> To: [email-masked] <mailto:[email-masked]>
>  >> Cc: [email-masked] 
> <mailto:[email-masked]>
>  >> Subject: Re: [netlmm] Home Network Prefix
>  >> Hello Vijay,
>  >> On Wednesday 23 January 2008, Vijay Devarapalli wrote:
>  >>> Julien Laganier wrote:
>  >>>> I have a problem with Vijay's statement "the IPv6
>  >> prefix/address is
>  >>>> always assigned unless it is is known that the mobile node is
>  >>>> IPv4-only."
>  >>>>
>  >>>> I'm assuming that meant "unless the network knows that the mobile
>  >>>> node is IPv4 only".
>  >>> Yes. Otherwise the IPv6 prefix/address is always
>  >> advertised/assigned.
>  >>>> What would be a method by which the network determine
>  >> whether the MN
>  >>>> is IPv4-only (resp. IPv6 enabled) or not.
>  >>> Multiple mechanisms.
>  >> All right. See my comments below:
>  >>
>  >>> - The fact that the mobile node is IPv4-only is stored in
>  >> the user's
>  >>> policy profile. This of course won't work if the user changes the
>  >>> device.
>  >> Right. So this is not an option.
>  >>
>  >>> - Device capabilities based on the device identifier.
>  >> The device identifier most likely identifies the hardware,
>  >> not the software running on it. We would rather need to use a
>  >> S/W release identifier. Not sure this is reasonable to assume
>  >> that 1) a S/W release identifier is available to the network,
>  >> and 2) that the network knows which IP version is support by
>  >> a given S/W release.
>  >>
>  >>> - Mobile node indicates it capabilities to the MAG via a L2
>  >> mechanism.
>  >>
>  >> This assumes that the L2 is aware of L3 capabilities. Not
>  >> sure this is realistic (how can the L2 knows which S/W
>  >> release of IP is above), neither if this is good thing --
>  >> sounds a bit like a layering violation.
>  >>
>  >>> 4. Admin configuration on the MAG and the LMA if the admin
>  >> knows that
>  >>> it is all going to be IPv4-only mobile nodes in a particular system.
>  >> I'd rather say "admin configuration if the operator wants to deploy an
>  >> IPv4 only network". Would you agree? But then there's the
>  >> question of whether or not it's good to use v6-enabled
>  >> technology for v4-only deployments... Maybe this is too
>  >> philosophical, but I'd like us to at least think about the
>  >> implications.
>  >>
>  >> Cheers,
>  >>
>  >> --julien
>  >>
>  >>
>  >> [email-masked] <mailto:[email-masked]>
>  > [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 19 Feb 2008 15:19:18 -0800 (PST)

Behcet,

> Allocating an HNP would do no harm to IPv4-only MN and also would provide consistent interface to all MNs.

Its not about the harm, its about the cost. To allocate a unique IPv6
for each MN's attached interface (if the MN is IPv6 enabled on not or
if the deployment even has IPv6 infrastructure or no), maintain the
routing state at both LMA and MAG, this has an impact on box scalability.
We should see, how we can provide some knob for the operator to disable
this, if its not required.

Sri