Subject: [netlmm] About the Agenda for the meeting - your input is needed

From: "Soininen Jonne (NSN FI/Espoo)" <[email-masked]>
Date: Thu, 28 Feb 2008 00:34:46 +0200

Hello everybody,

I didn't have the possibility before today to combine the agenda, though I
kind of knew what to expect. I think we have a problem for which I would
like to ask for your help.

First of all the proposed skeleton is the following:

Network-based Local Mobility Management (NetLMM)

---------------------------------------------------------
TUESDAY, March 11, 2008
0900-1130 Morning Session I

Chairs: 
Jonne Soininen <[email-masked]>
Vidya Narayanan <[email-masked]>

---------------------------------------------------------
PRELIMINARIES
Agenda review
Blue sheets
Notes and Jabber scribe
WG status

WG DRAFT DISCUSSIONS

Topic: Proxy Mobile IPv6
Draft: draft-ietf-netlmm-proxymip6-11.txt

Topic: IPv4 Support for Proxy Mobile IPv6
Draft: draft-ietf-netlmm-pmip6-ipv4-support-02.txt

Topic: Interface between a Proxy MIPv6 Mobility Access Gateway and a Mobile
Node
Draft: draft-ietf-netlmm-mn-ar-if-03

POSSIBLE NEW WORK ITEMS

Presentations of the possible new work items

RECHARTERING DISCUSSIONS

NEXT STEPS and WRAP UP
---------------------------------------------------------
So we have basically 2.5 hours to spend, and we _have to_ discuss the
current WG drafts, and get to understand what are we doing going forward.
The emphasis of the work has to be on these two things.

I have listed the following requests for presentations (the order is not
important):

-Multiple Interface Support with PMIPv6 (15 Min) - Vijay
 (draft-devarapalli-netlmm-multihoming-02.txt)

-PMIPv6 Heartbeat Mechanism (10 Min) - Vijay
 (draft-devarapalli-netlmm-pmipv6-heartbeat-01.txt)

-PMIPv6 and MIPv4 interactions (10 min) - Vijay

-Multihoming Scenarios (10 min) - Ahmad

-GRE keying (5 min) - Ahmad

-Route Optimization (10 min) - Christian

-Inter-MAG Route Optimization (10 min) Ashutosh

-Inter-technology handover extensions (10 min) - Marco

-PMIPv6 support Transient CoA Registration (10 min) - Ahmad
 draft-muhanna-netlmm-pmipv6-support-transient-coa-00.txt

-Proxy Network Mobility (10 Min) - John

-Secondary Binding Cache Entries for PMIP (10 min) - Oliver
 draft-blume-netlmm-secondary-bce-proxymip6ho-00.txt

-Multiple interface support (10 min) - Mohana
 draft-jeyatharan-netlmm-multi-interface-ps-01.txt

-Proxy Mobile IPv6 indication and discovery (10 min) - Basavaraj
 draft-damic-netlmm-pmip6-ind-discover-03.txt

And I'm pretty sure I forgot something (please remind me if I did).

The problem is that this does not really fit. We cannot have all of these
presentations and accomplish our main goal of the meeting. So, I think we
have to compress and rethink the presentations.

However, I see some patterns/groups (again the order is not of importance):

Interaction
 -PMIP6-MIP4
 -PMIP6-MIP6 (presented in earlier meeting)

Multiple interface support/Multihoming
 -Vijay
 -Mohana
 -Ahmad
 -Marco?

Route Optimization
 -Christian
 -Ashutosh

Multiple COA Registration
 -Ahmad
 -Oliver

Others
 -GRE keying (Ahmad)
 -Heart Beat (Vijay)
 -PMIP indication and discovery (Basavaraj)

Could we do some grouping here or cooperation to get the different problems
areas at least presented? In addition, I would think it would be good to get
the items presented that it seems our "customers" like 3GPP, 3GPP2, and
Wimax Forum expect us to get done. I think this is extremely important input
for the rechartering discussion.

Any ideas or suggestions?

Cheers,

Jonne.

PS. I think we will let only the people enter the meeting room who have
commented/reviewed the remaining WG items we have in the current charter...
;)

PS/2: Any volunteers for Jabber scribes and minute takers?

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34
E-mail: [email-masked]

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Frank Xia <[email-masked]>
Date: Wed, 27 Feb 2008 16:52:32 -0600

Hi Soininen

I think  that "RADIUS Proxy Mobile IPv6" is another topic to consider for
rechartering.
http://tools.ietf.org/wg/netlmm/draft-xia-netlmm-radius-02.txt

It is necessary mechanism when deploying PMIPv6 using RADIUS as AAA protocol.

In fact, the corresponding document, Diamter Proxy Mobile IPv6, is also  being 
discussed  as a rechartering item in DIME WG.
http://tools.ietf.org/wg/dime/draft-korhonen-dime-pmip6-03.txt.

BR
Frank

----- Original Message ----- 
From: "Soininen Jonne (NSN FI/Espoo)" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, February 27, 2008 4:34 PM
Subject: [netlmm] About the Agenda for the meeting - your input is needed

Hello everybody,

Chairs: 

WG DRAFT DISCUSSIONS

Topic: Proxy Mobile IPv6

POSSIBLE NEW WORK ITEMS

RECHARTERING DISCUSSIONS

NEXT STEPS and WRAP UP

Interaction
 -PMIP6-MIP4

Route Optimization
 -Christian
 -Ashutosh

Others
 -GRE keying (Ahmad)
 -Heart Beat (Vijay)

Cheers,

Jonne.

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34

---

From: Marco Liebsch <[email-masked]>
Date: Thu, 28 Feb 2008 10:24:25 +0100

Hi Jonne,

our slot about inter-tech handover is based on our last meeting's
rapid fire presentation about the same topic. We followed comments
(whatever was possible in 5 minutes ;-) and provided a more detailed
problem statement in our update. This could be taken as PS to motivate
work on inter-tech related extensions. Closely related work is Ahmad's
(transient CoAs) and Oliver's (secondary CoA).

We could go for a common presentation to motivate the work
on inter-technology handover as input to the re-charter discussion
and briefly refer to associated proposals for solution. I am also
fine with doing such a summary and present it in Philadelphia.

marco

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 28 Feb 2008 04:55:56 -0600

Hi Marco,

The common practice is to let these drafts be presented separately and
give people a chance to understand the difference in each usecase and
problem statement and then the wg decides on the next steps if there is
overlapping.

As far as I know that has been the practice. A very close one is how
multihoming has been addressed in last meeting and is addressed in this
meeting. Even Proxy Mobile IPv6 itself was done the same way when there
was two drafts.

We probably this time do not need to present new ideas and drafts in a
rapid fire mode and people would have a better chance to digest them
more naturally:)

I appreciate you volunteering for a common presentation, However, I
would like to continue support the agenda as proposed by Jonne.

Best Regards,
Ahmad

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Marco Liebsch
> Sent: Thursday, February 28, 2008 5:24 PM
> To: Soininen Jonne (NSN FI/Espoo)
> Cc: [email-masked]
> Subject: Re: [netlmm] About the Agenda for the meeting - your 
> input is needed
> 
> Hi Jonne,
> 
> our slot about inter-tech handover is based on our last 
> meeting's rapid fire presentation about the same topic. We 
> followed comments (whatever was possible in 5 minutes ;-) and 
> provided a more detailed problem statement in our update. 
> This could be taken as PS to motivate work on inter-tech 
> related extensions. Closely related work is Ahmad's 
> We could go for a common presentation to motivate the work on 
> inter-technology handover as input to the re-charter 
> discussion and briefly refer to associated proposals for 
> solution. I am also fine with doing such a summary and 
> present it in Philadelphia.
> 
> marco
> 
> 
> 
> > I didn't have the possibility before today to combine the agenda, 
> > though I kind of knew what to expect. I think we have a problem for 
> > which I would like to ask for your help.
> >
> > Jonne Soininen <[email-masked]> Vidya Narayanan 
> > <[email-masked]>
> >
> > Topic: Interface between a Proxy MIPv6 Mobility Access 
> Gateway and a 
> > Mobile Node
> > I have listed the following requests for presentations (the 
> order is 
> > not
> > important):
> >
> > The problem is that this does not really fit. We cannot have all of 
> > these presentations and accomplish our main goal of the 
> meeting. So, I 
> > think we have to compress and rethink the presentations.
> >
> > Multiple interface support/Multihoming  -Vijay  -Mohana  -Ahmad  
> > -Marco?
> >
> > Route Optimization
> >  -Christian
> >  -Ashutosh
> >
> > Could we do some grouping here or cooperation to get the different 
> > problems areas at least presented? In addition, I would 
> think it would 
> > be good to get the items presented that it seems our 
> "customers" like 
> > 3GPP, 3GPP2, and Wimax Forum expect us to get done. I think this is 
> > extremely important input for the rechartering discussion.
> >
> > PS. I think we will let only the people enter the meeting room who 
> > have commented/reviewed the remaining WG items we have in 
> the current charter...
> > ;)
> >

---

From: Marco Liebsch <[email-masked]>
Date: Thu, 28 Feb 2008 12:07:54 +0100

Hi Ahmad,

sure, if there is time to go through each proposal, I am fine. My 
understanding was
that related topics should be grouped. Having a common presentation 
about the
problem to be addressed seems a reasonable step to achieve this goal. And I
think motivating the same work in multiple presentations is somehow 
superfluous.
But as I said, if my understanding was wrong and there is time and 
interest in
individual solution presentations, I am fine ;-)

Thanks and best regards,

marco

Ahmad Muhanna schrieb:
>>> So we have basically 2.5 hours to spend, and we _have to_ 
>>>       
>> discuss the 
>>     
>>> current WG drafts, and get to understand what are we doing 
>>>       
>> going forward.
>>     
>>> However, I see some patterns/groups (again the order is not 
>>>       
>> of importance):
>>     
>>> Interaction
>>>  -PMIP6-MIP4

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 28 Feb 2008 08:27:27 -0800

Hi Jonne,

I would suggest avoid any kind of presentations that would
just present or "introduce" a draft for 5 or 10 minutes. We
should spend the face-to-face time on re-chartering. I hope
we can spend some time on figuring out what is needed today
for a PMIPv6 deployment, figure out what is broken that
needs to be fixed, what optimizations would be useful in the
future, etc..

We already had the 5-10 minutes rapid-fire presentations at
the last meeting. I hope we don't repeat that. Once you put
up a list of items that the WG is considering chartering, I
am sure folks will glance through the drafts and figure out
what is in the drafts. :)

I would further categorize the current solutions we have as
follows.

1. Required for PMIPv6 deployment
- LMA discovery
- RADIUS and Diameter extensions (MAG-AAA and LMA-AAA interfaces)
- GRE keys
- Binding revocation (this is guess is being done in the MEXT WG)
- Heartbeat mechanism for PMIPv6

2. Interactions with host-based mobility protocols
- PMIPv6 - MIPv6 interactions
- PMIPv6 - MIPv4 interactions

3. Multiple interface support and multi-homing
- Different multi-homing scenarios (various drafts)
- Handovers across interfaces using PMIPv6 (various drafts)

4. Handover optimizations
- Transient CoA (Ahmad)
- Two stage proxy BU (Marco)
- FMIPv6 signaling for inter-MAG tunneling and CT (MIPSHOP WG)

5. NEMO support with PMIPv6

6. PMIPv6 route optimization

IMHO, 5) and 6) are of low importance. 1) is most important. 4)
is very murky, requires more discussion.

I am sure I missed some items. I probably categorized one or
two solutions wrongly too. It wasn't intentional. I have listed
whatever I could remember. This could be a start for the
re-chartering discussion.

> In addition, I would think it would be good to get

This is a good idea. We should try to standardize solutions
that these SDOs depend on ASAP. But at the same time please
lets avoid "rubber-stamping" solutions that were developed
in the SDOs. In any case, they shouldn't be anything more than
Informational.

Hope that helps.

Vijay

---

From: "john.zhao" <[email-masked]>
Date: Thu, 28 Feb 2008 18:36:11 +0100

Hi, Vijay
    I find in this version the mobile ip type selection is removed from that previous one. I'm not sure if it is only missed temporarily. But at here, I only want to confirm about the topic related to distinguish the mobility protocol to be used. Because in last we also have a draft about that.But it is not belong to the content of charter at that time. So I didn't update continuely. 
    So my question is if the mobility type selection or decision should be discussed in next meeting?
    If no need, that is ok. Even I like that topic.
    If yes, maybe you will update the agend. And I hope you can count me as a input for that topic.

    Best Rgds,
Thanks.

john.zhao
2008-02-28

发件人： Vijay Devarapalli
发送时间： 2008-02-28 17:28:59
收件人： Soininen Jonne (NSN FI/Espoo)
抄送： [email-masked]
主题： Re: [netlmm] About the Agenda for the meeting - your input is needed

Hi Jonne,

Hope that helps.

Vijay

---

From: "BLUME, Oliver" <[email-masked]>
Date: Thu, 28 Feb 2008 19:07:30 +0100

Hi Vijay,

>re-chartering discussion.

one candidate for re-categorization is my draft on secondary bindings. 
I'd like to see that grouped into category 4 ("Handover optimizations") together with Marco's and Ahmed's drafts, rather than in category 3 ("Handovers across interfaces using PMIPv6 (various drafts)"), where I guess you subsummed it. Marco has confirmed the close relation between the drafts.

Thanks and regards,

Oliver

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Vijay Devarapalli
Gesendet: Donnerstag, 28. Februar 2008 17:27
An: Soininen Jonne (NSN FI/Espoo)
Cc: [email-masked]
Betreff: Re: [netlmm] About the Agenda for the meeting - your input is needed

Hi Jonne,

I would suggest avoid any kind of presentations that would just present or "introduce" a draft for 5 or 10 minutes. We should spend the face-to-face time on re-chartering. I hope we can spend some time on figuring out what is needed today for a PMIPv6 deployment, figure out what is broken that needs to be fixed, what optimizations would be useful in the future, etc..

We already had the 5-10 minutes rapid-fire presentations at the last meeting. I hope we don't repeat that. Once you put up a list of items that the WG is considering chartering, I am sure folks will glance through the drafts and figure out what is in the drafts. :)

I would further categorize the current solutions we have as follows.

IMHO, 5) and 6) are of low importance. 1) is most important. 4) is very murky, requires more discussion.

I am sure I missed some items. I probably categorized one or two solutions wrongly too. It wasn't intentional. I have listed whatever I could remember. This could be a start for the re-chartering discussion.

> In addition, I would think it would be good to get the items presented 
> that it seems our "customers" like 3GPP, 3GPP2, and Wimax Forum expect 
> us to get done. I think this is extremely important input for the 
> rechartering discussion.

This is a good idea. We should try to standardize solutions that these SDOs depend on ASAP. But at the same time please lets avoid "rubber-stamping" solutions that were developed in the SDOs. In any case, they shouldn't be anything more than Informational.

Hope that helps.

Vijay