Subject: Re: [netlmm] About the Agenda for the meeting - your input is needed

From: "Soininen Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 03 Mar 2008 17:14:20 +0200

Frank,

I thought radius extensions would rather be at radext WG than in netlmm. 
This would then be in line with dime and the diameter work as well.

Cheers,

Jonne.
ext Frank Xia wrote:
> Hi Soininen
>
> I think  that "RADIUS Proxy Mobile IPv6" is another topic to consider for
> rechartering.
> http://tools.ietf.org/wg/netlmm/draft-xia-netlmm-radius-02.txt
>
> It is necessary mechanism when deploying PMIPv6 using RADIUS as AAA protocol.
>
> In fact, the corresponding document, Diamter Proxy Mobile IPv6, is also  being 
> discussed  as a rechartering item in DIME WG.
> http://tools.ietf.org/wg/dime/draft-korhonen-dime-pmip6-03.txt.
>
> BR
> Frank
>
> ----- Original Message ----- 
> From: "Soininen Jonne (NSN FI/Espoo)" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, February 27, 2008 4:34 PM
> Subject: [netlmm] About the Agenda for the meeting - your input is needed
>
>
> Hello everybody,
>
> I didn't have the possibility before today to combine the agenda, though I
> kind of knew what to expect. I think we have a problem for which I would
> like to ask for your help.
>
> First of all the proposed skeleton is the following:
>
> Network-based Local Mobility Management (NetLMM)
>
> ---------------------------------------------------------
> TUESDAY, March 11, 2008
> 0900-1130 Morning Session I
>
> Chairs: 
> Jonne Soininen <[email-masked]>
> Vidya Narayanan <[email-masked]>
>
> ---------------------------------------------------------
> PRELIMINARIES
> Agenda review
> Blue sheets
> Notes and Jabber scribe
> WG status
>
> WG DRAFT DISCUSSIONS
>
> Topic: Proxy Mobile IPv6
> Draft: draft-ietf-netlmm-proxymip6-11.txt
>
> Topic: IPv4 Support for Proxy Mobile IPv6
> Draft: draft-ietf-netlmm-pmip6-ipv4-support-02.txt
>
> Topic: Interface between a Proxy MIPv6 Mobility Access Gateway and a Mobile
> Node
> Draft: draft-ietf-netlmm-mn-ar-if-03
>
> POSSIBLE NEW WORK ITEMS
>
> Presentations of the possible new work items
>
> RECHARTERING DISCUSSIONS
>
> NEXT STEPS and WRAP UP
> ---------------------------------------------------------
> So we have basically 2.5 hours to spend, and we _have to_ discuss the
> current WG drafts, and get to understand what are we doing going forward.
> The emphasis of the work has to be on these two things.
>
> I have listed the following requests for presentations (the order is not
> important):
>
> -Multiple Interface Support with PMIPv6 (15 Min) - Vijay
>  (draft-devarapalli-netlmm-multihoming-02.txt)
>
> -PMIPv6 Heartbeat Mechanism (10 Min) - Vijay
>  (draft-devarapalli-netlmm-pmipv6-heartbeat-01.txt)
>
> -PMIPv6 and MIPv4 interactions (10 min) - Vijay
>
> -Multihoming Scenarios (10 min) - Ahmad
>
> -GRE keying (5 min) - Ahmad
>
> -Route Optimization (10 min) - Christian
>
> -Inter-MAG Route Optimization (10 min) Ashutosh
>
> -Inter-technology handover extensions (10 min) - Marco
>
> -PMIPv6 support Transient CoA Registration (10 min) - Ahmad
>  draft-muhanna-netlmm-pmipv6-support-transient-coa-00.txt
>
> -Proxy Network Mobility (10 Min) - John
>
> -Secondary Binding Cache Entries for PMIP (10 min) - Oliver
>  draft-blume-netlmm-secondary-bce-proxymip6ho-00.txt
>
> -Multiple interface support (10 min) - Mohana
>  draft-jeyatharan-netlmm-multi-interface-ps-01.txt
>
> -Proxy Mobile IPv6 indication and discovery (10 min) - Basavaraj
> draft-damic-netlmm-pmip6-ind-discover-03.txt
>
> And I'm pretty sure I forgot something (please remind me if I did).
>
> The problem is that this does not really fit. We cannot have all of these
> presentations and accomplish our main goal of the meeting. So, I think we
> have to compress and rethink the presentations.
>
> However, I see some patterns/groups (again the order is not of importance):
>
> Interaction
>  -PMIP6-MIP4
>  -PMIP6-MIP6 (presented in earlier meeting)
>
> Multiple interface support/Multihoming
>  -Vijay
>  -Mohana
>  -Ahmad
>  -Marco?
>
> Route Optimization
>  -Christian
>  -Ashutosh
>
> Multiple COA Registration
>  -Ahmad
>  -Oliver
>
> Others
>  -GRE keying (Ahmad)
>  -Heart Beat (Vijay)
>  -PMIP indication and discovery (Basavaraj)
>
> Could we do some grouping here or cooperation to get the different problems
> areas at least presented? In addition, I would think it would be good to get
> the items presented that it seems our "customers" like 3GPP, 3GPP2, and
> Wimax Forum expect us to get done. I think this is extremely important input
> for the rechartering discussion.
>
> Any ideas or suggestions?
>
> Cheers,
>
> Jonne.
>
> PS. I think we will let only the people enter the meeting room who have
> commented/reviewed the remaining WG items we have in the current charter...
> ;)
>
> PS/2: Any volunteers for Jabber scribes and minute takers?
>
>   

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Soininen Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 03 Mar 2008 17:23:09 +0200

Hello,

I wanted to wait if other people have something to say about this, but 
it seems that nobody else had input to this discussion.

I think I agree with you, Vijay. 5-10min rapid fire presentations are 
not the way to go anymore. That should be clear I guess. So, I think we 
should concentrate on the priority of the work that we _might_ have in 
the WG. Otherwise we will be swamped in work, and we won't get anything 
done in the WG.

I think Vijay's organization of work-items seems reasonable, but I would 
like to have also a bit of confirmation on the mailing list. Do people 
feel that the grouping makes sense? You don't have to agree or disagree 
on the order of the priorities, but the grouping as such. BTW, I would 
put the other SDO's wishes into the list of "Required for deployment" 
category at this point.

I think I will be organizing the WG Agenda around this as well, and I 
will be sending the updated agenda shortly.

Cheers,

Jonne.

ext Vijay Devarapalli wrote:
>
> Hi Jonne,
>
> I would suggest avoid any kind of presentations that would
> just present or "introduce" a draft for 5 or 10 minutes. We
> should spend the face-to-face time on re-chartering. I hope
> we can spend some time on figuring out what is needed today
> for a PMIPv6 deployment, figure out what is broken that
> needs to be fixed, what optimizations would be useful in the
> future, etc..
>
> We already had the 5-10 minutes rapid-fire presentations at
> the last meeting. I hope we don't repeat that. Once you put
> up a list of items that the WG is considering chartering, I
> am sure folks will glance through the drafts and figure out
> what is in the drafts. :)
>
> I would further categorize the current solutions we have as
> follows.
>
> 1. Required for PMIPv6 deployment
> - LMA discovery
> - RADIUS and Diameter extensions (MAG-AAA and LMA-AAA interfaces)
> - GRE keys
> - Binding revocation (this is guess is being done in the MEXT WG)
> - Heartbeat mechanism for PMIPv6
>
> 2. Interactions with host-based mobility protocols
> - PMIPv6 - MIPv6 interactions
> - PMIPv6 - MIPv4 interactions
>
> 3. Multiple interface support and multi-homing
> - Different multi-homing scenarios (various drafts)
> - Handovers across interfaces using PMIPv6 (various drafts)
>
> 4. Handover optimizations
> - Transient CoA (Ahmad)
> - Two stage proxy BU (Marco)
> - FMIPv6 signaling for inter-MAG tunneling and CT (MIPSHOP WG)
>
> 5. NEMO support with PMIPv6
>
> 6. PMIPv6 route optimization
>
> IMHO, 5) and 6) are of low importance. 1) is most important. 4)
> is very murky, requires more discussion.
>
> I am sure I missed some items. I probably categorized one or
> two solutions wrongly too. It wasn't intentional. I have listed
> whatever I could remember. This could be a start for the
> re-chartering discussion.
>
> > In addition, I would think it would be good to get
> This is a good idea. We should try to standardize solutions
> that these SDOs depend on ASAP. But at the same time please
> lets avoid "rubber-stamping" solutions that were developed
> in the SDOs. In any case, they shouldn't be anything more than
> Informational.
>
> Hope that helps.
>
> Vijay
>

---

From: Frank Xia <[email-masked]>
Date: Mon, 03 Mar 2008 09:38:30 -0600

Hi Jonne

I am following the practice in  MEXT in which RADIUS draft  is included
http://tools.ietf.org/wg/mext/draft-ietf-mip6-radius/.

IMO, it makes sense. 

BR
Frank

---

From: Basavaraj Patil <[email-masked]>
Date: Mon, 03 Mar 2008 09:59:24 -0600

Hi Jonne,

In terms of an agenda for the meeting, I think it is best to allocate the
time to the (3) documents that the WG is expected to complete and deliver.
Beyond that the WG needs to discuss what other work items are essential to
ensuring that the protocol can be deployed successfully.
Several SDOs who are now incorporating PMIP6 as a protocol solution in their
architectures require additional features (eg. GRE tunnelling support,
binding revocation, etc.)
Rechartering of the WG should be what we should focus on at this meeting and
take on work items that are absolutely essential.

Many of the features that are being proposed are "nice-to-have". I think it
is best if many of the features are discussed in an IETF RG (eg. Mobopts).
Route optimization is a good example, because we have see that RO has not
really seen traction and its applicability needs to be better understood.
Also the multihost related features are best dealt with in the RG prior to
taking on the topic in the WG. It is better to get some implementation and
deployment experience before tackling new features.

Setting the direction for the WG for the next 12 months is paramount. And my
opinion is that we should be focusing on add-on features that make PMIP6
deployable in various environments. Hence I see no reason to discuss all the
various proposals at the meeting and instead it is better if the time was
used for WG docs and rechartering. And if that does not take all the
allocated time, it is a good sign :)

-Raj

---

From: Marco Liebsch <[email-masked]>
Date: Mon, 03 Mar 2008 17:42:22 +0100

I think what is 'nice-to-have' and what is 'high-demand' should be
the focus of the planned re-charter discussion. Before moving
anything to the IRTF, possible work items should be addressed
in the NetLMM WG. Saying this I mean motivating the work
with a problem statement, preferably being supported by
implementation experiences.

Going through individual solution presentations might fail due
to lack of time, I agree.
But grouping topics and motivating associated work within a
single presentation seems to be a reasonable compromise.
This is my view on the general approach for this meeting.

Now inter-technology handover extensions: We could do a
rapid fire presentation including motivation and solution
presentation at IETF70, which received positive feedback.
Now there are two further proposals, addressing the same topic.
This should be an indication about the relevance of this topic.
At least a 10min slot to address the scope of this issue and to
discuss within the WG whether this is 'nice-to-have' or this
is 'what we and other SDOs really want' seems reasonable to me.

marco

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 03 Mar 2008 10:41:29 -0800

> http://tools.ietf.org/wg/mext/draft-ietf-mip6-radius/.

Not necessarily. I don't remember why we decided that the RADIUS
extensions had to be done in the MIP6 WG. Maybe RADEXT didn't
have the bandwidth for this work. Raj, do you remember?

That shouldn't be the reason why the NETLMM WG should standardize
the RADIUS extensions for PMIPv6.

Having said, I do think that we should work on the RADIUS
extensions somewhere.

Vijay

---

From: Basavaraj Patil <[email-masked]>
Date: Mon, 03 Mar 2008 12:55:49 -0600

The reason why MIP6 tool on the radius extensions work was because the
chairs believed that most of the competence for the work was in the MIP6 WG.
Radext chairs were okay with working on it as a joint WG document and ensure
that the last call and reviews are done by both WGs.

In the case of Netlmm as well, I think it would be best to consult with the
Radext chairs their opinion about the work being done as a Netlmm/Radext
joint WG I-D. 

-Raj

---

From: "BLUME, Oliver" <[email-masked]>
Date: Mon, 3 Mar 2008 20:14:45 +0100

I'd like to support Marco's emphasis on a slot for inter-tech Handover, with respesct to the deployment scenarios and SDO's use cases.

3GPP is one of these SDO's and is specifying PMIP as the protocol for inter-RAT technology in its enhanced system architecture (SAE), while intra-3GPP HO will rather still be done with GTP and other 3GPP proprietary protocols. Furthermore, 3GPP SAE has recently stated that  handover between e.g. LTE and WIMAX will require dual-radio terminals to enable make-before-break-handover.

So, for 3GPP SAE inter-tech handover is mandatory and requires simultaneous usage of two interfaces. This scenario is currently not well served in the PMIP draft, as it assumes that the old radio link is no longer available at the time of the new PBU, leading to packet loss and Handoff latency. The three drafts Marco mentioned address this issue and show way for smooth protocol performance during such handoffs. 

So IMHO inter-tech handoff improvement are key as an "add-on features that make PMIP6 deployable in various environments" (citeing Raj here) and as such should be part of WG-rechartering for the next 12 months. A presentation slot for this would be really helpful.

BR,

Oliver 

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Marco Liebsch
Gesendet: Montag, 3. März 2008 17:42
An: Basavaraj Patil
Cc: [email-masked]
Betreff: Re: [netlmm] About the Agenda for the meeting - your input is needed

I think what is 'nice-to-have' and what is 'high-demand' should be the focus of the planned re-charter discussion. Before moving anything to the IRTF, possible work items should be addressed in the NetLMM WG. Saying this I mean motivating the work with a problem statement, preferably being supported by implementation experiences.

Going through individual solution presentations might fail due to lack of time, I agree.
But grouping topics and motivating associated work within a single presentation seems to be a reasonable compromise.
This is my view on the general approach for this meeting.

Now inter-technology handover extensions: We could do a rapid fire presentation including motivation and solution presentation at IETF70, which received positive feedback.
Now there are two further proposals, addressing the same topic.
This should be an indication about the relevance of this topic.
At least a 10min slot to address the scope of this issue and to discuss within the WG whether this is 'nice-to-have' or this is 'what we and other SDOs really want' seems reasonable to me.

marco

Basavaraj Patil wrote:
> Hi Jonne,
>
> In terms of an agenda for the meeting, I think it is best to allocate 
> the time to the (3) documents that the WG is expected to complete and deliver.
> Beyond that the WG needs to discuss what other work items are 
> essential to ensuring that the protocol can be deployed successfully.
> Several SDOs who are now incorporating PMIP6 as a protocol solution in 
> their architectures require additional features (eg. GRE tunnelling 
> support, binding revocation, etc.) Rechartering of the WG should be 
> what we should focus on at this meeting and take on work items that 
> are absolutely essential.
>
> Many of the features that are being proposed are "nice-to-have". I 
> think it is best if many of the features are discussed in an IETF RG (eg. Mobopts).
> Route optimization is a good example, because we have see that RO has 
> not really seen traction and its applicability needs to be better understood.
> Also the multihost related features are best dealt with in the RG 
> prior to taking on the topic in the WG. It is better to get some 
> implementation and deployment experience before tackling new features.
>
> Setting the direction for the WG for the next 12 months is paramount. 
> And my opinion is that we should be focusing on add-on features that 
> make PMIP6 deployable in various environments. Hence I see no reason 
> to discuss all the various proposals at the meeting and instead it is 
> better if the time was used for WG docs and rechartering. And if that 
> does not take all the allocated time, it is a good sign :)
>
> -Raj
>
>
>> I didn't have the possibility before today to combine the agenda, 
>> though I kind of knew what to expect. I think we have a problem for 
>> which I would like to ask for your help.
>>
>> Jonne Soininen <[email-masked]> Vidya Narayanan 
>> <[email-masked]>
>>
>> Topic: Interface between a Proxy MIPv6 Mobility Access Gateway and a 
>> Mobile Node
>> The problem is that this does not really fit. We cannot have all of 
>> these presentations and accomplish our main goal of the meeting. So, 
>> I think we have to compress and rethink the presentations.
>>
>> Multiple interface support/Multihoming  -Vijay  -Mohana  -Ahmad  
>> -Marco?
>>
>> Route Optimization
>>  -Christian
>>  -Ashutosh
>>
>> Could we do some grouping here or cooperation to get the different 
>> problems areas at least presented? In addition, I would think it 
>> would be good to get the items presented that it seems our 
>> "customers" like 3GPP, 3GPP2, and Wimax Forum expect us to get done. 
>> I think this is extremely important input for the rechartering discussion.
>>
>> PS. I think we will let only the people enter the meeting room who 
>> have commented/reviewed the remaining WG items we have in the current charter...
>> ;)
>>

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Mon, 3 Mar 2008 12:13:18 -0800

Jonne, all,
I agree that we should not have the rapid fire presentations this time
around.  If there were drafts that had reasonable amount of discussions
on the mailing list, we could have had presentations of those, but, such
is not the case.  So, I think we should focus on the WG drafts and then
move on to rechartering topics.  

On the rechartering topics, I would avoid the usage of any grouping that
makes presumptions.  For instance, "required for deployment" at the
moment is a subjective category.  I think the view so far is from some
individual WG participants' perspective, which doesn't automatically get
categorized as such.  I'd like to have the grouping reflect the
technical meaning only - for instance, grouping in the context of
"multihoming" or "inter-tech handoffs" or "route optimization" make
sense - lets avoid grouping that reflects our (or anyone's) ideas of
what is required for deployment. 

On the SDO front, requirements from other SDOs must come in the form of
liaison letters and not just assertion from WG participants.  If there
are such requirements, the WG participants who participate in other SDOs
can perhaps take the to-do to bring those in the form of LSs.
Availability of such LSs will be helpful for the rechartering
discussions. 

Thanks,
Vidya 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Soininen Jonne 
> (NSN - FI/Espoo)
> Sent: Monday, March 03, 2008 7:23 AM
> To: ext Vijay Devarapalli
> Cc: [email-masked]
> I wanted to wait if other people have something to say about 
> this, but it seems that nobody else had input to this discussion.
> 
> I think I agree with you, Vijay. 5-10min rapid fire 
> presentations are not the way to go anymore. That should be 
> clear I guess. So, I think we should concentrate on the 
> priority of the work that we _might_ have in the WG. 
> Otherwise we will be swamped in work, and we won't get 
> anything done in the WG.
> 
> I think Vijay's organization of work-items seems reasonable, 
> but I would like to have also a bit of confirmation on the 
> mailing list. Do people feel that the grouping makes sense? 
> You don't have to agree or disagree on the order of the 
> priorities, but the grouping as such. BTW, I would put the 
> other SDO's wishes into the list of "Required for deployment" 
> category at this point.
> 
> I think I will be organizing the WG Agenda around this as 
> well, and I will be sending the updated agenda shortly.
> 
> Cheers,
> 
> Jonne.
> 
> > I would suggest avoid any kind of presentations that would just 
> > present or "introduce" a draft for 5 or 10 minutes. We should spend 
> > the face-to-face time on re-chartering. I hope we can spend 
> some time 
> > on figuring out what is needed today for a PMIPv6 
> deployment, figure 
> > out what is broken that needs to be fixed, what 
> optimizations would be 
> > useful in the future, etc..
> >
> the last 
> > meeting. I hope we don't repeat that. Once you put up a 
> list of items 
> > that the WG is considering chartering, I am sure folks will glance 
> > through the drafts and figure out what is in the drafts. :)
> >
> > I would further categorize the current solutions we have as follows.
> >
> > IMHO, 5) and 6) are of low importance. 1) is most important. 4) is 
> > very murky, requires more discussion.
> >
> > I am sure I missed some items. I probably categorized one or two 
> > solutions wrongly too. It wasn't intentional. I have listed 
> whatever I 
> > could remember. This could be a start for the re-chartering 
> > discussion.
> >
> > > In addition, I would think it would be good to get the items 
> > > presented that it seems our "customers" like 3GPP, 3GPP2, 
> and Wimax 
> > > Forum expect us to get done. I think this is extremely
> > important input
> that these 
> > SDOs depend on ASAP. But at the same time please lets avoid 
> > "rubber-stamping" solutions that were developed in the SDOs. In any 
> > case, they shouldn't be anything more than Informational.
> >
> > Hope that helps.
> >
> > Vijay
> >
>

---

From: "Soininen Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 03 Mar 2008 23:25:56 +0200

Hi,

I think what Raj proposes makes sense and I will start the discussion 
with the radext chairmen.

Cheers,

Jonne.

---

From: "Soininen Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 03 Mar 2008 23:36:07 +0200

Hi Vidya,

perhaps you are right that "needed for deployment" is a perhaps a wrong 
wording. However, luckily we have the 3GPP2 liaison from last year that 
did list some of their requirements, and we at least have the 3GPP 
dependencies list from 3GPP that does list the 3GPP currently required 
drafts. In addition, we were communicated that those are the drafts that 
they need in the last 3GPP-IETF conference call.

So, I think that at least on those SDOs we are set, for now.

Cheers,

Jonne.

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 03 Mar 2008 13:49:09 -0800

Soininen Jonne (NSN - FI/Espoo) wrote:
> wording. 

Not necessarily. I did not intend the category "Required for
PMIPv6 deployment" to mean that the SDOs want it. That category
was supposed to include whatever the NETLMM WG thinks is
critical for a realistic PMIPv6 deployment.

Take, for example, LMA discovery. SDOs don't need this, since
they have developed their own mechanisms for LMA discovery.
That does not mean we should avoid working on a standard LMA
discovery mechanism. That is very critical, IMO.

I was expecting a discussion in the NETLMM WG on what items
should be considered for that category.

Vijay

However, luckily we have the 3GPP2 liaison from last year that
>>> From: [email-masked] [mailto:[email-masked]] On 
>>> Behalf Of Soininen Jonne (NSN - FI/Espoo)
>>> I wanted to wait if other people have something to say about this, 
>>> but it seems that nobody else had input to this discussion.
>>>
>>> not the way to go anymore. That should be clear I guess. So, I think 
>>> we should concentrate on the priority of the work that we _might_ 
>>> have in the WG. Otherwise we will be swamped in work, and we won't 
>>> get anything done in the WG.
>>>
>>> I think Vijay's organization of work-items seems reasonable, but I 
>>> would like to have also a bit of confirmation on the mailing list. Do 
>>> people feel that the grouping makes sense? You don't have to agree or 
>>> disagree on the order of the priorities, but the grouping as such. 
>>> BTW, I would put the other SDO's wishes into the list of "Required 
>>> for deployment" category at this point.
>>>
>>>> could remember. This could be a start for the re-chartering discussion.
>>>>
>>>>

---

From: "Soininen Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 04 Mar 2008 00:35:31 +0200

Hi,

I'm ok of naming the group of documents "Required for PMIPv6 deployment" 
or "first priority", or anything else that explains that these are 
things that have to be gotten out of the door first. However, the 
content of that group is for the WG to determine, and I take Vijay's 
proposal just as input.

I think that others could also give input on the mailing list before the 
meeting, what they think is _absolutely needed_ for PMIP6. I would ask 
for some patience from people with their proposals. I know that 
everything that is proposed for the WG has some kind of use case - at 
least for the author of the document. Otherwise, people wouldn't propose 
these drafts. However, I would hope that people could wait with 
scenarios and technologies that are not essential in the first phase.

Cheers,

Jonne.

ext Vijay Devarapalli wrote:
>> perhaps you are right that "needed for deployment" is a perhaps a 
>> wrong wording. 
>
>> dependencies list from 3GPP that does list the 3GPP currently 
>> required drafts. In addition, we were communicated that those are the 
>> drafts that they need in the last 3GPP-IETF conference call.
>>
>>> move on to rechartering topics. On the rechartering topics, I would 
>>> avoid the usage of any grouping that
>>>> I think I agree with you, Vijay. 5-10min rapid fire presentations 
>>>> are not the way to go anymore. That should be clear I guess. So, I 
>>>> think we should concentrate on the priority of the work that we 
>>>> _might_ have in the WG. Otherwise we will be swamped in work, and 
>>>> we won't get anything done in the WG.
>>>>
>>>> would like to have also a bit of confirmation on the mailing list. 
>>>> Do people feel that the grouping makes sense? You don't have to 
>>>> agree or disagree on the order of the priorities, but the grouping 
>>>> as such. BTW, I would put the other SDO's wishes into the list of 
>>>> "Required for deployment" category at this point.
>>>>
>>>> I think I will be organizing the WG Agenda around this as well, and 
>>>> I will be sending the updated agenda shortly.
>>>>
>>>> Cheers,
>>>>
>>>> Jonne.
>>>>
>>>>> present or "introduce" a draft for 5 or 10 minutes. We should 
>>>>> spend the face-to-face time on re-chartering. I hope we can 
>>>>> spend       
>>>> some time   
>>>>> "rubber-stamping" solutions that were developed in the SDOs. In 
>>>>> any case, they shouldn't be anything more than Informational.
>>>>>
>>>>> Hope that helps.
>>>>>
>>>>> Vijay
>>>>>
>>>>>

---

From: <[email-masked]>
Date: Tue, 4 Mar 2008 08:33:13 +0100

Jonne,

While you are at this, you should also talk to Dime chairs
about equivalent Diameter work.

Cheers,
	Jouni

> Sent: 3. maaliskuuta 2008 23:26
> To: ext Basavaraj Patil
> Cc: [email-masked]
> >>>>> It is necessary mechanism when deploying PMIPv6 using 
> RADIUS as AAA
> >>>>> protocol.
> >>>>>
> >>>>> In fact, the corresponding document, Diamter Proxy 
> Mobile IPv6, is also
> >>>>> being 
> >>>>> areas at least presented? In addition, I would think it 
> would be good to
> >>>>> get
> >>>>> Wimax Forum expect us to get done. I think this is 
> extremely important
> >>>>> input

---

From: "Soininen Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 04 Mar 2008 09:45:51 +0200

Certainly.

ext [email-masked] wrote:
>>> The reason why MIP6 tool on the radius extensions work was 
>>>       
>> because the
>>     
>>> chairs believed that most of the competence for the work 
>>>       
>> was in the MIP6 WG.
>>     
>>> Radext chairs were okay with working on it as a joint WG 
>>>       
>> document and ensure
>>     
>>> In the case of Netlmm as well, I think it would be best to 
>>>       
>> consult with the
>>     
>>> Radext chairs their opinion about the work being done as a 
>>>       
>> Netlmm/Radext
>>     
>>> joint WG I-D. 
>>>
>>> -Raj 
>>>
>>>
>>>>> I am following the practice in  MEXT in which RADIUS 
>>>>>           
>> draft  is included
>>     
>>>>> Subject: Re: [netlmm] About the Agenda for the meeting - 
>>>>>           
>> your input is needed
>>     
>>>>>       
>>>>>           
>>>>>> Frank,
>>>>>>
>>>>>> I thought radius extensions would rather be at radext WG 
>>>>>>             
>> than in netlmm.
>>     
>>>>>> This would then be in line with dime and the diameter 
>>>>>>             
>> work as well.
>>     
>>>>>> Cheers,
>>>>>>
>>>>>> Jonne.
>>>>>> ext Frank Xia wrote:
>>>>>>         
>>>>>>             
>>>>>>> Hi Soininen
>>>>>>>
>>>>>>> I think  that "RADIUS Proxy Mobile IPv6" is another 
>>>>>>>               
>> topic to consider for
>>     
>>>>>>> rechartering.
>>>>>>> Subject: [netlmm] About the Agenda for the meeting - 
>>>>>>>               
>> your input is needed
>>     
>>>>>>> Hello everybody,
>>>>>>>
>>>>>>> I didn't have the possibility before today to combine 
>>>>>>>               
>> the agenda, though I
>>     
>>>>>>> kind of knew what to expect. I think we have a problem 
>>>>>>>               
>> for which I would
>>     
>>>>>>> Topic: Interface between a Proxy MIPv6 Mobility Access 
>>>>>>>               
>> Gateway and a Mobile
>>     
>>>>>>> Node
>>>>>>> So we have basically 2.5 hours to spend, and we _have 
>>>>>>>               
>> to_ discuss the
>>     
>>>>>>> current WG drafts, and get to understand what are we 
>>>>>>>               
>> doing going forward.
>>     
>>>>>>> I have listed the following requests for presentations 
>>>>>>>               
>> (the order is not
>>     
>>>>>>> important):
>>>>>>>
>>>>>>> And I'm pretty sure I forgot something (please remind 
>>>>>>>               
>> me if I did).
>>     
>>>>>>> The problem is that this does not really fit. We cannot 
>>>>>>>               
>> have all of these
>>     
>>>>>>> presentations and accomplish our main goal of the 
>>>>>>>               
>> meeting. So, I think we
>>     
>>>>>>> However, I see some patterns/groups (again the order is 
>>>>>>>               
>> not of importance):
>>     
>>>>>>> Interaction
>>>>>>>  -PMIP6-MIP4
>>>>>>> Could we do some grouping here or cooperation to get 
>>>>>>>               
>> the different problems
>>     
>>>>>>> the items presented that it seems our "customers" like 
>>>>>>>               
>> 3GPP, 3GPP2, and
>>     
>>>>>>> PS. I think we will let only the people enter the 
>>>>>>>               
>> meeting room who have
>>     
>>>>>>> commented/reviewed the remaining WG items we have in 
>>>>>>>               
>> the current charter...
>>     
>>>>>>> ;)
>>>>>>>

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Tue, 4 Mar 2008 00:02:38 -0800

Shouldn't we be first discussing the need for the RADIUS and Diameter
work in the context of NETLMM before we go to those chairs asking their
WGs to do some work for us?  I think the discussion on the need for the
work should happen as part of the rechartering discussions, knowing that
if we decide it is needed, we will ask RADEXT and DIME for input on
whether the work can happen there. 

- Vidya 

> Sent: Monday, March 03, 2008 11:46 PM
> To: ext [email-masked]
> Cc: [email-masked]
> > While you are at this, you should also talk to Dime chairs about 
> > equivalent Diameter work.
> >
> > Cheers,
> > 	Jouni
> >
> >
> >   
> >> [mailto:[email-masked]] On Behalf Of Soininen 
> Jonne (NSN - 
> >> FI/Espoo)
> your input 
> >> is needed
> >>>> extensions had to be done in the MIP6 WG. Maybe RADEXT 
> didn't have 
> >>>> the bandwidth for this work. Raj, do you remember?
> >>>>

---

From: "Sangjin Jeong" <[email-masked]>
Date: Tue, 4 Mar 2008 18:20:43 +0900

Hello Raj,

RO seems to be an attractive topic given that there exist several 
solution proposals for PMIP6 RO, IMHO. The applicability and 
scenarios are investigated in the RO problem statement document 
which is a joint work of several people. Also operators may want 
to deploy RO in order to efficiently manage their network resources.
I think it is not necessarily to move PMIP6 RO to the IRTF given that 
NEMO RO is handled by MEXT.

Regards,
Sangjin

----- Original Message ----- 
From: "Basavaraj Patil" <[email-masked]>
To: "Jonne Soininen" <[email-masked]>; <[email-masked]>
Sent: Tuesday, March 04, 2008 12:59 AM
Subject: Re: [netlmm] About the Agenda for the meeting - your input is needed

Hi Jonne,

-Raj

---

From: Hidetoshi Yokota <[email-masked]>
Date: Thu, 06 Mar 2008 12:08:30 +0900

Hi Raj and Sangjin,

Sorry for the late response. In 3GPP2, there has been a discussion on 
the call localization management, which shortcuts the path between the 
AGW and HA. This is still at the stage of requirements, but the PMIP RO 
could be a potential solution for it. So, this would be not just a "nice 
to have", but "indispensably nice to have":-).

Regards,
-- 
Hidetoshi

---

From: Ashutosh Dutta <[email-masked]>
Date: Wed, 05 Mar 2008 23:33:24 -0500

Raj, Sangjin, and Yokoat-san

I also agree that it would be preferable to carry out Route Optimization 
work within NETLMM working group, as it has a lot of dependency with 
other WG items and thus can best be served here.

It also maybe a good idea to extend the existing RO requirement draft 
and study the relevant RO drafts that are under submission and analyze 
their approaches to the problem. I know there are few folks in the WG 
who are interested in the RO work including myself.

Regards
Ashutosh

 > > Beyond that the WG needs to discuss what other work items are 
essential to
 > > Many of the features that are being proposed are "nice-to-have". I 
think it
 > > Also the multihost related features are best dealt with in the RG 
prior to
 >> >> I didn't have the possibility before today to combine the agenda, 
though I

---

From: "Soininen Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Thu, 06 Mar 2008 12:00:20 +0200

Hello everybody,

like I said previously, I think there is a use case or requirement for 
all of the proposals that people have written a draft for. Otherwise, 
they wouldn't have written the draft in the first place. It is not 
_that_ much fun to write drafts.

So, I don't think the discussion shouldn't be on the question if some 
feature is eventually needed but we should concentrate on the timing of 
the feature and the relationships of the features.

I think though RO is obviously something there is interest for, it is 
useless before where have all the bits and pieces together for PMIP6 
being effective in the basic use cases.

I really would hope that people would concentrate on the discussion on 
the priorities of the tasks in relationship to other tasks. If there is 
something that comes a bit later down the road perhaps IRTF would be a 
better place for them.

Cheers,

Jonne.

---

From: Marco Liebsch <[email-masked]>
Date: Thu, 06 Mar 2008 14:35:18 +0100

Jonne,

I understand that we need to prioritize. But I don't think solely NetLMM can
argue whether getting a RO protocol is a logical and needed next
step, or if this is future work, which allows taking more time for more 
research.
That's one reason why we came up with the RO problem statement and
requirements draft (draft-jeong-netlmm-pmipv6-roreq-01), which should serve
as living document to discuss different application scenarios (similar 
to what the
PMIP-MIP interaction document does) and associated requirements.

I think the existence of the RO slot on the NetLMM meeting agenda for IETF71
is well justified, but it should be taken to focus on the scope and 
analysis of scenarios
and associated requirements rather than solutions. Main interest is to 
receive feedback
from the WG about the relevance of RO for PMIPv6. Getting a first 
impression about
the priority list, that's my understanding of the re-charter discussion.
Then, indications from other SDOs would help. The problem statement and
requirements draft can serve as reference for such a discussion.

marco

---

From: "Soininen Jonne (NSN FI/Espoo)" <[email-masked]>
Date: Thu, 06 Mar 2008 16:00:58 +0200

Marco,

Thank you for writing the draft. However, we cannot look at RO in isolation,
and there is a good reason for every draft to be presented. Sadly, there is
no time to go through all the presentations.

I hope the people read that draft. That way they can take well part in the
discussion in the meeting.

Cheers,

Jonne.

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34
E-mail: [email-masked]

---

From: Marco Liebsch <[email-masked]>
Date: Thu, 06 Mar 2008 15:42:33 +0100

Sure, I didn't mean an isolated slot (sorry, my fault), but taking the 
work item
into account during the re-charter discussion and to not assign it to IRTF
work without taking more discussion and opinions into account.

Thanks,
marco

Soininen Jonne (NSN FI/Espoo) wrote:
>>>>>> Subject: Re: [netlmm] About the Agenda for the meeting - your input
>>>>>>             
>>>> is needed
>>>>         
>>>>>>
>>>>>> Hi Jonne,
>>>>>>
>>>>>> In terms of an agenda for the meeting, I think it is best to
>>>>>>             
>>>> allocate the
>>>>         
>>>>>> time to the (3) documents that the WG is expected to complete and
>>>>>>             
>>>> deliver.
>>>>         
>>>>>> Several SDOs who are now incorporating PMIP6 as a protocol solution
>>>>>>             
>>>> in their
>>>>         
>>>>>> Rechartering of the WG should be what we should focus on at this
>>>>>>             
>>>> meeting and
>>>>         
>>>>>> is best if many of the features are discussed in an IETF RG (eg.
>>>>>>             
>>>> Mobopts).
>>>>         
>>>>>> Route optimization is a good example, because we have see that RO
>>>>>>             
>>>> has not
>>>>         
>>>>>> really seen traction and its applicability needs to be better
>>>>>>             
>>>> understood.
>>>>         
>>>>>> taking on the topic in the WG. It is better to get some
>>>>>>             
>>>> implementation and
>>>>         
>>>>>> Setting the direction for the WG for the next 12 months is
>>>>>>             
>>>> paramount. And my
>>>>         
>>>>>> opinion is that we should be focusing on add-on features that make
>>>>>>             
>>>> PMIP6
>>>>         
>>>>>> deployable in various environments. Hence I see no reason to
>>>>>>             
>>>> discuss all the
>>>>         
>>>>>> various proposals at the meeting and instead it is better if the
>>>>>>             
>>>> time was
>>>>         
>>>>>>>> kind of knew what to expect. I think we have a problem for which
>>>>>>>>                 
>>>> I would
>>>>         
>>>>>>>> Topic: Interface between a Proxy MIPv6 Mobility Access Gateway
>>>>>>>>                 
>>>> and a Mobile
>>>>         
>>>>>>>> Node
>>>>>>>> current WG drafts, and get to understand what are we doing going
>>>>>>>>                 
>>>> forward.
>>>>         
>>>>>>>> I have listed the following requests for presentations (the order
>>>>>>>>                 
>>>> is not
>>>>         
>>>>>>>> important):
>>>>>>>>
>>>>>>>> The problem is that this does not really fit. We cannot have all
>>>>>>>>                 
>>>> of these
>>>>         
>>>>>>>> presentations and accomplish our main goal of the meeting. So, I
>>>>>>>>                 
>>>> think we
>>>>         
>>>>>>>> However, I see some patterns/groups (again the order is not of
>>>>>>>>                 
>>>> importance):
>>>>         
>>>>>>>> Interaction
>>>>>>>>  -PMIP6-MIP4
>>>>>>>> Could we do some grouping here or cooperation to get the
>>>>>>>>                 
>>>> different problems
>>>>         
>>>>>>>> areas at least presented? In addition, I would think it would be
>>>>>>>>                 
>>>> good to get
>>>>         
>>>>>>>> the items presented that it seems our "customers" like 3GPP,
>>>>>>>>                 
>>>> 3GPP2, and
>>>>         
>>>>>>>> Wimax Forum expect us to get done. I think this is extremely
>>>>>>>>                 
>>>> important input
>>>>         
>>>>>>>> PS. I think we will let only the people enter the meeting room
>>>>>>>>                 
>>>> who have
>>>>         
>>>>>>>> commented/reviewed the remaining WG items we have in the current
>>>>>>>>                 
>>>> charter...
>>>>         
>>>>>>>>  ;)
>>>>>>>>

---

From: Ashutosh Dutta <[email-masked]>
Date: Thu, 06 Mar 2008 10:01:03 -0500

Jonne, I also echo Marco's comments here. PMIP RO work would probably be 
better served if it is carried out in NETLMM working group as part of 
re-chartered WG item, since it would  have close link and 
inter-dependence with other NETLMM working group items and PMIP base 
draft(RFC).

Thus, it might be helpful to include RO as one of items for re-charter 
discussion.

Regards
Ashutosh

---

From: "Soininen Jonne (NSN FI/Espoo)" <[email-masked]>
Date: Thu, 06 Mar 2008 17:10:17 +0200

Hi Marco,

But of course, I don't see any reason that RO should not be considered. I
think we can only do fair and good discussion if we consider all of the
needed items.

I think for now, everything is up for discussion. Let's then see where the
discussion takes us before making conclusions. I totally agree with that!

Cheers,

Jonne.

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 10 Mar 2008 10:30:34 -0700

Hi Jonne,

I updated the list based on the comments received so far.

1. Important for PMIPv6 deployment (or whatever you want to call this).
- LMA discovery
- RADIUS and Diameter extensions (MAG-AAA and LMA-AAA interfaces)
- GRE keys
- Binding revocation
- Heartbeat mechanism for PMIPv6

3. Multiple interface support and multi-homing
- Different multi-homing scenarios 
(draft-devarapalli-netlmm-multihoming, 
draft-jeyatharan-netlmm-multi-interface-ps)
- Handovers across interfaces using PMIPv6 
(draft-devarapalli-netlmm-multihoming)

4. Handover optimizations
- Transient CoA (draft-muhanna-netlmm-pmipv6-support-transient-coa)
- Two stage proxy BU (draft-liebsch-netlmm-intertech-proxymip6ho)
- Secondary Bindings (draft-blume-netlmm-secondary-bce-proxymip6ho)
- FMIPv6 signaling for inter-MAG tunneling and CT (MIPSHOP WG - 
draft-yokota-mipshop-pfmipv6-02)

Hope that helps.

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 10 Mar 2008 10:33:26 -0700

> work without taking more discussion and opinions into account.

Taking the work to the IRTF MOBOPTS WG is not necessarily a bad
thing. We have a sort of working relationship where topics that
need more discussion or more accurate scoping are first discussed
in the mobopts group. Once the work is finalized there, we have
brought the work to the MIPSHOP or MIP6 working groups to
standardize them as proposed standards. It works.

Vijay

---

From: Marco Liebsch <[email-masked]>
Date: Mon, 10 Mar 2008 18:53:50 +0100

Vijay Devarapalli schrieb:
> thing.
I didn't say this.
>  We have a sort of working relationship where topics that
Sure. No need to convice me :-) But so far, we just heard only a few 
opinions about
what should be on the priority list. We need to go through some more 
discussion and
take the obviously increasing interest in this topic into account.

marco