Subject: [netlmm] The way forward as discussed during the WG meeting

From: "Soininen Jonne (NSN FI/Espoo)" <[email-masked]>
Date: Sat, 15 Mar 2008 15:20:40 +0200

Hello everybody,

Now that the IETF week is over, I think it is time to recap the meeting
outcome related to the rechartering of our beloved working group.

The consensus of the meeting was to concentrate on the work for the next
twelve months. We discussed in the meeting, which would be the work items we
would think should be done first.

The meeting was able to identify the following:

 * GRE Keying
 * PMIP6/MIP6 interactions
 * AAA - Diameter & Radius
 * LMA discovery

We'll have to see what is the right place to do the AAA work. It is either
in netlmm or in the relative AAA working group (Dime or Radex).

LMA discovery on the other hand is something that might be either solved in
AAA or specific separate procedure.

We couldn't find consensus on other work items, yet. Main reason was the
lack of clarity of the work needed. Thus, if we want to do one or two items
in addition to the now agreed work, we have to understand what the work is,
and its importance.

Thus, we discussed that the right way of identifying other work items, we
would need to have a paragraph or two describing the work, and listing the
people that would be interested to work on the topic. I would like to ask
the people that are interested to add work on the charter to

1) Describe the topic with a paragraph or two (what is needed, not the
solution itself)
2) Who would be the people who would be able and interested to invest to the
work. 

I have to remind everybody that time is of essence in deciding the new
charter. Our dear AD said that we should move quickly here. Thus, if you
think additional work is needed, please, write the description quickly and
list the people that would work on the topic.

Notice that the people who are listed as interested in additional topics
will also commit to further the other work in the charter through
contribution and review.

The consensus of the working group is tested on the mailing list. Thus, the
described way forward should be considered as a proposal. However, if
somebody would think this way forward is not the correct one, I would expect
those individuals to justify their objections quite carefully.

I hope this helps.

Cheers,

Jonne.

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34
E-mail: [email-masked]

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Sun, 16 Mar 2008 09:57:59 -0500

Hi Jonne,

The following topic received good support during the meeting and I would
to propose the following description to be considered as a wg work item:

Inter-MAG Handover Optimization:
================================
Base PMIPv6 protocol addresses inter-MAG handover by allowing the local
mobility anchor to immediately switch the bidirectional MAG-LMA tunnel
as soon as it receives the new proxy BU from the target MAG. Base PMIPv6
protocol does not  provide a mechanism to handle transit or in-flight
traffic after the LMA abruptly switched the MAG-LMA tunnel to point to
the target MAG. This may cause problems to applications that are
sensitive to traffic delay and packet loss. 

A mechanism which enables the LMA to avoid an abrupt MAG-LMA tunnel
switching and consequently provides a smooth active inter-MAG handover
by minimizing traffic delay and packet loss is extremely needed.

People willing to work on this item:
====================================
1. Ahmad Muhanna and all co-authors of draft:
http://www.ietf.org/internet-drafts/draft-muhanna-netlmm-pmipv6-support-
transient-coa-01.txt are interested but they can confirm individually.

2. I believe Marco Liebsch is very interested but he also can confirm. 

Regards,
Ahmad

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Soininen Jonne 
> (NSN FI/Espoo)
> Sent: Saturday, March 15, 2008 8:21 AM
> To: [email-masked]
> Subject: [netlmm] The way forward as discussed during the WG meeting
> 
> Hello everybody,
> 
> Now that the IETF week is over, I think it is time to recap 
> the meeting outcome related to the rechartering of our 
> beloved working group.
> 
> The consensus of the meeting was to concentrate on the work 
> for the next twelve months. We discussed in the meeting, 
> which would be the work items we would think should be done first.
> 
> We'll have to see what is the right place to do the AAA work. 
> It is either in netlmm or in the relative AAA working group 
> (Dime or Radex).
> 
> LMA discovery on the other hand is something that might be 
> either solved in AAA or specific separate procedure.
> 
> We couldn't find consensus on other work items, yet. Main 
> reason was the lack of clarity of the work needed. Thus, if 
> we want to do one or two items in addition to the now agreed 
> work, we have to understand what the work is, and its importance.
> 
> Thus, we discussed that the right way of identifying other 
> work items, we would need to have a paragraph or two 
> describing the work, and listing the people that would be 
> interested to work on the topic. I would like to ask the 
> people that are interested to add work on the charter to
> 
> 1) Describe the topic with a paragraph or two (what is 
> needed, not the solution itself)
> 2) Who would be the people who would be able and interested 
> to invest to the work. 
> 
> I have to remind everybody that time is of essence in 
> deciding the new charter. Our dear AD said that we should 
> move quickly here. Thus, if you think additional work is 
> needed, please, write the description quickly and list the 
> people that would work on the topic.
> 
> Notice that the people who are listed as interested in 
> additional topics will also commit to further the other work 
> in the charter through contribution and review.
> 
> The consensus of the working group is tested on the mailing 
> list. Thus, the described way forward should be considered as 
> a proposal. However, if somebody would think this way forward 
> is not the correct one, I would expect those individuals to 
> justify their objections quite carefully.
> 
> I hope this helps.
> 
> Cheers,
> 
> Jonne.
> 
> --
> Jonne Soininen
> Nokia Siemens Networks
> 
> Tel: +358 40 527 46 34

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Sun, 16 Mar 2008 10:23:09 -0500

Hi Jonne,

Another topic that was also hot during netlmm meeting is the following
one:

PMIPv6 Support Multihoming:
===========================

Base PMIPv6 protocol addresses multihoming with a very basic objective
in mind "Base PMIPv6 protocol must not break current multihoming
functionality of regular unmodified IPv6 hosts". However, there are
several different scenarios which are relevant to multihoming and can be
categorized in three groups as follows: Non-Nomadic Multihoming, Nomadic
Multihoming, and Transient multihoming. PMIPv6 support of all of the
relevant scenarios may require some change on the handset if the
respected functionality is to be supported.

An informational document is necessary to describe all applicable
multihoming scenarios with a thorough study and analysis of PMIPv6
support for such scenarios.

People willing to work on this item:
====================================
1. Ahmad Muhanna and Mohamed Khalil.
2. I am sure Vijay Devarapalli et. al, but they can confirm individually
3. I am sure Mohana Jeyatharan et. al., but they can confirm
individually

Regards,
Ahmad

---

From: "Sri Gundavelli" <[email-masked]>
Date: Sun, 16 Mar 2008 12:49:42 -0700

Hi Jonne,

We need do the MIB work for Proxy Mobile IPv6 protocol.
Glenn Keeni, MIB expert, has kindly agreed to work on this.
This work related operational management is tedious, but
required for Proxy Mobile IPv6 deployments. We need to
instrument this protocol and so this needs to be in the
charter. The initial draft will be published soon.

Title: 
   Proxy Mobile IPv6 Management Information Base (PMIP6 MIB)

Description: 
   Defines a portion of the Management Information Base (MIB),
   the Proxy Mobile IPv6 (PMIP6) MIB, for use with network
   management protocols in the Internet community.  In particular,
   the Proxy Mobile IPv6 MIB will be used to monitor and control the 
   mobility entities in a Proxy Mobile IPv6 domain involved in
   providing network-based mobility management support to a mobile
   node.

Authors: 
   Glenn Keeni, Kent Leung, Ryuji, Sri ..

Regards
Sri

> Sent: Saturday, March 15, 2008 6:21 AM
> To: [email-masked]
> the meeting
> for the next
> It is either
> reason was the
> work items, we
> to invest to the
> additional topics
> list. Thus, the

---

From: "Sri Gundavelli" <[email-masked]>
Date: Sun, 16 Mar 2008 13:18:53 -0700

and Ryuji has promised to get the MIB implementation done in
their code base ... :)

Sri

> [mailto:[email-masked]] On Behalf Of Sri Gundavelli
> Sent: Sunday, March 16, 2008 12:50 PM
> To: 'Soininen Jonne (NSN FI/Espoo)'; [email-masked]
> Cc: 'Ryuji Wakikawa'; 'Glenn M. Keeni'
> Subject: Re: [netlmm] The way forward as discussed during the 
> WG meeting
> 
> Hi Jonne,
> 
> deciding the new

---

From: Basavaraj Patil <[email-masked]>
Date: Sun, 16 Mar 2008 22:54:16 -0500

Ahmad,

Inter MAG HO optimization is addressed by I-D:
draft-yokota-mipshop-pfmipv6-02.txt

This I-D is now being considered in the MIPSHOP WG as part of the
rechartering effort.
The problem statement that you mention below is addressed by the solution
proposed in the above I-D.

-Raj

---

From: RYUJI WAKIKAWA <[email-masked]>
Date: Mon, 17 Mar 2008 17:41:13 +0900

Sri,

I agree that we should define MIB for PMIP.

> and Ryuji has promised to get the MIB implementation done in

Did I promise?

You don't know how boring to write MIB code, do you!

ryuji

---

From: Marco Liebsch <[email-masked]>
Date: Mon, 17 Mar 2008 11:07:37 +0100

I confirm what Ahmad indicates and I am of course interested in this
work, as we motivated the use of preliminary bindings for inter-technology
handover already at IETF70. Associated draft is here 
http://www.ietf.org/internet-drafts/draft-liebsch-netlmm-intertech-proxymip6ho-01.txt 

I guess there are more people being interested, as the author from
draft-blume-netlmm-secondary-bce-proxymip6ho-00.

All drafts focus on different aspects of uplink and downlink optimization,
but propose more or less the same mechanism. This shows that 
inter-technology
handover issues have been well recognized and solved. It also shows, 
that there are
issues with the base specification and that there is a not so small 
group being
interested in driving this work ahead. Associated protocol extensions can be
specified smoothly and would fit into the 12 months timeframe.

Regarding Ahmad's description, I would recommend to clearly indicate
issues related to inter-technology handover, whereas some of the proposed
extensions are beneficial even for intra-technology handover.

Thanks and best regards,
marco

---

From: "BLUME, Oliver" <[email-masked]>
Date: Mon, 17 Mar 2008 12:35:18 +0100

Hi Ahmad and Marco and all,

I agree to the joining of forces between the three drafts and that this should be addressed in the next 12 month. Though I could not participate in the IETF meeting I'd be interested to contribute such work.

Regards,

Oliver Blume 

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Marco Liebsch
Gesendet: Montag, 17. März 2008 11:08
An: Ahmad Muhanna
Cc: Marco Liebsch; [email-masked]
Betreff: Re: [netlmm] The way forward as discussed during the WG meeting

I confirm what Ahmad indicates and I am of course interested in this work, as we motivated the use of preliminary bindings for inter-technology handover already at IETF70. Associated draft is here http://www.ietf.org/internet-drafts/draft-liebsch-netlmm-intertech-proxymip6ho-01.txt 

Thanks and best regards,
marco

---

From: Marco Liebsch <[email-masked]>
Date: Mon, 17 Mar 2008 12:36:39 +0100

Hi Raj,

fmipv6 for PMIPv6 addresses inter-MAG tunneling for a
particular scenario and mandates some specific operation
of PMIP and other components to allow set up of a
bi-directional tunnel between ARs.

Our input to the NetLMM WG addresses various issues being
in partcular associated with inter-technology handover in
PMIPv6 enabled networks. There are three proposals which
solve these issues with an efficent extension to the base protocol.
That's why the NetLMM group is suitable to do this work.

marco

---

From: "BLUME, Oliver" <[email-masked]>
Date: Mon, 17 Mar 2008 13:20:08 +0100

Hi Raj,

To my understanding there is a difference between the two optimisation approaches:

FMIP (and pfmip) address the inter-MAG handoff by a context transfer and preparation of the handover in a communication between the two access points. This is especially useful for the case of a MN with a single interface. In this case the context transfer is between MAGs serving the same radio technology and context transfer is homogeneous.

On the other hand, for MN with multiple, simultaneously running interfaces (for different RATs) handover preparation and HO can be performed by break-before-make. In this case no direkt communication between MAGs is needed (context transfer may be more difficult for MAGs in different RATs) , but instead the communication is only MT-MAG1-LMA and MT-MAG2-LMA. Then context is related inside the LMA, linking the previous binding and the new binding.

The optimisations that has been described in the three drafts by Liebsch, Blume and Muhanna cover the second scenario and IMO are not related to MIPSHOP.
I hope this helps to clearify the approach.

Best regards,

Oliver
-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Marco Liebsch
Gesendet: Montag, 17. März 2008 12:37
An: Basavaraj Patil
Cc: [email-masked]; Marco Liebsch
Betreff: Re: [netlmm] The way forward as discussed during the WG meeting

Hi Raj,

fmipv6 for PMIPv6 addresses inter-MAG tunneling for a particular scenario and mandates some specific operation of PMIP and other components to allow set up of a bi-directional tunnel between ARs.

Our input to the NetLMM WG addresses various issues being in partcular associated with inter-technology handover in
PMIPv6 enabled networks. There are three proposals which solve these issues with an efficent extension to the base protocol.
That's why the NetLMM group is suitable to do this work.

marco

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Basavaraj Patil
Gesendet: Montag, 17. März 2008 04:54
An: ext Ahmad Muhanna; Jonne Soininen; [email-masked]
Cc: Marco Liebsch
Betreff: Re: [netlmm] The way forward as discussed during the WG meeting

Ahmad,

This I-D is now being considered in the MIPSHOP WG as part of the rechartering effort.
The problem statement that you mention below is addressed by the solution proposed in the above I-D.

-Raj

On 3/16/08 9:57 AM, "ext Ahmad Muhanna" <[email-masked]> wrote:

> Hi Jonne,
> 
> The following topic received good support during the meeting and I 
> would to propose the following description to be considered as a wg work item:
> 
> Base PMIPv6 protocol addresses inter-MAG handover by allowing the 
> local mobility anchor to immediately switch the bidirectional MAG-LMA 
> tunnel as soon as it receives the new proxy BU from the target MAG. 
> Base PMIPv6 protocol does not  provide a mechanism to handle transit 
> or in-flight traffic after the LMA abruptly switched the MAG-LMA 
> tunnel to point to the target MAG. This may cause problems to 
> applications that are sensitive to traffic delay and packet loss.
> 
> http://www.ietf.org/internet-drafts/draft-muhanna-netlmm-pmipv6-suppor
> t- transient-coa-01.txt are interested but they can confirm 
> individually.
> 
>> [mailto:[email-masked]] On Behalf Of Soininen Jonne (NSN 
>> FI/Espoo)
>> Now that the IETF week is over, I think it is time to recap the 
>> meeting outcome related to the rechartering of our beloved working 
>> group.
>> 
>> The consensus of the meeting was to concentrate on the work for the 
>> next twelve months. We discussed in the meeting, which would be the 
>> work items we would think should be done first.
>> 
>> It is either in netlmm or in the relative AAA working group (Dime or 
>> Radex).
>> 
>> LMA discovery on the other hand is something that might be either 
>> solved in AAA or specific separate procedure.
>> 
>> We couldn't find consensus on other work items, yet. Main reason was 
>> the lack of clarity of the work needed. Thus, if we want to do one or 
>> two items in addition to the now agreed work, we have to understand 
>> what the work is, and its importance.
>> 
>> Thus, we discussed that the right way of identifying other work 
>> items, we would need to have a paragraph or two describing the work, 
>> and listing the people that would be interested to work on the topic. 
>> I would like to ask the people that are interested to add work on the 
>> charter to
>> 
>> 1) Describe the topic with a paragraph or two (what is needed, not 
>> the solution itself)
>> 2) Who would be the people who would be able and interested to invest 
>> to the work.
>> 
>> I have to remind everybody that time is of essence in deciding the 
>> new charter. Our dear AD said that we should move quickly here. Thus, 
>> if you think additional work is needed, please, write the description 
>> quickly and list the people that would work on the topic.
>> 
>> Notice that the people who are listed as interested in additional 
>> topics will also commit to further the other work in the charter 
>> through contribution and review.
>> 
>> The consensus of the working group is tested on the mailing list. 
>> Thus, the described way forward should be considered as a proposal. 
>> However, if somebody would think this way forward is not the correct 
>> one, I would expect those individuals to justify their objections 
>> quite carefully.
>> 
>> I hope this helps.
>> 
>> Cheers,
>> 
>> Jonne.
>> 
>> --
>> Jonne Soininen
>> Nokia Siemens Networks
>> 
>> Tel: +358 40 527 46 34

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 17 Mar 2008 10:20:31 -0500

Raj,

I guess Jonne was asking for a proposal of the description without
getting into the details of the solution. I did not mean to list the
transient registration draft as a solution rather a pointer to the names
of co-authors and as I said, each co-author needs to confirm
individually. I also, listed Marco name who also have another draft
addressing the same topic.

On the other hand, if I recall correctly from the netlmm meeting, the
FMIPv6 solution was listed under the same item of Handover optimization
but it was the only item that is considered for MIPSHOP recharter
without detailed discussion on this list. My impression based on the AD
comment during the meeting is that the decision to take that as a
recharter item for MIPSHOP is still under consideration.

Regards,
Ahmad

> From: Basavaraj Patil [mailto:[email-masked]] 
> Sent: Sunday, March 16, 2008 10:54 PM
> To: Muhanna, Ahmad (RICH1:2H10); Jonne Soininen; [email-masked]
> Cc: Suresh Krishnan; Kent Leung (kleung); Marco Liebsch
> reason was

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 17 Mar 2008 11:10:45 -0700

Ahmad Muhanna wrote:

> My impression based on the AD

All the items being proposed for the new MIPSHOP charter are "under
consideration". We are soliciting comments on the proposed charter
right now. In fact, we will be sending the charter to the AD *after*
the WG concludes on what can/can't be added.

Vijay

---

From: Ryuji Wakikawa <[email-masked]>
Date: Mon, 17 Mar 2008 17:39:20 +0900

Sri,

Did I promise?

ryuji