Subject: [netlmm] draft-jhlee-netlmm-heartbeatlma-01.txt

From: Randal Hicks <[email-masked]>
Date: Thu, 6 Mar 2008 01:42:07 -0500

I see that modification of HEARTBEAT_LMA_INTERVAL between inquiring  
and responding
LMAs would throttle communications between them to manageable levels,  
however,
what guarantee do we have that another process ( i.e. virus ) will  
not effectively
ignore this request and solicit another inquiry early -- or even a  
flood of
inquiries?  Under 3.2 Receiving the Heartbeat Message, this LMA  
SHOULD be listed
as Ignored until n seconds have passed (to match  
HEARTBEAT_LMA_INTERVAL)...
just to keep the inquiring LMA honest and to guard against a flood.

This implies that the offending/inquiring LMA may reach  
MISSING_HEARTBEATS_LMA_ALLOWED.
Is this an appropriate response/mechanism?

	"if an LMA has exceeded its system resource
    	usage or its capacity, then the LMA is failed or crashed. In such
    	cases, the task of crashed LMA should be taken over or changed to
    	another LMA existing in the same PMIPv6-Domain as soon as  
possible."

Sufficient care should be taken that cascading failures do not ensue.

Regards,
Randal L. Hicks
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Jong-Hyouk Lee" <[email-masked]>
Date: Thu, 6 Mar 2008 19:56:09 +0900

Dear Randal.

The proposed Heartbeat mechanism for LMAs uses the heartbeat messages to
check reachability. Within this mechanism (inquiring and responding), a
lower degree network achieves a lower packet loss rate because packet loss
rate acts as a function of detection time.

Well, the configuration variables
(HEARTBEAT_LMA_INTERVAL, MISSING_HEARTBEATS_LMA_ALLOWED) can
be configured based on network degree. In addition, to prevent the cascading
failures, another configuration variable will be defined in the next
document. Thanks for your comments.

Cheers.

On Thu, Mar 6, 2008 at 3:42 PM, Randal Hicks <[email-masked]>
wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.8 (Darwin)
>
> iEYEARECAAYFAkfPkj8ACgkQHXnD0tz+/vwozgCbBBVlW1L9OpXMP+dmqf7JJDRo
> fvwAmQE/HVLZ362AEg1b6edSlgGSSJt2
> =48Ge
> -----END PGP SIGNATURE-----

-- 
Internet Management Technology Lab, Sungkyunkwan University.
Jong-Hyouk Lee.

#email: jonghyouk (at) gmail (dot) com
#webpage: http://cv.hurryon.org
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 06 Mar 2008 08:05:13 -0800

Jong-Hyouk,

The MIP6 WG (now the MEXT WG) had developed protocols for
home agent reliability. See
http://www.ietf.org/internet-drafts/draft-ietf-mip6-hareliability-03.txt

The above draft describes a mechanism between the home agents
to detect if one of them failed. It is based on sending
HELLO message periodically.

IMO, we should be using the same mechanism for detecting LMA
failure too. No reason to develop a new one.

Vijay

Jong-Hyouk Lee wrote:
> lower degree network achieves a lower packet loss rate because packet 
> loss rate acts as a function of detection time.
>  
> be configured based on network degree. In addition, to prevent the 
> cascading failures, another configuration variable will be defined in 
> the next document. Thanks for your comments.
>  
> Cheers.
>  
> On Thu, Mar 6, 2008 at 3:42 PM, Randal Hicks <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>

---

From: "Jong-Hyouk Lee" <[email-masked]>
Date: Fri, 21 Mar 2008 13:48:26 +0900

Hi, Vijay.

First, sorry for late response. Well, I've known about that. However, I
think that the failure detection mechanism for LMAs (for PMIPv6) needs. The
document for home agent reliability check is based on MIPv6. Do you think
that the document can be used both PMIPv6 and MIPv6? If then, we can use the
document. If not, we need to develop new one (even though some functions are
duplicated).

Cheers.

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 21 Mar 2008 10:25:37 -0700

Jong-Hyouk Lee wrote:
> think that the failure detection mechanism for LMAs (for PMIPv6) needs. 
> The document for home agent reliability check is based on MIPv6. Do you 
> think that the document can be used both PMIPv6 and MIPv6? If then, we 
> can use the document. 

Of course. The Hello messages defined in draft-ietf-mip6-hareliability 
can be used between the LMAs too.

Vijay

If not, we need to develop new one (even though
> some functions are duplicated).
>  
> Cheers.
>  
> On 3/7/08, *Vijay Devarapalli* <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Jong-Hyouk,
> 
>      > On Thu, Mar 6, 2008 at 3:42 PM, Randal Hicks
>     <[email-masked] <mailto:[email-masked]>
>      > <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >
>     <mailto:[email-masked] <mailto:[email-masked]>>