Subject: [netlmm] The way forward - Handover

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 17 Mar 2008 19:07:48 -0700 (PDT)

Let me point out that developing many solutions to PMIP6 handover issue in different WGs is unprecedented. 
Currently Mipshop is considering including it in its charter and it would be good idea for Ahmad, Marco, Rolf, et al. to contribute to this process positively and  take their cases to Mipshop.

Regards,

Behcet

----- Original Message ----
From: Vijay Devarapalli <[email-masked]>
To: Ahmad Muhanna <[email-masked]>
Cc: Marco Liebsch <[email-masked]>; [email-masked]
Sent: Monday, March 17, 2008 1:10:45 PM
Subject: Re: [netlmm] The way forward as discussed during the WG meeting

Ahmad Muhanna wrote:

> My impression based on the AD
> comment during the meeting is that the decision to take that as a
> recharter item for MIPSHOP is still under consideration.

All the items being proposed for the new MIPSHOP charter are "under
consideration". We are soliciting comments on the proposed charter
right now. In fact, we will be sending the charter to the AD *after*
the WG concludes on what can/can't be added.

Vijay

> 
> 
> Regards,
> Ahmad
>  
> 
>> -----Original Message-----
>> From: Basavaraj Patil [mailto:[email-masked]] 
>> Sent: Sunday, March 16, 2008 10:54 PM
>> To: Muhanna, Ahmad (RICH1:2H10); Jonne Soininen; [email-masked]
>> Cc: Suresh Krishnan; Kent Leung (kleung); Marco Liebsch
>> Subject: Re: [netlmm] The way forward as discussed during the 
>> WG meeting
>>
>>
>> Ahmad,
>>
>> Inter MAG HO optimization is addressed by I-D:
>> draft-yokota-mipshop-pfmipv6-02.txt
>>
>> This I-D is now being considered in the MIPSHOP WG as part of 
>> the rechartering effort.
>> The problem statement that you mention below is addressed by 
>> the solution proposed in the above I-D.
>>
>> -Raj
>>
>>
>> On 3/16/08 9:57 AM, "ext Ahmad Muhanna" <[email-masked]> wrote:
>>
>>> Hi Jonne,
>>>
>>> The following topic received good support during the meeting and I 
>>> would to propose the following description to be considered 
>> as a wg work item:
>>> Inter-MAG Handover Optimization:
>>> ================================
>>> Base PMIPv6 protocol addresses inter-MAG handover by allowing the 
>>> local mobility anchor to immediately switch the 
>> bidirectional MAG-LMA 
>>> tunnel as soon as it receives the new proxy BU from the target MAG. 
>>> Base PMIPv6 protocol does not  provide a mechanism to 
>> handle transit 
>>> or in-flight traffic after the LMA abruptly switched the MAG-LMA 
>>> tunnel to point to the target MAG. This may cause problems to 
>>> applications that are sensitive to traffic delay and packet loss.
>>>
>>> A mechanism which enables the LMA to avoid an abrupt MAG-LMA tunnel 
>>> switching and consequently provides a smooth active 
>> inter-MAG handover 
>>> by minimizing traffic delay and packet loss is extremely needed.
>>>
>>>
>>> People willing to work on this item:
>>> ====================================
>>> 1. Ahmad Muhanna and all co-authors of draft:
>>>
>> http://www.ietf.org/internet-drafts/draft-muhanna-netlmm-pmipv6-suppor
>>> t- transient-coa-01.txt are interested but they can confirm 
>>> individually.
>>>
>>> 2. I believe Marco Liebsch is very interested but he also 
>> can confirm.
>>>
>>> Regards,
>>> Ahmad
>>>  
>>>
>>>> -----Original Message-----
>>>> From: [email-masked]
>>>> [mailto:[email-masked]] On Behalf Of Soininen Jonne (NSN 
>>>> FI/Espoo)
>>>> Sent: Saturday, March 15, 2008 8:21 AM
>>>> To: [email-masked]
>>>> Subject: [netlmm] The way forward as discussed during the 
>> WG meeting
>>>> Hello everybody,
>>>>
>>>> Now that the IETF week is over, I think it is time to recap the 
>>>> meeting outcome related to the rechartering of our beloved working 
>>>> group.
>>>>
>>>> The consensus of the meeting was to concentrate on the 
>> work for the 
>>>> next twelve months. We discussed in the meeting, which 
>> would be the 
>>>> work items we would think should be done first.
>>>>
>>>> The meeting was able to identify the following:
>>>>
>>>>  * GRE Keying
>>>>  * PMIP6/MIP6 interactions
>>>>  * AAA - Diameter & Radius
>>>>  * LMA discovery
>>>>
>>>> We'll have to see what is the right place to do the AAA work.
>>>> It is either in netlmm or in the relative AAA working 
>> group (Dime or 
>>>> Radex).
>>>>
>>>> LMA discovery on the other hand is something that might be either 
>>>> solved in AAA or specific separate procedure.
>>>>
>>>> We couldn't find consensus on other work items, yet. Main 
>> reason was 
>>>> the lack of clarity of the work needed. Thus, if we want 
>> to do one or 
>>>> two items in addition to the now agreed work, we have to 
>> understand 
>>>> what the work is, and its importance.
>>>>
>>>> Thus, we discussed that the right way of identifying other work 
>>>> items, we would need to have a paragraph or two describing 
>> the work, 
>>>> and listing the people that would be interested to work on 
>> the topic. 
>>>> I would like to ask the people that are interested to add 
>> work on the 
>>>> charter to
>>>>
>>>> 1) Describe the topic with a paragraph or two (what is needed, not 
>>>> the solution itself)
>>>> 2) Who would be the people who would be able and 
>> interested to invest 
>>>> to the work.
>>>>
>>>> I have to remind everybody that time is of essence in deciding the 
>>>> new charter. Our dear AD said that we should move quickly 
>> here. Thus, 
>>>> if you think additional work is needed, please, write the 
>> description 
>>>> quickly and list the people that would work on the topic.
>>>>
>>>> Notice that the people who are listed as interested in additional 
>>>> topics will also commit to further the other work in the charter 
>>>> through contribution and review.
>>>>
>>>> The consensus of the working group is tested on the mailing list. 
>>>> Thus, the described way forward should be considered as a 
>> proposal. 
>>>> However, if somebody would think this way forward is not 
>> the correct 
>>>> one, I would expect those individuals to justify their objections 
>>>> quite carefully.
>>>>
>>>> I hope this helps.
>>>>
>>>> Cheers,
>>>>
>>>> Jonne.
>>>>
>>>> --
>>>> Jonne Soininen
>>>> Nokia Siemens Networks
>>>>
>>>> Tel: +358 40 527 46 34
>>>> E-mail: [email-masked]
>>>>
>>>>
>>>> _______________________________________________
>>>> netlmm mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/netlmm
>>>>
>>
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Marco Liebsch <[email-masked]>
Date: Tue, 18 Mar 2008 12:22:34 +0100

Hi Behcet,

I see your point. However, as I said I think applying FMIP to PMIPv6 is more
system level design and integration, which also aims at different 
scenarios. Other
optimization proposals to NetLMM, including ours, aim at a broader scope and
are specific extensions to the PMIPv6 protocol, as they affect inter 
alia binding
management. The need for such extensions is obvious and getting this 
work done
is my major interest. Where this is being done is not too relevant. 
However, I think
this particular work fits into NetLMM.

marco

Behcet Sarikaya schrieb:
> Currently Mipshop is considering including it in its charter and it 
> would be good idea for Ahmad, Marco, Rolf, et al. to contribute to 
> this process positively and take their cases to Mipshop.
>
> Regards,
>
> Behcet
>
> >> From: Basavaraj Patil [mailto:[email-masked] 
> <mailto:[email-masked]>]
> <mailto:[email-masked]>
> >> On 3/16/08 9:57 AM, "ext Ahmad Muhanna" <[email-masked] 
> <mailto:[email-masked]>> wrote:
> >>
> >>> Hi Jonne,
> >>>
> >>>> From: [email-masked] <mailto:[email-masked]>
> >>>> [mailto:[email-masked] <mailto:[email-masked]>] 
> On Behalf Of Soininen Jonne (NSN
> >>>> FI/Espoo)
> >>>> To: [email-masked] <mailto:[email-masked]>
> >>>> E-mail: [email-masked] <mailto:[email-masked]>
> >>>>
> >>>>
> >>>> [email-masked] <mailto:[email-masked]>
> > [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 18 Mar 2008 09:18:48 -0500

Hi Behcet,
 
I completely agree with you! We do not need multiple solutions for
PMIPv6 handover.

However, according to the proposed solution using FMIPv6, that solution
is NOT specific to PMIPv6. As a matter of fact, FMIPv6 solution has no
impact what so ever on PMIPv6 protocol and it easily could be used
regardless of the signaling protocol between the MAG and the LMA, e.g.
when using PMIPv4 (which is not a standard draft). Do not you agree?

In that case, we really do not have any problem, we only have one
proposed solution on the table which is generally captured by the three
drafts, muhanna et. al., Marco draft, and Oliver's. The other solution
could be renamed as "FMIPv6 for inter-AR lateral bidirectional tunnel
establishment" or if you split it functionally, it also could be used to
address inter-AR Context transfer mechanism.

Finally, as far as contributing to that effort, of course everyone
should contribute, especially those who believe that solution is
important and makes good sense for real deployment between Access
Routers.

Regards, 
Ahmad

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Behcet Sarikaya
	Sent: Monday, March 17, 2008 9:08 PM
	To: Vijay Devarapalli
	Cc: [email-masked]
	Subject: [netlmm] The way forward - Handover

	Let me point out that developing many solutions to PMIP6
handover issue in different WGs is unprecedented. 
	Currently Mipshop is considering including it in its charter and
it would be good idea for Ahmad, Marco, Rolf, et al. to contribute to
this process positively and take their cases to Mipshop.
	
	Regards,
	
	Behcet

	----- Original Message ----
	From: Vijay Devarapalli <[email-masked]>
	To: Ahmad Muhanna <[email-masked]>
	Cc: Marco Liebsch <[email-masked]>; [email-masked]
	Sent: Monday, March 17, 2008 1:10:45 PM
	Subject: Re: [netlmm] The way forward as discussed during the WG
meeting

	> recharter item for MIPSHOP is still under consideration.
	
	All the items being proposed for the new MIPSHOP charter are
"under
	consideration". We are soliciting comments on the proposed
charter
	right now. In fact, we will be sending the charter to the AD
*after*
	the WG concludes on what can/can't be added.
	
	Vijay