Subject: Re: [netlmm] About the Agenda for the meeting - your input is needed

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 3 Mar 2008 07:50:40 -0800 (PST)

Hi Jonne,
  MIP6 bootstrapping work which involved Radius extensions has been done in MIP6 WG not in radext. 
  The examples are:
RADIUS Mobile IPv6 Support http://tools.ietf.org/id/draft-ietf-mip6-radius-03.txt
if you read RFC 5026 on MIP6 Bootstrapping in Split Scenario, it says that Radius extensions are defined in mip6-radius draft.
  To my knowledge, radext WG was never involved in MIP6 bootstrapping  work, do you think that they would be willing to involve in PMIP6 bootstrapping work?
  Regards,

Behcet
----- Original Message ----
From: Soininen Jonne (NSN - FI/Espoo) <[email-masked]>
To: ext Frank Xia <[email-masked]>
Cc: [email-masked]
Sent: Monday, March 3, 2008 9:14:20 AM
Subject: Re: [netlmm] About the Agenda for the meeting - your input is needed

Frank,

I 
thought 
radius 
extensions 
would 
rather 
be 
at 
radext 
WG 
than 
in 
netlmm. 
This 
would 
then 
be 
in 
line 
with 
dime 
and 
the 
diameter 
work 
as 
well.

Cheers,

Jonne.
ext 
Frank 
Xia 
wrote:
Hi 
Soininen
I 
think  
that 
"RADIUS 
Proxy 
Mobile 
IPv6" 
is 
another 
topic 
to 
consider 
for
rechartering.
http://tools.ietf.org/wg/netlmm/draft-xia-netlmm-radius-02.txt
It 
is 
necessary 
mechanism 
when 
deploying 
PMIPv6 
using 
RADIUS 
as 
AAA 
protocol.
In 
fact, 
the 
corresponding 
document, 
Diamter 
Proxy 
Mobile 
IPv6, 
is 
also  
being 
discussed  
as 
a 
rechartering 
item 
in 
DIME 
WG.
http://tools.ietf.org/wg/dime/draft-korhonen-dime-pmip6-03.txt.
BR
Frank
----- 
Original 
Message 
----- 
From: 
"Soininen 
Jonne 
(NSN 
FI/Espoo)" 
<[email-masked]>
To: 
<[email-masked]>
Sent: 
Wednesday, 
February 
27, 
2008 
4:34 
PM
Subject: 
[netlmm] 
About 
the 
Agenda 
for 
the 
meeting 
- 
your 
input 
is 
needed
Hello 
everybody,
I 
didn't 
have 
the 
possibility 
before 
today 
to 
combine 
the 
agenda, 
though 
I
kind 
of 
knew 
what 
to 
expect. 
I 
think 
we 
have 
a 
problem 
for 
which 
I 
would
like 
to 
ask 
for 
your 
help.
First 
of 
all 
the 
proposed 
skeleton 
is 
the 
following:
Network-based 
Local 
Mobility 
Management 
(NetLMM)
---------------------------------------------------------
TUESDAY, 
March 
11, 
2008
0900-1130 
Morning 
Session 
I
Chairs: 
Jonne 
Soininen 
<[email-masked]>
Vidya 
Narayanan 
<[email-masked]>
---------------------------------------------------------
PRELIMINARIES
Agenda 
review
Blue 
sheets
Notes 
and 
Jabber 
scribe
WG 
status
WG 
DRAFT 
DISCUSSIONS
Topic: 
Proxy 
Mobile 
IPv6
Draft: 
draft-ietf-netlmm-proxymip6-11.txt
Topic: 
IPv4 
Support 
for 
Proxy 
Mobile 
IPv6
Draft: 
draft-ietf-netlmm-pmip6-ipv4-support-02.txt
Topic: 
Interface 
between 
a 
Proxy 
MIPv6 
Mobility 
Access 
Gateway 
and 
a 
Mobile
Node
Draft: 
draft-ietf-netlmm-mn-ar-if-03
POSSIBLE 
NEW 
WORK 
ITEMS
Presentations 
of 
the 
possible 
new 
work 
items
RECHARTERING 
DISCUSSIONS
NEXT 
STEPS 
and 
WRAP 
UP
---------------------------------------------------------
So 
we 
have 
basically 
2.5 
hours 
to 
spend, 
and 
we 
_have 
to_ 
discuss 
the
current 
WG 
drafts, 
and 
get 
to 
understand 
what 
are 
we 
doing 
going 
forward.
The 
emphasis 
of 
the 
work 
has 
to 
be 
on 
these 
two 
things.
I 
have 
listed 
the 
following 
requests 
for 
presentations 
(the 
order 
is 
not
important):
-Multiple 
Interface 
Support 
with 
PMIPv6 
(15 
Min) 
- 
Vijay
(draft-devarapalli-netlmm-multihoming-02.txt)
-PMIPv6 
Heartbeat 
Mechanism 
(10 
Min) 
- 
Vijay
(draft-devarapalli-netlmm-pmipv6-heartbeat-01.txt)
-PMIPv6 
and 
MIPv4 
interactions 
(10 
min) 
- 
Vijay
-Multihoming 
Scenarios 
(10 
min) 
- 
Ahmad
-GRE 
keying 
(5 
min) 
- 
Ahmad
-Route 
Optimization 
(10 
min) 
- 
Christian
-Inter-MAG 
Route 
Optimization 
(10 
min) 
Ashutosh
-Inter-technology 
handover 
extensions 
(10 
min) 
- 
Marco
-PMIPv6 
support 
Transient 
CoA 
Registration 
(10 
min) 
- 
Ahmad
draft-muhanna-netlmm-pmipv6-support-transient-coa-00.txt
-Proxy 
Network 
Mobility 
(10 
Min) 
- 
John
-Secondary 
Binding 
Cache 
Entries 
for 
PMIP 
(10 
min) 
- 
Oliver
draft-blume-netlmm-secondary-bce-proxymip6ho-00.txt
-Multiple 
interface 
support 
(10 
min) 
- 
Mohana
draft-jeyatharan-netlmm-multi-interface-ps-01.txt
-Proxy 
Mobile 
IPv6 
indication 
and 
discovery 
(10 
min) 
- 
Basavaraj
draft-damic-netlmm-pmip6-ind-discover-03.txt
And 
I'm 
pretty 
sure 
I 
forgot 
something 
(please 
remind 
me 
if 
I 
did).
The 
problem 
is 
that 
this 
does 
not 
really 
fit. 
We 
cannot 
have 
all 
of 
these
presentations 
and 
accomplish 
our 
main 
goal 
of 
the 
meeting. 
So, 
I 
think 
we
have 
to 
compress 
and 
rethink 
the 
presentations.
However, 
I 
see 
some 
patterns/groups 
(again 
the 
order 
is 
not 
of 
importance):
Interaction
-PMIP6-MIP4
-PMIP6-MIP6 
(presented 
in 
earlier 
meeting)
Multiple 
interface 
support/Multihoming
-Vijay
-Mohana
-Ahmad
-Marco?
Route 
Optimization
-Christian
-Ashutosh
Multiple 
COA 
Registration
-Ahmad
-Oliver
Others
-GRE 
keying 
(Ahmad)
-Heart 
Beat 
(Vijay)
-PMIP 
indication 
and 
discovery 
(Basavaraj)
Could 
we 
do 
some 
grouping 
here 
or 
cooperation 
to 
get 
the 
different 
problems
areas 
at 
least 
presented? 
In 
addition, 
I 
would 
think 
it 
would 
be 
good 
to 
get
the 
items 
presented 
that 
it 
seems 
our 
"customers" 
like 
3GPP, 
3GPP2, 
and
Wimax 
Forum 
expect 
us 
to 
get 
done. 
I 
think 
this 
is 
extremely 
important 
input
for 
the 
rechartering 
discussion.
Any 
ideas 
or 
suggestions?
Cheers,
Jonne.
PS. 
I 
think 
we 
will 
let 
only 
the 
people 
enter 
the 
meeting 
room 
who 
have
commented/reviewed 
the 
remaining 
WG 
items 
we 
have 
in 
the 
current 
charter...
;)
PS/2: 
Any 
volunteers 
for 
Jabber 
scribes 
and 
minute 
takers?

_______________________________________________
netlmm 
mailing 
list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 3 Mar 2008 07:58:09 -0800 (PST)

Hi Jonne,

I agree with the grouping in Vijay's email. I would also propose to add prefix management for HNP at the LMA to the group on Required 
for 
PMIPv6 
deployment. I think that Group 1 contains the SDO's wishes as well.

Kind regards,

Behcet

----- Original Message ----
From: Soininen Jonne (NSN - FI/Espoo) <[email-masked]>
To: ext Vijay Devarapalli <[email-masked]>
Cc: [email-masked]
Sent: Monday, March 3, 2008 9:23:09 AM
Subject: Re: [netlmm] About the Agenda for the meeting - your input is needed

Hello,

I 
wanted 
to 
wait 
if 
other 
people 
have 
something 
to 
say 
about 
this, 
but 
it 
seems 
that 
nobody 
else 
had 
input 
to 
this 
discussion.

I 
think 
I 
agree 
with 
you, 
Vijay. 
5-10min 
rapid 
fire 
presentations 
are 
not 
the 
way 
to 
go 
anymore. 
That 
should 
be 
clear 
I 
guess. 
So, 
I 
think 
we 
should 
concentrate 
on 
the 
priority 
of 
the 
work 
that 
we 
_might_ 
have 
in 
the 
WG. 
Otherwise 
we 
will 
be 
swamped 
in 
work, 
and 
we 
won't 
get 
anything 
done 
in 
the 
WG.

I 
think 
Vijay's 
organization 
of 
work-items 
seems 
reasonable, 
but 
I 
would 
like 
to 
have 
also 
a 
bit 
of 
confirmation 
on 
the 
mailing 
list. 
Do 
people 
feel 
that 
the 
grouping 
makes 
sense? 
You 
don't 
have 
to 
agree 
or 
disagree 
on 
the 
order 
of 
the 
priorities, 
but 
the 
grouping 
as 
such. 
BTW, 
I 
would 
put 
the 
other 
SDO's 
wishes 
into 
the 
list 
of 
"Required 
for 
deployment" 
category 
at 
this 
point.

I 
think 
I 
will 
be 
organizing 
the 
WG 
Agenda 
around 
this 
as 
well, 
and 
I 
will 
be 
sending 
the 
updated 
agenda 
shortly.

Cheers,

Jonne.

ext 
Vijay 
Devarapalli 
wrote:
Hi 
Jonne,
I 
would 
suggest 
avoid 
any 
kind 
of 
presentations 
that 
would
just 
present 
or 
"introduce" 
a 
draft 
for 
5 
or 
10 
minutes. 
We
should 
spend 
the 
face-to-face 
time 
on 
re-chartering. 
I 
hope
we 
can 
spend 
some 
time 
on 
figuring 
out 
what 
is 
needed 
today
for 
a 
PMIPv6 
deployment, 
figure 
out 
what 
is 
broken 
that
needs 
to 
be 
fixed, 
what 
optimizations 
would 
be 
useful 
in 
the
future, 
etc..
We 
already 
had 
the 
5-10 
minutes 
rapid-fire 
presentations 
at
the 
last 
meeting. 
I 
hope 
we 
don't 
repeat 
that. 
Once 
you 
put
up 
a 
list 
of 
items 
that 
the 
WG 
is 
considering 
chartering, 
I
am 
sure 
folks 
will 
glance 
through 
the 
drafts 
and 
figure 
out
what 
is 
in 
the 
drafts. 
:)
I 
would 
further 
categorize 
the 
current 
solutions 
we 
have 
as
follows.
1. 
Required 
for 
PMIPv6 
deployment
- 
LMA 
discovery
- 
RADIUS 
and 
Diameter 
extensions 
(MAG-AAA 
and 
LMA-AAA 
interfaces)
- 
GRE 
keys
- 
Binding 
revocation 
(this 
is 
guess 
is 
being 
done 
in 
the 
MEXT 
WG)
- 
Heartbeat 
mechanism 
for 
PMIPv6
2. 
Interactions 
with 
host-based 
mobility 
protocols
- 
PMIPv6 
- 
MIPv6 
interactions
- 
PMIPv6 
- 
MIPv4 
interactions
3. 
Multiple 
interface 
support 
and 
multi-homing
- 
Different 
multi-homing 
scenarios 
(various 
drafts)
- 
Handovers 
across 
interfaces 
using 
PMIPv6 
(various 
drafts)
4. 
Handover 
optimizations
- 
Transient 
CoA 
(Ahmad)
- 
Two 
stage 
proxy 
BU 
(Marco)
- 
FMIPv6 
signaling 
for 
inter-MAG 
tunneling 
and 
CT 
(MIPSHOP 
WG)
5. 
NEMO 
support 
with 
PMIPv6
6. 
PMIPv6 
route 
optimization
IMHO, 
5) 
and 
6) 
are 
of 
low 
importance. 
1) 
is 
most 
important. 
4)
is 
very 
murky, 
requires 
more 
discussion.
I 
am 
sure 
I 
missed 
some 
items. 
I 
probably 
categorized 
one 
or
two 
solutions 
wrongly 
too. 
It 
wasn't 
intentional. 
I 
have 
listed
whatever 
I 
could 
remember. 
This 
could 
be 
a 
start 
for 
the
re-chartering 
discussion.
In 
addition, 
I 
would 
think 
it 
would 
be 
good 
to 
get
the 
items 
presented 
that 
it 
seems 
our 
"customers" 
like 
3GPP, 
3GPP2, 
and
Wimax 
Forum 
expect 
us 
to 
get 
done. 
I 
think 
this 
is 
extremely 
important 
input
for 
the 
rechartering 
discussion.
This 
is 
a 
good 
idea. 
We 
should 
try 
to 
standardize 
solutions
that 
these 
SDOs 
depend 
on 
ASAP. 
But 
at 
the 
same 
time 
please
lets 
avoid 
"rubber-stamping" 
solutions 
that 
were 
developed
in 
the 
SDOs. 
In 
any 
case, 
they 
shouldn't 
be 
anything 
more 
than
Informational.
Hope 
that 
helps.
Vijay

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 3 Mar 2008 09:12:22 -0800 (PST)

Hi Raj,
  You are no longer chair, so you can speculate about which draft should go where freely 
  Regarding PMIP6 RO, my speculation would be mipshop. Handover optimization, route optimization are optimization work and they belong to mipshop.
  We need to convince mipshop chairs for this 

Regards,

Behcet
----- Original Message ----
From: Basavaraj Patil <[email-masked]>
To: Jonne Soininen <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Monday, March 3, 2008 9:59:24 AM
Subject: Re: [netlmm] About the Agenda for the meeting - your input is needed

Hi 
Jonne,

In 
terms 
of 
an 
agenda 
for 
the 
meeting, 
I 
think 
it 
is 
best 
to 
allocate 
the
time 
to 
the 
(3) 
documents 
that 
the 
WG 
is 
expected 
to 
complete 
and 
deliver.
Beyond 
that 
the 
WG 
needs 
to 
discuss 
what 
other 
work 
items 
are 
essential 
to
ensuring 
that 
the 
protocol 
can 
be 
deployed 
successfully.
Several 
SDOs 
who 
are 
now 
incorporating 
PMIP6 
as 
a 
protocol 
solution 
in 
their
architectures 
require 
additional 
features 
(eg. 
GRE 
tunnelling 
support,
binding 
revocation, 
etc.)
Rechartering 
of 
the 
WG 
should 
be 
what 
we 
should 
focus 
on 
at 
this 
meeting 
and
take 
on 
work 
items 
that 
are 
absolutely 
essential.

Many 
of 
the 
features 
that 
are 
being 
proposed 
are 
"nice-to-have". 
I 
think 
it
is 
best 
if 
many 
of 
the 
features 
are 
discussed 
in 
an 
IETF 
RG 
(eg. 
Mobopts).
Route 
optimization 
is 
a 
good 
example, 
because 
we 
have 
see 
that 
RO 
has 
not
really 
seen 
traction 
and 
its 
applicability 
needs 
to 
be 
better 
understood.
Also 
the 
multihost 
related 
features 
are 
best 
dealt 
with 
in 
the 
RG 
prior 
to
taking 
on 
the 
topic 
in 
the 
WG. 
It 
is 
better 
to 
get 
some 
implementation 
and
deployment 
experience 
before 
tackling 
new 
features.

Setting 
the 
direction 
for 
the 
WG 
for 
the 
next 
12 
months 
is 
paramount. 
And 
my
opinion 
is 
that 
we 
should 
be 
focusing 
on 
add-on 
features 
that 
make 
PMIP6
deployable 
in 
various 
environments. 
Hence 
I 
see 
no 
reason 
to 
discuss 
all 
the
various 
proposals 
at 
the 
meeting 
and 
instead 
it 
is 
better 
if 
the 
time 
was
used 
for 
WG 
docs 
and 
rechartering. 
And 
if 
that 
does 
not 
take 
all 
the
allocated 
time, 
it 
is 
a 
good 
sign 
:)

-Raj

On 
2/27/08 
4:34 
PM, 
"ext 
Soininen 
Jonne 
(NSN 
FI/Espoo)"
<[email-masked]> 
wrote:

Hello 
everybody,
I 
didn't 
have 
the 
possibility 
before 
today 
to 
combine 
the 
agenda, 
though 
I
kind 
of 
knew 
what 
to 
expect. 
I 
think 
we 
have 
a 
problem 
for 
which 
I 
would
like 
to 
ask 
for 
your 
help.
First 
of 
all 
the 
proposed 
skeleton 
is 
the 
following:
Network-based 
Local 
Mobility 
Management 
(NetLMM)
TUESDAY, 
March 
11, 
2008
0900-1130 
Morning 
Session 
I
Chairs: 
Jonne 
Soininen 
<[email-masked]>
Vidya 
Narayanan 
<[email-masked]>
PRELIMINARIES
Agenda 
review
Blue 
sheets
Notes 
and 
Jabber 
scribe
WG 
status
WG 
DRAFT 
DISCUSSIONS
Topic: 
Proxy 
Mobile 
IPv6
Draft: 
Topic: 
IPv4 
Support 
for 
Proxy 
Mobile 
IPv6
Draft: 
Topic: 
Interface 
between 
a 
Proxy 
MIPv6 
Mobility 
Access 
Gateway 
and 
a 
Mobile
Node
Draft: 
POSSIBLE 
NEW 
WORK 
ITEMS
Presentations 
of 
the 
possible 
new 
work 
items
RECHARTERING 
DISCUSSIONS
NEXT 
STEPS 
and 
WRAP 
UP
So 
we 
have 
basically 
2.5 
hours 
to 
spend, 
and 
we 
_have 
to_ 
discuss 
the
current 
WG 
drafts, 
and 
get 
to 
understand 
what 
are 
we 
doing 
going 
forward.
The 
emphasis 
of 
the 
work 
has 
to 
be 
on 
these 
two 
things.
I 
have 
listed 
the 
following 
requests 
for 
presentations 
(the 
order 
is 
not
important):
-Multiple 
Interface 
Support 
with 
PMIPv6 
(15 
Min) 
- 
Vijay
-PMIPv6 
Heartbeat 
Mechanism 
(10 
Min) 
- 
Vijay
-PMIPv6 
and 
MIPv4 
interactions 
(10 
min) 
- 
Vijay
-Multihoming 
Scenarios 
(10 
min) 
- 
Ahmad
-GRE 
keying 
(5 
min) 
- 
Ahmad
-Route 
Optimization 
(10 
min) 
- 
Christian
-Inter-MAG 
Route 
Optimization 
(10 
min) 
Ashutosh
-Inter-technology 
handover 
extensions 
(10 
min) 
- 
Marco
-PMIPv6 
support 
Transient 
CoA 
Registration 
(10 
min) 
- 
Ahmad
-Proxy 
Network 
Mobility 
(10 
Min) 
- 
John
-Secondary 
Binding 
Cache 
Entries 
for 
PMIP 
(10 
min) 
- 
Oliver
-Multiple 
interface 
support 
(10 
min) 
- 
Mohana
-Proxy 
Mobile 
IPv6 
indication 
and 
discovery 
(10 
min) 
- 
Basavaraj
And 
I'm 
pretty 
sure 
I 
forgot 
something 
(please 
remind 
me 
if 
I 
did).
The 
problem 
is 
that 
this 
does 
not 
really 
fit. 
We 
cannot 
have 
all 
of 
these
presentations 
and 
accomplish 
our 
main 
goal 
of 
the 
meeting. 
So, 
I 
think 
we
have 
to 
compress 
and 
rethink 
the 
presentations.
However, 
I 
see 
some 
patterns/groups 
(again 
the 
order 
is 
not 
of 
importance):
Interaction
-PMIP6-MIP4
-PMIP6-MIP6 
(presented 
in 
earlier 
meeting)
Multiple 
interface 
support/Multihoming
-Vijay
-Mohana
-Ahmad
-Marco?
Route 
Optimization
-Christian
-Ashutosh
Multiple 
COA 
Registration
-Ahmad
-Oliver
Others
-GRE 
keying 
(Ahmad)
-Heart 
Beat 
(Vijay)
-PMIP 
indication 
and 
discovery 
(Basavaraj)
Could 
we 
do 
some 
grouping 
here 
or 
cooperation 
to 
get 
the 
different 
problems
areas 
at 
least 
presented? 
In 
addition, 
I 
would 
think 
it 
would 
be 
good 
to 
get
the 
items 
presented 
that 
it 
seems 
our 
"customers" 
like 
3GPP, 
3GPP2, 
and
Wimax 
Forum 
expect 
us 
to 
get 
done. 
I 
think 
this 
is 
extremely 
important 
input
for 
the 
rechartering 
discussion.
Any 
ideas 
or 
suggestions?
Cheers,
Jonne.
PS. 
I 
think 
we 
will 
let 
only 
the 
people 
enter 
the 
meeting 
room 
who 
have
commented/reviewed 
the 
remaining 
WG 
items 
we 
have 
in 
the 
current 
charter...
;)
PS/2: 
Any 
volunteers 
for 
Jabber 
scribes 
and 
minute 
takers?