Subject: [netlmm] Shared link support for PMIPv6?

From: Julien Laganier <[email-masked]>
Date: Fri, 16 May 2008 16:18:45 +0200

Folks,

I'm wondering if it would make sense to include in the new WG charter a 
deliverable for PMIPv6 shared link support. What do people think?

Cheers,

--julien
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Fri, 16 May 2008 11:19:33 -0400

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Julien Laganier
> Sent: Friday, May 16, 2008 7:19 AM
> To: NETLMM Mailing List; [email-masked]
> Subject: [netlmm] Shared link support for PMIPv6?
> 
> Folks,
> 

I think we should.

Vijay

---

From: Frank Xia <[email-masked]>
Date: Fri, 16 May 2008 10:28:34 -0500

Hi Folks

IMHO, it is not necessary because there is no
requirement from the industry.

3GPP/3GPP2/WiMAX now only support p2p link model.

BR
Frank
  ----- Original Message ----- 
  From: Vijay Devarapalli 
  To: Julien Laganier ; NETLMM Mailing List ; [email-masked] 
  Sent: Friday, May 16, 2008 10:19 AM
  Subject: Re: [netlmm] Shared link support for PMIPv6?

  I think we should.

  Vijay

---

From: "Vijay Devarapallli" <[email-masked]>
Date: Fri, 16 May 2008 11:04:05 -0700

> 3GPP/3GPP2/WiMAX now only support p2p link model.

That is irrelevant.

Vijay

---

From: Frank Xia <[email-masked]>
Date: Fri, 16 May 2008 13:48:09 -0500

Hi Vijay

I DO think it is relevant.

When we talk about p2p link model PMIPv6 , IMO,
we are saying that home link is based on p2p link model.

From my understanding, 3GPP/3GPP2/WiMAX now only support p2p home link.

BR
Frank
  ----- Original Message ----- 
  From: Vijay Devarapallli 
  To: Frank Xia 
  Cc: Vijay Devarapalli ; Julien Laganier ; NETLMM Mailing List ; [email-masked] 
  Sent: Friday, May 16, 2008 1:04 PM
  Subject: Re: [netlmm] Shared link support for PMIPv6?

  That is irrelevant.

  Vijay

---

From: Basavaraj Patil <[email-masked]>
Date: Fri, 16 May 2008 17:18:18 -0500

In terms of prioritization, I think it is better to focus on drafts that
enhance the functionality of the current PMIP6 spec which is based on a P2P
link model.
And once there is some experience with implementations based on this (p2p
link) model of PMIP6, we could work on adding support for shared links. At
the present time I do not see a pressing need to work on this.

-Raj

---

From: <[email-masked]>
Date: Mon, 19 May 2008 09:26:09 +0200

Hi,

Yes, it makes sense; namely for WLAN use-cases.

Pierrick

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part
> de Julien Laganier
> Envoyé : vendredi 16 mai 2008 16:19
> À : NETLMM Mailing List; [email-masked]
> Objet : [netlmm] Shared link support for PMIPv6?
> 
> Folks,
>

---

From: Julien Laganier <[email-masked]>
Date: Mon, 19 May 2008 11:04:21 +0200

Frank,

> From my understanding, 3GPP/3GPP2/WiMAX now only support p2p home

While the fact that 3GPP/3GPP2/WiMAX endorse the technologies developed 
in the IETF is of course a good thing, IMO the IETF shouldn't limit 
itself to developing technologies for 3GPP/3GPP2/WiMAX.

There are some quite popular shared link technologies out there, e.g. 
IEEE 802.11.

--julien

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 19 May 2008 12:13:46 +0200

Julien Laganier wrote:
>> When we talk about p2p link model PMIPv6 , IMO, we are saying that
>> home link is based on p2p link model.
>> 
> While the fact that 3GPP/3GPP2/WiMAX endorse the technologies
> developed in the IETF is of course a good thing, IMO the IETF
> shouldn't limit itself to developing technologies for
> 3GPP/3GPP2/WiMAX.

I agree.

> There are some quite popular shared link technologies out there, e.g.

The generic question I had is whether a scenario of movement from one
WiFi-enabled subnet to another, while keeping an ongoing communication
up, has been felt as necessary somewhere.

A deployment like IETF meeting does have overlapping hotspots but: (1)
maybe all hotspots are in one subnet? (2) anybody ever complained s/he's
not given same address?

What are the scenarios?  The applications?

Alex

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: <[email-masked]>
Date: Mon, 19 May 2008 12:21:29 +0200

Hi Alex,

Please see comments inline.

Pierrick

> de Alexandru Petrescu
> Envoyé : lundi 19 mai 2008 12:14
> À : Julien Laganier
> Cc : [email-masked]
> Objet : Re: [netlmm] Shared link support for PMIPv6?
> 
> Julien Laganier wrote:
> > Frank,
> >

Inter-system mobility involving WLAN, e.g From WLAN to 3GPP, is a realistic scenario, IMHO.

---

From: Ryuji Wakikawa <[email-masked]>
Date: Mon, 19 May 2008 19:22:43 +0900

Hi Alex,

> What are the scenarios?  The applications?

A mobile node can roam between WiFI to WiMAX. Then the shared-link  
support might be required for WiFI.

ryuji

---

From: Ryuji Wakikawa <[email-masked]>
Date: Mon, 19 May 2008 19:25:43 +0900

Hello Pierrick

> realistic scenario, IMHO.

Right. I just sent the same message to Alex;-)

ryuji

---

From: Christian Vogt <[email-masked]>
Date: Mon, 19 May 2008 13:35:25 +0300

> deliverable for PMIPv6 shared link support. What do people think?

I support this.  Shared links are needed for P-MIPv6 to
support multi-access scenarios, such as residential WLAN
networks complementing 3GPP connectivity.

- Christian

---

From: Ashutosh Dutta <[email-masked]>
Date: Mon, 19 May 2008 06:48:54 -0400

From some preliminary experiments that we have conducted in the lab 
involving handoff between WiFi networks with PMIPv6, we have found that 
there are few problems that need to be addressed in order to support 
handoff between shared links.

Thus, I also agree that at some point it would be useful to look into 
supporting handoff between shared links (e.g., WiFi-WiFi, between 
multi-access networks where one of the networks (non-3GPP) may have 
shared link access).

Thanks
Ashutosh

---

From: "Premec, Domagoj" <[email-masked]>
Date: Mon, 19 May 2008 14:56:09 +0200

Hi,

> is a realistic scenario, IMHO.

It is possible to run PMIP in a WLAN enviroment with a per-MN prefix model, it is not that PMIP will not work unless there is a shared prefix model. 

Handover from the shared prefix to the per-MN prefix will probably be more of a problem then running per-MS prefix in a WLAN.

domagoj

> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: 19. svibanj 2008 12:21
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> > De : [email-masked] [mailto:[email-masked]] De la 
> > part de Alexandru Petrescu Envoyé : lundi 19 mai 2008 12:14 
> À : Julien 
> > Laganier Cc : [email-masked] Objet : Re: [netlmm] Shared 
> link support 
> > for PMIPv6?
> > 
> > Julien Laganier wrote:
> > > Frank,
> > >
> > >> From my understanding, 3GPP/3GPP2/WiMAX now only support 
> p2p home 
> > >> link.
> > >
> > maybe all hotspots are in one subnet? (2) anybody ever complained 
> > s/he's not given same address?
> >

---

From: Julien Laganier <[email-masked]>
Date: Mon, 19 May 2008 15:21:53 +0200

On Monday 19 May 2008, Premec, Domagoj wrote:
> It is possible to run PMIP in a WLAN enviroment with a per-MN prefix
> model, it is not that PMIP will not work unless there is a shared
> prefix model.

Domagoj,

Earlier the WG spent a huge amount of time discussing whether it was 
possible to implement per-MN prefix model on a shared link. I've been 
saying it's possible, others disagree with me, and we couldn't reach a 
conclusion. Now if the WG decides to work on that, I think we should do 
the engineering work to see how that would work since it's not that 
obvious.

Cheers,

--julien

---

From: Frank Xia <[email-masked]>
Date: Mon, 19 May 2008 09:22:35 -0500

Hi Julien

I am not against this work, but
I am just wondering if  it is the 
proper time.

BR
Frank

  ----- Original Message ----- 
  From: Julien Laganier 
  To: [email-masked] 
  Cc: Frank Xia ; Vijay Devarapallli ; [email-masked] 
  Sent: Monday, May 19, 2008 4:04 AM
  Subject: Re: [netlmm] Shared link support for PMIPv6?

  Frank,

  --julien

---

From: "Premec, Domagoj" <[email-masked]>
Date: Mon, 19 May 2008 17:18:12 +0200

Julien,

So we should probably differentiate between:

- making the per-MN PMIP6 mode work on a shared link
- and support for shared prefix in PMIP6 

If the handover between WLAN and WiMAX/3GPP is of concern, we should probably focus on per-MN prefix support in WLAN. It seems to me that IP session continuity can not be provided when switching between the per-MN and the shared prefix.

domagoj

> From: julien laganier [mailto:[email-masked]] On 
> Behalf Of Julien Laganier
> Sent: 19. svibanj 2008 15:22
> To: Premec, Domagoj
> Cc: [email-masked]; 
> [email-masked]; [email-masked]
> Earlier the WG spent a huge amount of time discussing whether 
> it was possible to implement per-MN prefix model on a shared 
> link. I've been saying it's possible, others disagree with 
> me, and we couldn't reach a conclusion. Now if the WG decides 
> to work on that, I think we should do the engineering work to 
> see how that would work since it's not that obvious.
> 
> Cheers,
> 
> --julien
>

---

From: Julien Laganier <[email-masked]>
Date: Mon, 19 May 2008 17:57:05 +0200

Domagoj,

Not confusing different things is of course better :)

I was specifically asking whether we want to work on making PMIPv6 work 
on a shared *link*.

Session continuity between shared link and PtP links presuppose that 
we're switching interfaces, which is explicitly ruled out as per our 
current charter: "The protocol will not attempt to hide handover 
between two separate interfaces on the mobile node."

Thus, under the assumption that we're not hiding handover between two 
separate interfaces, we do not provide session continuity between 
shared and PtP links. We can thus assume that there's a single shared 
link layer technology in a given PMIPv6 domain, and in that case 
deciding now between shared prefix vs. per-MN prefix is pretty much 
entering solution space. 

That being said, I agree with you that if we do want to take session 
continuity in the picture, it is very likely that only the per-MN 
prefix is viable. But that would require that we revisit the fact 
that "The protocol will not attempt to hide handover 
between two separate interfaces on the mobile node."

So maybe first we have to discuss whether we want to hide handover 
between two separate interfaces on the mobile node, and then, in 
conjunction with that, whether we want to support shared link.

--julien

On Monday 19 May 2008, Premec, Domagoj wrote:
> If the handover between WLAN and WiMAX/3GPP is of concern, we should
> probably focus on per-MN prefix support in WLAN. It seems to me that
> IP session continuity can not be provided when switching between the
> per-MN and the shared prefix.
>
> domagoj
>
> > > It is possible to run PMIP in a WLAN enviroment with a
> >
> > per-MN prefix
> >

---

From: "Premec, Domagoj" <[email-masked]>
Date: Tue, 20 May 2008 14:30:58 +0200

Julien,

Should we also discuss inter-access handover as part of re-chartering?

It seems that there is some interest for such work, several postings mention handover between WLAN/3GPP/WiMAX. Both 3GPP and WiMAX decided to use PMIP6 for inter-access mobility.

While the baseline PMIP6 spec does provide some support for inter-access handover, I'm not convinced that this is enough and IMO a more detailed description of how inter-access handover in netlmm domain works is needed.

regards
domagoj

> Sent: 19. svibanj 2008 17:57
> To: Premec, Domagoj
> I was specifically asking whether we want to work on making 
> PMIPv6 work on a shared *link*.
> 
> Session continuity between shared link and PtP links 
> presuppose that we're switching interfaces, which is 
> explicitly ruled out as per our current charter: "The 
> protocol will not attempt to hide handover between two 
> separate interfaces on the mobile node."
> 
> Thus, under the assumption that we're not hiding handover 
> between two separate interfaces, we do not provide session 
> continuity between shared and PtP links. We can thus assume 
> that there's a single shared link layer technology in a given 
> PMIPv6 domain, and in that case deciding now between shared 
> prefix vs. per-MN prefix is pretty much entering solution space. 
> 
> That being said, I agree with you that if we do want to take 
> session continuity in the picture, it is very likely that 
> only the per-MN prefix is viable. But that would require that 
> we revisit the fact that "The protocol will not attempt to 
> hide handover between two separate interfaces on the mobile node."
> 
> So maybe first we have to discuss whether we want to hide 
> handover between two separate interfaces on the mobile node, 
> and then, in conjunction with that, whether we want to 
> support shared link.
> 
> --julien
> 
> > > From: julien laganier [mailto:[email-masked]] 
> On Behalf 
> > > Of Julien Laganier
> > > > > Inter-system mobility involving WLAN, e.g From WLAN 
> to 3GPP, is 
> > > > > a realistic scenario, IMHO.
> > > >
> > > possible to implement per-MN prefix model on a shared link. I've 
> > > been saying it's possible, others disagree with me, and 
> we couldn't 
> > > reach a conclusion. Now if the WG decides to work on 
> that, I think 
> > > we should do the engineering work to see how that would 
> work since 
> > > it's not that obvious.
> > >
> > > Cheers,
> > >
> > > --julien
> 
> 
>

---

From: Julien Laganier <[email-masked]>
Date: Tue, 20 May 2008 14:42:18 +0200

Domagoj,

> Should we also discuss inter-access handover as part of

Yes, this is what I had in mind. 

So there's two things we can consider adding to the charter:

- support for inter-access handover (with service continuity)
- support for shared link

--julien

---

From: Frank Xia <[email-masked]>
Date: Tue, 20 May 2008 09:20:26 -0500

Hi Julien

As to support for inter-access handover, I think
it is better to  differentiate it from MIPSHOP 
proposed charter item.

In MIPSHOP proposed charter, the following text read
"4. Use of FMIPv6 with Proxy Mobile IPv6
    Proxy Mobile IPv6 (PMIPv6) is a network-based mobility
    management protocol where a node in the access network, called
    the Mobile Access Gateway (MAG) handles mobility on behalf of
    the mobile node.  It has been proposed to use FMIPv6 to
    optimize the handover in terms of reducing the packet loss and
    transferring relevant context from the old MAG to the new MAG.
    The working group will work on specifying FMIPv6 extensions to
    enable fast handovers for PMIPv6."

BR
Frank
  ----- Original Message ----- 
  From: Julien Laganier 
  To: Premec, Domagoj 
  Cc: [email-masked] 
  Sent: Tuesday, May 20, 2008 7:42 AM
  Subject: [netlmm] Inter access HO and/or shared link support (Was: Shared link support for PMIPv6?)

  Domagoj,

  --julien

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 20 May 2008 13:18:15 -0400

Its already been proposed as part of the chain of emails with the
subject "The way forward as discussed...." after the last IETF meeting.

I haven't seen a followup from Jonne (after the initial mail on March
15) on what the next steps are with respect to re-chartering.

Vijay 

> Sent: Tuesday, May 20, 2008 5:42 AM
> To: Premec, Domagoj
> Cc: [email-masked]
> Subject: [netlmm] Inter access HO and/or shared link support 
> (Was: Sharedlink support for PMIPv6?)
> 
> Domagoj,
>

---

From: Frank Xia <[email-masked]>
Date: Tue, 20 May 2008 10:05:20 -0500

Hi Julien

If you read the corresponding draft,
you will find the "FMIPv6 together 
with PMIPv6" is explicitely
for inter-access handovers.

BR
Frank
  ----- Original Message ----- 
  From: Julien Laganier 
  To: Frank Xia 
  Cc: Premec, Domagoj ; [email-masked] 
  Sent: Tuesday, May 20, 2008 9:32 AM
  Subject: Re: inter-access handover

  Hi Frank,

  To me there's no confusion. 

  What we've been discussing here in NETLMM is how to handle inter-access 
  handover with PMIPv6, which is currently unspecified.

  The proposed MIPSHOP charter item below talk about using FMIPv6 together 
  with PMIPv6, which does not imply inter-access handovers for PMIPv6 are 
  supported. 

  The two things might be combined, and in case both WGs decide to carry 
  on with the new charter items, care should be taken so that they work 
  together, i.e. it is possible to use the FMIPv6 for PMIPv6 while doing 
  inter-access handover.

  Cheers,

  --julien

---

From: Julien Laganier <[email-masked]>
Date: Tue, 20 May 2008 16:32:37 +0200

Hi Frank,

Cheers,

--julien

---

From: <[email-masked]>
Date: Wed, 21 May 2008 10:25:46 +0200

Hi Frank,
 
IMHO, before thinking about "FMIP together with PMIP", we should think about PMIP alone. So, Julien's topics really make sense (especially for operators). I think it is worth adding both inter-access handover and support for shared links to the charter since it reflects realistic use-cases.
 
Regards,
Pierrick

________________________________

De : [email-masked] [mailto:[email-masked]] De la part de Frank Xia
Envoyé : mardi 20 mai 2008 17:05
À : Julien Laganier
Cc : [email-masked]
Objet : Re: [netlmm] inter-access handover
 
Hi Julien

BR
Frank
	----- Original Message ----- 
	From: Julien Laganier <mailto:[email-masked]>  
	To: Frank Xia <mailto:[email-masked]>  
	Cc: Premec, Domagoj <mailto:[email-masked]>  ; [email-masked] 
	Sent: Tuesday, May 20, 2008 9:32 AM
	Subject: Re: inter-access handover
	 
	Hi Frank,

	

	Cheers,
	
	--julien

---

From: Niklas Neumann <[email-masked]>
Date: Wed, 21 May 2008 17:23:54 +0200

Hello Pierrick,

from what I understand, PMIP has the following characteristics that 
distinguishes it from other approaches:

1) It is link layer agnostic and
2) it doesn't require any support from the MN except plain IP(v6).

Imo those are two important points that should not be given up. Under 
this prerequisite do you think it is possible to provide inter-access 
handovers?

Similarly for the question of inter-interface handovers: Without support 
from the MN (e.g. in form of an indication when an inter-interface 
handover instead of a 2nd point of attachment (multi-homing) is wanted) 
does it make sense to change the current approach to treat different 
interfaces as different PoAs?

Or did I misunderstand you and you didn't want to change the PMIP draft 
but just specify some additional functions? This, however, would bring 
us back to the question why not to think about "FMIP together with PMIP"?

Regards,
   Niklas

[email-masked] wrote:
> Hi Frank,
> 
>  
> 
> IMHO, before thinking about "FMIP together with PMIP", we should think 
> about PMIP alone. So, Julien's topics really make sense (especially for 
> operators). I think it is worth adding both inter-access handover and 
> support for shared links to the charter since it reflects realistic 
> use-cases.
> 
>  
> 
> Regards,
> 
> Pierrick
> 
>  
> 
>  
> 
>  
> 
> ------------------------------------------------------------------------
> 
> *De :* [email-masked] [mailto:[email-masked]] *De la 
> part de* Frank Xia
> *Envoyé :* mardi 20 mai 2008 17:05
> *À :* Julien Laganier
> *Cc :* [email-masked]
> *Objet :* Re: [netlmm] inter-access handover
> 
>  
> 
> Hi Julien
> 
>  
> 
>     *From:* Julien Laganier <mailto:[email-masked]>
> 
>     *To:* Frank Xia <mailto:[email-masked]>
> 
>     *Cc:* Premec, Domagoj <mailto:[email-masked]> ;
>     [email-masked] <mailto:[email-masked]>
> 
>     *Sent:* Tuesday, May 20, 2008 9:32 AM
> 
>     *Subject:* Re: inter-access handover
> 
>      
> 
>     Hi Frank,
> 
>     >   Cc: [email-masked] <mailto:[email-masked]>
>     >   [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
> 

-- 
Niklas Neumann - University of Goettingen, Institute of Informatics
http://user.informatik.uni-goettingen.de/~nneuman1/
Tel: +49 551 39-14419
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Marco Liebsch <[email-masked]>
Date: Wed, 21 May 2008 17:54:39 +0200

> - support for inter-access handover (with service continuity)
I support this and refer again to existing drafts about appropriate
extensions to PMIPv6 that have been submitted to NetLMM so far.

> - support for shared link
Here I am not sure if we run into the same issues as we tried to solve some
time ago until PMIPv6 technical scope has been limited to p2p links and
individual HNPs. According to what I understand from chairs, the charter
being discussed first should comprise work items for the next 12 months
(well, that was in March..). Any other work that has no high priority and
may take longer to specify, may be in scope of a subsequent step. I
see a PMIPv6-specific solution on inter-tech handover definitely in
scope of the 12 months charter, as there is solid work on solutions
available. Shared-link and/or shared prefix support maybe not.

marco

---

From: Julien Laganier <[email-masked]>
Date: Wed, 21 May 2008 18:07:26 +0200

Hello Marco,

On Wednesday 21 May 2008, Marco Liebsch wrote:
> Here I am not sure if we run into the same issues as we tried to
> solve some time ago until PMIPv6 technical scope has been limited to
> p2p links and individual HNPs. According to what I understand from
> chairs, the charter being discussed first should comprise work items
> for the next 12 months (well, that was in March..). Any other work
> that has no high priority and may take longer to specify, may be in
> scope of a subsequent step. I see a PMIPv6-specific solution on
> inter-tech handover definitely in scope of the 12 months charter, as
> there is solid work on solutions available. Shared-link and/or shared
> prefix support maybe not.

Shared link support as been quite debated earlier on the mailing list, 
and an earlier version of the MN-AR draft actually had a solution to 
implement per-MN prefix on a shared link (by sending unicast RAs to MNs 
containing PIO with L bit (on-link) reset).

As to the priority of these two items, as of now, and to my 
understanding, we have not yet any "customer" for inter-access HO, 
while the shared link support would be required to accommodate 
PMIPv6-based trusted non-3GPP accesses from shared link layer such as 
IEEE 802.11.

Thus, it's not so clear to me whether inter-access HO has a higher 
priority than shared link support. Note that I'm not claiming it should 
have lower priority.

Cheers,

--julien

---

From: <[email-masked]>
Date: Wed, 21 May 2008 18:23:42 +0200

> De : Niklas Neumann [mailto:[email-masked]]
> Envoyé : mercredi 21 mai 2008 17:24
> À : SEITE Pierrick RD-RESA-REN
> Cc : [email-masked]
> but just specify some additional functions? 

I didn't ask for modification to PMIP draft, I just said that I support "inter-tech handover" (note that some drafts already address the issue) and "support for shared link". 

This, however, would bring
> us back to the question why not to think about "FMIP together with PMIP"?

Yes, why not. But I think we should first consider solution with PMIP alone,  possibly with appropriate extension like in draft-liebsch-netlmm-intertech-proxymip6ho.

Hope that clarifies,
Regards,
Pierrick
> (Was:
> >     >  Shared link support for PMIPv6?)
> >     >
> >     >
> >     >   Domagoj,
> >     >

---

From: "BLUME, Oliver" <[email-masked]>
Date: Wed, 21 May 2008 18:25:59 +0200

Hello Julien,

To my understanding 3GPP is not requiring PMIP for intra-technology handover (that is done by LTE, WIMAX or UMTS specific L2 mobility), but wants to deploy PMIP for the integration of these technologies in an SAE-architecture. Typical 3GPP usecase of PMIP would be for LTE-WIMAX-HO or LTE-HRPD-HO or even WIMAX-WLAN-HO. Furthermore, 3GPP is assuming dual radio handover between access technologies.

Doesn't that count as a customer requesting PMIP inter-tech support ?

Best regards,

Oliver

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Julien Laganier
Gesendet: Mittwoch, 21. Mai 2008 18:07
An: [email-masked]
Betreff: Re: [netlmm] Inter access HO and/or shared link support (Was:Shared link support for PMIPv6?)

Hello Marco,

On Wednesday 21 May 2008, Marco Liebsch wrote:
> Here I am not sure if we run into the same issues as we tried to solve 
> some time ago until PMIPv6 technical scope has been limited to p2p 
> links and individual HNPs. According to what I understand from chairs, 
> the charter being discussed first should comprise work items for the 
> next 12 months (well, that was in March..). Any other work that has no 
> high priority and may take longer to specify, may be in scope of a 
> subsequent step. I see a PMIPv6-specific solution on inter-tech 
> handover definitely in scope of the 12 months charter, as there is 
> solid work on solutions available. Shared-link and/or shared prefix 
> support maybe not.

Shared link support as been quite debated earlier on the mailing list, and an earlier version of the MN-AR draft actually had a solution to implement per-MN prefix on a shared link (by sending unicast RAs to MNs containing PIO with L bit (on-link) reset).

As to the priority of these two items, as of now, and to my understanding, we have not yet any "customer" for inter-access HO, while the shared link support would be required to accommodate PMIPv6-based trusted non-3GPP accesses from shared link layer such as IEEE 802.11.

Thus, it's not so clear to me whether inter-access HO has a higher priority than shared link support. Note that I'm not claiming it should have lower priority.

Cheers,

--julien

---

From: "Vijay Devarapallli" <[email-masked]>
Date: Wed, 21 May 2008 10:55:14 -0700

Hello Marco, Julien and all,

We are mixing up inter-access technology handovers using PMIPv6 with
optimizations to PMIPv6 handovers. The handover optimization
mechanisms would be applicable to both intra and inter access
technology handovers.

Both have already been proposed in response to Jonne's email on the
"Way Forward".

Vijay

---

From: Julien Laganier <[email-masked]>
Date: Fri, 30 May 2008 18:22:17 +0200

Hi Oliver,

 On Wednesday 21 May 2008, BLUME, Oliver wrote:
> Hello Julien,
>
> To my understanding 3GPP is not requiring PMIP for intra-technology
> handover (that is done by LTE, WIMAX or UMTS specific L2 mobility),
> but wants to deploy PMIP for the integration of these technologies in
> an SAE-architecture. Typical 3GPP usecase of PMIP would be for
> LTE-WIMAX-HO or LTE-HRPD-HO or even WIMAX-WLAN-HO. Furthermore, 3GPP
> is assuming dual radio handover between access technologies.

PMIPv6 is used for intra-LTE handover in Rel-8 EPS.

> Doesn't that count as a customer requesting PMIP inter-tech support ?

Yes and no. The various 3GPP/3GPP2/WiMax HO entails complex coordination 
between very different network architectures. The PMIP support for 
inter-tech HO would thus only be one piece of the larger picture. Thus 
it might well be that they choose to design the entire inter-tech HO 
themselves. Or not.
 
Bottom line: I don't want to launch a debate on what has highest 
priority. I agree that prioritization is important in project 
management, but one needs to know the relative priorities to do that.

It's not too clear to me what are the priorities of these work items, 
and since we have people interested to work on both of these, my 
opinion is that we can just work on both in this WG.

--julien

---

From: "Chowdhury, Kuntal" <[email-masked]>
Date: Fri, 30 May 2008 15:18:50 -0400

PMIP6 is also used for inter-tech handover in 3GPP. Ref: single radio
LTE - HRPD optimized handover specs.

-Kuntal

> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Julien Laganier
> Sent: Friday, May 30, 2008 11:22 AM
> To: [email-masked]
> Cc: BLUME, Oliver
> Subject: Re: [netlmm] Inter access HO and/or shared link support
> (Was:Sharedlink support for PMIPv6?)
> 
> Hi Oliver,
>