Subject: [netlmm] Question on draft-ietf-netlmm-pmip6-ipv4-support-04.txt

From: "Desire Oulai" <[email-masked]>
Date: Tue, 15 Jul 2008 16:05:37 -0400

Hi, 

  In section 3.4.2, I think that the PBU/PBA exchange must take place
after the MAG receives the DHCPACK because at this point, the MAG will
be able to include a reserved IPv4 HoA in the PBU that will be checked
by the LMA. May be you can be more precise than saying PBU/PBA and DHCP
message exchange are processed in parallel ? 
Regards
Desire

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 15 Jul 2008 14:07:26 -0700 (PDT)

Hi Desire,

> message exchange are processed in parallel ?

Agree. These are independent operations. The MAG may trigger PMIP
signaling right after the access authentication and the DHCP
DISCOVER event may happen any time during or after the PMIP signaling.
We can add a note related to this.

Thanks
Sri

---

From: "Desire Oulai" <[email-masked]>
Date: Tue, 15 Jul 2008 18:45:05 -0400

Hi Sri,

 I understand better. I have a questions though:

In the same section 3.4.2, it is mentioned 
   o  When the mobile access gateway receives the DHCPOFFER from the
      DHCP server, it MUST verify whether the DHCP server offers the
      correct IPv4 home address which is indicated in the Agent Remote
      ID Sub-option of the DHCPDISOCVERY.  If the DHCP server offers the
      different address from the expected address, the mobile access
      gateway MUST drop the DHCPOFFER.  

  In the case the proposed address in the DHCPOFFER differs, should the MAG abort the PMIP session or continue even if the DHCP server does not acknowledge the IPv4 address (which may be a potential address conflict)?

Regards 

Désiré

> -----Original Message-----
> From: Sri Gundavelli [mailto:[email-masked]] 
> Sent: July 15, 2008 5:07 PM
> To: Desire Oulai
> Cc: [email-masked]
> Subject: Re: [netlmm] Question on 
> draft-ietf-netlmm-pmip6-ipv4-support-04.txt
> 
> Hi Desire,
> 
> 
> > by the LMA. May be you can be more precise than saying PBU/PBA and 
> > DHCP message exchange are processed in parallel ?
> > Regards
> 
> 
> Agree. These are independent operations. The MAG may trigger 
> PMIP signaling right after the access authentication and the 
> DHCP DISCOVER event may happen any time during or after the 
> PMIP signaling.

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 15 Jul 2008 15:50:35 -0700 (PDT)

Hi Desire,

>  In the case the proposed address in the DHCPOFFER differs, should the MAG abort the PMIP session or continue even if the DHCP server does not acknowledge the IPv4 address (which may be a potential…

MAG should abort the PMIP session as it cannot offer mobility to that
address. It can probably re-register and request the offered address.
Will clarify this error case.

Thanks
Sri