Subject: [netlmm] Timestamp Option for Message Ordering

From: Sandesh <[email-masked]>
Date: Tue, 29 Jul 2008 17:29:37 +0530

Hi All,

I am proposing a solution for the problem which
section '5.5 Timestamp Option for Message Ordering'
of draft-ietf-netlmm-proxymip6-18.txt intends to solve.
Please ignore this mail if this approach has been discussed earlier.

IMO problem can be defined as following -
------------------------------------------
When LMA has received two or more PBU message for binding lifetime extension
from two or more MAGs (and has not received PBUs from with lifetime = 0
indicating MN detachment from all except one) then (in the absence of sequence
number and timestamp) how can it be find out which MAG the MN is
actually connected to.

SOLUTION
------------------------------------------
In this solution a new trigger type in BRI (from LMA to MAG) is added which
indicate 'PBU Registration Confusion'.

MAG Procedures -
MAG PROCEDURE 1. MAG retransmits PBU if matching PBA is not received before
  retransmission timeout. If MN is attached to MAG it keeps on
retransmitting PBU
  until it receives matching PBA. If MN detaches from MAG it
retransmits PBU with
  lifetime = 0 a number of times (N).
MAG PROCEDURE 2. MAG sends PBU again if it receives BRI (Trigger = PBU
Registration Confusion).
  And after that it does PBU retransmissions as per MAG PROCEDURE 1.

LMA procedures -
LMA CASE 1: LMA received two or more PBUs (with lifetime !=0) and it has not
sent PBA to any of the MAGs.
It does not send PBA to any MAG. Soon it will receive the PBUs
with lifetime = 0 from MAGs from which MN has detached and PBU(lifetime !=0)
retransmission from MAG to which MN is actually attached.
MN is considered to be attached to a MAG if and only all MAGs except one sends
PBUs(lifetime = 0) and that one MAG sends PBU (lifetime !=0).
A max timer can be defined to declare that MN is not attached to the MAG if no
PBUs are received from a MAG (which first sent PBU with lifetime !=0) for
that max timer duration.
After the decision has been taken about which MAG an MN is attached to PBAs
(status =0) are sent to all the MAGs.

LMA CASE 2: LMA received two or more PBUs (with lifetime !=0) and it has
sent PBA (Status = 0) to one of the MAGs.
LMA send BRI(Trigger = PBU Registration Confusion) to the MAG to which
it has sent
PBA (Status = 0). After that LMA follows the procedure defined in Case

Sequence number in PBU can be considered per MAG and can be used to drop
old/duplicate PBUs from the same MAG.

Disadvantage of this approach is that it will take little longer to declare
which MAG a MN is attached to.

Advantages of this solution are -
- MAG need not send timestamp to LMA in PBUs
- MAG need not sync sequence number with other MAGs.

Thanks and Regards,
Sandesh
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 29 Jul 2008 05:14:18 -0700 (PDT)

Sandesh,

The issue is bit more complex. Sending  a revocation message
is not suffcient. Note that the Seq Number scheme will work
much better in the presence of inter-MAG CT. Any case, you
can always write a I-D on other approaches for solving the
BU ordering issue and bring this to discussion. Also, please
see the (to be) WG draft on PMIP/MIP coexistence draft, it
addresses the related scenario.

Thanks
Sri

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 29 Jul 2008 09:06:03 -0400

Sandesh,

> IMO problem can be defined as following -

One of the approaches, the timestamp or the sequence number is always
used. So we don't have a scenario where neither are present. 

Vijay

>   retransmitting PBU until it receives matching PBA. If MN detaches
>   from MAG it retransmits PBU with lifetime = 0 a number of times (N).
> MAG PROCEDURE 2. MAG sends PBU again if it receives BRI (Trigger =
>   PBU Registration Confusion). And after that it does PBU
> retransmissions as per MAG PROCEDURE 1. 
> 
> LMA procedures -
> with lifetime = 0 from MAGs from which MN has detached and
> PBU(lifetime !=0) retransmission from MAG to which MN is actually
> attached. 
> LMA send BRI(Trigger = PBU Registration Confusion) to the MAG to
> which it has sent PBA (Status = 0). After that LMA follows the
> procedure defined in Case 
>

---

From: Sandesh <[email-masked]>
Date: Tue, 29 Jul 2008 18:59:08 +0530

Hi Vijay,

I am proposing an alternate solution to the issue which timestamp or
sequence number (sent in PBU after sequence number sync between MAGs )
are trying to solve.
In other words this solution intends to remove the need of timestamp
and sequence number sync between MAGs.

Thanks and Regards,
Sandesh

-- 
Ph: +91-9341784637