Subject: Re: [netlmm] About Public IPv4 Address address in draft-ietf-netlmm-pmip6-ipv4-support-03

From: Sri Gundavelli <[email-masked]>
Date: Wed, 9 Jul 2008 21:21:27 -0700 (PDT)

Hi Xiaoyan,

The IPv4 address that the LMA allocates can be an globally
routable address or a private IPv4 address. And this has
no bearing on the what type of addresses the MAG is using,
i.e., if it is behind a NAT or not, as the traffic from
the mobile node is always tunneled and so the private
topology is hidden. So, this address can be a private or
a public address. But, if the LMA is deployed for hosted
models, potentially multiple MN's using same private IPv4
HoA, then this requires GRE key support, that is the other
draft in the WG.

Sri

On Thu, 10 Jul 2008, Shi Xiaoyan wrote:

> Hi Sri,
>
> I have doubts about whether a public address for IPv4-MN-HoA is necessary.
>
> Public address is uesed to avoid the IP address conflict between MN and MAG.
> But there has been a long discussion on mail list in the past. It seems that
> IPv4 Default Router Address Option could be utilized to this issue.
>
> Is it still necessary that assign public IPv4 address for MN-HoA?
>
>
> Regards,
> Xiaoyan
>
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Basavaraj Patil <[email-masked]>
Date: Wed, 09 Jul 2008 23:26:23 -0500

Sri,

Is there really a need to support MAG or LMA being located behind a NAT?
Do you expect the LMAA or the Proxy-COA to be private IPv4 addresses? Or can
we suggest that these addresses be globally routable?

-Raj

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 9 Jul 2008 21:38:15 -0700 (PDT)

Hi Raj,

We dont support LMA behind NAT. But, MAG behind a NAT is
a reasonable assumption. We cannot have restrictions on
network topologies. It is possible a given access network
is behind a NAT. This does not exactly reflect the affordability
of an operator for an IPv4 public address. We have to be bit
more open on where a MAG function can get deployed in future. Its
just a flexibility. But, I do agree, in most cases its a public
address.

Sri

---

From: Basavaraj Patil <[email-masked]>
Date: Wed, 09 Jul 2008 23:47:07 -0500

Hi Sri,

Okay... I guess it is possible to have MAG functionality in access routers
that only have private addresses. It does make things a bit more complex.
Maybe you can just recommend that the Proxy-CoA be assigned a globally
routable address when possible.

-Raj

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 10 Jul 2008 01:38:03 -0700 (PDT)

Hi Raj,

> routable address when possible.

Sure, that is the recommended configuration,  makes sense.

Regards
Sri

---

From: Shi Xiaoyan <[email-masked]>
Date: Thu, 10 Jul 2008 12:06:26 +0800

Hi Sri,

 

Regards,
Xiaoyan

---

From: Shi Xiaoyan <[email-masked]>
Date: Thu, 10 Jul 2008 17:51:44 +0800

Hi Sri,

As you said, MN could be assigned a private IPv4 address. But there is a
little inconsistent subscription in Section 3. Should the following
description be deleted in next version?

 [RYUJI The IPv4 home address MUST be the global IPv4
   address.  A private IPv4 address assignment as an IPv4 home address
   is prohibited.  There is no gurantee to assign the IPv4 private home
   address which is different from the private address configured at a
   mobile access gateway.]

Regards,
Xiaoyan

> -----Original Message-----
> From: Sri Gundavelli [mailto:[email-masked]] 
> Sent: Thursday, July 10, 2008 12:21 PM
> To: Shi Xiaoyan
> Cc: [email-masked]
> Subject: Re: About Public IPv4 Address address in 
> draft-ietf-netlmm-pmip6-ipv4-support-03
> 
> Hi Xiaoyan,
> 
> routable address or a private IPv4 address. And this has no 
> bearing on the what type of addresses the MAG is using, i.e., 
> if it is behind a NAT or not, as the traffic from the mobile 
> node is always tunneled and so the private topology is 
> hidden. So, this address can be a private or a public 
> address. But, if the LMA is deployed for hosted models, 
> potentially multiple MN's using same private IPv4 HoA, then 
> this requires GRE key support, that is the other draft in the WG.
> 
> Sri
> 
>