Subject: Re: [netlmm] Some questions fordraft-ietf-netlmm-pmip6-ipv4-support-03

From: Behcet Sarikaya <[email-masked]>
Date: Sun, 6 Jul 2008 12:53:22 -0700 (PDT)

I am OK if Dave Thaler is OK 
Besides, I don't think this document should specify IPv4 addressing model. The base document does specify it for IPv6 which is needed.

----- Original Message ----
From: Vijay Devarapalli <[email-masked]>
To: Sri Gundavelli <[email-masked]>; Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Thursday, July 3, 2008 3:09:28 PM
Subject: RE: [netlmm] Some questions fordraft-ietf-netlmm-pmip6-ipv4-support-03

> We dont have the luxury to alloate a unique prefix for each mobile
> node. That multiplies the address space requirement by 4 times.

[behcet] There are solutions for this technical problem, I discussed this once with Dave, based on the use of private address space.

> 4903 recommendation is primarily for IPv6. All though some of
> the issues are applicable to IPv4, we cannot go the extreme of
> allocating a prefix for each node. This is inline with 3344,
> 3344bis or DSMIP6.

Agree.

Vijay

Regards,

Behcet
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Soininen Jonne (NSN FI/Espoo)" <[email-masked]>
Date: Tue, 08 Jul 2008 17:40:55 +0300

Hi,

IPv6 and IPv4 work a bit differently when it comes to addressing. You don't
generally talk in IPv4 about "prefixes", but you talk about single
addresses. In v4, it is ok to allocate a single address, and this is usually
the case (you usually don't really get a subnet from your ISP, but a single
address). 

In addition, in IPv4 a link can have just one IPv4 address (like in the case
of PPP or PPPoE/A). The hosts don't generate more addresses themselves, etc.
IPv4 is just different from IPv6 in this regard.

IMHO, the document should not talk about anything of IPv4 "prefixes" - in
IPv4 you don't often talk about prefixes, but subnets.

For the IPv4 case, a single address per MN is enough.

Cheers,

Jonne.
On 7/6/08 10:53 PM, "ext Behcet Sarikaya" <[email-masked]> wrote:

> Besides, I don't think this document should specify IPv4 addressing model. The
> base document does specify it for IPv6 which is needed.
> 
> 
> 
> Subject: RE: [netlmm] Some questions
> fordraft-ietf-netlmm-pmip6-ipv4-support-03
> 
> [behcet] There are solutions for this technical problem, I discussed this once
> with Dave, based on the use of private address space.
> 

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34
E-mail: [email-masked]

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 9 Jul 2008 08:03:37 -0700 (PDT)

Hi Jonne,

> IPv4 you don't often talk about prefixes, but subnets.

This makes sense, to keep the terminology correct. I agree.

> For the IPv4 case, a single address per MN is enough.

We dont have an explicit restriction for this. Based on the address
configuration modes supported on the access link, this can be different,
such as in case of IKEv2, where multiple IPv4 addresses can be delivered
as part of the configuration payload. And also there is the 3GPP case
of potentially more than one address for a PDP context. However, in most
cases its just a single address for attached interface and that should be
sufficient.

Thanks
Sri

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 09 Jul 2008 08:07:53 -0700

On 7/9/08 8:03 AM, "Sri Gundavelli" <[email-masked]> wrote:

> as part of the configuration payload.

Jonne said, "a single address per MN is enough", which is a correct
statement. You can assign more than one if you want.

> And also there is the 3GPP case
> of potentially more than one address for a PDP context.

For IPv4 PDP contexts, I believe there is just one IPv4 address per PDP
context.

> However, in most

Agree.

Vijay

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 9 Jul 2008 08:13:23 -0700 (PDT)

Hi Vijay,

> statement. You can assign more than one if you want.

Sure, I agree as well. I wanted to state that we are not restricting this
case, however.

> For IPv4 PDP contexts, I believe there is just one IPv4 address per PDP

Ok. I will take your word on this.

Sri