Subject: Re: [netlmm] comments on draft-devarapalli-netlmm-pmipv6-heartbeat

From: "Vijay Devarapalli" <[email-masked]>
Date: Thu, 3 Jul 2008 13:26:55 -0400

I just submitted a new version removing the sentence about the LMA
storing the sequence number. The new version is at 
http://www.ietf.org/internet-drafts/draft-devarapalli-netlmm-pmipv6-hear
tbeat-03.txt

Vijay

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Premec, Domagoj
> Sent: Monday, June 09, 2008 5:45 AM
> To: Ahmad Muhanna; Suresh Krishnan
> Cc: [email-masked]; Julien Laganier
> Subject: Re: [netlmm] comments on draft-devarapalli-netlmm-pmipv6-
> heartbeat
> 
> Ahmad,
> 
> I agree that if the seq. no. is used to detect re-boots, then the LMA
> needs to save it. And if it is used only to match requests to replies,
> then there is no need to save it. Meanwhile Julien explained that in
the
> latter case the LMA is not required to save it, so I guess this
> requirement will be removed from the draft.
> 
> IMO, both approaches work and each has its own pros and cons.
> 
> domagoj
> 
> 
> > -----Original Message-----
> > From: Ahmad Muhanna [mailto:[email-masked]]
> > Sent: 06. lipanj 2008 17:07
> > To: Premec, Domagoj; Suresh Krishnan
> > Cc: [email-masked]; Julien Laganier; Julien Laganier
> > Subject: RE: [netlmm] comments on
> > draft-devarapalli-netlmm-pmipv6-heartbeat
> >
> > Hi Domagoi/All,
> >
> > My understanding of the restart counter that it is only used
> > to indicate that the Peer has restarted. If that that the
> > case, then what you mentioned about using the first 255 seq.
> > nos as an indication for restart should work (similar to FA
> > restart mechanism in MIP4) However, in order for that to
> > work, the LMA needs to save the latest sq. no. at least for
> > the first 256 numbers.
> >
> > In other words,
> >
> > LMA does not save the sq. no. as long as the sq. no is larger
> > than 256.
> > However, the first time the LMA receives a HB with sq. no.
> > less than 256, LMA consider that the peer has rebooted and
> > then save that number.
> > Because the next HB will possible have sq. no less that 256
> > and we do not want the LMA to think that the MAG has rebooted
> > one more time.
> >
> > In response to the number of lost messages as a possible
> > cause for not detecting a failure, I guess the LMA need to
> > miss 256 HB messages before that ever happen.
> >
> >
> > Regards,
> > Ahmad
> >
> >
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]] On Behalf Of Premec, Domagoj
> > > Sent: Friday, June 06, 2008 3:57 AM
> > > To: Suresh Krishnan
> > > Cc: [email-masked]; Julien Laganier
> > > Subject: Re: [netlmm] comments on
> > > draft-devarapalli-netlmm-pmipv6-heartbeat
> > >
> > > Hi Suresh,
> > >
> > > hmm... MAG resets sequence number counter when it re-boots:
> > >
> > > MAG -> LMA seq number x (received)
> > > (MAG Reboot)
> > > MAG -> LMA seq number 1 (lost)
> > > ...
> > > MAG -> LMA seq number x (lost)
> > > MAG -> LMA seq number x+1 (received)
> > >
> > > The precondition is that first x messages after re-boot are
> > lost. This
> > > can be taken care of by having the MAG increment the
> > sequence number
> > > only for successful heartbeat transactions and not every
> > time it sends
> > > a heartbeat message.
> > > So basically the MAG keeps re-transmitting the same message
> > until it
> > > gets a response.
> > >
> > > I just wanted to understand why the LMA is required to save the
> > > sequence number and as I couldn't see any other reasons I
> > thought it
> > > must be to detect recoveries. I still don't have an answer to that
> > > question.
> > >
> > > domagoj
> > >
> > >
> > >
> > > > -----Original Message-----
> > > > From: Suresh Krishnan [mailto:[email-masked]]
> > > > Sent: 05. lipanj 2008 22:41
> > > > To: Premec, Domagoj
> > > > Cc: Julien Laganier; [email-masked]
> > > > Subject: Re: [netlmm] comments on
> > > > draft-devarapalli-netlmm-pmipv6-heartbeat
> > > >
> > > > Hi Domagoj,
> > > >    If we use the same sequence number to detect restarts and for
> > > > matching requests to replies there are some cases where we
> > > will get a
> > > > false negative. e.g.
> > > >
> > > >
> > > > MAG -> LMA seq number x (received)
> > > > (MAG Reboot)
> > > > MAG -> LMA seq number x (lost)
> > > > MAG -> LMA seq number x+1 (received)
> > > >
> > > > In this case the LMA would wrongly assume that the MAG had not
> > > > restarted. This is why we require a separate restart
> > > counter stored in
> > > > non-volatile memory.
> > > >
> > > > Cheers
> > > > Suresh
> > > >
> > > > Premec, Domagoj wrote:
> > > > > Julien,
> > > > >
> > > > >> Using the sequence number as the restart counter would tie
> > > > >> reachability testing and restart detection.
> > > > >
> > > > > I think of it as a single mechanism that is able to detect
> > > > both restarts and reachability.
> > > > >
> > > > >>  In the absence of
> > > > >> restart, that would not allow the receiver of a response
> > > > to match it
> > > > >> with the appropriate request.
> > > > >
> > > > > I'm not sure I understand your point.
> > > > >
> > > > > I thought that using a single counter would be simpler.
> > > > Anyway, I have no strong opinion on this. .
> > > > >
> > > > > domagoj
> > > > >
> > > > >
> > > > >
> > > > >> -----Original Message-----
> > > > >> From: julien laganier [mailto:[email-masked]]
> > > > On Behalf Of
> > > > >> Julien Laganier
> > > > >> Sent: 05. lipanj 2008 15:33
> > > > >> To: [email-masked]
> > > > >> Cc: Premec, Domagoj; Vijay Devarapalli
> > > > >> Subject: Re: [netlmm] comments on
> > > > >> draft-devarapalli-netlmm-pmipv6-heartbeat
> > > > >>
> > > > >> On Thursday 05 June 2008, Premec, Domagoj wrote:
> > > > >>> Vijay,
> > > > >>>
> > > > >>> I looked at the -02 version, and it doesn't explain why the
> > > > >> LMA needs
> > > > >>> to save the sequence number received in the heartbeat
> > > > >> message. Let me
> > > > >>> ask this in a different way: how does the LMA react when it
> > > > >> receives
> > > > >>> the heartbeat message with unexpected sequence number?
> > > > >>>
> > > > >>> I thought that the saved sequence numbers could be used
> > > to detect
> > > > >>> re-boots. If a node detects an unexpected sequence number,
> > > > >> this is a
> > > > >>> signal that the peer node re-booted. To distinguish
> > between the
> > > > >>> roll-over of a sequence number and re-boot, the sequnce
> > > > >> number should
> > > > >>> re-start from 256 in case of roll-over.
> > > > >>>
> > > > >>> This seems as simpler mechanism since it uses only one
> > > > counter and
> > > > >>> doesn't require non-volatile memory.
> > > > >> Domagoj,
> > > > >>
> > > > >> Sequence number and restart counter have different semantics.
> > > > >>
> > > > >> The sequence number is used to match a response with a
> > > request and
> > > > >> thus should be different for different requests sent out.
> > > > Independent
> > > > >> from the fact the peer restarted or nor, this allows to test
> > > > >> reachability of the peer.
> > > > >>
> > > > >> OTOH, the restart counter is used to detect if a peer has
> > > > restarted.
> > > > >> It shall stay the same if no restart occurred, and shall be
> > > > >> incremented if the peer restarted.
> > > > >>
> > > > >> Using the sequence number as the restart counter would tie
> > > > >> reachability testing and restart detection. In the absence of
> > > > >> restart, that would not allow the receiver of a response
> > > > to match it
> > > > >> with the appropriate request.
> > > > >>
> > > > >> --julien
> > > > >>
> > > > > _______________________________________________
> > > > > netlmm mailing list
> > > > > [email-masked]
> > > > > https://www.ietf.org/mailman/listinfo/netlmm
> > > >
> > > >
> > > _______________________________________________
> > > netlmm mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/netlmm
> > >
> >
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netlmm
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Frank Xia <[email-masked]>
Date: Thu, 03 Jul 2008 14:19:14 -0500

Hi Vijay

Firstly, I am open with the draft which is a good
idea to keep connection alive.

Something is not very clear to me, and  hopefully
you can help me to understand.

IKEv2 (RFC4306) has INFORMATIONAL
message to keep connection between peers,
and IKE is mandatory to LMA&MAG.

So, IMHO, IKEv2 is  an existing alternative for
maintaining connections.

BR
Frank

----- Original Message ----- 
From: "Vijay Devarapalli" <[email-masked]>
To: "Premec, Domagoj" <[email-masked]>; "Ahmad Muhanna" 
<[email-masked]>; "Suresh Krishnan" <[email-masked]>
Cc: <[email-masked]>; "Julien Laganier" <[email-masked]>
Sent: Thursday, July 03, 2008 12:26 PM
Subject: Re: [netlmm] comments on draft-devarapalli-netlmm-pmipv6-heartbeat

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Thu, 3 Jul 2008 16:08:31 -0400

Hi Frank,

> and IKE is mandatory to LMA&MAG.

IKEv2 is mandatory to implement. Not mandatory to use between the LMA
and the MAG. FWIW, I don't believe IKEv2/IPsec will be used between the
MAG and the LMA in 3GPP-based deployments.

Vijay