Subject: Re: [netlmm] Lack of session indication

From: "Vijay Devarapalli" <[email-masked]>
Date: Wed, 13 Aug 2008 13:46:50 -0400

Hello all,

I am confused by this email thread. Not sure what was concluded. 

We need to conclude on whether the LMA should silently drop the tunneled
packets or send a message to indicate absence of the binding cache
entry.

IMO, if there is an unsolicited Heartbeat Response (or an unsolicited
Node Echo Reply) message sent by the LMA after it reboots and looses
PMIPv6 session state and if there is a binding revocation message from
the LMA to the MAG whenever a binding is removed, then we eliminate all
possible cases of ending up in a situation where the MAG thinks there is
a BCE when there isn't one at the LMA. The unsolicited Heartbeat
Response or the binding revocation could be lost, but then we start
dealing with extreme corner cases. The LMA dropping the tunneled packets
is sufficient. More so, since there is a cost associated with triggering
a control plane message from the data plane for the MN-specific
indication.

Let me know if folks agree/disagree with this.

Vijay

> -----Original Message-----
> From: Koodli, Rajeev [mailto:[email-masked]] 
> Sent: Tuesday, August 12, 2008 10:32 AM
> To: Sri Gundavelli
> Cc: Vijay Devarapalli; Shi Xiaoyan; [email-masked]
> Subject: RE: Lack of session indication
> 
> 
> 
> > > [RKo:>] Okay, but the MAG may receive a packet from LMA 
> for the MN.
> > >
> > 
> > hmm ... If the MAG has performed de-registration procedure with the
> > LMA, the states should be cleared on both the peers. All 
> the explicit
> > session termination events on the LMA or MAG or the normal dereg
> > procedures on the MAG, should always clear the session 
> states on both
> > the peers. If this does not work reliably, any new 
> signaling messages
> > will suffer the same.
> 
> [RKo:>] My bad. I was thinking of the analogue of what we have been
> discussing - LMA receiving packets for a MN when no BCE exists. 
> 
> > >
> > > What we need is a message from LMA to MAG with "no binding exists
> for
> > > HoA/HNP or for GRE Keys", which are present in the data packet
> itself.
> > > We can do that also with a U-NERP message.
> > >
> > 
> > I've not analyzed this scenario or the proposed solution in detail.
> > Some how we need an indication to the peer on the state loss.
> 
> [RKo:>] Yes, we need to capture this.
> 
> -Rajeev
> 
> 
> > 
> > Sri
> > 
> 
> 
> "This email message and any attachments are confidential 
> information of Starent Networks, Corp. The information 
> transmitted may not be used to create or change any 
> contractual obligations of Starent Networks, Corp.  Any 
> review, retransmission, dissemination or other use of, or 
> taking of any action in reliance upon this e-mail and its 
> attachments by persons or entities other than the intended 
> recipient is prohibited. If you are not the intended 
> recipient, please notify the sender immediately -- by 
> replying to this message or by sending an email to 
> [email-masked] -- and destroy all copies of 
> this message and any attachments without reading or 
> disclosing their contents. Thank you."
> 
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 13 Aug 2008 12:59:27 -0500

Hi Vijay,
I agree.

Regards,
Ahmad

> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: Wednesday, August 13, 2008 12:47 PM
> To: Koodli, Rajeev; Sri Gundavelli; Basavaraj Patil; Hesham 
> Soliman; Muhanna, Ahmad (RICH1:2H10)
> Cc: Shi Xiaoyan; [email-masked]
> We need to conclude on whether the LMA should silently drop 
> the tunneled packets or send a message to indicate absence of 
> the binding cache entry.
> 
> IMO, if there is an unsolicited Heartbeat Response (or an 
> unsolicited Node Echo Reply) message sent by the LMA after it 
> reboots and looses
> PMIPv6 session state and if there is a binding revocation 
> message from the LMA to the MAG whenever a binding is 
> removed, then we eliminate all possible cases of ending up in 
> a situation where the MAG thinks there is a BCE when there 
> isn't one at the LMA. The unsolicited Heartbeat Response or 
> the binding revocation could be lost, but then we start 
> dealing with extreme corner cases. The LMA dropping the 
> tunneled packets is sufficient. More so, since there is a 
> cost associated with triggering a control plane message from 
> the data plane for the MN-specific indication.
> 
> information 
> > of Starent Networks, Corp. The information transmitted may 
> not be used 
> > to create or change any contractual obligations of Starent 
> Networks, 
> > Corp.  Any review, retransmission, dissemination or other 
> use of, or 
> attachments 
> > by persons or entities other than the intended recipient is 
> > prohibited. If you are not the intended recipient, please 
> notify the 
> > sender immediately -- by replying to this message or by sending an 
> > email to [email-masked] -- and destroy all 
> copies of

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 13 Aug 2008 11:24:24 -0700 (PDT)

> or send a message to indicate absence of the binding cache
> entry.

A resounding NO to this, I thought.

As I see it, the gap/scenarios are:

1.) Failure in LMA-MAG path, detection
2.) Inconsistent binding states on the LMA/MAG for the following
     reasons
    a) MAG performed a dereg procedure
    b) LMA/MAG trigerred a revocation procedure
    c) LMA/MAG rebooted

Nothing is required for #a. States are cleared on both the ends.
So is for #b with the use of revocation message.

For #c, we need a mechanism for the peers to detect the peer rebooted
and all the sessions are gone. We need this indication. The missing
pieces are #1 and #2c.  No need for reacting to tunneling messages
etc, thats not required.

Sri