Subject: Re: [netlmm] Lack of session indication

From: Sri Gundavelli <[email-masked]>
Date: Wed, 13 Aug 2008 11:59:37 -0700 (PDT)

Hi Rajeev,

On Wed, 13 Aug 2008, Koodli, Rajeev wrote:

>
> Hi Sri,
>
>>
>>> or send a message to indicate absence of the binding cache
>>> entry.
>>
>> A resounding NO to this, I thought.
>
> [RKo:>] Perhaps from you :-)
>

To make sure, for data path message, if there is no binding, you are in
favour of sending a signaling error message ?

I'm not able to see when we would end up with this case, if we solve
the #1 and #2 (a,b and c) cases from my prev email. Unless, I'm missing
some other scenario.

Regards
Sri
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Basavaraj Patil <[email-masked]>
Date: Wed, 13 Aug 2008 14:17:06 -0500

Sri,

I guess it is possible to have an LMA in a state which loses a BCE of an MN
for whatever reason. This is a scenario which may be remote, but nonetheless
exists. An error message to the MAG would address this problem with no
significant impact IMO.

-Raj

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 13 Aug 2008 12:24:52 -0700 (PDT)

Hi Raj,

On Wed, 13 Aug 2008, Basavaraj Patil wrote:

> exists.

But, how ? No reboot, no revocation event, no dereg, but the binding
disappears ?

Sri

---

From: Basavaraj Patil <[email-masked]>
Date: Wed, 13 Aug 2008 14:38:41 -0500

Sri,

You are assuming ideal or perfect software and platforms that never have
issues. There could be corruption of memory, BCEs being overwritten because
of bad implementation, etc.  As I said, these are very remote cases. But
they exist. Your view is that the BCE only disappears if the LMA reboots or
there is a dereg event. I can also view the scenario where AAA requests the
LMA to deprecate the BCE and in the absence of any revocation mechanism the
MAG has no awareness (and as you know revocation is not mandatorily required
for deploying PMIP6). So IMO there are scenarios which could be dealt with
via an error notification to the MAG.

-Raj

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 13 Aug 2008 12:47:33 -0700 (PDT)

Hi Raj,

AAA event is still a revocation event. My point is that the creation
and termination of BCE events have to be predictable, else its an
unpredictable system with strange corner cases. I've not seen this in
our implementations of HA or LMA and hence the comment. We can see
what others say about this scenario.

Thanks
Sri

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Wed, 13 Aug 2008 16:02:52 -0400

Raj,

FWIW, we haven't been able to come up with a convincing scenario. So, I
don't think we should specify the MN-specific indication until we do
have a scenario that needs to be addressed.

Vijay 

> -----Original Message-----
> From: Basavaraj Patil [mailto:[email-masked]] 
> Sent: Wednesday, August 13, 2008 12:17 PM
> To: Sri Gundavelli; Koodli, Rajeev
> Cc: Vijay Devarapalli; Hesham Soliman; Ahmad Muhanna; Shi 
> Xiaoyan; [email-masked]
> Subject: Re: Lack of session indication
> 
> 
> Sri,
>