Subject: Re: [netlmm] Lack of session indication

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 11 Aug 2008 11:59:49 -0700

Koodli, Rajeev wrote:
> Hi Vijay,
> 
>> Or we could define a new status code '3' that would say "Missing Proxy
>> Binding Cache Entry".
>>
>> Using an "Unsolicited Node Echo Reply" (or an unsolicited Heartbeat
>> Response) seems wrong semantically. Of course, both would work.
>>
> 
> [RKo:>] Why is it wrong semantically? We did not encounter this scenario
> earlier. At this stage, given that this is not addressed in the base
> PMIP specification, path management ID is the right place to specify
> this, and I wish to keep the number of messages exchanged to minimal
> (two, in draft-koodli-netlmm-path-and-session-management) and
> self-contained. 

I am fine with the "lack of session indication" message being specified 
in the path management draft. Anyway, nothing can be added to the PMIPv6 
base specification at this point. It has already completed the AUTH48 
stage.

BTW, Binding Error is part of the MIPv6/PMIPv6 stack. It is not a new 
message.

Using path management messages for this is semantically wrong, IMO. The 
reason is that the path management messages are used for checking path 
reachability and restart of PMIPv6 end points. They are not specific to 
a particular mobile node's session. We already have a message for 
indicating lack of a binding, i.e., the Binding Error message. I am 
suggesting re-using that message.

Vijay

> 
> -Rajeev
>  
> 
>> Comments?
>>
>> Vijay
>>
>>
>>> -----Original Message-----
>>> From: [email-masked]
>>> [mailto:[email-masked]] On Behalf Of Koodli, Rajeev
>>> Sent: Monday, August 11, 2008 7:57 AM
>>> To: Shi Xiaoyan
>>> Cc: [email-masked]
>>> Subject: Re: [netlmm] Questions for
>>> koodli-netlmm-path-and-session-management
>>>
>>> Hello Xiaoyan,
>>>
>>>
>>>
>>> Yes, we will clarify that in the next version.
>>>
>>> I think we can also use GRE Keys for the same purpose.
>>>
>>>
>>>
>>> Regards,
>>>
>>>
>>>
>>> -Rajeev
>>>
>>>
>>>
>>>
>>>
>>> ________________________________
>>>
>>> From: Shi Xiaoyan [mailto:[email-masked]]
>>> Sent: Sunday, August 10, 2008 8:29 PM
>>> To: Koodli, Rajeev
>>> Cc: [email-masked]; 'tanshiyong'
>>> Subject: Questions for koodli-netlmm-path-and-session-management
>>>
>>>
>>>
>>> Hi,Rajeev
>>>
>>>
>>>
>>> In section 3:
>>>
>>>
>>>
>>>    Due to a full or partial failure, a node may no longer have
> session
>>>    information (i.e., BCE) for some MN.  When a packet from
>>> its peer for
>>>    such a MN is received (e.g., LMA receives a packet from a MAG),
> the
>>>    node SHOULD immediately send a U-NERP message containing the MN-
>>>    Identifier.  This informs the peer of the absence of a BCE
>>> for the MN
>>>    identified by the MN-Identifier.
>>>
>>>
>>>
>>> Data packets between LMA and MAG are IP-in-IP encapsulated.
>>> When LMA recieves a data packet without matching BCE, LMA
>>> only obtain the inner source IP address. It means that LMA
>>> don't know which MN the data packet belongs to  and LMA only
>>> know there is not a BCE matching the inner source IP.
>>>
>>>
>>>
>>> So, I think the U-NERP should be identified by home address
>>> (HoA, inner source IP).
>>>
>>>
>>>
>>>
>>>
>>> Regards,
>>> Xiaoyan
>>>
>>>
>>>
>>>
> 
> 
> "This email message and any attachments are confidential information of Starent Networks, Corp. The information transmitted may not be used to create or change any contractual obligations of Starent Networks, Corp.  Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this e-mail and its attachments by persons or entities other than the intended recipient is prohibited. If you are not the intended recipient, please notify the sender immediately -- by replying to this message or by sending an email to [email-masked] -- and destroy all copies of this message and any attachments without reading or disclosing their contents. Thank you."

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 13 Aug 2008 09:20:18 -0500

Hi Vijay,

> 
> Koodli, Rajeev wrote:
> > Hi Vijay,
> > 
> >> Or we could define a new status code '3' that would say "Missing 
> >> Proxy Binding Cache Entry".
> >>
> > [RKo:>] Why is it wrong semantically? We did not encounter this 
> > scenario earlier. At this stage, given that this is not 
> addressed in 
> > the base PMIP specification, path management ID is the 
> right place to 
> > specify this, and I wish to keep the number of messages 
> exchanged to 
> > minimal (two, in 
> draft-koodli-netlmm-path-and-session-management) and 
> > self-contained.
> 
> I am fine with the "lack of session indication" message being 
> specified in the path management draft. Anyway, nothing can 
> be added to the PMIPv6 base specification at this point. It 
> has already completed the AUTH48 stage.
> 
> BTW, Binding Error is part of the MIPv6/PMIPv6 stack. It is 
> not a new message.
> 
> Using path management messages for this is semantically 
> wrong, IMO. The reason is that the path management messages 
> are used for checking path reachability and restart of PMIPv6 
> end points. They are not specific to a particular mobile 
> node's session. 

[Ahmad]
Hopefully, it is never too late:)
I just would like to say that I agree with what you just said here.
Indeed Path management is not to be used for tracking a particular
mobile node session.

> We already have a message for indicating lack 
> of a binding, i.e., the Binding Error message. I am 

> >>>    information (i.e., BCE) for some MN.  When a packet 
> from its peer 
> >>> for
> >>>    Identifier.  This informs the peer of the absence of a BCE for 
> >>> the MN
> >>> When LMA recieves a data packet without matching BCE, LMA only 
> >>> obtain the inner source IP address. It means that LMA don't know 
> >>> which MN the data packet belongs to  and LMA only know 
> there is not 
> >>> a BCE matching the inner source IP.
> >>>
> >>>
> >>>
> >>> So, I think the U-NERP should be identified by home address (HoA, 
> >>> inner source IP).
> >>>
> >>>
> >>>
> >>>
> >>>
> >>> Regards,
> >>> Xiaoyan
> >>>
> >>>
> >>>
> >>>
> > 
> > 
> > "This email message and any attachments are confidential 
> information of Starent Networks, Corp. The information 
> transmitted may not be used to create or change any 
> contractual obligations of Starent Networks, Corp.  Any 
> review, retransmission, dissemination or other use of, or 
> taking of any action in reliance upon this e-mail and its 
> attachments by persons or entities other than the intended 
> recipient is prohibited. If you are not the intended 
> recipient, please notify the sender immediately -- by 
> replying to this message or by sending an email to 
> [email-masked] -- and destroy all copies of 
> this message and any attachments without reading or 
> disclosing their contents. Thank you."
> 
>