Subject: Re: [netlmm] Some questions on draft-muhanna-netlmm-grekey-option-04

From: "Desire Oulai" <[email-masked]>
Date: Tue, 19 Aug 2008 09:54:38 -0400

Hi Ahmad,

  In 3GPP, i think MN-ID + APN will be sufficient to identify the
connection as it is the BCE lookup key. The bulk deregistration case you
mentioned is a more appropriate scenario for including GRE key in the
dereg message.

Regards

Desire

> Date: Mon, 18 Aug 2008 14:35:58 -0500
> From: "Ahmad Muhanna" <[email-masked]>
> Subject: Re: [netlmm] Some questions on
> 	draft-muhanna-netlmm-grekey-option-04
> To: "Charles E. Perkins" <[email-masked]>,	"Sri Gundavelli"
> 	<[email-masked]>
> Cc: [email-masked]
> Message-ID:
>
<[email-masked]>
> Content-Type: text/plain;	charset="us-ascii"
> 
> Hi Charlie,
> 
> I was thinking that in the case that the same MN-ID (NAI) is used for
registering multiple PDN connections where each connection is assigned a
GRE key, It will be useful to send a de-registration which > include the
MN-ID and the GRE key associated with that connection. Also, if bulk
registration is supported, bulk de-registration for specific connections
but not all is also possible. In that case, including > the GRE key
would be helpful too.
>
>Regards,
>Ahmad
> 
>
>> -----Original Message-----
>> From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of Charles E. Perkins
>> Sent: Monday, August 18, 2008 2:24 PM
>> To: Sri Gundavelli
>> Cc: [email-masked]
>> Subject: Re: [netlmm] Some questions on
>> draft-muhanna-netlmm-grekey-option-04
>> 
>> 
>> Hello Sri,
>> 
>> Sri Gundavelli wrote:
>> >
>> >>
>> >> Can't we simplify it by saying GRE keys are only included in the 
>> >> initial PBU/PBAck? Why keep it optional for the MAG to include the

>> >> GRE key in the PBU for de-registration?
>> >>
>> >
>> > I do not think we should disallow this completely. If this
>> not needed
>> > in dereg, optional tag will be fine. In cases, where this may be 
>> > needed, let them send the key in all messages.
>> 
>> Can you say more about the cases where this is needed?
>> 
>> Regards,
>> Charlie P.
>> 
>> 
>> _______________________________________________
>> netlmm mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netlmm
>> 

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 19 Aug 2008 09:58:44 -0500

Hi Desire,
 
I agree. Thanks!
 
<as a side note> It may become necessary in the case if primary and
secondary PDP contexts are supported. 
But I agree with your comment that currently MN-ID and the APN is
sufficient and bulk deregistration is more appropriate.

Regards, 
Ahmad 

________________________________

	From: Desire Oulai [mailto:[email-masked]] 
	Sent: Tuesday, August 19, 2008 8:55 AM
	To: Muhanna, Ahmad (RICH1:2H10)
	Cc: [email-masked]
	Subject: Re: [netlmm] Some questions on
draft-muhanna-netlmm-grekey-option-04

	Hi Ahmad, 

	  In 3GPP, i think MN-ID + APN will be sufficient to identify
the connection as it is the BCE lookup key. The bulk deregistration case
you mentioned is a more appropriate scenario for including GRE key in
the dereg message.

	Regards 

	Desire 

	> I was thinking that in the case that the same MN-ID (NAI) is
used for registering multiple PDN connections where each connection is
assigned a GRE key, It will be useful to send a de-registration which >
include the MN-ID and the GRE key associated with that connection. Also,
if bulk registration is supported, bulk de-registration for specific
connections but not all is also possible. In that case, including > the
GRE key would be helpful too.

	>> [mailto:[email-masked]
<mailto:[email-masked]> ] On Behalf Of Charles E. Perkins 
	>> Can you say more about the cases where this is needed? 
<https://www.ietf.org/mailman/listinfo/netlmm>