Subject: Re: [netlmm] Comments on draft-ietf-netlmm-pmip6-ipv4-support-04.txt

From: "Koodli, Rajeev" <[email-masked]>
Date: Thu, 14 Aug 2008 18:08:25 -0400

Sri,

I tend to agree with Vijay: I don't see any issue in having a
configuration variable that toggles UDP encapsulation ON/OFF based on
the particular deployment. 

Regards,

-Rajeev

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Vijay Devarapalli
> Sent: Thursday, August 14, 2008 1:38 PM
> To: Sri Gundavelli
> Cc: [email-masked]
> Subject: Re: [netlmm] Comments on
draft-ietf-netlmm-pmip6-ipv4-support-
> 04.txt
> 
> Sri,
> 
> Ok, lets agree to disagree on the "PBU message consistency".
> 
> However, I would still like to see the MAG configuration option to not
> use UDP tunneling for the PBU messages specified, if it is known that
> there is no NAT on the path. With this configuration option, you would
> either use IPv6-over-IPv4 or with IPv6-in-UDP-over-IPv4 consistently.
> 
> > While we clearly support encap of traffic in IPv4 packet (no
> > UDP),
> 
> We were not discussing that at all. You are making it appear as if you
> are conceding something. :)
> 
> > I dont
> > see value in enabling that for control messages, that is the
> > approach of
> > DSMIP as well.
> 
> This I completely disagree with. If there is not going to be NAT
between
> the MAG and the LMA in many of the PMIPv6 deployments, we should not
be
> mandating UDP encapsulation for the PBU/PBAck messages. It should be
> possible to have the MAG and the LMA use plain IPv6-over-IPv4
> encapsulation for all the PMIPv6 control messages.
> 
> Vijay
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netlmm
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 14 Aug 2008 15:21:59 -0700

Hello Rajeev,

I think there should be two configuration variables:
- One to force UDP encapsulation
- One to prohibit UDP encapsulation
This would allow for a dynamic mode of operation,
in which the device could test for NAT and then use
UDP if NAT is detected in that network.

Regards,
Charlie P.

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 14 Aug 2008 15:34:51 -0700 (PDT)

Hi Charlie,

> UDP if NAT is detected in that network.

This is perfectly fine. We have defined config options for the
data path, as when to enable/disable/force UDP encap of data
messages. The question was about control messages. Would you
prefer sending  Proxy Binding Update message in two modes:

- IPv6 in IPv4-UDP
- IPv6 in IPv4

or just one mode as as in DSMIP

- IPv6 in IPv4-UDP.

Sending IPv6 encap packets in native IPv4 requires additional
configuration on the LMA. This will be least used and will
create one more mode. Sending control messages to UDP port
will also ensure MIP6 application in user space can recv it
and with no additional configuration for v6-over-v4 on the
LMA.

If there is a strong need, we can enable this. But, my gut
feeling says, it wont be used. Also, DSMIP does not support
this mode. But, if any implementors are sure, this is required,
sure will support this mode.

Thanks
Sri