Subject: Re: [netlmm] I-D Action:draft-ietf-netlmm-pmipv6-heartbeat-01.txt

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 3 Oct 2008 08:01:53 -0700 (PDT)

Hi Vijay,
  I read this draft.
6 authors for 9 pages, wow!
Seriously, though, have you considered the Hello protocol we have in HA Reliability draft for which you are a co-author?

Another question: you mentioned the unsolicited heartbeat response message sent by a node that restarts to all other nodes. Is this a well-known technique in fault-tolerant computing?

Lastly, a small typo: if
   required, to reduce of burden of sending periodic heartbeat messages. 
maybe use reduce burden of sending ...

Regards,

Behcet

----- Original Message ----
From: Vijay Devarapalli <[email-masked]>
To: [email-masked]
Sent: Tuesday, September 30, 2008 6:40:31 PM
Subject: Re: [netlmm] I-D Action:draft-ietf-netlmm-pmipv6-heartbeat-01.txt

Just a minor update. Fixed three typos/mistakes that Mohana spotted.
Added a section on protocol configuration variables.

Vijay

[email-masked] wrote:
> A New Internet-Draft is available from the on-line
> Internet-Drafts directories.
> This draft is a work item of the Network-based Localized
> Mobility Management Working Group of the IETF.
> 
> 
>     Title           : Heartbeat Mechanism for Proxy Mobile IPv6
>     Author(s)       : V. Devarapalli, et al.
>     Filename        : draft-ietf-netlmm-pmipv6-heartbeat-01.txt     
>     Pages           : 11 
>     Date            : 2008-09-30
> 
> Proxy Mobile IPv6 is a network-based mobility management protocol.
> The mobility entities involved in the Proxy Mobile IPv6 protocol, the
> Mobile Access Gateway (MAG) and the Local Mobility Anchor (LMA),
> setup tunnels dynamically to manage mobility for a mobile node within
> the Proxy Mobile IPv6 domain.  This document describes a heartbeat
> mechanism between the MAG and the LMA to detect failures quickly and
> take appropriate action. 
> 
> A URL for this Internet-Draft is:
>
http://www.ietf.org/internet-drafts/draft-ietf-netlmm-pmipv6-heartbeat-0
1.txt 
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Fri, 3 Oct 2008 11:31:02 -0400

> 6 authors for 9 pages, wow!

It was a result of merging two documents. 

> Seriously, though, have you considered the Hello protocol we
> have in HA Reliability draft for which you are a co-author?

The Hello messages defined in the HA reliability draft is intended for
use between home agents in the same local or distributed clusters. It
shouldn't be used between the MAG and the LMA. They are different
network entities. They can be used for LMA reliability, however.

> Another question: you mentioned the unsolicited heartbeat
> response message sent by a node that restarts to all other
> nodes. Is this a well-known technique in fault-tolerant computing?

What is "fault-tolerant computing"?

> maybe use reduce burden of sending ...

Thanks for catching the typo.

Vijay

> Subject: Re: [netlmm] I-D
> Action:draft-ietf-netlmm-pmipv6-heartbeat-01.txt
> 
>>    Pages          : 11 Date            : 2008-09-30
>>