Subject: [netlmm] comment on draft-ietf-netlmm-grekey-option-01

From: "Premec, Domagoj" <[email-masked]>
Date: Fri, 10 Oct 2008 14:59:01 +0200

Hi Ahmad,

I have a comment on the interactions between the binding revocation mechanism and the alt-CoA usage as specified in RFC 5213. According to the RFC 5213, the MAG is allowed to use the alt-CoA to redirect the downlink traffic to an address different from the source address of the PBU. In this case the Binding revocation will get sent to the alt-CoA address, but I think it should actually be sent to the source address of the PBU, as this is where the signalling part of the MAG is located. Is this is a valid concern or should we assume that the MAG also accepts signalling messages at the alt-CoA?

domagoj

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 10 Oct 2008 08:02:54 -0500

Hi Domagoj,

I believe this is a valid concern. I guess either way should work, but I
believe the cleaner solution is to have some text to indicate that if
the alt-CoA included in the PBU, the revocation should be sent to the
same address the PBA is sent to. In this case the source of the PBU.

If people feels that is the best approach, we can add some clarification
to the draft.

What do you think?

Regards,
Ahmad

> -----Original Message-----
> From: Premec, Domagoj [mailto:[email-masked]] 
> Sent: Friday, October 10, 2008 7:59 AM
> To: Muhanna, Ahmad (RICH1:2H10)
> Cc: Netlmm
> Subject: comment on draft-ietf-netlmm-grekey-option-01
> 
> Hi Ahmad,
> 
> I have a comment on the interactions between the binding 
> revocation mechanism and the alt-CoA usage as specified in 
> RFC 5213. According to the RFC 5213, the MAG is allowed to 
> use the alt-CoA to redirect the downlink traffic to an 
> address different from the source address of the PBU. In this 
> case the Binding revocation will get sent to the alt-CoA 
> address, but I think it should actually be sent to the source 
> address of the PBU, as this is where the signalling part of 
> the MAG is located. Is this is a valid concern or should we 
> assume that the MAG also accepts signalling messages at the alt-CoA?
> 
> domagoj
> 
>

---

From: "Premec, Domagoj" <[email-masked]>
Date: Fri, 10 Oct 2008 15:13:42 +0200

Ahmad,

IMO sending the Binding revocation to the source IP of the PBU is the right way to go and I'd like to see this documented in the draft. Though this will require the extension of the BCE structure as the LMA will need to save both the source IP of the PBU and the alt-CoA.

domagoj

> From: Ahmad Muhanna [mailto:[email-masked]] 
> Sent: 10. listopad 2008 15:03
> To: Premec, Domagoj
> Cc: Netlmm
> Subject: RE: comment on draft-ietf-netlmm-grekey-option-01
> 
> Hi Domagoj,
> 
> I believe this is a valid concern. I guess either way should 
> work, but I believe the cleaner solution is to have some text 
> to indicate that if the alt-CoA included in the PBU, the 
> revocation should be sent to the same address the PBA is sent 
> to. In this case the source of the PBU.
> 
> If people feels that is the best approach, we can add some 
> clarification to the draft.
> 
> What do you think?
> 
> Regards,
> Ahmad
>  
> 
> > I have a comment on the interactions between the binding revocation 
> > mechanism and the alt-CoA usage as specified in RFC 5213. 
> According to 
> > the RFC 5213, the MAG is allowed to use the alt-CoA to redirect the 
> > downlink traffic to an address different from the source address of 
> > the PBU. In this case the Binding revocation will get sent to the 
> > alt-CoA address, but I think it should actually be sent to 
> the source 
> the MAG is 
> > located. Is this is a valid concern or should we assume 
> that the MAG 
> > also accepts signalling messages at the alt-CoA?
> > 
> > domagoj
> > 
> > 
>

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 10 Oct 2008 08:31:45 -0500

Hi Domagoj,

I agree. Let us wait and see what other folks think of this. 
If there is no objection, then we can add the clarification text and the
new field in the MN BCE at the LMA.

Thanks!

Regards,
Ahmad

> Sent: Friday, October 10, 2008 8:14 AM
> Subject: RE: comment on draft-ietf-binding-revocation-01
> 
> Ahmad,
> 
> IMO sending the Binding revocation to the source IP of the 
> PBU is the right way to go and I'd like to see this 
> documented in the draft. Though this will require the 
> extension of the BCE structure as the LMA will need to save 
> both the source IP of the PBU and the alt-CoA.
> 
> domagoj
> 
> 
> > I believe this is a valid concern. I guess either way 
> should work, but 
> > I believe the cleaner solution is to have some text to 
> indicate that 
> > if the alt-CoA included in the PBU, the revocation should 
> be sent to 
> > the same address the PBA is sent to. In this case the source of the 
> > PBU.
> > 
> revocation