Subject: Re: [netlmm] DHCP Scenarios in draft-ietf-netlmm-pmip6-ipv4-support

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 23 Oct 2008 12:38:04 -0700 (PDT)

DHCP server at the MAG is WiMAX model and the solution in draft-ietf-netlmm-pmip6-ipv4-support I think is consistent with what WiMAX uses for PMIPv4. WiMAX has DHCP proxy server at ASN-GW which would house the MAG. There is also DHCP Relay possible to be had in ASN-GW but it is optional.

Regards,

Behcet

----- Original Message ----
From: Sri Gundavelli <[email-masked]>
To: Charles E. Perkins <[email-masked]>
Cc: [email-masked]; Ryuji Wakikawa <[email-masked]>
Sent: Thursday, October 23, 2008 1:42:23 PM
Subject: Re: [netlmm] DHCP Scenarios in draft-ietf-netlmm-pmip6-ipv4-support

Hi Charlie,

On Thu, 23 Oct 2008, Charles E. Perkins wrote:

>
> Hello Sri,
>
> Do you really want to promote having dozens or
> hundreds of DHCP databases for the poor network
> administrator to configure, debug, update, and
> manage?  Yow.
>
> I should buy stock in companies selling medicine
> for migraines.
>

I understand we have strong preferences for certain
modes and we may think its a head ache to support
some other modes. But, protocols have to reasonably
flexible and allow minimal configurations.

Forcing only one mode of DHCP configuration, co-location
on the LMA, will require every DHCP message to hit the
LMA. We already have a dependency for the PMIP signaling
to be complete and this requires DHCP messages to hit
all the way home. In some cases, this will eliminate that
extra round trip.

We should minimize configurations, but at the same time,
that goal should not endup imposing strong deployment
restrictions.

Sri

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: [email-masked]
Date: Fri, 24 Oct 2008 16:08:34 +0900

Hi Behcet,

OK, WiMAX uses DHCP server at MAG (ASN-GW) as a default.

thanks,
ryuji

At Thu, 23 Oct 2008 12:38:04 -0700 (PDT),
Behcet Sarikaya wrote:
> 
> [1  <multipart/alternative (7bit)>]
> [1.1  <text/plain; us-ascii (7bit)>]
> [1.2  <text/html; us-ascii (7bit)>]
> 
> [2  <text/plain; us-ascii (7bit)>]