Subject: [netlmm] Query of Global Binding Revocation

From: "Magesh Shanmugam" <[email-masked]>
Date: Tue, 11 Nov 2008 18:14:38 +0530

All
 
During Global Binding Revocation (i.e. MAG sending BRI message with A, P and
G bit set and Revocation Trigger = Per Peer Policy) procedure, will MAG
handle 
any Binding Registration or Binding De-registration (i.e. MN-ATTACH or
MN-DETACH). If so, what is the call flow between MAG and LMA.
 
Thanks
S Magesh
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 11 Nov 2008 23:53:58 -0600

Magesh,
 
I assume your question is as follows:
While MAG1 is processing a Global BRI from LMA1, what MAG1 would do if
it receives a MN-ATTACH or MN-DETACH, right?
 
CASE No. 1: MN-ATTACH for a NEW MN:
-----------------------------------
In case MAG1 receives a MN-ATTACH for a new MN, which does not have a
binding at MAG1 and LMA1, then I have the following comments:

I assume that there is a reason for the LMA to send a Global Revocation
to MAG1; In Ideal situation, other networks elements which is involved
in the MN attach and dynamically assigns the MN an LMA, should avoid
assigning this LMA new sessions, at least with that specific MAG1.
However, what needs to be done here, IMO, should be based on a local
per-peer policy. 
 
One option for the per-peer local policy is to always allow MAG1 to send
a PBU to LMA1 anyway, in this case LMA1 would still have the chance to
reject the PBU or ACCEPT.

CASE No. 2: MN-DETACH for a MN which has a Binding at MAG1 and LMA1
(RACE CONDITION):
------------------------------------------------------------------------
-------------
In this case, I believe MAG1 should NOT send a de-registration PBU to
the LMA1, because it is meaningless.
 
Hope this answers your concern.

Regards, 
Ahmad 

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Magesh Shanmugam
	Sent: Tuesday, November 11, 2008 9:45 PM
	To: [email-masked]
	Subject: [netlmm] Query of Global Binding Revocation

	All
	 
	During Global Binding Revocation (i.e. MAG sending BRI message
with A, P and G bit set and Revocation Trigger = Per Peer Policy)
procedure, will MAG handle 
	any Binding Registration or Binding De-registration (i.e.
MN-ATTACH or MN-DETACH). If so, what is the call flow between MAG and
LMA.
	 
	Thanks
	S Magesh

---

From: "Magesh Shanmugam" <[email-masked]>
Date: Thu, 13 Nov 2008 10:51:06 +0530

Ahmad

Yes, the cases mentioned are correct. Thanks for the detailed explanation.

S Magesh

-----Original Message-----
From: Ahmad Muhanna [mailto:[email-masked]] 
Sent: Wednesday, November 12, 2008 11:24 AM
To: Magesh Shanmugam; [email-masked]
Subject: RE: [netlmm] Query of Global Binding Revocation

Magesh,
 
I assume your question is as follows:
While MAG1 is processing a Global BRI from LMA1, what MAG1 would do if it
receives a MN-ATTACH or MN-DETACH, right?

I assume that there is a reason for the LMA to send a Global Revocation to
MAG1; In Ideal situation, other networks elements which is involved in the
MN attach and dynamically assigns the MN an LMA, should avoid assigning this
LMA new sessions, at least with that specific MAG1.
However, what needs to be done here, IMO, should be based on a local
per-peer policy. 
 
One option for the per-peer local policy is to always allow MAG1 to send a
PBU to LMA1 anyway, in this case LMA1 would still have the chance to reject
the PBU or ACCEPT.

CASE No. 2: MN-DETACH for a MN which has a Binding at MAG1 and LMA1 (RACE
CONDITION):
------------------------------------------------------------------------
-------------
In this case, I believe MAG1 should NOT send a de-registration PBU to the
LMA1, because it is meaningless.

Regards,
Ahmad 

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Magesh Shanmugam
	Sent: Tuesday, November 11, 2008 9:45 PM
	To: [email-masked]
	Subject: [netlmm] Query of Global Binding Revocation

	All
	 
	During Global Binding Revocation (i.e. MAG sending BRI message with
A, P and G bit set and Revocation Trigger = Per Peer Policy) procedure, will
MAG handle 
	any Binding Registration or Binding De-registration (i.e.
MN-ATTACH or MN-DETACH). If so, what is the call flow between MAG and LMA.
	 
	Thanks
	S Magesh