Subject: [netlmm] Query on DHCP Delegation Router

From: "Magesh Shanmugam" <[email-masked]>
Date: Fri, 26 Dec 2008 17:57:36 +0530

Hi
 
As per RFC 5213 (Proxy Mobile IPv6), MAG requests LMA for prefix assignment
for an attached MN.  When LMA (acting as DHCP Requesting Router) 
receives PBU, it will send DHCP Solicit Message to DHCP Delegation Router.
DHCP Delegation Router in turn sends the Prefixe(s) 
to the Requesting Router through DHCP Reply Message.  LMA will build PBA
message with the received prefixe(s) and send it back to MAG.  
 
When there are multiple MN(s) connected to the MAG and MAG requests LMA for
prefix assignment, how will the DHCP Delegation Router will
allocate unique prefixes to each MN, since RFC5213 supports only
per-MN-prefix model?
 
Thanks
S Magesh
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 29 Dec 2008 07:34:35 -0800 (PST)

________________________________
From: Magesh Shanmugam <[email-masked]>
To: [email-masked]; [email-masked]
Cc: [email-masked]
Sent: Friday, December 26, 2008 6:27:36 AM
Subject: Query on DHCP Delegation Router

Hi
 
As per RFC 5213 
(Proxy Mobile IPv6), MAG requests LMA for prefix assignment for an attached 
MN.  When LMA (acting as DHCP Requesting Router) 
receives PBU, it will 
send DHCP Solicit Message to DHCP Delegation Router.  DHCP Delegation 
Router in turn sends the Prefixe(s) 
to the Requesting 
Router through DHCP Reply Message.  LMA will build PBA message with the 
received prefixe(s) and send it back to MAG.  
 
When there are 
multiple MN(s) connected to the MAG and MAG requests LMA for prefix assignment, 
how will the DHCP Delegation Router will
allocate unique 
prefixes to each MN, since RFC5213 supports only per-MN-prefix 
model?

[behcet] For each MN, LMA sets a different IA_ID in the Solicit message as explained in draft-sarikaya-netlmm-prefix-delegation. DR assigns unique prefixes.
 IA_ID is a 4-octet field, we suggested extending it to 8-octets but DHC WG did not favor it. Such a change would have made it easy to associate IA_ID s with the link layer IDs.

Regards,

Behcet
 
Thanks
S 
Magesh