Subject: Re: [netlmm] DHCP Server Options for IPv4 Support

From: "Damic, Damjan" <[email-masked]>
Date: Tue, 9 Dec 2008 04:51:15 +0100

Hello Vidya, netlmm folks,

I believe the collocated DHCP Server deserves its mention in the
PMIPv6-IPv4 spec. The DHCP Proxy is an established concept in some
architecutures (not only applied to v4 case, DHCPv6 proxy is used
likewise).
IMHO there is no justified reason to proclaim a specific DHCP mode as an
integral part of PMIPv6 architecture. Assuming then the intention is
informative and aimed as deployment guideline only, listing both options
should be the right way to go.

Hence, casting my vote for option b)

Thanks,
Damjan

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of
>Narayanan, Vidya
>Sent: Monday, December 08, 2008 9:11 AM
>To: [email-masked]
>Subject: [netlmm] DHCP Server Options for IPv4 Support
>
>All,
>As of the Minneapolis meeting, the WG still seemed undecided 
>about whether
>or not it is a good idea to keep multiple options for the DHCP server
>location as part of the IPv4 spec.  
>
>This is an attempt to get to consensus on this topic.  Please 
>respond with
>one of the following two options to the list. 
>
>a) Limit to one option of having the LMA be the DHCP server. 
>
>b) Keep the option of having the DHCP Server be located at the 
>MAG in the
>draft as well. 
>
>Please provide a reasoning for your choice.  Please respond by 
>Dec 12, 2008.
>
>Thanks,
>Vidya
>_______________________________________________
>netlmm mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netlmm
>
>
>
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 9 Dec 2008 08:00:59 -0800 (PST)

Hi Damjan,
  This discussion is about DHCPv4 server/relay choices. DHCPv6 case is covered in RFC 5213 and only DHCP Relay is allowed at the MAG.
  As for DHCPv4, the latest draft makes the Relay default mode with the possibility of LMA sending a PBA to instruct MAG to become DHCPv4 Server for this MN.
  It seems like all the above text is non normative but I couldn't validate why it is like that.

Regards,

Behcet

________________________________
From: "Damic, Damjan" <[email-masked]>
To: [email-masked]; [email-masked]
Sent: Monday, December 8, 2008 9:51:15 PM
Subject: Re: [netlmm] DHCP Server Options for IPv4 Support

Thanks,
Damjan