Subject: [netlmm] DHCP Server Options for IPv4 Support

From: "Narayanan, Vidya" <[email-masked]>
Date: Sun, 7 Dec 2008 23:11:18 -0800

All,
As of the Minneapolis meeting, the WG still seemed undecided about whether or not it is a good idea to keep multiple options for the DHCP server location as part of the IPv4 spec.  

This is an attempt to get to consensus on this topic.  Please respond with one of the following two options to the list. 

a) Limit to one option of having the LMA be the DHCP server. 

b) Keep the option of having the DHCP Server be located at the MAG in the draft as well. 

Please provide a reasoning for your choice.  Please respond by Dec 12, 2008.

Thanks,
Vidya
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Alper Yegin" <[email-masked]>
Date: Mon, 8 Dec 2008 17:47:14 +0200

(b) 

Because:

At least one industry architecture (WiMAX) that uses PMIPv6 already relies
on DHCP proxy model, and

The work to support DHCP proxy is already done (it is in the spec), and

I don't see any valid technical reason to document one option, but not the
equally possible other option.

Alper

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Narayanan, Vidya
> Sent: Monday, December 08, 2008 9:11 AM
> To: [email-masked]
> Subject: [netlmm] DHCP Server Options for IPv4 Support
> 
> All,
> As of the Minneapolis meeting, the WG still seemed undecided about
> whether or not it is a good idea to keep multiple options for the DHCP
> server location as part of the IPv4 spec.
> 
> This is an attempt to get to consensus on this topic.  Please respond
> with one of the following two options to the list.
>

---

From: Basavaraj Patil <[email-masked]>
Date: Mon, 08 Dec 2008 11:52:36 -0600

Hi Vidya,

The location of the DHCP server is immaterial as per the explanation
provided by Sri at the WG meeting in Minneapolis. The IPv4 support I-D does
not cause any changes to the DHCP protocol.
The choice of where the DHCP server function is located is a matter of
deployment. And the I-D simply explains the possibilities.
What specific reason exists to mandate the DHCP server location in the
context of this I-D?
If the location of the DHCP server in the MAG breaks either PMIP6 or DHCP,
then the WG may want to mandate a specific option. But in the absence of any
such issue (at least from what was clarified by the authors), I do not see a
need for the WG to mandate anything in this case.

-Raj

On 12/8/08 1:11 AM, "ext Narayanan, Vidya" <[email-masked]> wrote:

> All,
> As of the Minneapolis meeting, the WG still seemed undecided about whether or
> not it is a good idea to keep multiple options for the DHCP server location as
> part of the IPv4 spec.
> 
> This is an attempt to get to consensus on this topic.  Please respond with one
> of the following two options to the list.
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 8 Dec 2008 12:28:01 -0800 (PST)

Hi Raj,
  The current draft-06 enables configuring DHCP server/relay per-MN basis.
  Are you saying that this is sufficient?

Regards,

Behcet

________________________________
From: Basavaraj Patil <[email-masked]>
To: "ext Narayanan, Vidya" <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Monday, December 8, 2008 11:52:36 AM
Subject: Re: [netlmm] DHCP Server Options for IPv4 Support

Hi Vidya,

-Raj

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 08 Dec 2008 19:03:20 -0500

Hi Vidya,

> b) Keep the option of having the DHCP Server be located at the MAG in the draft as well. 

I had requested two meetings ago that all normative text in the 
scenarios section be removed and the authors agreed. If that is done, 
there is no major disadvantage in choosing b). If it is not done, then I 
would vote for limiting the MAG to only being a relay.

Thanks
Suresh

---

From: "john.zhao" <[email-masked]>
Date: Wed, 10 Dec 2008 09:29:43 +0800

Hi, Vidya and all
	One cent.
	From system perspective, I would like both of the two options are
listed at there. In addition, from arch perspective, I think it is the best
that there is a way to indicate to MAG about which one is the right choice
for a specific user. So to your question, I choose b.

	Best Rgds,
Thanks,

John.zhao

-----邮件原件-----
All,
As of the Minneapolis meeting, the WG still seemed undecided about whether
or not it is a good idea to keep multiple options for the DHCP server
location as part of the IPv4 spec.  

This is an attempt to get to consensus on this topic.  Please respond with
one of the following two options to the list. 

b) Keep the option of having the DHCP Server be located at the MAG in the
draft as well. 

Thanks,
Vidya

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 10 Dec 2008 18:46:18 -0800

My preference is for a).

I don't think the additional "DHCP deployment flexibility" provided in 
draft-ietf-netlmm-pmip6-ipv4-support-06.txt really helps. It creates 
issues when two SDOs architectures interwork and they happen to use 
different DHCP modes.

We are already facing issues of having to support both DHCP relay and 
DHCP server functions on a MAG at the same time depending on which LMA 
is used for which mobile node. It is not trivial to have the same MAG 
act as both DHCP relay and server at the same time.

Vijay

---

From: Ryuji Wakikawa <[email-masked]>
Date: Thu, 11 Dec 2008 17:37:12 +0100

Hi Vidya

b)

We now have IPv4 DHCP Support Mode option for possible  
interoperability issue
between MAGs and LMA.

regards,
ryuji

On 2008/12/08, at 8:11, Narayanan, Vidya wrote:

> whether or not it is a good idea to keep multiple options for the  
> DHCP server location as part of the IPv4 spec.
>
> This is an attempt to get to consensus on this topic.  Please  
> respond with one of the following two options to the list.
>

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 11 Dec 2008 09:42:24 -0800 (PST)

My preference is for b).

Reason:

Adding to what Raj, Alper and others already pointed out ..

We do not have control on the deployment of network elements, or on
the system architectures. Its not a good idea to force the use of
only a specific mode, when the other mode is adopted by some
architectures. As a general IETF spec, neutral to system architectures,
we should list out the minimal and obvious config modes and specify
how the protocol works in such scenario.

The spec only talks how the address configuration works in Proxy
Mobile IPv6 system. There are no DHCP protocol extensions, its a
general informational text. While there is a preference to collocate
DHCP server with LMA, there are also good reasons to deploy the DHCP
server on a MAG, for reasons of local configuration delivery, Ex:
Local SIP server in the access domain, when configuration operations
are not centralized, or for reasons to avoid the DHCP messages
always being sent to the home network. If this creates an issue in
mix of configurations where multiple modes are used in the same
PMIP domain, as suggested by some folks, the new option that was added
should be sufficient.

Sri

On Thu, 11 Dec 2008, Ryuji Wakikawa wrote:

> Hi Vidya
>
> b)
>
> We now have IPv4 DHCP Support Mode option for possible interoperability issue
> between MAGs and LMA.
>
> regards,
> ryuji
>
>

---

From: "Mohana Jeyatharan" <[email-masked]>
Date: Fri, 12 Dec 2008 12:08:49 +0800

Hi All,

I support option (b). There is no need to restrict the document to
support DHCP functionality at the LMA only. Different deployments can
pick where to locate the DHCP functionality. This is my general view.

BR,
Mohana
> >> b) Keep the option of having the DHCP Server be located at 
> the MAG in 
> >> the draft as well.
> >>

---

From: Julien Laganier <[email-masked]>
Date: Mon, 15 Dec 2008 12:39:52 +0100

Hello Vidya,

I prefare a-bis)

Limit the draft to informative text describing the scenario where the 
MAG is configured as a DHCP relay because:

- it works.
- it's using standard IETF technologies.
- it's not an endorsement of creative DHCP implementations and 
deployments that were not developed in the IETF.
- it does not preculde these creative DHCP implementation to be designed 
elsewhere and deployed where they make sense.

I do not see drawbacks in the above.

--julien

-- 
--julien

---

From: "Jong-Hyouk Lee" <[email-masked]>
Date: Tue, 16 Dec 2008 12:13:54 +0900

Hi, all.

I support the option b.

As Sri pointed, there is no need to restrict the document to force the use
of only a specific mode.
Cheers.
On Mon, Dec 15, 2008 at 8:39 PM, Julien Laganier <

-- 
Internet Management Technology Lab, Sungkyunkwan University.
Jong-Hyouk Lee.

#email: jonghyouk (at) gmail (dot) com
#webpage: http://cv.hurryon.org
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm