Subject: [netlmm] Processing of BRI (Binding Revocation) by MAG

From: "Magesh Shanmugam" <[email-masked]>
Date: Mon, 19 Jan 2009 18:00:27 +0530

Ahmad
 
I have a query regarding the handling of Binding Revocation by MAG for
individual binding session.  
Following is the scenario:
 
Scenario:
 
1. Proxy Mobile Initial Registration, MAG sends PBU to LMA with HNP option
set to ALL_ZERO for MN 1.
2. LMA in turn sends back PBA with 3 HNP(s) assigned to MN 1 and updates
Binding Cache Entry.
3. MAG updates Binding Update List entry and sends Router Advertisement to
the MN with all the 
    prefixes and prefix lifetime. 
    Note: MAG considers the prefix lifetime as binding lifetime and starts
Binding Lifetime timer.
4. Bi-directional tunnel is established between MAG and LMA.  
5. Prefix Route(s) are created for all the prefixes at MAG.
6. MN 1 gets one IP Address from the alloted 3 HNP(s).
7. LMA sends BRI message with one HNP (out of the alloted 3 HNPs) with
revoke trigger as 
   "ADMINISTRATIVE REASON".
 
After step 7, when MAG receives BRI message with only one HNP and MN-ID:
 
Queries:
 
1. Will MAG stop the binding lifetime timer (started after binding session
establishment), due to the
    received BRI message?
2. Will MAG delete the complete Binding Update List maintained for the MN
(MN 1) or will it delete
    only the corresponding HNP entry from the BUL and send RA message to MN
1 (eventhough
    the IP Address used by MN is not from the HNP received in BRI message)?
If it deletes only the
    corresponding HNP entry, what will happen to the Binding Lifetime timer?
 
Thanks
S Magesh
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 19 Jan 2009 08:10:27 -0600

Ahmad
	 
	I have a query regarding the handling of Binding Revocation by
MAG for individual binding session.  
	Following is the scenario:
	 
	Scenario:
	 
	1. Proxy Mobile Initial Registration, MAG sends PBU to LMA with
HNP option set to ALL_ZERO for MN 1.
	2. LMA in turn sends back PBA with 3 HNP(s) assigned to MN 1 and
updates Binding Cache Entry.
	3. MAG updates Binding Update List entry and sends Router
Advertisement to the MN with all the 
	    prefixes and prefix lifetime. 
	    Note: MAG considers the prefix lifetime as binding lifetime
and starts Binding Lifetime timer.
	4. Bi-directional tunnel is established between MAG and LMA.  
	5. Prefix Route(s) are created for all the prefixes at MAG.
	6. MN 1 gets one IP Address from the alloted 3 HNP(s).
	7. LMA sends BRI message with one HNP (out of the alloted 3
HNPs) with revoke trigger as 
	   "ADMINISTRATIVE REASON".
	 
	After step 7, when MAG receives BRI message with only one HNP
and MN-ID:
	 
	Queries:
	 
	1. Will MAG stop the binding lifetime timer (started after
binding session establishment), due to the
	    received BRI message?
	2. Will MAG delete the complete Binding Update List maintained
for the MN (MN 1) or will it delete
	    only the corresponding HNP entry from the BUL and send RA
message to MN 1 (eventhough
	    the IP Address used by MN is not from the HNP received in
BRI message)?  If it deletes only the
	    corresponding HNP entry, what will happen to the Binding
Lifetime timer? 
	 
	[Ahmad]
	If the LMA assigned 3 HNP for MN1, then if the LMA would like to
revoke all of the HNPs, the LMA have one of the following options:
	 
	1. Send BRI with MN-ID option ONLY. This means that all HNPs are
revoked, or
	2. Send a BRI with MN-ID and all HNPs.
	 
	Although, the draft recommend Number 1 BUT does not prevent No.
2.
	 
	On the other hand, if the LMA sends a BRI with MN-ID and a
single HNP, then the MAG MUST consider the revocation of that single HNP
and MUST NOT remove the MN1 from the BUL.
	 
	Hope this help.
	 
	Regards,
	Ahmad 
	 
	Thanks
	S Magesh

---

From: "Magesh Shanmugam" <[email-masked]>
Date: Tue, 20 Jan 2009 12:23:08 +0530

Ahmad
 
My comments inline...
 
Thanks
S Magesh

  _____  

From: Ahmad Muhanna [mailto:[email-masked]] 
Sent: Monday, January 19, 2009 7:40 PM
To: Magesh Shanmugam
Cc: [email-masked]; [email-masked]
Subject: RE: Processing of BRI (Binding Revocation) by MAG

Ahmad

Scenario:

 
Queries:

[Ahmad]
If the LMA assigned 3 HNP for MN1, then if the LMA would like to revoke all
of the HNPs, the LMA have one of the following options:
 
1. Send BRI with MN-ID option ONLY. This means that all HNPs are revoked, or

[Magesh] If there are multiple interfaces (multi-homed) for the same MN,
will MAG remove the Binding Update List maintained for all the interfaces, 
as there is no Link Layer Identifier Option in the BRI message?

Although, the draft recommend Number 1 BUT does not prevent No. 2.
 
On the other hand, if the LMA sends a BRI with MN-ID and a single HNP, then
the MAG MUST consider the revocation of that single HNP and MUST NOT remove
the MN1 from the BUL.
 
[Magesh]
What will be the status of binding lifetime timer?  
Will the timer be running even though the single HNP is removed from BUL
entry (or will the timer be stopped).
 
IMO, if LMA tries to revoke a particular mobility session (Binding Cache
Entry), it has to send the MN-ID and all the 
HNP(s) allocated for the particular session.  Sending of one HNP out of the
allocated n HNP(s) should be 
treated as Invalid Case. The behavior should be same as PBU received from
MAG for De-Registration (where all the
HNP(s) allocated are present in the PBU message).
 
Hope this help.
 
Regards,
Ahmad 
 
Thanks
S Magesh

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 20 Jan 2009 03:55:14 -0600

Ahmad
		 
		I have a query regarding the handling of Binding
Revocation by MAG for individual binding session.  
		Following is the scenario:
		 
		Scenario:
		 
		1. Proxy Mobile Initial Registration, MAG sends PBU to
LMA with HNP option set to ALL_ZERO for MN 1.
		2. LMA in turn sends back PBA with 3 HNP(s) assigned to
MN 1 and updates Binding Cache Entry.
		3. MAG updates Binding Update List entry and sends
Router Advertisement to the MN with all the 
		    prefixes and prefix lifetime. 
		    Note: MAG considers the prefix lifetime as binding
lifetime and starts Binding Lifetime timer.
		4. Bi-directional tunnel is established between MAG and
LMA.  
		5. Prefix Route(s) are created for all the prefixes at
MAG.
		6. MN 1 gets one IP Address from the alloted 3 HNP(s).
		7. LMA sends BRI message with one HNP (out of the
alloted 3 HNPs) with revoke trigger as 
		   "ADMINISTRATIVE REASON".
		 
		After step 7, when MAG receives BRI message with only
one HNP and MN-ID:
		 
		Queries:
		 
		1. Will MAG stop the binding lifetime timer (started
after binding session establishment), due to the
		    received BRI message?
		2. Will MAG delete the complete Binding Update List
maintained for the MN (MN 1) or will it delete
		    only the corresponding HNP entry from the BUL and
send RA message to MN 1 (eventhough
		    the IP Address used by MN is not from the HNP
received in BRI message)?  If it deletes only the
		    corresponding HNP entry, what will happen to the
Binding Lifetime timer? 
		 
		[Ahmad]
		If the LMA assigned 3 HNP for MN1, then if the LMA would
like to revoke all of the HNPs, the LMA have one of the following
options:
		 
		1. Send BRI with MN-ID option ONLY. This means that all
HNPs are revoked, or 
		 
		[Magesh] If there are multiple interfaces (multi-homed)
for the same MN, will MAG remove the Binding Update List maintained for
all the interfaces, 
		as there is no Link Layer Identifier Option in the BRI
message? 
		 
		[Ahmad]
		The intention is to have this work sort of a mini global
revocation. In other words, if the LMA would like to revoke all of the
MN bindings, then including the MN-ID alone will suffice. I do not see
any problem in that and should be applicable to multihomed too. If the
LMA would like to revoke a single HNP, then LMA need to include the one
that needs to be revoked. 

		Although, the draft recommend Number 1 BUT does not
prevent No. 2.
		 
		On the other hand, if the LMA sends a BRI with MN-ID and
a single HNP, then the MAG MUST consider the revocation of that single
HNP and MUST NOT remove the MN1 from the BUL.
		 
		[Magesh]
		What will be the status of binding lifetime timer?  
		Will the timer be running even though the single HNP is
removed from BUL entry (or will the timer be stopped). 
		 
		[Ahmad]
		I probably need to clarify this one. If each HNP maps to
a separate binding, then that binding timer which is defined by the
included HNP should be cancelled. please see more below.   
		 
		[Magesh]
		IMO, if LMA tries to revoke a particular mobility
session (Binding Cache Entry), it has to send the MN-ID and all the 
		HNP(s) allocated for the particular session. Sending of
one HNP out of the allocated n HNP(s) should be treated as Invalid Case.

		 The behavior should be same as PBU received from MAG
for De-Registration (where all the
		HNP(s) allocated are present in the PBU message). 
		 
		[Ahmad]
		I guess we have two cases here. If the BCE is allocated
more than one HNP in the same PBU/PBA, then the LMA should send BRI with
MN-ID and no HNP(s) included to revoke the MN BCE. In this specific
case, if the LMA chooses to include the HNP option, the LMA SHOULD
include all of the allocated HNP(s). IMO, the LMA should include the
MN-ID ONLY and should suffice.
		 
		The other usecase, if the MN with multihoming has
multiple BCE(s) with different HNPs for each BCE. In this case, the LMA
MAY send a BRI to revoke a single BCE, e.g. with HNP=HNP1. In case the
LMA sends a BRI with MN-ID ONLY, i.e. without any HNP(s), the MAG should
handle this as if all of the MN BCE(s) have been revoked. In other
words, if the MN-ID has multiple BCE with different HNP(s), then the
inclusion of the HNP in the BRI is crucial for defining the MN BCE that
is being revoked.
		 
		I will make sure that the text in the draft is clear on
this.
		 
		Regards,
		Ahmad
		 
		Hope this help.
		 
		Regards,
		Ahmad 
		 
		Thanks
		S Magesh