Subject: Re: [netlmm] Extending IPv4 mobility to an existing IPv6 ONLY mobility session

From: "Ahmad Muhanna" <[email-masked]>
Date: Sun, 25 Jan 2009 08:17:19 -0600

Ryuji and Sri,

I am not sure if this question have been answered yet or it went
unnoticed.
Do you have an answer for the question?

Regards,
Ahmad

> -----Original Message-----
> From: Muhanna, Ahmad (RICH1:2H10) 
> Sent: Wednesday, January 21, 2009 5:10 PM
> To: 'Ryuji Wakikawa'; 'Sri Gundavelli'
> Cc: [email-masked]'
> Subject: Extending IPv4 mobility to an existing IPv6 ONLY 
> mobility session
> 
> Hi Ryuji and Sri,
>  
> The following text is under section 3.1.2.1., it says:
>  
>  
>    o  If there exists a Binding Cache entry that can be 
> associated with
>       the request and if it is determined that the request is a re-
>       registration request and with the request to extend IPv4 home
>       address mobility support to the existing IPv6-only mobility
>       session, considerations from Section 3.1.2.2 MUST be 
> applied with
>       respect to IPv4 support.
> 
> What does this bullet is trying to say? My understanding of 
> the above text is as follows:
> If the LMA receives a PBU re-registration which can be 
> associated with an existing IPv6 ONLY mobility session BUT it 
> only has IPv4 HoA option, the LMA should consider this PBU as 
> re-registration to extend (actually offer/request maybe a 
> more appropriate) IPv4 mobility to the existing mobility session?
> 
> Is my understanding correct?
> 
> If yes, which consideration from section 3.1.2.2 is relative to this?
> 
> Thanks!
> 
> Regards,
> Ahmad 
> 
> 
_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Sun, 25 Jan 2009 10:27:53 -0800 (PST)

Hi Ahmad,

> Do you have an answer for the question?

Sorry for the delay.

>> more appropriate) IPv4 mobility to the existing mobility session?

There is an existing IPv6-only mobility session, but the rereg is also for
extending IPv4 mobility support, i.e. the PBU has the IPv4 HoA option in
addition to the IPv6 Home Network prefix option(s), then the
considerations from 3.1.2.2 w.r.t to IPv4 support should be applied.

"request to extend IPv4 home address mobility support to the existing
IPv6-only mobility session"

extend appears ok in this. Any case, this can be clarified better
w.r.t to the presence of both types of options in the request.

Thanks
Sri

---

From: Behcet Sarikaya <[email-masked]>
Date: Sun, 25 Jan 2009 16:19:59 -0800 (PST)

Why do we need to cover this scenario?
Do we have a reverse case too?

Regards,

Behcet

________________________________
From: Sri Gundavelli <[email-masked]>
To: Ahmad Muhanna <[email-masked]>
Cc: [email-masked]
Sent: Sunday, January 25, 2009 12:27:53 PM
Subject: Re: [netlmm] Extending IPv4 mobility to an existing IPv6 ONLY mobility session

Hi Ahmad,

Sorry for the delay.

Thanks
Sri

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 26 Jan 2009 23:13:59 -0600

Hi Sri,

> >> Subject: Extending IPv4 mobility to an existing IPv6 ONLY mobility 
> >> session
> >>
> >> Hi Ryuji and Sri,
> >>
> >>    o  If there exists a Binding Cache entry that can be associated 
> >> with
> >>       session, considerations from Section 3.1.2.2 MUST be applied 
> >> with
> >>       respect to IPv4 support.
> >>
> >> What does this bullet is trying to say? My understanding 
> of the above 
> >> text is as follows:
> >> If the LMA receives a PBU re-registration which can be associated 
> >> with an existing IPv6 ONLY mobility session BUT it only 
> has IPv4 HoA 
> >> option, the LMA should consider this PBU as 
> re-registration to extend 
> >> (actually offer/request maybe a more appropriate) IPv4 mobility to 
> >> the existing mobility session?
> >>
> 
> There is an existing IPv6-only mobility session, but the 
> rereg is also for extending IPv4 mobility support, i.e. the 
> PBU has the IPv4 HoA option in addition to the IPv6 Home 
> Network prefix option(s), then the considerations from 
> 3.1.2.2 w.r.t to IPv4 support should be applied.
> 
> "request to extend IPv4 home address mobility support to the 
> existing IPv6-only mobility session"
> 
> extend appears ok in this. Any case, this can be clarified 
> better w.r.t to the presence of both types of options in the request.

[Ahmad]
The explanation seems straight forward, however, the wording makes it
look far more complex. I support simplification:)

Thanks!

Regards,
Ahmad