Subject: [netlmm] I-D Action:draft-ietf-netlmm-grekey-option-05.txt

From: [email-masked]
Date: Wed, 18 Feb 2009 10:00:01 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network-based Localized Mobility Management Working Group of the IETF.

	Title           : GRE Key Option for Proxy Mobile IPv6
	Author(s)       : A. Muhanna, et al.
	Filename        : draft-ietf-netlmm-grekey-option-05.txt
	Pages           : 24
	Date            : 2009-02-18

This specification defines a new Mobility Option for allowing the
mobile access gateway and the local mobility anchor to negotiate GRE
(Generic Routing Encapsulation) encapsulation mode and exchange the
downlink and uplink GRE keys which are used for marking the downlink
and uplink traffic that belong to a specific mobility session.  In
addition, the same mobility option is used to explicitly negotiate
the GRE encapsulation mode only without exchanging the GRE keys.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-netlmm-grekey-option-05.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Wed, 18 Feb 2009 12:11:01 -0600

Hello Jari and All,
I have submitted a new revision which address all of Jari latest
comments.

Please take a look and let us know if you have any comments. 

We appreciate your comments and help in reviewing this draft.

Many thanks in advance!

Here is a brief list of the changes:
1. Removed the (K) bit from the GRE Key option and made sure that when
GRE encapsulation mode only is negotiated, GRE Key Identifier field is
omitted.

2. Replaced the text which talks about the GRE keys distribution being
out-of-scope in case of GRE encapsulation mode only by "no GRE keys are
used"

3. Addressed the SHOULD vs. MUST Issue, in the case of GRE encapsulation
is NOT required BUT PBU has the GRE key option.

4. Addressed all comments about section 7. 

Regards,
Ahmad

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Wednesday, February 18, 2009 12:00 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [netlmm] I-D Action:draft-ietf-netlmm-grekey-option-05.txt
> 
> This draft is a work item of the Network-based Localized 
> Mobility Management Working Group of the IETF.
> 
> 
> This specification defines a new Mobility Option for allowing 
> the mobile access gateway and the local mobility anchor to 
> negotiate GRE (Generic Routing Encapsulation) encapsulation 
> mode and exchange the downlink and uplink GRE keys which are 
> used for marking the downlink and uplink traffic that belong 
> to a specific mobility session.  In addition, the same 
> mobility option is used to explicitly negotiate the GRE 
> encapsulation mode only without exchanging the GRE keys.
> 
> Below is the data which will enable a MIME compliant mail 
> reader implementation to automatically retrieve the ASCII 
> version of the Internet-Draft.
>

---

From: jouni korhonen <[email-masked]>
Date: Fri, 20 Feb 2009 10:26:16 +0200

Hi Ahmad,

Thanks for the hard work Ahmad. I wanted to say that comments I made  
on the -03 version have been addressed in -05 to a degree I am happy  
with them. I am especially pleased to see the informative stack  
layouts and the ESP text there. Just one question on Section 9. The  
last sentence says: "The IPsec traffic selectors will contain the  
protocol number for GRE, .." How that would work with TLV?

Regarding the TLV encoding, I would prefer the format Henrik proposed  
(and Vijay reminded us about).

Cheers,
	Jouni

On Feb 18, 2009, at 8:11 PM, Ahmad Muhanna wrote:

> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netlmm

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 20 Feb 2009 18:50:29 -0600

Hi Jouni,
Thanks for reviewing the draft one more time and your kind words!
Please see comments inline.

Regards,
Ahmad

> Subject: Few comments on draft-ietf-netlmm-grekey-option-05.txt
> 
> Hi Ahmad,
> 
> Thanks for the hard work Ahmad. I wanted to say that comments 
> I made on the -03 version have been addressed in -05 to a 
> degree I am happy with them. I am especially pleased to see 
> the informative stack layouts and the ESP text there. Just 
> one question on Section 9. The last sentence says: "The IPsec 
> traffic selectors will contain the protocol number for GRE, 
> .." How that would work with TLV?

[Ahmad]
I am assuming that the TLV header wont have any impact in this case.
However, the Next Header field in the TLV header will be set to ESP in
the case of transport mode unless I am missing something. 

> 
> Regarding the TLV encoding, I would prefer the format Henrik 
> proposed (and Vijay reminded us about).

[Ahmad]
Sure. Will include that in the next revision.

> > out-of-scope in case of GRE encapsulation mode only by "no GRE keys 
> > are used"
> >
> > 3. Addressed the SHOULD vs. MUST Issue, in the case of GRE 
> > encapsulation is NOT required BUT PBU has the GRE key option.
> >