Subject: [netlmm] Partial Handoff support in Proxy Mobile IPv6

From: Sri Gundavelli <[email-masked]>
Date: Thu, 19 Mar 2009 19:58:02 -0700 (PDT)

We have posted this draft on extending Proxy Mobile IPv6 protocol
to support partial session handoff. In the context of flow management,
this provides the basic hooks on the network side, for supporting
such semantics.

http://tools.ietf.org/html/draft-jeyatharan-netext-pmip-partial-handoff-00

Which ever WG will eventually have charter for this, ignoring that
aspect, please comment on this.

Thanks
Sri

---

From: "Frank Xia" <[email-masked]>
Date: Thu, 19 Mar 2009 22:45:23 -0500

Hi Sri

I had a chance to quick look.

Flow is regarding applications (there are tons
of  applications), while prefixes are about
addressing which basically serves internet connectivity.

Internet community is trying to separate
identifier from locator regarding IP address semantics.
However, you guys overload IP address (including prefix)
with new meaning  :-)

BR
Frank

----- Original Message ----- 
From: "Sri Gundavelli" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, March 19, 2009 9:58 PM
Subject: [netlmm] Partial Handoff support in Proxy Mobile IPv6

> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netlmm

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 19 Mar 2009 20:55:25 -0700 (PDT)

Hi Frank,

In 5213, as part of the handoff we move all prefixes
associated with a given interface, to some interface
to support inter-tech handoffs. If you look at the
Handoff Indicator values, there are no semantics for
partial address/prefix set movement. This provides the
support for that and the resultant applicability for
partial flow movement, from the traffic mgmt perspective.

So, my intent of saying "flow" is in the above context and
sure its overloaded usage here :)

Sri

On Thu, 19 Mar 2009, Frank Xia wrote:

> ----- Original Message ----- From: "Sri Gundavelli" <[email-masked]>
> To: <[email-masked]>

---

From: "Mohana Jeyatharan" <[email-masked]>
Date: Fri, 20 Mar 2009 12:02:34 +0800

Hi Frank,

Just to add more to what Sri has said, there needs to be support for
such partial handoff of prefixes because in some cases different packet
data networks will handle different prefixes given to a MN. Also, each
of there packet data network will handle different types of traffic.
Thus such collective movements of flows of the same type is essential.
There needs to be support for this.

BR,
Mohana

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Sri Gundavelli
> Sent: Friday, March 20, 2009 11:55 AM
> To: Frank Xia
> Cc: [email-masked]
> Subject: Re: [netlmm] Partial Handoff support in Proxy Mobile IPv6
> 
> Hi Frank,
> 
> associated with a given interface, to some interface to 
> support inter-tech handoffs. If you look at the Handoff 
> Indicator values, there are no semantics for partial 
> address/prefix set movement. This provides the support for 
> that and the resultant applicability for partial flow 
> movement, from the traffic mgmt perspective.
> 
> > Flow is regarding applications (there are tons of  applications), 
> > while prefixes are about addressing which basically serves internet 
> > connectivity.
> >
> > Internet community is trying to separate identifier from locator 
> > regarding IP address semantics.
> > However, you guys overload IP address (including prefix) with new 
> > meaning  :-)
> >
> > BR
> > Frank
> >
> >> to support partial session handoff. In the context of flow 
> >> management,  this provides the basic hooks on the network 
> side, for 
> >> supporting  such semantics.
> >>
> >>  
> >>

---

From: "Frank Xia" <[email-masked]>
Date: Thu, 19 Mar 2009 23:45:54 -0500

Hi Mohana

Does the solution satify the following requirement?

There are two interfaces (3GPP and WLAN) on which
3 application (2 for 3GPP and 1 for WLAN) are runing on them.

Now, one of the application on 3GPP interafce is expected
to move to the WLAN interface.

BR
Frank

----- Original Message ----- 
From: "Mohana Jeyatharan" <[email-masked]>
To: "Sri Gundavelli" <[email-masked]>; "Frank Xia" 
<[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, March 19, 2009 11:02 PM
Subject: RE: [netlmm] Partial Handoff support in Proxy Mobile IPv6

Hi Frank,

BR,
Mohana

---

From: "Mohana Jeyatharan" <[email-masked]>
Date: Fri, 20 Mar 2009 13:33:32 +0800

Hi Frank,

I think, the scenario you have in mind is more tied to flow mobility.
For this support you need the same HNP across MN interfaces. 

But, partial handoff is completely removing a prefix from an interface
and transferring to another interface. It is tansferring all flows that 
belongs to one or more prefixes from one interface to a new interface 
or existing interface.

So partial handoff can also achieve the transferrig of flows tied to an 
application to another interface by tansferring the prefix to another
interface. 

BR,
Mohana

> From: Frank Xia [mailto:[email-masked]] 
> Sent: Friday, March 20, 2009 12:46 PM
> To: Mohana Jeyatharan; Sri Gundavelli
> Cc: [email-masked]
> Now, one of the application on 3GPP interafce is expected to 
> move to the WLAN interface.
> 
> BR
> Frank
>

---

From: Frank Xia <[email-masked]>
Date: Fri, 20 Mar 2009 09:42:16 -0500

Hi Mohana

Partial handoff  seems not to solve flow mobility.

Then, what is problem you are trying to solve?
Could you explain the scenarios?

BR
Frank

----- Original Message ----- 
From: "Mohana Jeyatharan" <[email-masked]>
To: "Frank Xia" <[email-masked]>; "Sri Gundavelli" 
<[email-masked]>
Cc: <[email-masked]>
Sent: Friday, March 20, 2009 12:33 AM
Subject: RE: [netlmm] Partial Handoff support in Proxy Mobile IPv6

Hi Frank,

BR,
Mohana

---

From: Sri Gundavelli <[email-masked]>
Date: Fri, 20 Mar 2009 07:51:27 -0700 (PDT)

Frank,

The flow movement is for the flows associated with a prefix or prefixes
and not a random set of flows. Movement purely on a flow basic requires
same of set of prefixes on multiple interfaces. Sure, that can be another
goal, but thats not the scope of this work. This just allows partial
prefix movement, extending handoff indicator. We should ignore the term
flow movement here.

Sri

On Fri, 20 Mar 2009, Frank Xia wrote:

> ----- Original Message ----- From: "Mohana Jeyatharan" 
> <[email-masked]>

---

From: Frank Xia <[email-masked]>
Date: Fri, 20 Mar 2009 10:04:03 -0500

Hi Sri

I  want to  understand what the problem you are
trying to solve, and what the use case is behind the solution.
You can temporarily leave away your solution for a while.

As for different understanding on flow movement and
partial handoff,  I prefer expressing my opinion after
I understand the background.

BR
Frank

----- Original Message ----- 
From: "Sri Gundavelli" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Cc: "Mohana Jeyatharan" <[email-masked]>; 
<[email-masked]>
Sent: Friday, March 20, 2009 9:51 AM
Subject: Re: [netlmm] Partial Handoff support in Proxy Mobile IPv6

---

From: Sri Gundavelli <[email-masked]>
Date: Fri, 20 Mar 2009 08:11:59 -0700 (PDT)

Hi Frank,

Sure. That's fair. Lets see if this topic will be broadly
covered in any of the WG presentations, covering all the use
cases.

Specifically in this context of partial handoff, the draft
has some use cases ...etc, may be you can take a look and see
how this fits in to the broad work of flow movement. But, the
scope of this work is very much limited to partial prefix
movement, a specific missing case in 5213.

Thanks
Sri

---

From: Frank Xia <[email-masked]>
Date: Fri, 20 Mar 2009 10:22:00 -0500

Hi Sri

Good.
This give us more topics  for face-to-face
discussing in the IETF meeting.

BR
Frank

----- Original Message ----- 
From: "Sri Gundavelli" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Cc: "Mohana Jeyatharan" <[email-masked]>; 
<[email-masked]>
Sent: Friday, March 20, 2009 10:11 AM
Subject: Re: [netlmm] Partial Handoff support in Proxy Mobile IPv6

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 20 Mar 2009 08:19:00 -0700 (PDT)

Hi Sri,
  Isn't this what David said earlier in netext list, written in draft form? I suggest acknowledging him.
  
Regards,

Behcet

________________________________
From: Sri Gundavelli <[email-masked]>
To: [email-masked]
Sent: Thursday, March 19, 2009 9:58:02 PM
Subject: [netlmm] Partial Handoff support in Proxy Mobile IPv6

Thanks
Sri

---

From: Sri Gundavelli <[email-masked]>
Date: Fri, 20 Mar 2009 10:54:43 -0700 (PDT)

>   Isn't this what David said earlier in netext list, written in draft form? I suggest acknowledging him.

??? Said what ?

I'm not on the netext list and dont know who said what.
But, I can certainly say thanks to any one who agreed
with this. Thanks David !

Sri

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 20 Mar 2009 12:32:53 -0700 (PDT)

Hi Sri,
  Here is the story:
http://www.mobileip.jp/pipermail/netext/20090311/000195.html
is the link to David's message talking about it.

I am quite confused now, because David was referring to Sec. 2.1 of draft-jeyatharan-netext-multihoming-ps-01.txt. This draft was issued on March 9 and immediately announced in netext. 

Your draft was announced on March 3 http://www.ietf.org/mail-archive/web/i-d-announce/current/msg24282.html and first-authored by the same person. But never announced before today in netlmm. Also draft-jeyatharan-netext-multihoming-ps-01.txt in Sec. 2.1 seems to be written in a way not to be aware of a solution that was submitted a week ago.

  So let me correct myself, the idea was not by David but he brought attention to the idea. All parties in the discussion (Rajeev, Mohana, Carlos) circa March 9-10-11 did not mention your draft.

Regards,

Behcet

________________________________
From: Sri Gundavelli <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Friday, March 20, 2009 12:54:43 PM
Subject: Re: [netlmm] Partial Handoff support in Proxy Mobile IPv6

??? Said what ?

Sri

---

From: Sri Gundavelli <[email-masked]>
Date: Fri, 20 Mar 2009 12:57:09 -0700 (PDT)

Behcet,

> I am quite confused now,
..
>   So let me correct myself, the idea was not by David but he brought 
attention to the idea.

Dont be confused ..that much of detailed focus not needed for
this discussion. I'm just trying to get some interest for the
work at a high level ...

I'm looking at this work item, as minor and independent
extension which should have been in 5213 and that
we discussed before. Vijay and me thought, we should have
covered this earlier and we could not. Trying to see how
this can be done quickly and wherever it fits. The mult-homing
work etc have different goal and scope, but will present this
there as well for completeness ..., to avoid such confusion..

Thanks
Sri