Subject: [netlmm] I-D Action:draft-ietf-netlmm-grekey-option-07.txt

From: [email-masked]
Date: Sun, 26 Apr 2009 17:45:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network-based Localized Mobility Management Working Group of the IETF.

	Title           : GRE Key Option for Proxy Mobile IPv6
	Author(s)       : A. Muhanna, et al.
	Filename        : draft-ietf-netlmm-grekey-option-07.txt
	Pages           : 24
	Date            : 2009-04-26

This specification defines a new Mobility Option for allowing the
Mobile Access Gateway and the Local Mobility Anchor to negotiate GRE
(Generic Routing Encapsulation) encapsulation mode and exchange the
downlink and uplink GRE keys which are used for marking the downlink
and uplink traffic that belong to a specific mobility session.  In
addition, the same mobility option can be used to negotiate the GRE
encapsulation mode without exchanging the GRE keys.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-netlmm-grekey-option-07.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Yungui Wang <[email-masked]>
Date: Thu, 30 Apr 2009 08:40:28 +0800

Okey, SHOULD is fine. 

B.R.
Yungui 

> -----Original Message-----
> From: Ahmad Muhanna [mailto:[email-masked]] 
> Sent: Wednesday, April 29, 2009 8:00 PM
> To: [email-masked]
> Subject: RE: [netlmm] FW: I-D 
> Action:draft-ietf-netlmm-grekey-option-07.txt
> 
> Hi,
> 
> > > > -----Original Message-----
> > > > From: Yungui Wang [mailto:[email-masked]]
> > > > Sent: Tuesday, April 28, 2009 9:50 PM
> > > > To: Muhanna, Ahmad (RICH1:2H10); [email-masked]
> > > > Subject: RE: [netlmm] FW: I-D
> > > > Action:draft-ietf-netlmm-grekey-option-07.txt
> > > > 
> > > > 
> > > > It is just an example. Maybe I-D 'LMA redirection' 
> described case 
> > > > could be for your information.
> > > [Ahmad]
> > > Okay.. Is it GRE renumbering or LMA reboot or LMA 
> > redirection ... By 
> > > the time we get to the scenario you have in mind we have a 
> > long list 
> > > of different terms and high level description of things that you 
> > > somehow assume they are synonymous:)
> > > 
> > 
> > In my mind, the GRE renumbering may happen in case of LMA 
> > reboot or LMA redirection or manual operation or something 
> > else.  Is this relationship not correct? Of course, I have to 
> > say I can't explain these scenarios in two or three words.
> > 
> > > > However, re-numbering GRE
> > > > key may be possible.
> > > > 
> > > > On the other side, why doesn't the draft emphasize that 
> 'MAG MUST 
> > > > carry the same downlink GRE key...' during re-registration? :)
> > > 
> > > [Ahmad]
> > > Well.. You seem to think that these two cases are alike:) 
> > At any point 
> > > of time, if the MAG decides to change the MN session 
> > downlink GRE key, 
> > > it could send a PBU and negotiate a new GRE keys? Can the 
> > LMA do the 
> > > same?
> > > 
> > 
> > Good question. As the draft's author, could you tell me the 
> > answer? Do you think MAG should have the special right over 
> > LMA on processing GRE key of MN session? If yes, why?
> [Ahmad]
> It is NOT a matter of allowing the MAG to have special right vs. not
> special right.
> It is the limitation of the protocol which we need to understand and
> take in consideration.
> 
> > 
> > > In my mind, the case of LMA reboot, assuming that the LMA 
> lost the 
> > > state of the MN BCE, there is an out of synch state 
> between the LMA 
> > > and the MAG anyway. I believe from the LMA prospective, the case 
> > > probably falls under the initial registration rather than 
> > > re-registration. We need to minimize loss of traffic by NOT 
> > > introducing a loose requirement which allows NOT an 
> > implementation to 
> > > change the uplink GRE without paying attention to the 
> fact that MAY 
> > > cause some serious loss of traffic.
> > > 
> > 
> > Allowing it doesn't mean inducing it done. I had said, 
> > "Normally, the LMA will return the same uplink GRE key during 
> > re-registration. ...". 
> > I just thought, it is not necessary to make that too restricted.
> [Ahmad]
> That's good. Your initial recommendation is to remove the word "same"
> completely, which I disagree.
> That is what needed from a constructive discussion. In my 
> mind, there is
> a rare case where the LMA may maintain or get hold of the MN BCE state
> in a failure (reboot) scenario, somehow, or an LMA 
> redirection where the
> state is moved to another LMA. In that case, the LMA needs the
> flexibility to generate a new GRE key. That is understood BUT rare.
> 
> In this case, we should allow the LMA to do that by easing the
> restriction and replace "MUST" with "SHOULD".
> 
> Do you mind posting this on the mailing list. It is important for the
> list to know the conclusion. 
> I do not see your posting as an attempt to delay the draft.
> 
> > 
> > B.R.
> > Yungui
> > 
> > > > 
> > > > 
> > > > B.R.
> > > > Yungui
> > > >   
> > > > 
> > > > > -----Original Message-----
> > > > > From: Ahmad Muhanna [mailto:[email-masked]]
> > > > > Sent: Wednesday, April 29, 2009 9:54 AM
> > > > > To: [email-masked]; [email-masked]
> > > > > Subject: RE: [netlmm] FW: I-D
> > > > > Action:draft-ietf-netlmm-grekey-option-07.txt
> > > > > 
> > > > > 
> > > > > 
> > > > > Hmmmmm... Interesting ...
> > > > > What kind of reboot is the one you have in mind which only
> > > > cause the
> > > > > loss of the uplink GRE key?
> > > > > May be it is better to understand the scenario you have in
> > > > mind before
> > > > > we start looking into recommendations and opinions......
> > > > > 
> > > > > Regards,
> > > > > Ahmad
> > > > > 
> > > > > > -----Original Message-----
> > > > > > From: Yungui Wang [mailto:[email-masked]]
> > > > > > Sent: Tuesday, April 28, 2009 8:08 PM
> > > > > > To: Muhanna, Ahmad (RICH1:2H10); [email-masked]
> > > > > > Subject: RE: [netlmm] FW: I-D
> > > > > > Action:draft-ietf-netlmm-grekey-option-07.txt
> > > > > > 
> > > > > > 
> > > > > > Hello
> > > > > > 
> > > > > > In the draft, there are multiple paragraphs mentioned 
> > 'LMA MUST 
> > > > > > return the same uplink GRE key...'. I am not sure why it
> > > > emphasizes
> > > > > > the word 'same'. Normally, the LMA will return the same
> > > > uplink GRE
> > > > > > key during re-registration. However, in some certain
> > > > cases, the LMA
> > > > > > may re-number GRE key (such as reboot, etc.). Thus,
> > > > 'same' should be
> > > > > > deleted.
> > > > > > 
> > > > > > B.R.
> > > > > > Yungui
> > > > > > 
> > > > > > > -----Original Message-----
> > > > > > > From: [email-masked]
> > > > > > > [mailto:[email-masked]] On Behalf Of 
> Ahmad Muhanna
> > > > > > > Sent: Monday, April 27, 2009 8:59 AM
> > > > > > > To: [email-masked]
> > > > > > > Subject: [netlmm] FW: I-D
> > > > > > > Action:draft-ietf-netlmm-grekey-option-07.txt
> > > > > > > 
> > > > > > > 
> > > > > > > Hi,
> > > > > > > 
> > > > > > > We submitted a new revision of the GRE key draft which
> > > > > > addresses all
> > > > > > > the comments we received during the IESG Discuss and
> > > > one offline
> > > > > > > comment which addresses an overlook of the LMA behavior
> > > > > > with respect
> > > > > > > to the inclusion of uplink GRE key in the PBA when
> > > receiving a
> > > > > > > re-registration PBU. We just added some text to capture
> > > > > the obvious.
> > > > > > > 
> > > > > > > Please let us know if you have any comments.
> > > > > > > 
> > > > > > > Regards,
> > > > > > > Ahmad
> > > > > > > 
> > > > > > > -----Original Message-----
> > > > > > > From: [email-masked] 
> > > > > > > [mailto:[email-masked]] On Behalf Of 
> > > > > > > [email-masked]
> > > > > > > Sent: Sunday, April 26, 2009 7:45 PM
> > > > > > > To: [email-masked]
> > > > > > > Cc: [email-masked]
> > > > > > > Subject: I-D Action:draft-ietf-netlmm-grekey-option-07.txt
> > > > > > > 
> > > > > > > A New Internet-Draft is available from the on-line
> > > > > Internet-Drafts
> > > > > > > directories.
> > > > > > > This draft is a work item of the Network-based
> > > > Localized Mobility
> > > > > > > Management Working Group of the IETF.
> > > > > > > 
> > > > > > > 
> > > > > > > downlink and uplink GRE keys which are used for 
> marking the
> > > > > > downlink
> > http://www.ietf.org/internet-drafts/draft-ietf-netlmm-grekey-o
> > > > > > > ption-07.t
> > > > > > > xt
> > > > > > >