Subject: [netlmm] FW: next steps for netext

From: Jari Arkko <[email-masked]>
Date: Fri, 03 Apr 2009 09:57:23 +0200

FYI -- comments appreciated:

Jari Arkko wrote:
> In the meeting we ended up having a big argument about the multihoming 
> and handover parts. I don't know what to do about that yet, but I 
> would still like to suggest that the other parts should move forward. 
> I edited the charter from the web site. Comments appreciated:
>
> -------
>
> Network-Based Mobility Extensions (NETEXT)
>
> Last Modified: 2009-04-03
>
> Chair(s):
> TBD
>
> Internet Area Director(s):
> Ralph Droms <[email-masked]>
> Jari Arkko <[email-masked]>
>
> Internet Area Advisor:
> TBD
>
> Mailing Lists:
> http://www.mobileip.jp/mailman/listinfo/netext
>
> Description of Working Group:
>
> Proxy Mobile IPv6, specified in RFC 5213, is a network-based mobility 
> protocol. It uses a Mobile Access Gateway (MAG) and a Local Mobility 
> Anchor (LMA) to allow hosts to move around within a domain while 
> keeping their address or address prefix stable. Proxy Mobile IPv6 has 
> been incorporated into a number of products and deployments are 
> starting. Certain deployment considerations, including localized 
> routing and bulk refresh of lifetime are already emerging.
>
> The working group will focus on the following topics relevant for 
> network-based mobility:
>
> Localized Routing: a specification for routing traffic between the 
> MAG(s) without involving the LMA. That is, allow the MAGs to route 
> traffic between hosts from one MAG to another, without being tunneled 
> all the way to the LMA. This reduces latency and backhaul load. 
> Applications such as voice can benefit from the reduced latency. Hosts 
> are not affected, as they still send and receive their packets via the 
> MAG.
>
> Bulk Refresh: a specification of improving the signaling load for 
> binding lifetime refresh. The current specifications call for the 
> handling of each mobility session independent of each other. When a 
> large number of hosts are served by a single MAG, a periodic refresh 
> of the binding lifetimes can lead to a signaling storm. The purpose of 
> the Bulk Refresh feature is to construct a protocol feature that 
> allows such refreshes to occur on a per-MAG basis.
>
> LMA Redirection: a specification for allowing an LMA to redirect a MAG 
> to another LMA. This is primarily needed as a way to perform load 
> balancing, and is complementary to the initial LMA discovery work in 
> the NETLMM WG.
>
> The proposed activity will be complementary to the existing IETF 
> Working Groups, notably the NETLMM and MEXT WGs.  The NETEXT working 
> group will also act as the primary forum where new extensions on top 
> of the Proxy Mobile IPv6 protocol can be developed. The addition of 
> such new extensions to the working group involves addition of the 
> extension to this charter through the normal rechartering process.
>
> Milestones
>
> May 2009             WG chartered
> July 2009              Initial WG draft on Bulk Refresh
> September 2009  Initial WG draft on LMA Redirection
> November 2009   Initial WG draft on Route Optimization
> December 2009   Submit Bulk Refresh to IESG for publication as a 
> Proposed Standard RFC
> January 2009       Submit LMA Redirection to IESG for publication as a 
> Proposed Standard RFC
> April 2010            Submit Route Optimization to IESG for 
> publication as a Proposed Standard RFC
>
>

---

From: Junghoon Jee <[email-masked]>
Date: Fri, 3 Apr 2009 17:34:45 +0900

Hi Jari,

I have a comment about the proposed item of the "Localized Routing".
My comment is inline.

2009/4/3 Jari Arkko <[email-masked]>:
>> In the meeting we ended up having a big argument about the multihoming and
>> handover parts. I don't know what to do about that yet, but I would still
>> like to suggest that the other parts should move forward. I edited the
>> charter from the web site. Comments appreciated:
>>
>> -------
>>
>> protocol. It uses a Mobile Access Gateway (MAG) and a Local Mobility Anchor
>> (LMA) to allow hosts to move around within a domain while keeping their
>> address or address prefix stable. Proxy Mobile IPv6 has been incorporated
>> into a number of products and deployments are starting. Certain deployment
>> considerations, including localized routing and bulk refresh of lifetime are
>> already emerging.
>>
>> Localized Routing: a specification for routing traffic between the MAG(s)
>> without involving the LMA. That is, allow the MAGs to route traffic between
>> hosts from one MAG to another, without being tunneled all the way to the
>> LMA. This reduces latency and backhaul load. Applications such as voice can
>> benefit from the reduced latency. Hosts are not affected, as they still send
>> and receive their packets via the MAG.

It seems to me that this localized routing aims to reduce the handover
latency of PMIPv6.
Regarding the reduction of the handover latency, there may be various
ways to realize that.
The mentioned way of routing traffic between MAG and MAG would be one way.
I'd say that is one way not the only way that NETEXT should follow.
Therefore, I am questioning whether we can expand this item more
broadly like "Reducing Latency".
By defining the charter item this way, we could give a chance that
more competitive solutions can compete.
This eventually makes a better protocol which would be accepted more widely.

>> Bulk Refresh: a specification of improving the signaling load for binding
>> lifetime refresh. The current specifications call for the handling of each
>> mobility session independent of each other. When a large number of hosts are
>> served by a single MAG, a periodic refresh of the binding lifetimes can lead
>> to a signaling storm. The purpose of the Bulk Refresh feature is to
>> construct a protocol feature that allows such refreshes to occur on a
>> per-MAG basis.
>>
>> LMA Redirection: a specification for allowing an LMA to redirect a MAG to
>> another LMA. This is primarily needed as a way to perform load balancing,
>> and is complementary to the initial LMA discovery work in the NETLMM WG.
>>
>> The proposed activity will be complementary to the existing IETF Working
>> Groups, notably the NETLMM and MEXT WGs.  The NETEXT working group will also
>> act as the primary forum where new extensions on top of the Proxy Mobile
>> IPv6 protocol can be developed. The addition of such new extensions to the
>> working group involves addition of the extension to this charter through the
>> normal rechartering process.
>>
>> Milestones
>>
>> May 2009             WG chartered
>> December 2009   Submit Bulk Refresh to IESG for publication as a Proposed
>> Standard RFC
>> April 2010            Submit Route Optimization to IESG for publication as
>> a Proposed Standard RFC
>>
>>
>
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netlmm
>

Best Regards,
Junghoon

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 3 Apr 2009 08:14:51 -0700 (PDT)

Hi Jari,
  I agree with and support this charter proposal.
As some people indicate there are many other things out there but they have not been discussed in the BoF and we don't know the consensus issue.
  Regards,

Behcet

________________________________
From: Jari Arkko <[email-masked]>
To: "[email-masked]" <[email-masked]>
Sent: Friday, April 3, 2009 2:57:23 AM
Subject: [netlmm] FW: next steps for netext

Jari Arkko wrote:
> In the meeting we ended up having a big argument about the multihoming and handover parts. I don't know what to do about that yet, but I would still like to suggest that the other parts should move forward. I edited the charter from the web site. Comments appreciated:
> 
> -------
> 
> Proxy Mobile IPv6, specified in RFC 5213, is a network-based mobility protocol. It uses a Mobile Access Gateway (MAG) and a Local Mobility Anchor (LMA) to allow hosts to move around within a domain while keeping their address or address prefix stable. Proxy Mobile IPv6 has been incorporated into a number of products and deployments are starting. Certain deployment considerations, including localized routing and bulk refresh of lifetime are already emerging.
> 
> The working group will focus on the following topics relevant for network-based mobility:
> 
> Localized Routing: a specification for routing traffic between the MAG(s) without involving the LMA. That is, allow the MAGs to route traffic between hosts from one MAG to another, without being tunneled all the way to the LMA. This reduces latency and backhaul load.. Applications such as voice can benefit from the reduced latency. Hosts are not affected, as they still send and receive their packets via the MAG.
> 
> Bulk Refresh: a specification of improving the signaling load for binding lifetime refresh. The current specifications call for the handling of each mobility session independent of each other. When a large number of hosts are served by a single MAG, a periodic refresh of the binding lifetimes can lead to a signaling storm. The purpose of the Bulk Refresh feature is to construct a protocol feature that allows such refreshes to occur on a per-MAG basis.
> 
> LMA Redirection: a specification for allowing an LMA to redirect a MAG to another LMA. This is primarily needed as a way to perform load balancing, and is complementary to the initial LMA discovery work in the NETLMM WG.
> 
> The proposed activity will be complementary to the existing IETF Working Groups, notably the NETLMM and MEXT WGs.  The NETEXT working group will also act as the primary forum where new extensions on top of the Proxy Mobile IPv6 protocol can be developed. The addition of such new extensions to the working group involves addition of the extension to this charter through the normal rechartering process.
> 
> Milestones
> 
> May 2009            WG chartered
> December 2009  Submit Bulk Refresh to IESG for publication as a Proposed Standard RFC
> January 2009      Submit LMA Redirection to IESG for publication as a Proposed Standard RFC
> April 2010            Submit Route Optimization to IESG for publication as a Proposed Standard RFC
> 
>

---

From: "Koodli, Rajeev" <[email-masked]>
Date: Fri, 3 Apr 2009 12:08:09 -0400

Hi Junghoon,
 
I am not sure if you have been following NetExt, but the problem (i.e., Localized Routing) is scoped to be protocol development involving MAG - MAG and LMA - MAG. This is a continuation of what is referred to in RFC 5213. 
 
Regards,
 
-Rajeev

From: [email-masked] on behalf of Junghoon Jee
Sent: Fri 4/3/2009 1:34 AM
To: Jari Arkko
Cc: [email-masked]
Subject: Re: [netlmm] FW: next steps for netext

Hi Jari,

Best Regards,
Junghoon

---

From: Hesham Soliman <[email-masked]>
Date: Tue, 07 Apr 2009 00:26:33 +1100

Looks good Jari. 

Hesham

---

From: Junghoon Jee <[email-masked]>
Date: Tue, 7 Apr 2009 12:06:50 +0900

Hi Rajeev,

I am deeply interested in optimizing the PMIP like many operators who
are curiously investing the possibility of adopting PMIP into their
infrastructures for various services.

Yes, Rajeev. I have not been following NetExt. Therefore, I was little
bit hesitated to share my view on this specific work.
However, I thought that it's not so late because I tend to believe
that cleaning up the charter is a starting point which needs not to be
so specific toward a specific solution.

Again, It seems to me that the current language for this specific item
in the proposed charter is little bit specific.

BR,
Junghoon