Subject: Re: [netlmm] [dhcwg] Request for review of draft-xia-netlmm-lma-discovery-01.txt

From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 04 May 2009 14:34:23 +0300

Hi,

I agree with Vijay. So far there has been no identified need to have 
DHCP client functionality in the MAG. MAG is basically infrastructure 
equipment and I wonder if DHCP is really the right technology for it.

In addition, I don't know if Vidya has, but I at least I have not asked 
for any official review of this document, which is just an individual draft.

Cheers,

Jonne.
ext Vijay Devarapalli wrote:
> Behcet,
>
> We had numerous discussions on this in the past. The MAG is not a DHCP
> client according to any of the specifications we have so far. I don't think
> it makes sense for the MAG to implement DHCP client functionality just to
> obtain the LMA IP address.
>
> Moreover, the MAG acting as a DHCP client doesn't is not valid in any of the
> SDO architectures that are using PMIPv6.
>
> We shouldn't extend protocols just because we can.
>
> Vijay
>
> On 4/29/09 12:20 PM, "Behcet Sarikaya" wrote:
>
>   
>> Hi Ted,
>>   The reason we wrote this draft is already stated in netlmm charter
>> (http://www.ietf.org/html.charters/netlmm-charter.html) item 6 which states
>> that:
>> 6) Automatic LMA discovery: This will define the ability for MAGs to
>> automatically discover and use an LMA within a PMIPv6 domain. The
>> scope of this effort may include specifying the use of DNS or DHCP
>> based LMA discovery or LMA discovery using policy information
>> retrieved via AAA protocols
>>
>>   At the moment we don't know if netlmm will adopt this draft. There is
>> another draft co-authored by Vijay which is about some other non-DHCP means of
>> LMA discovery, hence Vijay's intervention here .
>>   Based on the above having a quick preliminary review by DHC WG will be quite
>> helpful to netlmm folks.
>>  
>> Regards,
>>  
>> Behcet
>>
>> From: Ted Lemon <[email-masked]>
>> To: Vijay Devarapalli <[email-masked]>
>> Cc: dhc WG <[email-masked]>; "[email-masked]" <[email-masked]>
>> Sent: Wednesday, April 29, 2009 1:00:49 PM
>> Subject: Re: [dhcwg] Request for review of
>> draft-xia-netlmm-lma-discovery-01.txt
>>
>> On Apr 29, 2009, at 12:39 PM, Vijay Devarapalli wrote:
>>     
>>> I am not sure who requested this draft to be reviewed by the DHC WG.
>>> There is no consensus in the NETLMM WG at this point for the PMIPv6 MAG
>>> function to use DHCPv6 to obtain the LMA IP address. So any DHC WG
>>> review would be premature at this point.
>>>       
>> My motivation in asking for review of this document before it's been adopted
>> by the netlmm working group as a work item, is that it appears to make a
>> rather novel use of the DHCPv6 protocol.  Unless the netlmm working group has
>> already decided not to adopt this draft, I think it makes some sense for you
>> to consider feedback from the DHC working group on the draft when you are
>> deliberating on whether or not to adopt the draft as a netlmm working group
>> item.
>>
>> So if in fact there is no likelihood that the netlmm working group will adopt
>> this draft, it would certainly save us some effort to know that.  Otherwise I
>> think actually this is a good time for the DHC working group to give the draft
>> a quick preliminary review.
>>
>> _______________________________________________
>> dhcwg mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dhcwg
>>
>>  
>>     
>
> _______________________________________________
> netlmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netlmm
>

---

From: Frank Xia <[email-masked]>
Date: Mon, 04 May 2009 10:33:45 -0500

Hi Jonne

I don't get the logic you have.

Our protocol design servers  business requirment.
I believe if there is a solid scenario, there is
no reason for us  to refuse it just  say "currently
there is no ready DHCP client".

BTW, we did not ask DHC group to review before
the Ted commented it.

BR
Frank

----- Original Message ----- 
From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
To: "ext Vijay Devarapalli" <[email-masked]>
Cc: "dhc WG" <[email-masked]>; <[email-masked]>; "Ted Lemon" 
<[email-masked]>
Sent: Monday, May 04, 2009 6:34 AM
Subject: Re: [netlmm] [dhcwg] Request for review 
ofdraft-xia-netlmm-lma-discovery-01.txt

> Hi,
>
> I agree with Vijay. So far there has been no identified need to have DHCP 
> client functionality in the MAG. MAG is basically infrastructure equipment 
> and I wonder if DHCP is really the right technology for it.
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 4 May 2009 09:47:16 -0700 (PDT)

Hi Jonne,
  Your argument seems to contradict netlmm charter.
If you read the charter, it clearly says DHCP based LMA discovery is possible, for you convenience I give the link: http://www.ietf.org/html.charters/netlmm-charter.html

Maybe you were away when the charter was drafted and discussed and agreed upon on the ML and unfortunately couldn't make your concerns known.

Kind regards,

Behcet

________________________________
From: "Soininen, Jonne (NSN - FI/Espoo)" <jonne.soininen@nsn..com>
To: ext Vijay Devarapalli <[email-masked]>
Cc: Behcet Sarikaya <[email-masked]>; Ted Lemon <[email-masked]>; dhc WG <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Monday, May 4, 2009 6:34:23 AM
Subject: Re: [netlmm] [dhcwg] Request for review of draft-xia-netlmm-lma-discovery-01.txt

Hi,

I agree with Vijay. So far there has been no identified need to have DHCP client functionality in the MAG. MAG is basically infrastructure equipment and I wonder if DHCP is really the right technology for it.

In addition, I don't know if Vidya has, but I at least I have not asked for any official review of this document, which is just an individual draft.

Cheers,

Jonne.
ext Vijay Devarapalli wrote:
>> LMA discovery, hence Vijay's intervention here ..

---

From: Frank Xia <[email-masked]>
Date: Mon, 04 May 2009 12:12:26 -0500

Hi Folks

You are most appreciated on commenting the scenario!

LMA and HA are mostly collocated in real deployments,
and LMA/HA availability information is stored in
a DHCP server in some cases. How does the MAG 
retrieve the LMA information from the DHCP server?

Some addtional information is appendixed for helping
you in evaluating the scenario:
1) LMA/HA are  usually collocated in 3GPP/3GPP2
   /WiMAX.   That is, LMA/HA have the same IP address.
2)http://tools.ietf.org/id/draft-ietf-mip6-hiopt-17.txt 
  is used for a mobile node to fetch HA information 
  from a DHCP server in Mobile IPv6
3) 3GPP 24.303 adopts "Home agent address 
   discovery based on DHCPv6"
4)DHCP client function is enabled for
 a mobile router in draft 
 http://tools.ietf.org/id/draft-ietf-mext-nemo-pd-02.txt

BR
Frank

---

From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 05 May 2009 14:30:18 +0300

Hi,

Yes, we are allowed to work on the topic - no question about it. However,

I'm just personally arguing that it is not very useful. At least I think
DHCP based LMA discovery is not good for PMIP. For client based MIP it makes
more sense.

Cheers,

Jonne. 

On 5/4/09 7:47 PM, "ext Behcet Sarikaya" <[email-masked]> wrote:

> If you read the charter, it clearly says DHCP based LMA discovery is possible,
> for you convenience I give the link:
> http://www.ietf.org/html.charters/netlmm-charter.html
> 
> Maybe you were away when the charter was drafted and discussed and agreed upon
> on the ML and unfortunately couldn't make your concerns known.
> 
> Kind regards,
> 
> Behcet
> 
> 
> 
> 
> Cc: Behcet Sarikaya <[email-masked]>; Ted Lemon <[email-masked]>; dhc WG
> <[email-masked]>; "[email-masked]" <[email-masked]>
> client functionality in the MAG. MAG is basically infrastructure equipment and
> I wonder if DHCP is really the right technology for it.
> 
> In addition, I don't know if Vidya has, but I at least I have not asked for
> any official review of this document, which is just an individual draft.
> 
> Cheers,
> 
> Jonne.

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34
E-mail: [email-masked]

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 5 May 2009 07:17:40 -0700 (PDT)

Hi Jonne,
  Pls see inline.

Regards,

Behcet

From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Sent: Tuesday, May 5, 2009 6:30:18 AM
Subject: Re: [netlmm] [dhcwg] Request for review of draft-xia-netlmm-lma-discovery-01.txt

[behcet] glad to hear that.

[behcet] What our draft is doing is to reuse what was defined for client MIP in hiopt for PMIP, no additional requirement there. The only additional architectural addition needed for this is DHCP Client at the MAG. For various reasons if you have a Relay Agent entity you will also have DHCP Client entity. 
 
IETF should follow the charter and offer all these various ways of LMA discovery and then sometime in the future we will see which one survives, isn't this the right approach?

Cheers,

Jonne. 

On 5/4/09 7:47 PM, "ext Behcet Sarikaya" <[email-masked]> wrote:

>>> LMA discovery, hence Vijay's intervention here ...

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34

Hi,

---

From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Wed, 06 May 2009 10:10:02 +0300

Behcet,

Please, see below:

On 5/5/09 5:17 PM, "ext Behcet Sarikaya" <[email-masked]> wrote:
<snip>

> [behcet] What our draft is doing is to reuse what was defined for client MIP
> in hiopt for PMIP, no additional requirement there. The only additional
> architectural addition needed for this is DHCP Client at the MAG. For various
> reasons if you have a Relay Agent entity you will also have DHCP Client
> entity. 

And like said, though DHCP based HA discovery is fine for _client_ mobile
IP, it makes IMHO absolutely no sense _Proxy_ Mobile IP.

>  
> IETF should follow the charter and offer all these various ways of LMA
> discovery and then sometime in the future we will see which one survives,
> isn't this the right approach?

First, we also do follow the charter in case we do not standardize DHCP
based LMA discovery - so the charter does not restrict us at all here.

Second, it is not the idea of standardization to standardize a load of
options. The idea is to make good, interoperable specifications. I think the
DHCP based LMA discovery is useful, and thus, would not make it in the
market place. Specifying this option would just confuse people, and thus, be
more harmful.

Cheers,

Jonne.

>> and

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34

---

From: Frank Xia <[email-masked]>
Date: Wed, 06 May 2009 09:55:52 -0500

Hi Jonne

Why dont you have a look  my email
on "Evaluation of  DHCP LMA discovery
scenario"?　Let focus on real requirement.

BR
Frank

----- Original Message ----- 
From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
To: "Behcet Sarikaya" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, May 06, 2009 2:10 AM
Subject: Re: [netlmm] [dhcwg] Request for review of 

Behcet,

Please, see below:

Cheers,

Jonne.

>> for
>>>> another draft co-authored by Vijay which is about some other non-DHCP 
>>>> means
>>>> of
>>>> rather novel use of the DHCPv6 protocol. Unless the netlmm working 
>>>> group
>>>> has
>>>> already decided not to adopt this draft, I think it makes some sense 
>>>> for
>>>> you
>>>> this draft, it would certainly save us some effort to know that. 
>>>> Otherwise
>>>> I
>>>> think actually this is a good time for the DHC working group to give 
>>>> the
>>>> draft

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 6 May 2009 13:44:24 -0700 (PDT)

Hi Jonne,
  Please see below.

Kind regards,

Behcet

Sent: Wednesday, May 6, 2009 2:10:02 AM

Yes we can work on DNS based methods but we do not have to standardize a load of options. Same for AAA protocol based LMA discovery and combinations thereof.
I think my argument makes equal sense. 
Behcet,

Please, see below:

[Behcet] OK, then my counter argument is: DNS based HA discovery is good for Client Mobile IP but not for Proxy Mobile.. Because MN using DNS is well known technique, I don't think we can say the same for MAG using DNS?