Subject: Re: [netlmm] [netext] revised charter for the working group

From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
Date: Fri, 08 Jan 2010 09:55:03 +0200

Hi Frank,

On 1/7/10 7:28 PM, "ext Frank Xia" <[email-masked]> wrote:

[snip.]
>> 
>> <netlmm chair hat on>
>> DHCP has been mentioned in the current netlmm charter. However, it is just
>> one option, there has not been any commitment to the work - just the
>> possibility if there would be consensus for the work.
>> 
>> There was a discussion some time ago, and there was no consensus to do
>> DHCP
>> based LMA discovery. People at that point found that it was not a useful
>> solution. Hence, it has not been specified.
>> 
>> You brought it up again some weeks ago. However, nobody else has supported
>> it. Therefore we (the chairs) have not seen a need to change our opinions
>> on
>> the consensus.
> Frank=> How many people expresses their technical points?  It is very clear
> you
> said something 
> http://www.ietf.org/mail-archive/web/netlmm/current/msg06382.html
> in which  I did not see technical points.
> I dont know where your consensus opinion came from.
> AFAIK, these people supported the DHC: Behcet, Frank, Sri, Jong-Hyouk Lee.
> The following people were against this: you, Vijay.

The discussion died and nobody has supported you in this discussion for a
long time. If these people (outside you and Behcet) still support this idea,
I'm sure they're going to speak up. If there is enough support adding DHCP
option into the current spec is possible. However, you do need support.

Lack of discussion and expression of support == no support. That's how it
works.

>> </chair hat off>
[snip]

>> 
>> <netlmm chair hat on>
>> There has been absolutely no consensus to add this to the WG draft that is
>> still under discussion (draft-ietf-netlmm-lma-discovery). If you want
>> something in, you have to get support. If you don't get support, you don't
>> get it in.
> Frank=>Don't mix concepts  between slience and  "no consensus".
> AFAIK Julien also had similar idea, please check
> http://www.ietf.org/mail-archive/web/netlmm/current/msg06183.html.

Silence is the same as no support. It is true that Julien described the
solution that you later put in a draft on the mailing list pretty early on.
However, I have not seen him - or anybody else except you - support the
standardization of the described method.

If there is support, the things can change. However, you need support first.

I hope this is now clear enough. If your ideas are useful and important I'm
sure you have no problem of getting support for them. Currently, there is
none.

Sorry for everybody on netext list. This later part of the discussion would
be more suited for the netlmm mailing list. However, as the discussion
started on the new charter topic, I thought it would be good for people to
understand the background.

Frank, if you want to continue to discuss the DHCP and DNS options, let's do
it at the netlmm list.

Cheers,

Jonne.

> 
>> 
>> Just having an I-D and just the authors pushing for it is not quite
>> enough.
> Frank=>Every one knows this topic is not brain surgury.  IMHO, people keep
> silent just because of lacking interest.   It will be great if you encourage
> people to express their technical points.
> 
>> 
>> </netlmm chair hat off>
>> 
>> <individual>
>> I believe that there has been no support for this work in netlmm. If there
>> is no significant change in support, I think it would be strange to take
>> up
>> something in netext that has been already discarded in netlmm.
>> 
>> Of course, the support and the need for these or any other possible
>> solutions may change over time. Let's have this discussion when we are at
>> that stage, though.
>> </individual>
>> 
>> Cheers,
>> 
>> Jonne.
>> 
>>> 
>>> BR
>>> Frank
>>> 
>>> ----- Original Message -----
>>> From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
>>> To: "ext Frank Xia" <[email-masked]>; "jouni"
>>> <[email-masked]>; "Behcet Sarikaya" <[email-masked]>
>>> Cc: <[email-masked]>
>>> Sent: Thursday, January 07, 2010 10:14 AM
>>> Subject: Re: [netext] revised charter for the working group
>>> 
>>> 
>>>> Hi Frank,
>>>> 
>>>> I don't care either. However, my understanding is that we have settled
>>>> it
>>>> already - at least until now there has been no support for DHCP based
>>>> LMA
>>>> discovery.
>>>> 
>>>> This may change over time of course. However, I don't think it has
>>>> changed
>>>> enough to take this as a charter item in netext.
>>>> 
>>>> Cheers,
>>>> 
>>>> Jonne.
>>>> 
>>>> 
>>>> On 1/7/10 5:59 PM, "ext Frank Xia" <[email-masked]> wrote:
>>>> 
>>>>> Hi Jonne
>>>>> 
>>>>> In fact, I don't care too much about where to settle this down.
>>>>> 
>>>>> I only have a little bit sense of discouragement in
>>>>> technical disussion in NETLMM on this topic.
>>>>> 
>>>>> BR
>>>>> Frank
>>>>> 
>>>>> ----- Original Message -----
>>>>> From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
>>>>> To: "ext Frank Xia" <[email-masked]>; "jouni"
>>>>> <[email-masked]>; "Behcet Sarikaya" <[email-masked]>
>>>>> Cc: <[email-masked]>
>>>>> Sent: Thursday, January 07, 2010 3:33 AM
>>>>> Subject: Re: [netext] revised charter for the working group
>>>>> 
>>>>> 
>>>>>> Hi,
>>>>>> 
>>>>>> It seems that Frank and Behcet have decided to bring this up here.
>>>>>> 
>>>>>> We have extensively discussed the DCHP-based discovery over the last
>>>>>> months
>>>>>> in the netlmm list, and there has never been support for it. I
>>>>>> understand
>>>>>> that the authors of the draft are keen on this. However, support from
>>>>>> other
>>>>>> people have been lacking.
>>>>>> 
>>>>>> So, I don't support taking this up here.
>>>>>> 
>>>>>> Cheers,
>>>>>> 
>>>>>> Jonne.
>>>>>> 
>>>>>> 
>>>>>> On 1/5/10 11:14 PM, "ext Frank Xia" <[email-masked]> wrote:
>>>>>> 
>>>>>>> Hi Jouni
>>>>>>> 
>>>>>>> At the first, it is not a bad idea to discuss DHCP-based solution.
>>>>>>> 
>>>>>>> Even with DNS solution, IMHO, it seems good
>>>>>>> to consider to elaborate the draft with information
>>>>>>> from
>>>>>>> http://tools.ietf.org/id/draft-sarikaya-netlmm-lma-dnsdiscovery-01.txt.
>>>>>>> 
>>>>>>> BR
>>>>>>> Frank
>>>>>>> 
>>>>>>> 
>>>>>>> ----- Original Message -----
>>>>>>> From: "jouni" <[email-masked]>
>>>>>>> To: "Behcet Sarikaya" <[email-masked]>
>>>>>>> Cc: <[email-masked]>
>>>>>>> Sent: Tuesday, January 05, 2010 1:31 PM
>>>>>>> Subject: Re: [netext] revised charter for the working group
>>>>>>> 
>>>>>>> 
>>>>>>>> Behcet,
>>>>>>>> 
>>>>>>>> 
>>>>>>>> On Jan 5, 2010, at 7:36 PM, Behcet Sarikaya wrote:
>>>>>>>> 
>>>>>>>>> Hi Jari,
>>>>>>>>>   Would it be possible to also move Netlmm Charter Item 6 into
>>>>>>>>> NetExt?
>>>>>>>>> With the currently adopted solution, LMA discovery is far from
>>>>>>>>> being
>>>>>>>>> resolved. Some scenarios that are important remain uncovered.
>>>>>>>>> Solutions
>>>>>>>>> parallel to MIPv6 solutions have somehow gone unrecognized. I think
>>>>>>>>> this
>>>>>>>>> is against basic design principles of PMIPv6.
>>>>>>>> 
>>>>>>>> Are you again referring with all this to your DHCP-based solution
>>>>>>>> for
>>>>>>>> LMA
>>>>>>>> discovery?
>>>>>>>> 
>>>>>>>> JOuni
>>>>>>>> 
>>>>>>>> 
>>>>>>>>>   In fact LMA discovery is not rocket science. If this item is
>>>>>>>>> moved
>>>>>>>>> to
>>>>>>>>> NetExt, a working group draft can be obtained very quickly.
>>>>>>>>> 
>>>>>>>>> Regards,
>>>>>>>>> 
>>>>>>>>> Behcet
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> ----- Original Message ----
>>>>>>>>>> From: Jari Arkko <[email-masked]>
>>>>>>>>>> To: [email-masked]
>>>>>>>>>> Sent: Mon, January 4, 2010 6:32:44 PM
>>>>>>>>>> Subject: [netext] revised charter for the working group
>>>>>>>>>> 
>>>>>>>>>> All,
>>>>>>>>>> 
>>>>>>>>>> I would like to propose some text for the working group's new
>>>>>>>>>> charter,
>>>>>>>>>> based on
>>>>>>>>>> discussions in IETF-76 about the outcome of the cross-interface
>>>>>>>>>> handover
>>>>>>>>>> and
>>>>>>>>>> flow mobility work. Please see the attachments for the new charter
>>>>>>>>>> text
>>>>>>>>>> and diff
>>>>>>>>>> to the current one. Comments appreciated, as always.
>>>>>>>>>> 
>>>>>>>>>> We are also moving one work item from the NETLMM working group
>>>>>>>>>> here,
>>>>>>>>>> as
>>>>>>>>>> the
>>>>>>>>>> former group is winding down.
>>>>>>>>>> 
>>>>>>>>>> Jari
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> _______________________________________________
>>>>>>>>> netext mailing list
>>>>>>>>> [email-masked]
>>>>>>>>> https://www.ietf.org/mailman/listinfo/netext
>>>>>>>> 
>>>>>>>> _______________________________________________
>>>>>>>> netext mailing list
>>>>>>>> [email-masked]
>>>>>>>> https://www.ietf.org/mailman/listinfo/netext
>>>>>>> 
>>>>>>> _______________________________________________
>>>>>>> netext mailing list
>>>>>>> [email-masked]
>>>>>>> https://www.ietf.org/mailman/listinfo/netext
>>>>>> 
>>>>>> -- 
>>>>>> Jonne Soininen
>>>>>> Nokia Siemens Networks
>>>>>> 
>>>>>> Tel: +358 40 527 46 34
>>>>>> E-mail: [email-masked]
>>>>>> 
>>>>>> 
>>>>> 
>>>> 
>>>> -- 
>>>> Jonne Soininen
>>>> Nokia Siemens Networks
>>>> 
>>>> Tel: +358 40 527 46 34
>>>> E-mail: [email-masked]
>>>> 
>>>> 
>>> 
>> 
>> -- 
>> Jonne Soininen
>> Nokia Siemens Networks
>> 
>> Tel: +358 40 527 46 34
>> E-mail: [email-masked]
>> 
>> 
> 

-- 
Jonne Soininen
Nokia Siemens Networks

Tel: +358 40 527 46 34
E-mail: [email-masked]

---

From: Frank Xia <[email-masked]>
Date: Fri, 08 Jan 2010 10:36:07 -0600

Hi Jonne

Besides my inline reply, please also
check the following additional comments.

Let do this thing in a constructive way.
Just don't regard silence as consensus.

You as a co-chair encourage people
to express their technical points.
Discussion can produce high quality document
from the WG. You have talents to make people talk !
( For example, If no one is against DHC
solution from technical perpspetive, we
will include this as proposed in the charter :-)  )

I will muzzle my mouth if  people
think the solution does not work.

1) Please check DHC solution in
http://www.ietf.org/mail-archive/web/netlmm/current/msg06163.html

2)Please also check DNS solution
http://tools.ietf.org/id/draft-sarikaya-netlmm-lma-dnsdiscovery-01.txt.

BR
Frank

----- Original Message ----- 
From: "Soininen, Jonne (NSN - FI/Espoo)" <[email-masked]>
To: "ext Frank Xia" <[email-masked]>; "jouni" 
<[email-masked]>; "Behcet Sarikaya" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, January 08, 2010 1:55 AM
Subject: Re: [netext] revised charter for the working group

> option into the current spec is possible. However, you do need support.
Frank=>Why do you still say that?  I gave you the names who supported this.
Only You and Vijay were against this.

> standardization of the described method.
Frank=>When  you talk about history,  please check section "Dynamic LMA"
of http://tools.ietf.org/id/draft-xia-netlmm-radius-00.txt
which covered the main idea of
 http://tools.ietf.org/id/draft-ietf-netlmm-lma-discovery-02.txt.

> understand the background.
Frank=>Jonne, don't worry about this. Most mobile IP people subscribe
both :-)

> Frank, if you want to continue to discuss the DHCP and DNS options, let's 
Frank=>Sure