Subject: Re: [netlmm] Review of LMA Discovery document

From: Christian Vogt <[email-masked]>
Date: Mon, 3 May 2010 07:27:03 +0200

Jouni Korhonen wrote:

> Agree that they are not show-stoppers. Maybe the document could emphasize more clearly that the DNS administrator just has to know what he's doing. Enhancing the first paragraph slightly.
> 
>   A number of LMA discovery solutions described in Section 2 and
>   Section 3 eventually depend on the DNS.  This section discusses
>   impacts of the DNS response caching and issues related to the Dynamic
>   DNS [RFC2136] updates. The impacts and related issues can mostly be
>   avoided by a proper DNS administration that takes PMIPv6 domain
>   deployment aspects into consideration.

Excellent.  I think this text would be very good to have in the document.

- Christian

---

From: Christian Vogt <[email-masked]>
Date: Mon, 3 May 2010 07:31:40 +0200

Behcet:

Right, this document does not describe a DNS-based LMA discovery method.  But it analyzes some potential issues with such a method, and my comments relate to this analysis.  I felt that it be noteworthy that some of the potential issues can be avoided by proper implementation and administration.

Does this make sense?

- Christian

On Apr 30, 2010, at 21:37, Behcet Sarikaya wrote:

> Hi Christian,
> 
>   The way DNS is used in the draft is how an ordinary host makes a DNS query.
> 
>   This is no DNS based LMA discovery. I think you (and Julien) had already indicated this in your mails to the list earlier. RFC 5026-like DNS discovery has been described in our draft as we had indicated many times in the list.  In fact DNS based LMA discovery in PMIPv6 is much more secure and efficient that MIPv6 DNS discovery of HAs.
> 
> My suggestion is to drop totally Section 4 as this section is artificial without a real DNS discovery solution and instead merge draft-sarikaya-netlmm-lma-dnsdiscovery-01
> 
> 
> with this draft.
> 
> Regards,
> 
> Behcet
> ----- Original Message ----
>> From: Christian Vogt <[email-masked]>
>> To: NETLMM Mailing List <[email-masked]>
>> Cc: jouni korhonen <[email-masked]>
>> Sent: Thu, April 29, 2010 4:53:40 PM
>> Subject: [netlmm] Review of LMA Discovery document
>> 
>> Folks,
> 
> Jouni asked me to review the LMA Discovery document.  I did 
>> this, and
> found that the document is mature and well written, and should 
>> be
> progressed further as soon as possible.  I have just one comment 
>> on
> section 4:
> 
> Section 4 gives two classes of reasons not to use the 
>> DNS for LMA
> discovery.  The first class is related to update propagation 
>> latencies
> caused by caching.  The second class is related to update 
>> latencies
> caused by primary-to-secondary server synchronization.  My 
>> comment
> relates to the first class of reasons:
> 
> Can't the issues 
>> described be well avoided?  In deployments where the
> DNS is to be used 
>> for LMA discovery, make sure you have DNS
> implementations that accept low 
>> TTLs, and set your TTLs low -- that
> seems to be it.  I agree that the 
>> issues you are describing do need to
> be considered, and hence it is very 
>> important to document them.  But I
> personally don't see them as 
>> show-stoppers.
> 
> This said, your second class of reasons may be more 
>> intractable.
> 
> Hope this helps.  Best regards,
> 
> - 
>> Christian
> 
> _______________________________________________
> netlmm 
>> mailing list
>> href="mailto:[email-masked]">[email-masked]
>> href="https://www.ietf.org/mailman/listinfo/netlmm" target=_blank 
>>> https://www.ietf.org/mailman/listinfo/netlmm
> 
> 
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 5 May 2010 08:13:40 -0700 (PDT)

----- Original Message ----
> To: Behcet Sarikaya <[email-masked]>
> Cc: NETLMM Mailing List <[email-masked]>; jouni korhonen <[email-masked]>
> Sent: Mon, May 3, 2010 12:31:40 AM
> Subject: Re: [netlmm] Review of LMA Discovery document
> 
> Behcet:

Right, this document does not describe a DNS-based LMA discovery 
> method.  But it analyzes some potential issues with such a method, and my 
> comments relate to this analysis.  I felt that it be noteworthy that some 
> of the potential issues can be avoided by proper implementation and 
> administration.

> Does this make sense?

Only if Jouni adds a normative reference to where this is described, i.e. 
http://tools.ietf.org/id/draft-sarikaya-netlmm-lma-dnsdiscovery-03.txt

Regards,

Behcet

---

From: Christian Vogt <[email-masked]>
Date: Wed, 5 May 2010 19:33:00 +0200

> http://tools.ietf.org/id/draft-sarikaya-netlmm-lma-dnsdiscovery-03.txt

I am sure Jouni will be able to do this.

- Christian

---

From: <[email-masked]>
Date: Wed, 5 May 2010 20:03:11 +0200

Why normative?
You can put it as an Informative reference.

-Raj

On 5/5/10 12:33 PM, "ext Christian Vogt" <[email-masked]>
wrote:

> netlmm mailing list
> [email-masked]

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 5 May 2010 11:35:13 -0700 (PDT)

Raj, the right solution is to merge the two drafts.
What is the point of talking about caching issues of DNS based LMA discovery without giving a solution?

----- Original Message ----
> From: "[email-masked]" <[email-masked]>
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Sent: Wed, May 5, 2010 1:03:11 PM
Why normative?
You can put it as an Informative 
> reference.

-Raj

On 5/5/10 12:33 PM, "ext Christian Vogt" 
> <> href="mailto:[email-masked]">[email-masked]>
wrote:

>> Only if Jouni 
> adds a normative reference to where this is described, i.e.
>> 
> netlmm mailing 
> list

---

From: "Soininen, Jonne (NSN-FI/Espoo)" <[email-masked]>
Date: Thu, 06 May 2010 17:52:26 +0300

Hi,

There is no reason to add this document as a reference as it is currently
not going anywhere. It is not part of any charter and not on an individual
track either. Thus, it cannot be a reference.

> without giving a solution?

You don't merge drafts at this point. The other one is a WG draft, and if
the WG wishes to add something to that draft it is just added to that draft.
However, there needs to be some support to do that.

Cheers,

Jonne.

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 10 May 2010 15:25:33 -0700 (PDT)

Hi Jonne,
  It is rather strange that we sometimes forget the past.

Here, as an example, about a year ago this message has been posted on netlmm list:

http://www.ietf.org/mail-archive/web/netlmm/current/msg06132.html

which suggested merging the drafts. 

 At your speed, I bet you next year this time, we are gonna be discussing the same things and each side arguing the same way 
J
 
while there is such a simple way out.
 
Behcet

________________________________
Hi,

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Tue, 11 May 2010 23:36:01 -0700

Behcet,
We've discussed this topic enough and it's time to move on. As Jonne said, there is a WG document and if there is sufficient consensus, things can be added/changed there.  However, there isn't sufficient consensus to add what you are asking.  Hence, we need to move on instead of endlessly discussing this.  

Thanks,
Vidya

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Monday, May 10, 2010 3:26 PM
To: Soininen, Jonne (NSN-FI/Espoo)
Cc: [email-masked]
Subject: Re: [netlmm] Review of LMA Discovery document

Hi Jonne,

 
 
Behcet

---

From: Frank Xia <[email-masked]>
Date: Wed, 12 May 2010 09:37:37 -0500

Hi Vidya

IMHO, "endlessly discussing "only means
a small tug-of-war between chairs and us.

You push this topic without pay enough 
attention on technical issues. 

BR
Frank

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Narayanan, Vidya
Sent: Wednesday, May 12, 2010 1:36 AM
To: Behcet Sarikaya; Soininen, Jonne (NSN-FI/Espoo)
Cc: [email-masked]
Subject: Re: [netlmm] Review of LMA Discovery document

Behcet,
We've discussed this topic enough and it's time to move on. As Jonne said,
there is a WG document and if there is sufficient consensus, things can be
added/changed there.  However, there isn't sufficient consensus to add what
you are asking.  Hence, we need to move on instead of endlessly discussing
this.  

Thanks,
Vidya

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Behcet Sarikaya
Sent: Monday, May 10, 2010 3:26 PM
To: Soininen, Jonne (NSN-FI/Espoo)
Cc: [email-masked]
Subject: Re: [netlmm] Review of LMA Discovery document

Hi Jonne,

Here, as an example, about a year ago this message has been posted on netlmm
list:

 At your speed, I bet you next year this time, we are gonna be discussing
the same things and each side arguing the same way 
J

Behcet

On 5/5/10 9:35 PM, "ext Behcet Sarikaya" <[email-masked]> wrote:

> What is the point of talking about caching issues of DNS based LMA
discovery
> without giving a solution?

---

From: "Soininen, Jonne (NSN-FI/Espoo)" <[email-masked]>
Date: Wed, 12 May 2010 21:26:50 +0300

Frank,

The issue seems to be really between you and us chairs. It seems that the
rest of the WG is not interested. If you have a complaint about our
behavior, please, address our AD, who is in the cc-field.

Please, take this off-line now. I think we (the chairs) have made our
assessment of the situation.

Cheers,

Jonne.

---

From: Frank Xia <[email-masked]>
Date: Wed, 12 May 2010 14:06:03 -0500

Hi Jonne

I posted the scenario, and am waiting for the response
of the technical comments. In fact, I have talked to
some people in the WG off-line, they were wondering why
you objected the DHCP case without convincing reason.

DHCP solution is stated in the WG charter. 
It is not necessary to take all things in the charter as
things keep changing, however, I think we should do adequate 
technical evaluation.

BR
Frank

-----Original Message-----
From: Soininen, Jonne (NSN-FI/Espoo) [mailto:[email-masked]] 
Sent: Wednesday, May 12, 2010 1:27 PM
To: ext Frank Xia; Vidya Narayanan; 'Behcet Sarikaya'
Cc: [email-masked]; Jari Arkko
Subject: Re: [netlmm] Review of LMA Discovery document

Frank,

Cheers,

Jonne.