Subject: Re: [netlmm] FW: I-D Action:draft-ietf-netlmm-lma-discovery-04.txt

From: "Soininen, Jonne (NSN-FI/Espoo)" <[email-masked]>
Date: Tue, 01 Jun 2010 11:15:31 +0300

Hi Frank,

On 6/1/10 6:53 AM, "ext Frank Xia" <[email-masked]> wrote:

> Hi Jonne
> 
> I would like to stop debating this with you
> because it seems that you won't try to solve the
> problem in a constructive way.

Sorry, I think I've given you a way to push your scenario: Get support.
However, you have not been able to get it. As soon as you get support for
your scenario there most probably will be more discussion.

Perhaps, it is just not the right time for DHCP based LMA discovery. You
always have the time to post your draft to netext and try get it forward
there independently of the current draft.

> 
> However, I would like to post the following
> arguments later so that relevant people would
> have some technical comments eventually.
> 
> As for "Automatic LMA discovery" WG item, Netlmm
> charter says " This will define the ability for MAGs
> to automatically discover and use an LMA within a
> PMIPv6 domain. The scope of this effort may include
> specifying the use of DNS or DHCP based LMA discovery
> or LMA discovery using policy information retrieved
> via AAA protocols"
> 
> DHCP solution is valuable for the scenario that
> LMA and HA are collocated (e.g. in 3GPP/WiMAX),
> and LMA/HA availability information is  stored
> in a DHCP server( 3GPP 24.303  "Home agent
> address discovery based on DHCPv6").

Just to put the record straight here: 3GPP does not use, and is currently
not planning to use DHCP for LMA discovery. It does not fit the
architecture, and has no purpose in 3GPP system.

Maybe you should take a look at the 3GPP specs on SAE bearer establishment,
and you'll notice your mistake on this.

DHCP does fit for HA discovery, when the HA is local to the network where
the MN comes up. However, setting up infrastructure elements (MAGs) is a bit
different. 

> 
> The chairs try to exclude DHCP solution from the
> chartered WG item without soliciting enough
> technical comments.

Frank, this topic has been up now for a very long time. You have not been
able to demonstrate any support for your point of view. Please, find the
people to support your point of view - with technical arguments.

This is the only thing you have to do.

Cheers,

Jonne.

> 
> BR
> Frank
> 
> -----Original Message-----
> From: Soininen, Jonne (NSN-FI/Espoo) [mailto:[email-masked]]
> Sent: Monday, May 31, 2010 5:20 AM
> To: ext Frank Xia; [email-masked]
> Subject: Re: [netlmm] FW: I-D Action:draft-ietf-netlmm-lma-discovery-04.txt
> 
> Hi Frank,
> 
> 
> On 5/27/10 6:12 PM, "ext Frank Xia" <[email-masked]> wrote:
> 
>> Hi Jonne
>> 
>> Could you stop pushing this without solving
>> the existing problems?
> 
> I don't really understand what problems you are referring to. I know that
> there is a scenario that you have been pushing, but has not got any support
> on the list.
> 
>> 
>> If you can not find a way, here is my suggestion:
>> You can ask some experts except you chairs and authors
>> in the WG to review the DHCP scenarios that I posted,
>> and send their comments in the mailing list.
> 
> This is the last-call of a WG document. I've seen that you have tried to
> rally support for your scenarios. Everybody who thinks that this scenario is
> missing from the document can comment on the last call and ask it to be
> added. Then we can have a debate about it - if needed.
> 
> However, only you have been supporting your own proposal. Nobody else has
> written any supportive comments.
> 
> I assure you that the WG is open to comments to this document. However, if
> there are none. There is nothing to consider.
> 
> Cheers,
> 
> Jonne.
> 
>> 
>> BR
>> Frank
>> 
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of
>> Soininen, Jonne (NSN-FI/Espoo)
>> Sent: Thursday, May 27, 2010 4:11 AM
>> To: [email-masked]
>> Subject: [netlmm] FW: I-D Action:draft-ietf-netlmm-lma-discovery-04.txt
>> 
>> Hello,
>> 
>> Jouni has published a new version of the LMA discovery document. Please,
>> take a look to see if this version is acceptable for publishing as an RFC.
>> 
>> Cheers,
>> 
>> Jonne.
>> ------ Forwarded Message
>>> From: "ext [email-masked]" <[email-masked]>
>>> Reply-To: <[email-masked]>
>>> Date: Mon, 24 May 2010 08:00:01 -0700 (PDT)
>>> To: <[email-masked]>
>>> Cc: "[email-masked]" <[email-masked]>
>>> Subject: I-D Action:draft-ietf-netlmm-lma-discovery-04.txt
>>> 
>>> A New Internet-Draft is available from the on-line Internet-Drafts
>>> directories.
>>> This draft is a work item of the Network-based Localized Mobility
>> Management
>>> Working Group of the IETF.
>>> 
>>> 
>>> Title           : LMA Discovery for Proxy Mobile IPv6
>>> Author(s)       : J. Korhonen, V. Devarapalli
>>> Filename        : draft-ietf-netlmm-lma-discovery-04.txt
>>> Pages           : 10
>>> Date            : 2010-05-24
>>> 
>>> Large Proxy Mobile IPv6 deployments would benefit from a
>>> functionality, where a Mobile Access Gateway could dynamically
>>> discover a Local Mobility Anchor for a Mobile Node attaching to a
>>> Proxy Mobile IPv6 domain.  The purpose of the dynamic discovery
>>> functionality is to reduce the amount of static configuration in the
>>> Mobile Access Gateway.  This document describes several possible
>>> dynamic Local Mobility Anchor discovery solutions.
>>> 
>>> A URL for this Internet-Draft is:
>>> 
> http://www.ietf.org/internet-drafts/draft-ietf-netlmm-lma-discovery-04.txt
>>> 
>>> Internet-Drafts are also available by anonymous FTP at:
>>> ftp://ftp.ietf.org/internet-drafts/
>>> 
>>> Below is the data which will enable a MIME compliant mail reader
>>> implementation to automatically retrieve the ASCII version of the
>>> Internet-Draft.
>>> _______________________________________________
>>> I-D-Announce mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/i-d-announce
>>> Internet-Draft directories: http://www.ietf.org/shadow.html
>>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>> 
>> ------ End of Forwarded Message
>> 
>> 
>

---

From: Frank Xia <[email-masked]>
Date: Tue, 01 Jun 2010 15:14:49 -0500

Hi Jonne

Please see my inlines.

I am also waiting for others who are from the 
WG members, Ads, or IESG to comment technically.

BR
Frank

-----Original Message-----
From: Soininen, Jonne (NSN-FI/Espoo) [mailto:[email-masked]] 
Sent: Tuesday, June 01, 2010 3:16 AM
To: ext Frank Xia; [email-masked]
Subject: Re: [netlmm] FW: I-D Action:draft-ietf-netlmm-lma-discovery-04.txt

Hi Frank,

Frank=>When we discussed in NETEXT, you asked us to come back to NETLMM.
Now you would like to separate them. Please don't give people wrong
impression which is that you are pushing your own company's document
whatever ways you take :-) 

Just to put the record straight here: 3GPP does not use, and is currently
not planning to use DHCP for LMA discovery. 
Frank=>What about DNS for LMA discovery?
Probably this is the missing part, and we are going to bring it up.

It does not fit the architecture, and has no purpose in 3GPP system.
Frank=>Probably you are too confident when you say these. 
3GPP system has been evolving to solve real problems and 
accommodate new requirements. By the way, I just illustrated 
a general scenario which 3GPP is only one possible network.

Maybe you should take a look at the 3GPP specs on SAE bearer establishment,
and you'll notice your mistake on this.
Frank=>Maybe you just point out what's wrong with the scenario which
is simple so that every one can make a judgement even without 3GPP
background.
I prefer not debating 3GPP architectural issue here

DHCP does fit for HA discovery, when the HA is local to the network where
the MN comes up. 
Frank=>HA/LMA can be local or remote, and our proposal is consistent with
solution which is specified in " DHCP Options for Home Information 
Discovery in MIPv6 "(draft-ietf-mip6-hiopt-17.txt).

However, setting up infrastructure elements (MAGs) is a bit
different.
Frank=>Could you make it more specific?

Frank=> IMO, silence does not mean opposition. However, you are the 
chair who is responsible for the quality of the deliverable
of the WG.  No offense, as a chair, your strong negative technical 
comments are not encouraging open discussion  :-).  

Cheers,

Jonne.

> Subject: Re: [netlmm] FW: I-D
Action:draft-ietf-netlmm-lma-discovery-04.txt

---

From: "Soininen, Jonne (NSN-FI/Espoo)" <[email-masked]>
Date: Thu, 03 Jun 2010 17:15:30 +0300

Hi Frank,

I really hope that other people would talk to this point. It seems that we
have one person pushing for a technology and complaining me having a bias on
this topic.

For the record, yes, the author of this document does work for the same
company as I do. Yes, this is a possible conflict of interest. However, we
are not talking about pushing a document that would be "my employer's
draft". We have a working group document, which we - as the WG - would like
to get finished.

Frank and Behcet, you have proposed additions to the WG document. However,
as far as I can see, it is just you. There are no other people active in
this discussion. Nobody is voicing their support for your proposal.

If other people are, I hope they feel free to comment. Only way to measure
support in the IETF is by seeing who speaks up. I know that both of you
state that there would be support that people have indicated to you
privately. Maybe you can encourage them to become public on the list.

I think we should stop discussing the administrative issue here. Frank, and
Behcet, if you have an objection or concerns to the process of this WG,
or/and my impartiality as a chair, I hope you know you can always complain
to Jari and bring this issues up with him.

However, as my impartiality has been put under question, I think the
cleanest thing is to have Vidya to take care of this draft now that she is
back at work. Just for the record, I only started this WGLC because Vidya
wasn't back from her leave at that time.

Vidya, is this ok with you?

Cheers,

Jonne.

---

From: Frank Xia <[email-masked]>
Date: Thu, 03 Jun 2010 14:51:25 -0500

Hi Jonne

I wanted to stop this kind of debating two emails before.

Surely, I will re-post my understanding about the issues
at the right time.

At the same time, I applaud that Jari or other people to 
speak up.  Just as you said, "for the record", 
I could be wrong, however, please let know where.

BR
Frank

-----Original Message-----
From: Soininen, Jonne (NSN-FI/Espoo) [mailto:[email-masked]] 
Sent: Thursday, June 03, 2010 9:16 AM
To: ext Frank Xia; [email-masked]
Subject: Re: [netlmm] FW: I-D Action:draft-ietf-netlmm-lma-discovery-04.txt

Hi Frank,

Cheers,

Jonne.

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Fri, 4 Jun 2010 10:45:43 -0700

Jonne,
I can certainly take this draft from here on - however, I'd like people to note that the WG document has been operating in conformance to WG consensus.  I have expressed earlier already that it is time to move on from this issue.  

Frank, please take this offline to our AD if you are convinced that anything needs to be done here.  At this point, this discussion does not belong on the mailing list. 

Thanks,
Vidya

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Soininen, Jonne (NSN-FI/Espoo)
Sent: Thursday, June 03, 2010 7:16 AM
To: ext Frank Xia; [email-masked]
Subject: Re: [netlmm] FW: I-D Action:draft-ietf-netlmm-lma-discovery-04.txt

Hi Frank,

Cheers,

Jonne.

_______________________________________________
netlmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netlmm

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 4 Jun 2010 13:22:41 -0700 (PDT)

Hi Jonne,

snipped

> Frank and Behcet, you 
> have proposed additions to the WG document. However,
as far as I can see, it 
> is just you. There are no other people active in
this discussion. Nobody is 
> voicing their support for your proposal.

Are you sure?
What about this?

http://www.ietf.org/mail-archive/web/netlmm/current/msg06489.html

and this

http://www.ietf.org/mail-archive/web/netlmm/current/msg06132.html

You feel free to make unjustified claims on what 3GPP is planning to do just to push your own biased view.

You mentioned that draft merger is not possible but you also mentioned that things can be added to the current draft.
Let's add good content to the draft. 

We are not after seeing our names as authors, we would like to see the right content in this  draft 

which seemes to be the last in Netlmm. 
Let's do this and then say good bye to Netlmm.

Cheers,

Behcet

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Fri, 4 Jun 2010 18:12:29 -0700

Behcet,
These emails have been referenced so many times now, without much value.  Normative references to drafts that have no status in the WG and have not gained any consensus are not making sense.  After looking at the emails, we have already concluded that there has not been sufficient consensus to do what you are asking. 

Please take this discussion to our AD if you need further action. As I've already said, this discussion is not appropriate for the WG mailing list in its current form.  

Thanks,
Vidya

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Friday, June 04, 2010 1:23 PM
To: Soininen, Jonne (NSN-FI/Espoo); [email-masked]
Subject: Re: [netlmm] FW: I-D Action:draft-ietf-netlmm-lma-discovery-04.txt

Hi Jonne,

snipped

as far as I can see, it 

Are you sure?
What about this?

and this

Cheers,

Behcet

---

From: Frank Xia <[email-masked]>
Date: Fri, 04 Jun 2010 22:51:50 -0500

Hi Jari

I accept Vidya's suggestion to request your involvement.

As for "Automatic LMA discovery" WG item, Netlmm charter says " This will
define the ability for MAGs to automatically discover and use an LMA within
a
PMIPv6 domain. The scope of this effort may include specifying the use of
DNS or DHCP based LMA discovery or LMA discovery using policy information
retrieved via AAA protocols"

DHCP solution is valuable for the scenario that LMA and HA are collocated
(e.g. in 3GPP/WiMAX), and LMA/HA availability information is  stored in a
DHCP server( 3GPP 24.303  "Home agent address discovery based on DHCPv6").

IMHO, the chairs try to exclude DHCP solution from the chartered WG item
without soliciting enough technical comments.

BR
Frank

-----Original Message-----
From: Narayanan, Vidya [mailto:[email-masked]] 
Sent: Friday, June 04, 2010 12:46 PM
To: Soininen, Jonne (NSN-FI/Espoo); ext Frank Xia; [email-masked]
Subject: RE: [netlmm] FW: I-D Action:draft-ietf-netlmm-lma-discovery-04.txt

Jonne,
I can certainly take this draft from here on - however, I'd like people to
note that the WG document has been operating in conformance to WG consensus.
I have expressed earlier already that it is time to move on from this issue.

Frank, please take this offline to our AD if you are convinced that anything
needs to be done here.  At this point, this discussion does not belong on
the mailing list. 

Thanks,
Vidya

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of

Hi Frank,

Cheers,

Jonne.

---

From: "Soininen, Jonne (NSN-FI/Espoo)" <[email-masked]>
Date: Mon, 07 Jun 2010 18:52:35 +0300

Behcet,

> to push your own biased view.

I think we have now overstepped a boundary of discussing the issue. Let's
continue discussion on this topic off-line now.

Cheers,

Jonne.

On 6/4/10 11:22 PM, "ext Behcet Sarikaya" <[email-masked]> wrote:

> You mentioned that draft merger is not possible but you also mentioned that
> things can be added to the current draft.

---

From: Jari Arkko <[email-masked]>
Date: Mon, 07 Jun 2010 15:05:21 -0400

Frank,

I have reviewed this discussion.

First, the charter text that you quoted merely suggests possible ways to 
provide the functionality, it is not a guarantee that each possible 
design will be taken up. (And in fact, having something in the charter 
is not a guarantee that the WG will work even on the functionality at 
all, if there is not enough interest.)

Second, both chairs have indicated that there is no consensus in the 
working group to adopt the additional material that you suggested. In my 
review of the mailing list archives, there was some but very little 
support for this. In particular, I did not see many people who said they 
need this themselves, though there were a few who were agreeing to 
adding material if others felt it was important. In my opinion, the 
support that I saw does not justify additions to the current document. 
If other people speak up the situation could change. I also I tend to 
agree with Vidya's assessment that we've talked about this enough, we 
should no longer be repeating the same arguments from the same people. 
If there are additional folks who care about this, I'd love to hear 
about it though. You mentioned Wimax at some point; perhaps those people 
can say something?

Third, I also reviewed the working group document, and my opinion is 
that it is already bloated and has too many solutions and too little 
guidance on what should actually be done. The WG can consider this as my 
last call comment; I'd rather see reduction in the document than 
extension. Also, the document should make it clear that it describes 
possible solution directions and not the solutions themselves. And I 
would really like to see some statement about what the recommended 
solution direction is. Personally, I think the AAA solution is workable, 
but passing information from the mobile node via L2 would be a 
provisioning nightmare.

Jari