Subject: [Netmod-ver-dt] YANG versioning - Design team meetings

From: Robert Wilton <[email-masked]>
Date: Thu, 26 Jul 2018 13:36:48 +0100

Hi,

Sorry, I should have emailed earlier, but I suggest that we continue the 
design team meetings at the same time slot.  I.e. Thursday, 3 pm BST.

I am around this week, and next week, but then away for a reasonable 
amount of August.  I don't know if folks want to continue the meetings 
over August, or have a break until September?

In terms of next steps for the DT, then my proposal is:

(1) Finalize the requirements text.  I think that this is relative minor 
and can be done over email, perhaps best on the NETMOD alias directly.
(2) Discuss solutions:

Personally, I'm still of the opinion, that the semver draft seems like 
the most likely path forward, but I think that we need to at least 
consider the broad pros and cons of alternative solutions. My aim here 
is try and get buy in from the WG on the direction of the solution now 
rather than in 4 months time.

To this end I would like to suggest that we aim to produce a short ID 
that lists the main alternative solutions and has bullet point lists of 
the relative pros and cons.

In particular I think that the three solution spaces that are worth 
comparing are:
   (i) The solution that we have today (i.e. RFC 7950 rules).
   (ii) The Chris Hopps variant of RFC 7950:
       - Change the module name for major version changes, use revision 
date for minor versions.
       - Consider whether tooling, or changes to the protocols, can 
minimize the impact of changing the module name.
  (iii) A semver solution, as described in the clacla draft.

Note that I mainly want to evaluate against requirements in section 5.  
In particular subsections 1, 2 and 3, and 5.  I think that we can ignore 
the requirements for subsection 4 related to data node life cycle since 
I think that it a tangential problem, and the solution space is much 
simpler.

Is everyone happy doing this, and agree that this is a useful step? Or 
perhaps, better put, is anyone opposed to doing this?

Thanks,
Rob

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thu, 26 Jul 2018 13:58:26 +0000

I am good with this plan.  However, I will not make today’s meeting.  I’ll be back next week.

Joe

PGP Key : http://www.marcuscom.com/pgp.asc

> On Jul 26, 2018, at 05:37, Robert Wilton <rwilton=[email-masked]> wrote:
> 
> Hi,
> 
> Sorry, I should have emailed earlier, but I suggest that we continue the design team meetings at the same time slot.  I.e. Thursday, 3 pm BST.
> 
> I am around this week, and next week, but then away for a reasonable amount of August.  I don't know if folks want to continue the meetings over August, or have a break until September?
> 
> (1) Finalize the requirements text.  I think that this is relative minor and can be done over email, perhaps best on the NETMOD alias directly.
> (2) Discuss solutions:
> 
> Personally, I'm still of the opinion, that the semver draft seems like the most likely path forward, but I think that we need to at least consider the broad pros and cons of alternative solutions. My aim here is try and get buy in from the WG on the direction of the solution now rather than in 4 months time.
> 
> To this end I would like to suggest that we aim to produce a short ID that lists the main alternative solutions and has bullet point lists of the relative pros and cons.
> 
> In particular I think that the three solution spaces that are worth comparing are:
>       - Change the module name for major version changes, use revision date for minor versions.
>       - Consider whether tooling, or changes to the protocols, can minimize the impact of changing the module name.
> Note that I mainly want to evaluate against requirements in section 5.  In particular subsections 1, 2 and 3, and 5.  I think that we can ignore the requirements for subsection 4 related to data node life cycle since I think that it a tangential problem, and the solution space is much simpler.
> 
> Is everyone happy doing this, and agree that this is a useful step? Or perhaps, better put, is anyone opposed to doing this?
> 
> Thanks,
> Rob
> 
> _______________________________________________
> Netmod-ver-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: Robert Wilton <[email-masked]>
Date: Thu, 26 Jul 2018 15:12:22 +0100

Well, it looks like nobody was expecting a meeting today. :-)

So, I will cancel now, but we should meet next Thursday.

Please can everyone state a preference as to whether they would like the 
meetings to continue through the remainder of August, or should we just 
wait until September.  The only two dates that I can make in August are 
next week (2nd) and the 23rd.

Thanks,
Rob

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 26 Jul 2018 16:17:42 +0200

On Thu, Jul 26, 2018 at 03:12:22PM +0100, Robert Wilton wrote:
> meetings to continue through the remainder of August, or should we just wait
> until September.  The only two dates that I can make in August are next week
> (2nd) and the 23rd.
>

I am traveling next week. Perhaps it makes sense to resume in September.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 26 Jul 2018 14:19:43 +0000

I can make August 2nd, 23rd and 30th. Maybe meet next week for a recap and then wait until September?

On 2018-07-26, 10:12 AM, "Netmod-ver-dt on behalf of Robert Wilton" <[email-masked] on behalf of rwilton=[email-masked]> wrote:

    
    
    Thanks,
    Rob

---

From: Robert Wilton <[email-masked]>
Date: Thu, 26 Jul 2018 15:42:18 +0100

On 26/07/2018 13:36, Robert Wilton wrote:
> Hi,
>
> Sorry, I should have emailed earlier, but I suggest that we continue 
> the design team meetings at the same time slot.  I.e. Thursday, 3 pm BST.
>
> (1) Finalize the requirements text.  I think that this is relative 
> minor and can be done over email, perhaps best on the NETMOD alias 
> directly.
> (2) Discuss solutions:
>
> that lists the main alternative solutions and has bullet point lists 
> of the relative pros and cons.
>
Perhaps a 4th possible solution to consider would be having 
<major>.<minor> version numbers in the module but not use semantic 
versioning.  The major/minor represents the significance of the change, 
and instead users of the modules must rely on tooling to detect non 
backwards compatible changes.

Thanks,
Rob

>
> Note that I mainly want to evaluate against requirements in section 
> 5.  In particular subsections 1, 2 and 3, and 5.  I think that we can 
> ignore the requirements for subsection 4 related to data node life 
> cycle since I think that it a tangential problem, and the solution 
> space is much simpler.
>

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 26 Jul 2018 15:48:50 +0000

Hi guys,

I'm OK for most Thursdays (took vact in early July) so fine to join when others want to continue/resume.  Note - I may not be on all your lists for meeting invites, etc (new to the DT).  I am on the netmod-ver-dt mail list though.

In the solutions below we don't include one that I proposed to deal with multiple parallel s/w streams.  I think we should still keep that under discussion (even if we aren't sure we'd decide to address it in a phase 1 solution).  We should at least make sure our solution doesn't preclude how a vendor could still address it while also using our solution within a stream.

Rgds,
Jason

> -----Original Message-----
> From: Netmod-ver-dt <[email-masked]> On Behalf Of
> Robert Wilton
> Sent: Thursday, July 26, 2018 10:42 AM
> To: [email-masked]
> Subject: Re: [Netmod-ver-dt] YANG versioning - Design team meetings
> 
> 
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 26 Jul 2018 18:07:09 +0200

Hi Jason,

if you think that handling multiple versioned branches is a
requirement, you should make sure that the requirements properly
cover that.

/js

---

From: Joe Clarke <[email-masked]>
Date: Thu, 26 Jul 2018 12:21:27 -0400

> next week (2nd) and the 23rd.

I'm around until Aug 16, and then back in September.  So if we want to
postpone until Sep, that works for me.

Joe

>>> On Jul 26, 2018, at 05:37, Robert Wilton
>>> <rwilton=[email-masked]> wrote:
>>>
>>> Hi,
>>>
>>> amount of August.  I don't know if folks want to continue the
>>> meetings over August, or have a break until September?
>>>
>>> Personally, I'm still of the opinion, that the semver draft seems
>>> like the most likely path forward, but I think that we need to at
>>> least consider the broad pros and cons of alternative solutions. My
>>> aim here is try and get buy in from the WG on the direction of the
>>> solution now rather than in 4 months time.
>>>
>>> Is everyone happy doing this, and agree that this is a useful step?
>>> Or perhaps, better put, is anyone opposed to doing this?
>>>
>>> Thanks,
>>> Rob
>>>

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 26 Jul 2018 17:07:42 +0000

I personally think it is. Otherwise I'm worried our solution won't cover real vendor use cases.  I don't think we should scope this work to only cover standards track models.

Rgds,
Jason

> From: Juergen Schoenwaelder <[email-masked]>
> Sent: Thursday, July 26, 2018 12:07 PM
> To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>
> Cc: Robert Wilton <rwilton=[email-masked]>; netmod-ver-
> [email-masked]
> > I'm OK for most Thursdays (took vact in early July) so fine to join when
> others want to continue/resume.  Note - I may not be on all your lists for
> meeting invites, etc (new to the DT).  I am on the netmod-ver-dt mail list
> though.
> >
> > In the solutions below we don't include one that I proposed to deal with
> multiple parallel s/w streams.  I think we should still keep that under
> discussion (even if we aren't sure we'd decide to address it in a phase 1
> solution).  We should at least make sure our solution doesn't preclude how a
> vendor could still address it while also using our solution within a stream.
> >
> > Rgds,
> > Jason
> >

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 26 Jul 2018 16:40:06 -0700

I am available for any meetings in August.

> On Jul 26, 2018, at 7:12 AM, Robert Wilton <rwilton=[email-masked]> wrote:
> 
> Please can everyone state a preference as to whether they would like the meetings to continue through the remainder of August, or should we just wait until September.  The only two dates that I can make in August are next week (2nd) and the 23rd.
> 
> Thanks,
> Rob
> 
> 

Mahesh Jethanandani
[email-masked]

---

From: Robert Wilton <[email-masked]>
Date: Fri, 27 Jul 2018 13:09:09 +0100

Hi Jason,

For some reason, I didn't seem to get your original email.  It seems 
that my (and Joe's) email address is getting mangled to dmarc.ietf.org 
for some reason.  I'll try and find out what is going on here.

Otherwise, for the parallel s/w streams I think that it might be a good 
idea to start a separate netmod-ver-dt thread to discuss whether this 
should be a requirement.

Thanks,
Rob

On 26/07/2018 18:07, Sterne, Jason (Nokia - CA/Ottawa) wrote:
>> From: Juergen Schoenwaelder<[email-masked]>
>> To: Sterne, Jason (Nokia - CA/Ottawa)<[email-masked]>
>> Cc: Robert Wilton<rwilton=[email-masked]>; netmod-ver-
>> [email-masked]
>>>> From: Netmod-ver-dt<[email-masked]>  On Behalf Of
>>>> Robert Wilton
>>>> To:[email-masked]
>> Fax:   +49 421 200 3103<https://www.jacobs-university.de/>
> .
>

---

From: "Susan Hares" <[email-masked]>
Date: Sun, 29 Jul 2018 14:43:27 -0400

I can meet on Thursdays in August. 

Sue 

-----Original Message-----
From: Netmod-ver-dt [mailto:[email-masked]] On Behalf Of Mahesh Jethanandani
Sent: Thursday, July 26, 2018 7:40 PM
To: Robert Wilton
Cc: Joe Clarke (jclarke); [email-masked]
Subject: Re: [Netmod-ver-dt] YANG versioning - Design team meetings

Mahesh Jethanandani
[email-masked]