Subject: [Netmod-ver-dt] clacla solution for import by semantic revision.

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 13 Jul 2018 11:39:55 -0700

Reading through clacla-netmod-yang-model-update document, and specifically Section 2.2, the draft states that:

   Today YANG 1.1 allows one to
   specify the revision date of the imported module, but that is too
   specific, as even a small spelling correction of the imported module
   results in a change to its revision date, thus making the module
   revision ineligible for import.

I do not understand the last part of the statement. Why is the module revision ineligible for import?

It also states that importing modules using semantic versioning is more flexible because a module at a specific MAJOR version or higher is acceptable.  But isn’t a MAJOR version change by default a backward incompatible change. Why would a model find importing a “or higher” MAJOR version acceptable? I can understand someone finding semver:import-versions “[2-5]” acceptable because they have looked at all the revisions 2-5 and found the backward incompatible changes non-impacting, but to give a blank check on any future MAJOR revision … ???

Cheers.

Mahesh Jethanandani
[email-masked]

---

From: Balazs Lengyel <[email-masked]>
Date: Sun, 15 Jul 2018 15:09:48 -0400

On 7/13/2018 2:39 PM, Mahesh
Jethanandani wrote:

Reading through clacla-netmod-yang-model-update document, and
specifically Section 2.2, the draft states that:

I do not understand the last part of the
statement. Why is the module revision ineligible for import?

BALAZS: Because for any change you need to
update the revision data. So even if you just corrected a
meaningless spelling error  (like an authors name from
BLazs->Balazs)  you have a new revision data that is not what
was specified in the import's revision-date statement :
ineligible.

It also states that importing modules using
semantic versioning is more flexible because a module at a
specific MAJOR version or higher is acceptable.  But isn’t a
MAJOR version change by default a backward incompatible
change. Why would a model find importing a “or higher” MAJOR
version acceptable? I can understand someone finding
semver:import-versions “[2-5]” acceptable because they have
looked at all the revisions 2-5 and found the backward
incompatible changes non-impacting, but to give a blank check
on any future MAJOR revision … ???

BALAZS: Yes there is some risk with an
open-ended check,  but that is what we are already doing in some
cases. It eliminates the need for updates for the next major
versions, but has some risks. We can discuss it.

Cheers.

Mahesh Jethanandani

[email-masked]

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]