Subject: [Netmod-ver-dt] Requirements updates

From: Joe Clarke <[email-masked]>
Date: Fri, 12 Oct 2018 02:23:56 -0400

I have Jason's text for the definition of NBC.  I have Balazs' text for
the client compatibility.  I think I can find the proposed changes for
Chris.  What about the release versioning and any other text required?

I want to make sure I merge everything correctly.

Thanks.

Joe

---

From: Robert Wilton <[email-masked]>
Date: Fri, 12 Oct 2018 10:03:25 +0100

Hi Joe,

I think the remaining piece of text is adding this requirement as 1.4:

        1.4  The solution MUST allow for modules to be
             versioned by software release.  In particular,
             backwards compatible enhancements and bug fixes
             MUST be allowed in any non latest release.

Thanks,
Rob

On 12/10/2018 07:23, Joe Clarke wrote:
> _______________________________________________
> Netmod-ver-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt
> .
>

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 15 Oct 2018 13:20:36 +0000

Hi,

I thought this was for next rev of draft-verdt-netmod-yang-versioning-reqs but from looking at github, this is actually for the solutions draft (the reqs draft hasn’t been updated in 4 months)?

Thanks,
Reshad.

From: Netmod-ver-dt <[email-masked]> on behalf of "Robert Wilton -X (rwilton - ENSOFT LIMITED at Cisco)" <[email-masked]>
Date: Friday, October 12, 2018 at 5:03 AM
To: "Joe Clarke (jclarke)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Netmod-ver-dt] Requirements updates

Hi Joe,

Thanks,

Rob

Thanks.

Joe

[email-masked]<mailto:[email-masked]>

..

---

From: Joe Clarke <[email-masked]>
Date: Mon, 15 Oct 2018 09:22:52 -0400

On 10/15/18 09:20, Reshad Rahman (rrahman) wrote:
> Hi,
> 
>  
> 
> I thought this was for next rev of
> draft-verdt-netmod-yang-versioning-reqs but from looking at github, this
> is actually for the solutions draft (the reqs draft hasn’t been updated
> in 4 months)?

I am working on the reqs draft update now.  I've committed a few changes
locally, and I will push to develop when I'm done (so we can all
review).  Should be in a couple of hours.

Joe

> 
>  
> 
> Thanks,
> 
> Reshad.
> 
>  
> 
> *From: *Netmod-ver-dt <[email-masked]> on behalf of
> "Robert Wilton -X (rwilton - ENSOFT LIMITED at Cisco)" <[email-masked]>
> *Date: *Friday, October 12, 2018 at 5:03 AM
> *To: *"Joe Clarke (jclarke)" <[email-masked]>,
> "[email-masked]" <[email-masked]>
> *Subject: *Re: [Netmod-ver-dt] Requirements updates
> 
>  
> 
> Hi Joe,
> 
>     [email-masked] <mailto:[email-masked]>
>