Subject: [Netmod-ver-dt] Import-versions proposal

From: Balázs Lengyel <[email-masked]>
Date: Wed, 6 Feb 2019 15:57:42 +0000

Hello,

I have an alternative proposal for import-versions. I hope it is easier 
to understand. See attachment. Lets discuss it!

regards Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909              email: [email-masked]

---

From: Joe Clarke <[email-masked]>
Date: Thu, 7 Feb 2019 09:54:59 -0500

> to understand. See attachment. Lets discuss it!

Thanks, Balazs.  This is a good start.

Overall, I like the '+' as a way to say "or greater."  That said, I
think it's still a bit too complex.  I think you should drop the
"import" from the extension (since we're already in the import context):

import example-module {
    semver:versions 3.6.1;
}

I also think we should allow for a syntax like:

import example-module {
    semver:versions 3;
}

This could be extended to MINOR as well.

Which says that any 3.x.x is allowed.  This will be the common case most
likely, right?  And that is bounded at 3.x.x whereas 3+ would be
anything 3.x.x through N.x.x.  This wouldn't include any Ms, though.
This is kind of like your "+comp", but without the additional suffix.

Your range makes sense.  Assuming inclusive is probably the best way.
You can easily make it exclusive by just going to one version less.

Joe

> 
> regards Balazs
> 
> 
> _______________________________________________
> Netmod-ver-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt
>