Subject: [Netmod-ver-dt] Latest doc version

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 27 Feb 2019 18:07:22 +0000

Just pushed to the github develop branch.

Latest draft version attached.

Still to do:

-        Update abstract

-        Probably should add some definitions.

-        Resolve comments from Balazs (across the doc)

-        Resolve comments from Reshad on chapter 2.

-        Incorporate text from Balazs on instance data versioning.

-        Chapter 4 needs some serious focus.

-        Add tree output and updates the text around the YANG modules.

Thanks,
Rob

---

From: Qin Wu <[email-masked]>
Date: Fri, 1 Mar 2019 07:10:16 +0000

Hi, Rob:
A few comments on the latest version

1.       Section 1, paragraph 2, 2nd bullet

      An extension to allow YANG module imports to be restricted to

      modules with particular semantic versions, allowing inter-module

      version dependencies to be captured within YANG module

      definitions.

  [Qin]s/An extension/A YANG extension

2.       Section 1.2, paragraph 2

   [Qin]: which requirements have not been addressed, should this be clear in this section?

3.       Section 1.2 paragraph 3

   [Qin]:draft-wang-netmod-module-revision-management-01 section 4.1 is also

   targeted to address requirements 2.1 defined in draft-verdt-netmod-yang-versioning-reqs-02

   and will review details in section 6.

4.       Section 2.1

   Q.  Does statement ordering need to be considered as part of the

   comparison?  RW: I think the answer should be no.  RR: ordering

   matters for RPC/action input as per https://tools.ietf.org/html/

   rfc7950#section-7.5.7

   [Qin]: I believe when you compare two modules, statement order in one module

   should be adjusted to follow the same statement order of the other module. But

   not sure automation tool can be built to do this. Manual provision on the statement

   order is needed.

5.       Section 2.2

      Module definitions that follow the semver.org 2.0.0 versioning

      scheme are fully compatible with implementations that understand

      the YANG semantic versioning scheme.

  [Qin]:What about module definitions that follows YANG semantics versioning schema defined in this document?

  are they compatible with implementation that understand YANG semantics version schema defined in this document,

  probably the answer is yes, but it is not clear in the text.

6.       Section 3, paragraph 3 said

“   changing the name of a leaf could break an

   import but frequently would not, ”

[Qin]:frequently changing the name of a leaf would not break an import? Would you clarify this?

7.       Section 3, paragraph 4

   [Qin]: Do we support some import statement contains version statement or

   some import statement contains revision-date? Are these important statement interchangeable?

8.       Section 5.1 said:

“

The following rules remove the ambiguity:”

I feel these rules are more related to RFC8407 instead of [I-D.ietf-netconf-rfc7895bis].

So the last rule should be default rule defined in RFC8407

“

   If a module import statement could resolve to more than one module

   revision defined in the datastore schema, none of those revisions are

   implemented, and none of the modules revisions have a YANG semantic

   version number, then the import MUST resolve to the module that has

   the most recent revision-date.

”

The other two rules are additional rules that can be used to enhance RFC8407, but I didn’t check details.
Will review remaining sections when in convenience.

-Qin
发件人: Netmod-ver-dt [mailto:[email-masked]] 代表 Rob Wilton (rwilton)
发送时间: 2019年2月28日 2:07
收件人: [email-masked]
主题: [Netmod-ver-dt] Latest doc version

Still to do:

-          Update abstract

Thanks,
Rob