Subject: Re: [Netmod-ver-dt] Module naming

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 22 Feb 2019 18:51:41 +0000

I agree it should be SHOULD. Other char options: $ or @@.

From: Netmod-ver-dt <[email-masked]> on behalf of "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Friday, February 22, 2019 at 1:40 PM
To: "Rob Wilton (rwilton)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Netmod-ver-dt] Module naming

I think this is a SHOULD (as it is in the YANG Guidelines RFC 8407). And I can't think of a better char than %.

Jason

From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob Wilton (rwilton)
Sent: Friday, February 22, 2019 12:29 PM
To: [email-masked]
Subject: [Netmod-ver-dt] Module naming

The draft currently has this open issue:

   o  We could consider a new naming convention for module files.
      Today, module files are named using a [email-masked]<mailto:[email-masked]>
      notation.  We could consider module%semver.yang or
      module#version.yang variants.  Re-using the '@' for version is not
      ideal, so another separator character should be used.  In this
      manner, both version and revision could be used.

If we have time, then I think that we should address this in the main body of the text.  If we are using import by version, then it would be very useful to be able to look for a file that would conform to that import statement.

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 22 Feb 2019 23:23:09 +0000

Not $ as it is a shell metacharacter.  I think Balazs proposed #.  I think either % or # should be used.

Joe

PGP Key : http://www.marcuscom.com/pgp.asc

On Feb 23, 2019, at 03:51, Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> on behalf of "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 22, 2019 at 1:40 PM
To: "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netmod-ver-dt] Module naming

Jason

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Rob Wilton (rwilton)
Sent: Friday, February 22, 2019 12:29 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Netmod-ver-dt] Module naming

If we have time, then I think that we should address this in the main body of the text.  If we are using import by version, then it would be very useful to be able to look for a file that would conform to that import statement.
_______________________________________________
Netmod-ver-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 22 Feb 2019 23:38:42 +0000

Sounds good.

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Friday, February 22, 2019 at 6:23 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>, "Rob Wilton (rwilton)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Netmod-ver-dt] Module naming

Joe

Jason

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 22 Feb 2019 23:44:56 +0000

Now that I think about it, % may be treated as a meta character in Windows.  I think # might be safest.

Joe

On Feb 23, 2019, at 08:38, Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:

Sounds good.

From: "Joe Clarke (jclarke)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 22, 2019 at 6:23 PM
To: "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>
Cc: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]<mailto:[email-masked]>>, "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netmod-ver-dt] Module naming

Joe

Jason

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 23 Feb 2019 08:49:58 +0100

> Now that I think about it, % may be treated as a meta character in Windows.  I think # might be safest.

# Whatever character you pick, it will require quoting in some contexts.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Joe Clarke <[email-masked]>
Date: Sat, 23 Feb 2019 19:43:55 -0500

> # Whatever character you pick, it will require quoting in some contexts.

Sure.  I find '@' gets quoted by bash.  But '$' would interview with
more things (certainly with more Unix shells).

We should try and minimize pain.

Joe

---

From: Balázs Lengyel <[email-masked]>
Date: Mon, 25 Feb 2019 09:07:56 +0000

Hello,

Not the most important topic, but I agree with myself about the
#  :-)

One more question about this:

"ietf-system#3.2.1m.yang"  doesn't look good, as
the dots are used to separate the file extension/type.  I would
rather use something else instead of dots. e.g.

ietf-system#3-2-1m.yang

regards Balazs

On 2019. 02. 23. 0:38, Reshad Rahman
(rrahman) wrote:

Sounds good.

From: "Joe Clarke
(jclarke)" <[email-masked]>

To: "Reshad Rahman (rrahman)"
<[email-masked]>

Cc: "Sterne, Jason (Nokia - CA/Ottawa)"
<[email-masked]>, "Rob Wilton (rwilton)"
<[email-masked]>, "[email-masked]"
<[email-masked]>

Not $ as it is a shell metacharacter.  I
think Balazs proposed #.  I think either % or # should be
used.

Joe

On Feb 23, 2019, at 03:51, Reshad Rahman (rrahman) <[email-masked]>
wrote:

I agree it
should be SHOULD. Other char options: $ or @@.

From: Netmod-ver-dt
<[email-masked]>
on behalf of "Sterne, Jason (Nokia - CA/Ottawa)"
<[email-masked]>

To: "Rob Wilton (rwilton)" <[email-masked]>,
"[email-masked]"
<[email-masked]>

I think this is a SHOULD (as it is in
the YANG Guidelines RFC 8407). And I can't think of a
better char than %.

Jason

From:
Netmod-ver-dt <[email-masked]>
On Behalf Of Rob Wilton (rwilton)

The draft
currently has this open issue:

o  We could consider a new naming
convention for module files.

Today, module files are named
using a
[email-masked]

notation.  We could consider
module%semver.yang or

module#version.yang variants.
Re-using the '@' for version is not

ideal, so another separator
character should be used.  In this

manner, both version and revision
could be used.

If we have time,
then I think that we should address this in the main
body of the text.  If we are using import by
version, then it would be very useful to be able to
look for a file that would conform to that import
statement.

[email-masked]

[email-masked]

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 25 Feb 2019 11:15:02 +0100

On Mon, Feb 25, 2019 at 09:07:56AM +0000, Balázs Lengyel wrote:
> 
>    "ietf-system#3.2.1m.yang"� doesn't look good, as the dots are used to
>    separate the file extension/type.� I would rather use something else
>    instead of dots. e.g.
> 
>    ietf-system#3-2-1m.yang
>

Since the current format is [email-masked] there is the option to
keep the @ symbol as long as we make sure that version numbers do not
clash with a valid revision date, e.g., [email-masked]. I think it is
desirable to keep the number of special characters down to a minimum.

If people think multiple dots are a problem, use a different separator
in the version number, although I think dots are the commonly used
format for the version numbers and they make the format collision free
regarding the revision-date. Decent systems should understand that the
extension separator is the last dot and not the first dot in a file
name. ;-)

/js

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 25 Feb 2019 15:04:01 +0000

I think that we just need to include one of these forms in the doc.  

# would probably be OK.

I guess that initially, I would lean towards using 'Using [email-masked]' for the "I think it is desirable to keep the number of special characters down to a minimum." reason stated below.

Rob

-----Original Message-----
From: Juergen Schoenwaelder <[email-masked]> 
Sent: 25 February 2019 10:15
To: Balázs Lengyel <[email-masked]>
Cc: Reshad Rahman (rrahman) <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>; [email-masked]; Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Netmod-ver-dt] Module naming

On Mon, Feb 25, 2019 at 09:07:56AM +0000, Balázs Lengyel wrote:
> 
>    "ietf-system#3.2.1m.yang"  doesn't look good, as the dots are used to
>    separate the file extension/type.  I would rather use something else
>    instead of dots. e.g.
> 
>    ietf-system#3-2-1m.yang
>

Since the current format is [email-masked] there is the option to keep the @ symbol as long as we make sure that version numbers do not clash with a valid revision date, e.g., [email-masked]. I think it is desirable to keep the number of special characters down to a minimum.

If people think multiple dots are a problem, use a different separator in the version number, although I think dots are the commonly used format for the version numbers and they make the format collision free regarding the revision-date. Decent systems should understand that the extension separator is the last dot and not the first dot in a file name. ;-)

/js

---

From: Joe Clarke <[email-masked]>
Date: Mon, 25 Feb 2019 17:24:55 -0500

> extension separator is the last dot and not the first dot in a file

I thought about using the same '@'.  Yep, it can work, but it I thought
that overloading may break tooling that isn't version aware (and may not
want to be).  On top of that, two characters could give you the ability
to specify both version and revision in the filename so you could
support both legacy and new tooling.

Overall, this is more of a bike shedy topic.  I'm really okay in any
number of choices here.

Joe

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 26 Feb 2019 00:01:20 +0100

> support both legacy and new tooling.

Existing 'legacy' tools expect <name>@<revision-date> and nothing
else, so I am not convinced by your second argument.

Will tools freak out if they find <name>@<version>? Maybe.
Will tools freak out if they find <name>#<version>? Maybe.

Anyway, freaking out tools will get fixed.

I am more concerned about another metacharacter that appears harmless
on first sight until you use it. The @ turned out to be a pain with
subversion, for example. Good, we all moved to git. Anyway, this is
a great topic for a WG to spend meeting time on. ;-)

/js

---

From: Joe Clarke <[email-masked]>
Date: Mon, 25 Feb 2019 18:04:49 -0500

> else, so I am not convinced by your second argument.

Yeah.  They'll pull the revision, but the module name will be mangled.

> Will tools freak out if they find <name>#<version>? Maybe.

Yep.  Maybe.

> a great topic for a WG to spend meeting time on. ;-)

Like I said, a bike shed to be sure.  And whatever color it ends up
getting painted, I'm okay with.

Joe