Subject: [Netmod-ver-dt] Module naming

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 22 Feb 2019 17:29:25 +0000

The draft currently has this open issue:

   o  We could consider a new naming convention for module files.
      Today, module files are named using a [email-masked]
      notation.  We could consider module%semver.yang or
      module#version.yang variants.  Re-using the '@' for version is not
      ideal, so another separator character should be used.  In this
      manner, both version and revision could be used.

If we have time, then I think that we should address this in the main body of the text.  If we are using import by version, then it would be very useful to be able to look for a file that would conform to that import statement.

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 22 Feb 2019 18:39:50 +0000

I think this is a SHOULD (as it is in the YANG Guidelines RFC 8407). And I can't think of a better char than %.

Jason

From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob Wilton (rwilton)
Sent: Friday, February 22, 2019 12:29 PM
To: [email-masked]
Subject: [Netmod-ver-dt] Module naming

      Today, module files are named using a [email-masked]<mailto:[email-masked]>