Subject: [Netmod-ver-dt] Splitting ietf-semver into two modules

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 25 Feb 2019 15:16:23 +0000

I would like to split the YANG module into two separate modules:

(i)               Type definition + extensions.

(ii)              YANG library augmentations.

I can think that there are scenarios where someone might want a dependency on only the type and/or extension without implementing any nodes, and I think that splitting the modules is cleaner than requiring it to be marked as import-only.

Does anyone agree or object?

Thanks,
Rob

---

From: Balázs Lengyel <[email-masked]>
Date: Mon, 25 Feb 2019 16:09:47 +0000

IMHO supporting the extension without making the values  visible
in yang-library seems something I would not want to do.

I can live with 2 modules, but I would not do it.

regards Balazs

On 2019. 02. 25. 16:16, Rob Wilton
(rwilton) wrote:

I would like to split the YANG module into
two separate modules:

(i)
Type definition + extensions.

(ii)
YANG library augmentations.

I can think that there are scenarios where
someone might want a dependency on only the type and/or
extension without implementing any nodes, and I think that
splitting the modules is cleaner than requiring it to be
marked as import-only.

Thanks,

Rob

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 25 Feb 2019 16:40:58 +0000

It's not because I want to avoid implementing YANG library.  It is more that I think that there are places where a YANG semantic version number might be useful, but where pulling in the rest of YANG library doesn't seem helpful.

E.g. in the YANG packages draft, I define an instance-data document, that wants to use the semver typedef to version packages, but doesn't really want to have to pull in YANG library (although it currently does for other definitions).

Over time there may be other examples where using the semver typedef is better rather than having to redefine multiple versions of it.  Alternatively, if the timing worked out perhaps the typedef could go into IETF types.  Juergen?

Generally, I think that it is cleaner to split types and definitions apart where it is reasonable for the types to be used independently from the data node definitions/augmentations.

As it stands every module that defines a semver number is now also going to have a dependency on YANG library.  I'm not sure that I'm really a fan of requiring that dependency.  In fact, I'm now wondering whether it wouldn't be better to split the extensions out into a third file :).
Ietf-semver-types.yang - defines the yang semver type (which we don't do today), and perhaps could go into ietf-types.yang
ietf-semver-ext.yang - defines YANG extensions to support semver.
ietf-semver-yang-library.yang - defines augmentations to YANG library, depends on ietf-semver-types.yang.

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]> On Behalf Of Balázs Lengyel
Sent: 25 February 2019 16:10
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] Splitting ietf-semver into two modules

IMHO supporting the extension without making the values  visible in yang-library seems something I would not want to do.
I can live with 2 modules, but I would not do it.

regards Balazs
On 2019. 02. 25. 16:16, Rob Wilton (rwilton) wrote:
I would like to split the YANG module into two separate modules:

Thanks,
Rob

[email-masked]<mailto:[email-masked]>

--

Senior Specialist

Mobile: +36-70-330-7909              email: [email-masked]<mailto:[email-masked]>

---

From: Benoit Claise <[email-masked]>
Date: Mon, 25 Feb 2019 18:28:33 +0100

As long as this is a single specification (basically one RFC as opposed 
to two), it doesn't matter much.

Regards,Benoit
>
> IMHO supporting the extension without making the values visible in 
> yang-library seems something I would not want to do.
>> (i)Type definition + extensions.
>>
>> (ii)YANG library augmentations.
>>
>> I can think that there are scenarios where someone might want a 
>> dependency on only the type and/or extension without implementing any 
>> nodes, and I think that splitting the modules is cleaner than 
>> requiring it to be marked as import-only.
>>
> Mobile: +36-70-330-7909              email:[email-masked]  
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 25 Feb 2019 17:30:30 +0000

Yes, still just one RFC, but defining multiple YANG modules.  I think that it would have minimal impact on the document.

Thanks,
Rob

From: Benoit Claise <[email-masked]>
Sent: 25 February 2019 17:29
To: Balázs Lengyel <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] Splitting ietf-semver into two modules

As long as this is a single specification (basically one RFC as opposed to two), it doesn't matter much.

Regards,Benoit

regards Balazs

Thanks,
Rob

--

Senior Specialist

---

From: Joe Clarke <[email-masked]>
Date: Mon, 25 Feb 2019 16:23:46 -0500

On 2/25/19 11:40, Rob Wilton (rwilton) wrote:
> As it stands every module that defines a semver number is now also going
> to have a dependency on YANG library.  I’m not sure that I’m really a
> fan of requiring that dependency.  In fact, I’m now wondering whether it
> wouldn’t be better to split the extensions out into a third file J.

I personally don't see why one wouldn't want a dependency on
ietf-yang-library if they're doing semver (at least from a server
perspective).

But your proposal just makes things more flexible without much downside,
so I have no objection.

Joe

> 
> Ietf-semver-types.yang – defines the yang semver type (which we don’t do
> today), and perhaps could go into ietf-types.yang
> ietf-semver-ext.yang – defines YANG extensions to support semver.
> ietf-semver-yang-library.yang – defines augmentations to YANG library,
> depends on ietf-semver-types.yang.
> 
>  
> 
> Thanks,
> Rob
> 
>  
> 
>  
> 
> *From:*Netmod-ver-dt <[email-masked]> *On Behalf Of
> *Balázs Lengyel
> *Sent:* 25 February 2019 16:10
> *To:* Rob Wilton (rwilton) <[email-masked]>; [email-masked]
> *Subject:* Re: [Netmod-ver-dt] Splitting ietf-semver into two modules
> 
>  
> 
>     dependency on only the type and/or extension without implementing
>     any nodes, and I think that splitting the modules is cleaner than
>     [email-masked] <mailto:[email-masked]>
> 
> Mobile: +36-70-330-7909              email: [email-masked] <mailto:[email-masked]> 
> 
>