Subject: [Netmod-ver-dt] Compatibility rules - one more example

From: Balázs Lengyel <[email-masked]>
Date: Tue, 12 Mar 2019 16:46:09 +0000

Hello,

Just one more example of how real-life compatibility is much more
complicated than our rules.  I still don't want to open a new
discussion on this, just trying to show that human consideration
is absolutely needed.

We have an action, that returns an integer that is used to
address a list entry. Due to mapping of an old design it is just
an integer. Its description states that it should be used as a
reference.

We will change this to a leafref with the appropriate path
statement.

The type is changed from int to leafref. Unless you understand the
plain English text about how the original integer was used this is
an NBC change.

leaf return-value {
type uint16 ;

to:

leaf return-value {  type leafref { path "../../mylist/mykey

regards Balazs

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]

---

From: Benoit Claise <[email-masked]>
Date: Tue, 12 Mar 2019 18:15:08 +0100

Hi
> discussion on this, just trying to show that human consideration is 
> absolutely needed.
>
Of course, otherwise everything would have been solved for quite some 
time with pyang --check-update-from.

Regards, B.
>
>
> We have an action, that returns an integer that is used to address a 
> list entry. Due to mapping of an old design it is just an integer. Its 
> description states that it should be used as a reference.
> We will change this to a leafref with the appropriate path statement.
> plain English text about how the original integer was used this is an 
> NBC change.
>
> leaf return-value { type uint16 ;
>
> to:
>
> Mobile: +36-70-330-7909              email:[email-masked]  
>
> _______________________________________________
> Netmod-ver-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Fri, 15 Mar 2019 13:56:27 +0000

OK but by our current rules this would be NBC because of the type change (even if the type & value space of the leafref target is a uint16).

From: Netmod-ver-dt <[email-masked]> On Behalf Of Benoit Claise
Sent: Tuesday, March 12, 2019 1:15 PM
To: Balázs Lengyel <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] Compatibility rules - one more example

Hi

Hello,

Just one more example of how real-life compatibility is much more complicated than our rules.  I still don't want to open a new discussion on this, just trying to show that human consideration is absolutely needed.
Of course, otherwise everything would have been solved for quite some time with pyang --check-update-from.

Regards, B.

We have an action, that returns an integer that is used to address a list entry. Due to mapping of an old design it is just an integer. Its description states that it should be used as a reference.
We will change this to a leafref with the appropriate path statement.
The type is changed from int to leafref. Unless you understand the plain English text about how the original integer was used this is an NBC change.
leaf return-value {  type uint16 ;

to:

regards Balazs

--

Senior Specialist

Mobile: +36-70-330-7909              email: [email-masked]<mailto:[email-masked]>

[email-masked]<mailto:[email-masked]>