Subject: [Netmod-ver-dt] IETF 104 versioning presentations

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 14 Mar 2019 11:37:15 +0000

In today's meeting I hope that we can work out a plan for who is presenting what.

We have a 45 min slot covering the versioning work, and I have a 10 min slot covering YANG packages.

Who, would like to present on some this?  Someone pointed out last week that it would might be good if someone other than me presented on some of this.

I propose that we split the presentations up as follows:

1)     Current status of the requirements draft (Joe? - 5 mins)

2)     Overview of versioning work & solution space (Rob? - 10 mins):

a.      Semantic versioning at the Module level (DT draft) - draft-verdt-netmod-yang-semver-00

b.      Semantic versioning at the Schema level (packages ID) - draft-rwilton-netmod-yang-packages-01

c.      Client backwards compatibility (version selection ID) - draft-wilton-netmod-yang-ver-selection-00

d.      Module/Schema comparison tooling (deferred for the moment).

3)     Module level semver draft - draft-verdt-netmod-yang-semver-00: (??? - 20 mins)

a.      Re-introduce the versioning scheme.

b.      Highlight main changes

c.      Highlight main open issues

d.      Ready for WG adoption?

4)     YANG packages draft, draft-rwilton-netmod-yang-packages-01 (Rob - 10 mins)

5)     YANG versioning selection draft, draft-wilton-netmod-yang-ver-selection-00 (Reshad? - 10 mins)

Thanks,
Rob

---

From: Joe Clarke <[email-masked]>
Date: Thu, 14 Mar 2019 09:23:17 -0400

On 3/14/19 07:37, Rob Wilton (rwilton) wrote:
> In today’s meeting I hope that we can work out a plan for who is
> presenting what.
> 
>  
> 
> Who, would like to present on some this?  Someone pointed out last week
> that it would might be good if someone other than me presented on some
> of this.
> 
>  
> 
> 1)     Current status of the requirements draft (Joe? – 5 mins)

Sure.

> 
> 2)     Overview of versioning work & solution space (Rob? – 10 mins):

Probably for the best.

> c.      Client backwards compatibility (version selection ID) -
> draft-wilton-netmod-yang-ver-selection-00
> 

I'm happy to help wherever, but Balazs might be good here.

> 4)     YANG packages draft, draft-rwilton-netmod-yang-packages-01 (Rob –
> 10 mins)
> 
> 5)     YANG versioning selection draft,
> draft-wilton-netmod-yang-ver-selection-00 (Reshad? – 10 mins)

I like this breakdown.  Makes sense to me.

Joe

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 15 Mar 2019 14:10:09 +0000

To conclude on this:

Joe will do the reqs presentation. (5 mins)
I will do the overview (10 mins)
Balazs will do module level semver draft (20 mins)
I'll do YANG packages (10 mins)
Reshad or I will do YANG ver selection. (10 mins)

We should have slides ready for review by Weds.
The presentations are Mon morning, so probably need to give them in before the end of Sat.

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob Wilton (rwilton)
Sent: 14 March 2019 11:37
To: [email-masked]
Subject: [Netmod-ver-dt] IETF 104 versioning presentations

Thanks,
Rob