Subject: Re: [Netmod-ver-dt] Current slides

From: Qin Wu <[email-masked]>
Date: Fri, 22 Mar 2019 09:52:22 +0000

Page 4:
Suggest the following change:
OLD TEXT:
"
“The solution MUST provide a mechanism to support clients that expect an older version of a given module when the current version has had non-backwards-compatible changes.”
"
NEW TEXT:
"
“The solution MUST provide a mechanism to support clients to fall back to an older version of a given module when the current version has had non-backwards-compatible changes.”
"
-Qin
-----邮件原件-----
发件人: Netmod-ver-dt [mailto:[email-masked]] 代表 Joe Clarke
发送时间: 2019年3月22日 0:39
收件人: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
主题: Re: [Netmod-ver-dt] Current slides

On 3/21/19 10:21, Rob Wilton (rwilton) wrote:
> Hi,
> 
>  
> 
> This is hopefully the combined set of slides, if anyone would like to 
> review them before today’s meeting.

Here is my updated sub-deck.  Only the last slide changed.

I'll look over the rest of the slides in a bit.

Joe

---

From: Joe Clarke <[email-masked]>
Date: Fri, 22 Mar 2019 05:57:42 -0400

> “The solution MUST provide a mechanism to support clients to fall back to an older version of a given module when the current version has had non-backwards-compatible changes.”

I think those are different approaches.  If the client supports the
newer module, why would it need to fallback.  If it expects the older
module (because it has no knowledge of the new one), then the server
should allow that.

My take is that the requirement is written correctly.  That said, the
slide has it the way it is currently written in the draft, so it should
stay this way for the time being.

Also, I'll likely only present slide 2 and slide 6 to avoid more talk
than necessary.

Joe