Subject: [Netmod-ver-dt] Current slides

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 21 Mar 2019 14:21:30 +0000

Hi,

This is hopefully the combined set of slides, if anyone would like to review them before today's meeting.

Thanks,
Rob

---

From: Joe Clarke <[email-masked]>
Date: Thu, 21 Mar 2019 12:38:56 -0400

On 3/21/19 10:21, Rob Wilton (rwilton) wrote:
> Hi,
> 
>  
> 
> This is hopefully the combined set of slides, if anyone would like to
> review them before today’s meeting.

Here is my updated sub-deck.  Only the last slide changed.

I'll look over the rest of the slides in a bit.

Joe

---

From: Lou Berger <[email-masked]>
Date: Fri, 22 Mar 2019 15:17:17 -0400

I'm afraid you'll need another update of the slides.  See the mail I 
just sent to the list...

On 3/21/2019 10:21 AM, Rob Wilton (rwilton) wrote:
> _______________________________________________
> Netmod-ver-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 22 Mar 2019 21:47:19 +0000

FYI.  It looks like we need to rehash the requirements again.  I suspect that this will probably consume most of the available time.

Joe, we can move your changes back into the deck, but we also need to cover the points raised by Martin and Andy during the adoption poll.

With some offline discussion with Martin, his two main concerns seem to be:

1) Should NBC changes we allowed at all?
1b) If NBC changes are allowed are these restricted to just bug fixes, or feature changes as well.

2) Should any branching be allowed, and if so how much branching should be allowed?

Martin has also seemingly raised the question:

- Why do we need to change this at all given that revision dates work just fine!
Counter examples (i): All vendor YANG models, IETF l3SM YANG model, Open Config YANG models.

Thanks,
Rob

-----Original Message-----
From: Netmod-ver-dt <[email-masked]> On Behalf Of Lou Berger
Sent: 22 March 2019 19:17
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] Current slides

I'm afraid you'll need another update of the slides.  See the mail I just sent to the list...

On 3/21/2019 10:21 AM, Rob Wilton (rwilton) wrote:
> review them before today's meeting.
>
> Thanks,
>
> Rob
>
>

---

From: Joe Clarke <[email-masked]>
Date: Sat, 23 Mar 2019 03:29:09 -0400

> Joe, we can move your changes back into the deck, but we also need to cover the points raised by Martin and Andy during the adoption poll.

I looked at Lou's email.  Seems it's been adopted.  So I was thinking of
resubmitting now as a WG document and changing the title of the
presentation accordingly.

> 2) Should any branching be allowed, and if so how much branching should be allowed?

I can add these points for discussion.  We should have a position on
them in the slides, though.

For NBC changes, we (and the broader WG) seem to agree they should be
allowed.  We have said that bug fixes and feature changes would be
allowed, but we would recommend only bug fixes in older branches.  This
would be consistent (with the exception of branching) with what OC does.

Should branching be allowed?  I think we have to allow this.  This is a
big deal for vendors, and it's even been expressed that some IETF WGs
might want to make use of this.  Although, it's not clear they would
need to do NBC changes to non-current branches.

> Counter examples (i): All vendor YANG models, IETF l3SM YANG model, Open Config YANG models.

Would you even but this on a slide?

Joe