Subject: [Netmod-ver-dt] Proposed slides

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 18 Mar 2019 18:08:17 +0000

Attached is my proposed outline for the YANG ver DT slides

Feedback welcome.  I may possibly tweak the design team update and packaging slides a bit more, but don't intend to add/remove any slides.  I'm hoping that we can get through the presentations fairly quickly so that there is time to answer questions.

If the structure is OK, then down to Joe, Balazs, Reshad to add slides for the other sections please.

Thanks,
Rob

---

From: Joe Clarke <[email-masked]>
Date: Mon, 18 Mar 2019 18:05:38 -0400

On 3/18/19 14:08, Rob Wilton (rwilton) wrote:
> Feedback welcome.  I may possibly tweak the design team update and
> packaging slides a bit more, but don’t intend to add/remove any slides. 
> I’m hoping that we can get through the presentations fairly quickly so
> that there is time to answer questions.
> 
>  
> 

I think the structure looks okay.  I fixed a few minor typos.  I'll
provide my slides tomorrow or Wed.

Thanks, Rob.

Joe

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 18 Mar 2019 17:11:21 -0700

Fixed a few more typos. Updated deck attached.

Question, are we not asking for WG adoption of requirements draft? It is not in the last slide.

I like the example slides, but was confused between modules that have dates as versions and semver as versions. I am sure there is a good explanation for the numbers being used. Time for me to go read the two drafts...

> On Mar 18, 2019, at 3:05 PM, Joe Clarke <[email-masked]> wrote:
> 
> <draft-verdt-netmod-dt-update.pptx>_______________________________________________
> Netmod-ver-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt

Mahesh Jethanandani
[email-masked]

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 19 Mar 2019 05:16:54 +0000

We already have a poll for adoption on reqs.  I was just going to mention that in my slides.

Joe

PGP Key : https://www.marcuscom.com/pgp.asc

> On Mar 19, 2019, at 01:11, Mahesh Jethanandani <[email-masked]> wrote:
> 
> <draft-verdt-netmod-dt-update.pptx>

---

From: Balázs Lengyel <[email-masked]>
Date: Tue, 19 Mar 2019 09:23:12 +0000

Just some minor comments for now:

P9)

- iana crypt-hash is an import only module, like types, it is
unreasonable to implement it

- iana-if-type mistyped

P12) Ask for the adoption of the requirements draft as well.
IMHO adoption is a good idea, but who decides if it ever needs to
be released?  While it is good to keep it for record, I don't see
the need for pushing it through IESG+RFC-Editor. Maybe
reclassifying it to something else (informationl, experimental,
???) would be simpler.

Balazs

On 2019. 03. 18. 19:08, Rob Wilton
(rwilton) wrote:

Attached is my proposed outline for the
YANG ver DT slides

Feedback welcome.  I may possibly tweak the
design team update and packaging slides a bit more, but don’t
intend to add/remove any slides.  I’m hoping that we can get
through the presentations fairly quickly so that there is time
to answer questions.

If the structure is OK, then down to Joe,
Balazs, Reshad to add slides for the other sections please.

Thanks,

Rob

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 19 Mar 2019 10:34:16 +0000

Hi Mahesh,

Modules that have already been published don't have a YANG semver version, so we have to be able to cope with both.  Once a module have a YANG semver version assigned that is what should be used.

Thanks,
Rob

-----Original Message-----
From: Mahesh Jethanandani <[email-masked]> 
Sent: 19 March 2019 00:11
To: Joe Clarke (jclarke) <[email-masked]>
Cc: Rob Wilton (rwilton) <[email-masked]>; [email-masked]; Reshad Rahman (rrahman) <[email-masked]>; Balázs Lengyel <[email-masked]>
Subject: Re: [Netmod-ver-dt] Proposed slides

>> I’m hoping that we can get through the presentations fairly quickly 
>> so that there is time to answer questions.
>> 
>>  
>> 

Mahesh Jethanandani
[email-masked]

---

From: Joe Clarke <[email-masked]>
Date: Tue, 19 Mar 2019 09:01:36 -0400

> for the other sections please.

Here are my proposed slides.  Comments?

Joe

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 19 Mar 2019 13:17:58 +0000

Hi Joe,

I wonder if we can just get away with just having the "Changes since -01" and Summary slide?

I think that putting the changed requirements text up just risks folks spending time commenting on the requirements further, and I'm hoping that they don't.  Or if they do they want to, then it would be better to direct them to comment on the alias as part of the adoption call.

Thanks,
Rob

-----Original Message-----
From: Joe Clarke <[email-masked]> 
Sent: 19 March 2019 13:02
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]; Reshad Rahman (rrahman) <[email-masked]>; Balázs Lengyel <[email-masked]>
Subject: Re: Proposed slides

On 3/18/19 14:08, Rob Wilton (rwilton) wrote:
> packaging slides a bit more, but don't intend to add/remove any slides.
> I'm hoping that we can get through the presentations fairly quickly so 

Joe

---

From: Joe Clarke <[email-masked]>
Date: Tue, 19 Mar 2019 09:22:40 -0400

> I think that putting the changed requirements text up just risks folks spending time commenting on the requirements further, and I'm hoping that they don't.  Or if they do they want to, then it wou…

I thought it might also trigger additional discussion.  But I left them
there because I can imagine some people going, "what was req FOO again?"

Your call.  Remove them if you want.

Joe

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 19 Mar 2019 14:56:31 +0000

We could discuss tomorrow if you are able to dial in.

Thanks,
Rob

-----Original Message-----
From: Joe Clarke <[email-masked]> 
Sent: 19 March 2019 13:23
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]; Reshad Rahman (rrahman) <[email-masked]>; Balázs Lengyel <[email-masked]>
Subject: Re: Proposed slides

> I think that putting the changed requirements text up just risks folks spending time commenting on the requirements further, and I'm hoping that they don't.  Or if they do they want to, then it wou…

I thought it might also trigger additional discussion.  But I left them there because I can imagine some people going, "what was req FOO again?"

Joe

> To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]; 
> Reshad Rahman (rrahman) <[email-masked]>; Balázs Lengyel 
> <[email-masked]>
>> I'm hoping that we can get through the presentations fairly quickly

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 19 Mar 2019 14:56:46 +0000

Thanks for the comment.

Generally, I think that "implementing" a types only module is fine (logically it is implementing an empty set of data nodes). Besides this is required if it contains any identities, since otherwise they would not be available.

For packages, it may be more nuanced to allow for more flexibility in combining modules.  Although possibly that may also be resolved by allowing packages to not be referentially complete.  In summary, I think that there is more thinking required.

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]> On Behalf Of Balázs Lengyel
Sent: 19 March 2019 09:23
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]; Reshad Rahman (rrahman) <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>
Subject: Re: [Netmod-ver-dt] Proposed slides

P9)

- iana crypt-hash is an import only module, like types, it is unreasonable to implement it

- iana-if-type mistyped

P12) Ask for the adoption of the requirements draft as well.  IMHO adoption is a good idea, but who decides if it ever needs to be released?  While it is good to keep it for record, I don't see the need for pushing it through IESG+RFC-Editor. Maybe reclassifying it to something else (informationl, experimental, ???) would be simpler.

Balazs
On 2019. 03. 18. 19:08, Rob Wilton (rwilton) wrote:
Attached is my proposed outline for the YANG ver DT slides

Thanks,
Rob

--

Senior Specialist

Mobile: +36-70-330-7909              email: [email-masked]<mailto:[email-masked]>

---

From: Joe Clarke <[email-masked]>
Date: Tue, 19 Mar 2019 10:57:00 -0400

> We could discuss tomorrow if you are able to dial in.

I am planning to dial in.

Joe

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 19 Mar 2019 10:23:41 -0700

Is it tomorrow or Thur.?? I thought tomorrow was YANG-next meeting...

> On Mar 19, 2019, at 7:56 AM, Rob Wilton (rwilton) <[email-masked]> wrote:
> 
> _______________________________________________

Mahesh Jethanandani
[email-masked]

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 19 Mar 2019 17:26:30 +0000

Sorry for the confusion, it is on Thursday.  It has been a long week already ;-)

Thanks,
Rob

-----Original Message-----
From: Mahesh Jethanandani <[email-masked]> 
Sent: 19 March 2019 17:24
To: Rob Wilton (rwilton) <[email-masked]>
Cc: Joe Clarke (jclarke) <[email-masked]>; [email-masked]; Reshad Rahman (rrahman) <[email-masked]>; Balázs Lengyel <[email-masked]>
Subject: Re: [Netmod-ver-dt] Proposed slides

Mahesh Jethanandani
[email-masked]

---

From: Balázs Lengyel <[email-masked]>
Date: Thu, 21 Mar 2019 02:06:24 +0000

Here are my 2 slides to insert into Robs overview.
Balazs