Subject: Re: [Netmod-ver-dt] Current slides

From: Qin Wu <[email-masked]>
Date: Fri, 22 Mar 2019 11:00:32 +0000

Joe, thanks for clarification, it works for me now.

-Qin
-----邮件原件-----
发件人: Joe Clarke [mailto:[email-masked]] 
发送时间: 2019年3月22日 17:58
收件人: Qin Wu <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>; [email-masked]
主题: Re: [Netmod-ver-dt] Current slides

On 3/22/19 05:52, Qin Wu wrote:
> Page 4:
> Suggest the following change:
> OLD TEXT:
> "
> “The solution MUST provide a mechanism to support clients that expect an older version of a given module when the current version has had non-backwards-compatible changes.”
> "
> NEW TEXT:
> "
> “The solution MUST provide a mechanism to support clients to fall back to an older version of a given module when the current version has had non-backwards-compatible changes.”
> "

I think those are different approaches.  If the client supports the newer module, why would it need to fallback.  If it expects the older module (because it has no knowledge of the new one), then the server should allow that.

My take is that the requirement is written correctly.  That said, the slide has it the way it is currently written in the draft, so it should stay this way for the time being.

Also, I'll likely only present slide 2 and slide 6 to avoid more talk than necessary.

Joe

> -Qin
> -----邮件原件-----
> 发件人: Netmod-ver-dt [mailto:[email-masked]] 代表 Joe 
> Clarke
> 发送时间: 2019年3月22日 0:39
> 收件人: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
> 主题: Re: [Netmod-ver-dt] Current slides
> 
> On 3/21/19 10:21, Rob Wilton (rwilton) wrote:
>> Hi,
>>
>>  
>>
>> This is hopefully the combined set of slides, if anyone would like to 
>> review them before today’s meeting.
> 
> Here is my updated sub-deck.  Only the last slide changed.
> 
> I'll look over the rest of the slides in a bit.
> 
> Joe
>

---

From: Balázs Lengyel <[email-masked]>
Date: Fri, 22 Mar 2019 11:26:54 +0000

Hello,

Here is an updated version of my slides about the module semver. Please 
include them.

regards Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909              email: [email-masked]

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 22 Mar 2019 12:06:07 +0000

Thanks.

So, I think that the combined set of slides is attached.  Joe, Balazs, can you please check that I have incorporated your slides OK.

Thanks,
Rob

> -----Original Message-----
> From: Netmod-ver-dt <[email-masked]> On Behalf Of Balázs
> Lengyel
> Sent: 22 March 2019 11:27
> To: Qin Wu <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>;
> Rob Wilton (rwilton) <[email-masked]>; [email-masked]
> Subject: [Netmod-ver-dt] Balazs semver slides
> 
> Hello,
> 
> Here is an updated version of my slides about the module semver. Please include
> them.
> 
> regards Balazs
> 
> --

---

From: Balázs Lengyel <[email-masked]>
Date: Fri, 22 Mar 2019 12:13:44 +0000

Hello Rob,

I am OK with the slideset.

Balazs