Subject: Re: [Netmod-ver-dt] Balazs semver slides

From: wangzitao <[email-masked]>
Date: Sun, 24 Mar 2019 08:42:01 +0000

Hi Rob,

Can we allow to import two non-backward compatible models at the same time?

For the slides' example:
Available versions: 
0.1.0, 1.0.0, 1.1.0, 1.1.1m, 1.1.2M, 1.2.0, 1.2.1M, 1.3.0, 1.3.1, 2.0.0, 2.1.0

import example-module {     
     semver:version 1.1.0-1.1.1;
     semver:version 1.2.0;
     semver:version 1.3.0+;
   }

If the statement "semver:version 1.3.0+" means allow all versions after 1.3.0. it may cause some uncontrollable errors. For example, there is a new version 3.0.0 that delete a list which be augmented by example-module. This will cause obvious error. How to avoid it?

Best Regards!
-Michael

-----邮件原件-----
发件人: Netmod-ver-dt [mailto:[email-masked]] 代表 Rob Wilton (rwilton)
发送时间: 2019年3月23日 23:11
收件人: wangzitao <[email-masked]>; Balázs Lengyel <[email-masked]>; Qin Wu <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>; [email-masked]
主题: Re: [Netmod-ver-dt] Balazs semver slides

Hi Michael,

Because of the '+' in semver:version 1.3.0+;

Thanks,
Rob

> -----Original Message-----
> From: wangzitao <[email-masked]>
> Sent: 23 March 2019 10:40
> To: Rob Wilton (rwilton) <[email-masked]>; Balázs Lengyel 
> <[email-masked]>; Qin Wu <[email-masked]>; Joe Clarke
> (jclarke) <[email-masked]>; [email-masked]
> Subject: RE: [Netmod-ver-dt] Balazs semver slides
> 
> Hi Rob, Balazs,
> 
> One comment, Page-18 Import by version, you import versions with a 
> major version number of 1. Why it allow version '2.0.0' and '2.1.0'?
> 
> Best Regards!
> -Michael
> 
> -----邮件原件-----
> 发件人: Netmod-ver-dt [mailto:[email-masked]] 代表 Rob 
> Wilton (rwilton)
> 发送时间: 2019年3月22日 20:06
> 收件人: Balázs Lengyel <[email-masked]>; Qin Wu 
> <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>; 
> netmod-ver- [email-masked]
> 主题: Re: [Netmod-ver-dt] Balazs semver slides
> 
> Thanks.
> 
> So, I think that the combined set of slides is attached.  Joe, Balazs, 
> can you please check that I have incorporated your slides OK.
> 
> Thanks,
> Rob
> 
> 
> > -----Original Message-----
> > From: Netmod-ver-dt <[email-masked]> On Behalf Of 
> > Balázs Lengyel
> > Sent: 22 March 2019 11:27
> > To: Qin Wu <[email-masked]>; Joe Clarke (jclarke) 
> > <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>; 
> > [email-masked]
> > Subject: [Netmod-ver-dt] Balazs semver slides
> >
> > Hello,
> >
> > Here is an updated version of my slides about the module semver.
> > Please include them.
> >
> > regards Balazs
> >
> > --
> > Balazs Lengyel                       Ericsson Hungary Ltd.
> > Senior Specialist
> > Mobile: +36-70-330-7909              email: [email-masked]

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: Joe Clarke <[email-masked]>
Date: Sun, 24 Mar 2019 04:44:17 -0400

> If the statement "semver:version 1.3.0+" means allow all versions after 1.3.0. it may cause some uncontrollable errors. For example, there is a new version 3.0.0 that delete a list which be augment…

This is a risk the current module author takes.  If they feel the
imported module might change, then they would bound the upper import
with 1.3.0-1.MAX.MAX.

Joe

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Sun, 24 Mar 2019 09:29:56 +0000

Yes, to add to what Joe has said.

The assumption here is that most NBC changes will not break imports, and hence it is generally better to be flexible with your imports.  Of course, as Joe indicates, the solution allows the module author to decide how permissive they should be.

Thanks,
Rob

> From: Joe Clarke <[email-masked]>
> Sent: 24 March 2019 08:44
> To: wangzitao <[email-masked]>; Rob Wilton (rwilton)
> <[email-masked]>; Balázs Lengyel <[email-masked]>; Qin Wu
> <[email-masked]>; [email-masked]
> Subject: Re: [Netmod-ver-dt] Balazs semver slides
> 
> > If the statement "semver:version 1.3.0+" means allow all versions after 1.3.0.
> it may cause some uncontrollable errors. For example, there is a new version
> 3.0.0 that delete a list which be augmented by example-module. This will cause
> obvious error. How to avoid it?
> 
> This is a risk the current module author takes.  If they feel the imported module
> might change, then they would bound the upper import with 1.3.0-1.MAX.MAX.
> 
> Joe
> 
> >
> > Best Regards!
> > -Michael
> >
> >
> >
> > -----邮件原件-----
> > 收件人: wangzitao <[email-masked]>; Balázs Lengyel
> >> So, I think that the combined set of slides is attached.  Joe,
> >> Balazs, can you please check that I have incorporated your slides OK.
> >>
> >> Thanks,
> >> Rob
> >>
> >>