Subject: Re: [Netmod-ver-dt] Final updates to YANG module versioning draft?

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 11 Mar 2019 14:19:18 +0000

Thanks Rob for doing the editing, I think I know what you did this week-end….

I’ve made some small changes (just pushed).

Couple of other comments/questions (changes not made):
8.1.1 s/made to a latest/made to the latest/?
8.1.1 s/the updated module must use/the updated module MUST use/?

Regards,
Reshad.

P.S: I am away this Thursday.

From: Netmod-ver-dt <[email-masked]> on behalf of "Rob Wilton (rwilton)" <[email-masked]>
Date: Sunday, March 10, 2019 at 1:59 PM
To: "[email-masked]" <[email-masked]>
Subject: [Netmod-ver-dt] Final updates to YANG module versioning draft?

Hi all,

So, I think that I have made my final proposed updated to the draft before publishing tomorrow.   If you have minor trivial corrections that applying them directly might be best, or otherwise if you email me, I will commit them if I have time, although that is somewhat unlikely with the version selection draft still to write …

A summary of the changes:

  *   Markups from review comments
  *   Fixed various references
  *   Added example of YANG semantic version numbers, and reused the same example for the module and imports.  Possibly the example is slightly long and maybe could be condensed, but I was trying to illustrate all of the key points.
  *   Hopefully fixed the semver definitions as we discussed in the meeting on Thursday
  *   Heavily updated the section about updates to RFC 7950 rules to give a better description of how to classify modules based on their YANG statements.  Probably these section should be co-located into a subsection of chapter 2, but that will have to wait.
  *   Applied some markups to the Guidelines section.  Please can you all (Reshad in particular) check that these changes are OK.

I’ve also been adding various issues to the Github issue tracker.  It would be good to try and go through these in Prague and knock off as many as we can.  I don’t think that we should include all of these in our presentation to the NETMOD WG, probably just the most pertinent ones.
https://github.com/netmod-wg/yang-ver-dt/issues

I’ve attached the updated doc and diffs, but probably the commit notification is easiest to compare the diffs:

  Branch: refs/heads/develop

  Home:   https://github.com/netmod-wg/yang-ver-dt

  Commit: 5399283c5405937c6de86d95835b575677c4746f

      https://github.com/netmod-wg/yang-ver-dt/commit/5399283c5405937c6de86d95835b575677c4746f

  Author: rwilton <[email-masked]<mailto:[email-masked]>>

  Date:   2019-03-10 (Sun, 10 Mar 2019)

  Changed paths:

    M yang-semver/draft-verdt-netmod-yang-semver.txt

   M yang-semver/draft-verdt-netmod-yang-semver.xml

    M yang-semver/ietf-semver.yang

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 11 Mar 2019 14:45:09 +0000

From: Reshad Rahman (rrahman) <[email-masked]>
Sent: 11 March 2019 14:19
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] Final updates to YANG module versioning draft?

Thanks Rob for doing the editing, I think I know what you did this week-end….
[RW]
Ah, I’ve been discovered ;-)

Couple of other comments/questions (changes not made):
8.1.1 s/made to a latest/made to the latest/?
[RW]
Probably “made to a new latest”.

8.1.1 s/the updated module must use/the updated module MUST use/?
[RW]
This text is an example, so is non normative, and hence I think that must is right.

Thanks,
Rob

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> on behalf of "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>
Date: Sunday, March 10, 2019 at 1:59 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Netmod-ver-dt] Final updates to YANG module versioning draft?

Hi all,

A summary of the changes:
-        Markups from review comments
-        Fixed various references
-        Added example of YANG semantic version numbers, and reused the same example for the module and imports.  Possibly the example is slightly long and maybe could be condensed, but I was trying to illustrate all of the key points.
-        Hopefully fixed the semver definitions as we discussed in the meeting on Thursday
-        Heavily updated the section about updates to RFC 7950 rules to give a better description of how to classify modules based on their YANG statements.  Probably these section should be co-located into a subsection of chapter 2, but that will have to wait.
-        Applied some markups to the Guidelines section.  Please can you all (Reshad in particular) check that these changes are OK.

  Changed paths: