Subject: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] 840ed7: Update YANG solutions draft that describes overall...

From: Robert Wilton <[email-masked]>
Date: Thu, 30 May 2019 06:06:40 -0700

Branch: refs/heads/develop
  Home:   https://github.com/netmod-wg/yang-ver-dt
  Commit: 840ed78e65ad7f3c52ae6805f8dee22cb2ba9f4f
      https://github.com/netmod-wg/yang-ver-dt/commit/840ed78e65ad7f3c52ae6805f8dee22cb2ba9f4f
  Author: rwilton <[email-masked]>
  Date:   2019-05-30 (Thu, 30 May 2019)

  Changed paths:
    A yang-solutions/draft-verdt-netmod-yang-solutions.txt
    M yang-solutions/draft-verdt-netmod-yang-solutions.xml

  Log Message:
  -----------
  Update YANG solutions draft that describes overall solution space

  Commit: 2ae63cff180a861664c624f40080629ba6221730
      https://github.com/netmod-wg/yang-ver-dt/commit/2ae63cff180a861664c624f40080629ba6221730
  Author: rwilton <[email-masked]>
  Date:   2019-05-30 (Thu, 30 May 2019)

  Changed paths:
    M yang-mod-ver/draft-verdt-netmod-yang-module-versioning.txt
    M yang-mod-ver/draft-verdt-netmod-yang-module-versioning.xml

  Log Message:
  -----------
  Merge branch 'develop' of github.com:netmod-wg/yang-ver-dt into develop

  Commit: cbee7a9fadf1a59e5e2051bd9c53fcbdcadf3e2a
      https://github.com/netmod-wg/yang-ver-dt/commit/cbee7a9fadf1a59e5e2051bd9c53fcbdcadf3e2a
  Author: rwilton <[email-masked]>
  Date:   2019-05-30 (Thu, 30 May 2019)

  Changed paths:
    M yang-solutions/draft-verdt-netmod-yang-solutions.txt

  Log Message:
  -----------
  update permissions

Compare: https://github.com/netmod-wg/yang-ver-dt/compare/7b7ab6316eb8...cbee7a9fadf1

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 30 May 2019 13:09:50 +0000

This is my attempt at updating the solution overview draft.  The references still needs to be fixed up (as updated versions of the other drafts are published), and probably some of the details will need to refined for some of the drafts.

Comments welcome.

Thanks,
Rob

> -----Original Message-----
> From: Netmod-ver-dt <[email-masked]> On Behalf Of Robert
> Wilton
> Sent: 30 May 2019 14:07
> To: [email-masked]
> Subject: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] 840ed7: Update YANG
> solutions draft that describes overall...
> 
>       https://github.com/netmod-wg/yang-ver-
> dt/commit/840ed78e65ad7f3c52ae6805f8dee22cb2ba9f4f
>       https://github.com/netmod-wg/yang-ver-
> dt/commit/2ae63cff180a861664c624f40080629ba6221730
>       https://github.com/netmod-wg/yang-ver-
> dt/commit/cbee7a9fadf1a59e5e2051bd9c53fcbdcadf3e2a
> _______________________________________________
> Netmod-ver-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 30 May 2019 13:30:07 +0000

Thx for putting that together Rob.

I took a quick look and I like it. Fairly simple in what it is trying to achieve (just provide the overview of how the 5 solutions drafts map to the requirements).

We may be putting too much detail in section 3.1 though. It may tie the 2 drafts together too much (as we edit the draft, we'll keep having to go back and update this informational doc).

Jason

> From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob
> Wilton (rwilton)
> Sent: Thursday, May 30, 2019 9:10 AM
> Subject: Re: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] 840ed7: Update YANG
> This is my attempt at updating the solution overview draft.  The references
> still needs to be fixed up (as updated versions of the other drafts are
> published), and probably some of the details will need to refined for some of
> the drafts.
> 
> Comments welcome.
> 
> Thanks,
> Rob
> 
>

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 30 May 2019 15:40:19 +0000

Rob, thanks for doing this. Looks good overall. 

Minor comments + nits:
- Abstract says "temporary document". This is a way of saying we're not going to LC with that doc?
- Intro, remove 'the' from "The aim of the this draft" 
- Section 2, missing 's' in "The requirement..."
- Section 3.1 3rd bullet, "import extensions statement" -> "import extension statement"?
- Section 3.1 5th bullet, typo "compatiable"

Regards,
Reshad.

On 2019-05-30, 9:30 AM, "Netmod-ver-dt on behalf of Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    Jason

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 31 May 2019 10:16:07 +0000

Hi Jason,

Thanks for the review.

> From: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>
> Sent: 30 May 2019 14:30
> To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
> Subject: RE: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] 840ed7: Update YANG
> I took a quick look and I like it. Fairly simple in what it is trying to
> achieve (just provide the overview of how the 5 solutions drafts map to
> the requirements).
> 
> We may be putting too much detail in section 3.1 though. It may tie the 2
> drafts together too much (as we edit the draft, we'll keep having to go
> back and update this informational doc).

[RW] Yes, I sort of agree with you (I was thinking the same when I was writing it).

However, probably not worth investing time changing it now.  We can improve it in future if required.

Thanks,
Rob

> > Subject: Re: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] 840ed7: Update
> > YANG solutions draft that describes overall...
> >
> > This is my attempt at updating the solution overview draft.  The
> > references still needs to be fixed up (as updated versions of the
> > other drafts are published), and probably some of the details will
> > need to refined for some of the drafts.
> >
> > Comments welcome.
> >
> > Thanks,
> > Rob
> >
> >

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 31 May 2019 10:16:27 +0000

Thanks for the review.

Yes, my idea is that we wouldn't take this to WG LC, and its sole purpose it help the folks not actively involved in the versioning understand how the various drafts fit together.

I've fixed the other issues.

Thanks,
Rob

> From: Reshad Rahman (rrahman)
> Sent: 30 May 2019 16:40
> To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>; Rob Wilton
> (rwilton) <[email-masked]>; [email-masked]
> On 2019-05-30, 9:30 AM, "Netmod-ver-dt on behalf of Sterne, Jason (Nokia -
> CA/Ottawa)" <[email-masked] on behalf of
> [email-masked]> wrote:
> 
>     I took a quick look and I like it. Fairly simple in what it is trying
> to achieve (just provide the overview of how the 5 solutions drafts map to
> the requirements).
> 
>     We may be putting too much detail in section 3.1 though. It may tie
> the 2 drafts together too much (as we edit the draft, we'll keep having to
> go back and update this informational doc).
> 
>     Jason
> 
> YANG
> references