Subject: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] 77e66b: Updated guidelines section.

From: Reshad-Rahman <[email-masked]>
Date: Thu, 16 May 2019 06:36:29 -0700

Branch: refs/heads/develop
  Home:   https://github.com/netmod-wg/yang-ver-dt
  Commit: 77e66bd7cdd3647ab218eb84e02151b2d0b6a752
      https://github.com/netmod-wg/yang-ver-dt/commit/77e66bd7cdd3647ab218eb84e02151b2d0b6a752
  Author: Reshad Rahman <[email-masked]>
  Date:   2019-05-16 (Thu, 16 May 2019)

  Changed paths:
    A yang-mod-ver/draft-verdt-netmod-yang-module-versioning.txt
    M yang-mod-ver/draft-verdt-netmod-yang-module-versioning.xml

  Log Message:
  -----------
  Updated guidelines section.

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 16 May 2019 13:58:50 +0000

Thx Reshad for taking a stab at this. I started reviewing (although didn't get terribly far yet).

Section 6.1 mentions the following:

  "The use of status "deprecated" with the status-description statement
allows clients to plan a migration to alternative data nodes."

But that gives the impression that deprecation is our primary method for managing NBC changes. Deprecation is one technique for managing changes to YANG, but there is also the "packages" approach that Rob has been proposing as you mention in 6.1.1.

I think we should remove that sentence from section 6.1.

In 6.1.1, I'd propose we replace these two bullets:

   o  If the server can support NBC versions of the YANG module
      simultaneously using version selection, then the NBC changes MAY
      be done immediately.  Clients would be required to select the
      version which they support and the NBC change would have no impact
      on them.

   o  When possible, NBC changes are done incrementally to provide
clients time to adapt to NBC changes.

with this (change the order, updated the text):

   o  NBC changes can be done incrementally using the 'deprecated' status to provide clients time to adapt to NBC changes.

   o  If the server can support multiple versions of the YANG module, and allows the client to select the version (some ref to the packages & selection drafts ?), then NBC changes MAY be done without using 'status' statements. Clients would be required to select the version which they support and the NBC change would have no impact on them.

In general section 6 talks about managing NBC changes, but it doesn't talk much about branching and making changes on older versions. I think we need to give some weight/description/examples of that as well in here somehow.

Jason

> -----Original Message-----
> From: Netmod-ver-dt <[email-masked]> On Behalf Of
> Reshad-Rahman
> Sent: Thursday, May 16, 2019 9:36 AM
> To: [email-masked]
> Subject: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] 77e66b: Updated
> guidelines section.
> 
>       https://github.com/netmod-wg/yang-ver-
> dt/commit/77e66bd7cdd3647ab218eb84e02151b2d0b6a752
> _______________________________________________
> Netmod-ver-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod-ver-dt