Subject: [Netmod-ver-dt] NBC changes allowed, or only can be described?

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 4 Jun 2019 09:56:30 +0000

Comments at IETF 104 from Martin, and Jason's review comments, raise a question that we haven't properly explored/answered:

Should these documents only allow nbc changes to be expressed without formally allowing them in any way, or should NBC changes be formally allowed in some capacity?

The draft currently takes the latter approach, that NBC changes should explicitly be allowed (e.g. introduction, section 2: Refinements to YANG revision handling, and section 6 on guidelines).  But I just wanted to check that everyone agrees with this direction.

If we don't state that NBC changes are allowed in some capacity then our reclassifying status obsolete as an NBC change is going to be slightly odd in that it will no longer be formally allowed to change a node from deprecated to obsolete ...

Thoughts?
Rob

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 4 Jun 2019 12:49:57 +0000

On Jun 4, 2019, at 05:56, Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:

Comments at IETF 104 from Martin, and Jason’s review comments, raise a question that we haven’t properly explored/answered:

If we don’t state that NBC changes are allowed in some capacity then our reclassifying status obsolete as an NBC change is going to be slightly odd in that it will no longer be formally allowed to change a node from deprecated to obsolete …

I think, based on the requirements, we want to formally allow NBC changes.  Requirement 1.4 states that the solution must allow them.  So the solution must explicitly allow them.

I know this was one of the things that was contentious, though.  I think the feedback we got was to change this wording to “support” NBC changes, but I still need to go through the minutes.

Either way, support/allow, I think we should say that NBC changes are allowed insofar as they follow the rules of the solution.  If they do not, then they are subject to the rules of 7950#11.

Joe