Subject: Re: [Netmod-ver-dt] NBC changes allowed, or only can be described?

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 4 Jun 2019 12:49:26 +0000

Unless I’m missing a subtle point, it’d be a bit contradictory to allow nbc changes to be expressed, but without allowing nbc changes…. Here’s how you should do something which btw you aren’t allowed to do. So yes I agree with the stated direction.

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]> on behalf of "Rob Wilton (rwilton)" <[email-masked]>
Date: Tuesday, June 4, 2019 at 5:56 AM
To: "[email-masked]" <[email-masked]>
Subject: [Netmod-ver-dt] NBC changes allowed, or only can be described?

Comments at IETF 104 from Martin, and Jason’s review comments, raise a question that we haven’t properly explored/answered:

Should these documents only allow nbc changes to be expressed without formally allowing them in any way, or should NBC changes be formally allowed in some capacity?

The draft currently takes the latter approach, that NBC changes should explicitly be allowed (e.g. introduction, section 2: Refinements to YANG revision handling, and section 6 on guidelines).  But I just wanted to check that everyone agrees with this direction.

If we don’t state that NBC changes are allowed in some capacity then our reclassifying status obsolete as an NBC change is going to be slightly odd in that it will no longer be formally allowed to change a node from deprecated to obsolete …

Thoughts?
Rob

---

From: Balázs Lengyel <[email-masked]>
Date: Tue, 4 Jun 2019 15:32:05 +0000

+1   Balazs

On 2019. 06. 04. 14:49, Reshad Rahman
(rrahman) wrote:

Unless I’m missing a
subtle point, it’d be a bit contradictory to allow nbc
changes to be expressed, but without allowing nbc changes….
Here’s how you should do something which btw you aren’t
allowed to do. So yes I agree with the stated direction.

Regards,

Reshad.

From: Netmod-ver-dt
<[email-masked]> on behalf of "Rob
Wilton (rwilton)" <[email-masked]>

To: "[email-masked]"
<[email-masked]>

Subject: [Netmod-ver-dt] NBC changes allowed, or
only can be described?

Comments at IETF 104 from Martin, and
Jason’s review comments, raise a question that we haven’t
properly explored/answered:

Should these documents only allow nbc
changes to be expressed without formally allowing them in any
way, or should NBC changes be formally allowed in some
capacity?

The draft currently takes the latter
approach, that NBC changes should explicitly be allowed (e.g.
introduction, section 2: Refinements to YANG revision
handling, and section 6 on guidelines).  But I just wanted to
check that everyone agrees with this direction.

If we don’t state that NBC changes are
allowed in some capacity then our reclassifying status
obsolete as an NBC change is going to be slightly odd in that
it will no longer be formally allowed to change a node from
deprecated to obsolete …

Thoughts?

Rob

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]