Subject: [Netmod-ver-dt] References

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 5 Jun 2019 09:53:56 +0000

Next question:

The XML2RFC is warnings about these references that are not actually referenced:

Warning: no <xref> in <rfc> targets <reference anchor='I-D.openconfig-netmod-model-catalog'>
Warning: no <xref> in <rfc> targets <reference anchor='I-D.claise-semver'>
Warning: no <xref> in <rfc> targets <reference anchor='I-D.clacla-netmod-model-catalog'>
Warning: no <xref> in <rfc> targets <reference anchor='openconfigsemver'>
Warning: no <xref> in <rfc> targets <reference anchor='semver'>
Warning: no <xref> in <rfc> targets <reference anchor='yangcatalog'>

   [I-D.clacla-netmod-model-catalog]

              Clarke, J. and B. Claise, "YANG module for

              yangcatalog.org", draft-clacla-netmod-model-catalog-03

              (work in progress), April 2018.

   [I-D.claise-semver]

              Claise, B., Barnes, R., and J. Clarke, "Semantic

              Versioning and Structure for IETF Specifications", draft-

              claise-semver-02 (work in progress), January 2018.

   [I-D.openconfig-netmod-model-catalog]

              Shaikh, A., Shakir, R., and K. D'Souza, "Catalog and

              registry for YANG models", draft-openconfig-netmod-model-

              catalog-02 (work in progress), March 2017.

   [openconfigsemver]

              "Semantic Versioning for Openconfig Models",

              <http://www.openconfig.net/docs/semver/>.

   [semver]   "Semantic Versioning 2.0.0", <https://www.semver.org>.

   [yangcatalog]

              "YANG Catalog", <https://yangcatalog.org>.

I'm thinking that we can probably remove most of these references from this draft.  Do you think that there are any of these that we need to keep?

Thanks,
Rob

---

From: Balázs Lengyel <[email-masked]>
Date: Wed, 5 Jun 2019 10:43:55 +0000

yes, Balazs

On 2019. 06. 05. 11:53, Rob Wilton
(rwilton) wrote:

Next question:

The XML2RFC is warnings about these
references that are not actually referenced:

Warning:
no <xref> in <rfc> targets <reference
anchor='I-D.openconfig-netmod-model-catalog'>

Warning:
no <xref> in <rfc> targets <reference
anchor='I-D.claise-semver'>

Warning:
no <xref> in <rfc> targets <reference
anchor='I-D.clacla-netmod-model-catalog'>

Warning:
no <xref> in <rfc> targets <reference
anchor='openconfigsemver'>

Warning:
no <xref> in <rfc> targets <reference
anchor='semver'>

Warning:
no <xref> in <rfc> targets <reference
anchor='yangcatalog'>

[I-D.claise-semver]

[openconfigsemver]

[yangcatalog]

I’m thinking that we can probably remove
most of these references from this draft.  Do you think that
there are any of these that we need to keep?

Thanks,

Rob

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 5 Jun 2019 10:51:12 +0000

I’m interpreting your answer as “yes these can all be removed” 😊

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]> On Behalf Of Balázs Lengyel
Sent: 05 June 2019 11:44
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] References

yes, Balazs
On 2019. 06. 05. 11:53, Rob Wilton (rwilton) wrote:
Next question:

   [I-D.claise-semver]

   [openconfigsemver]

              <http://www.openconfig.net/docs/semver/><http://www.openconfig.net/docs/semver/>.

   [semver]   "Semantic Versioning 2.0.0", <https://www.semver.org><https://www.semver.org>.

   [yangcatalog]

              "YANG Catalog", <https://yangcatalog.org><https://yangcatalog.org>.

I’m thinking that we can probably remove most of these references from this draft.  Do you think that there are any of these that we need to keep?

Thanks,
Rob

[email-masked]<mailto:[email-masked]>

--

Senior Specialist

Mobile: +36-70-330-7909              email: [email-masked]<mailto:[email-masked]>

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Wed, 5 Jun 2019 12:33:33 +0000

On Jun 5, 2019, at 05:53, Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:

Next question:

              yangcatalog.org<http://yangcatalog.org/>", draft-clacla-netmod-model-catalog-03

   [I-D.claise-semver]

   [openconfigsemver]

   [semver]   "Semantic Versioning 2.0.0", <https://www.semver.org<https://www.semver.org/>>.

   [yangcatalog]

              "YANG Catalog", <https://yangcatalog.org<https://yangcatalog.org/>>.

We might want an informative reference to semver in this draft as an example overlay, but other than that, I think they can be dropped.

Joe

Thanks,
Rob