Subject: Re: [Netmod-ver-dt] References

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 5 Jun 2019 12:16:56 +0000

Hi,

Yes they can be removed but the semver ones should be in the semver specific draft?

What were the catalog references for?

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]> on behalf of "Rob Wilton (rwilton)" <[email-masked]>
Date: Wednesday, June 5, 2019 at 5:54 AM
To: "[email-masked]" <[email-masked]>
Subject: [Netmod-ver-dt] References

Next question:

The XML2RFC is warnings about these references that are not actually referenced:

Warning: no <xref> in <rfc> targets <reference anchor='I-D.openconfig-netmod-model-catalog'>
Warning: no <xref> in <rfc> targets <reference anchor='I-D.claise-semver'>
Warning: no <xref> in <rfc> targets <reference anchor='I-D.clacla-netmod-model-catalog'>
Warning: no <xref> in <rfc> targets <reference anchor='openconfigsemver'>
Warning: no <xref> in <rfc> targets <reference anchor='semver'>
Warning: no <xref> in <rfc> targets <reference anchor='yangcatalog'>

   [I-D.clacla-netmod-model-catalog]

              Clarke, J. and B. Claise, "YANG module for

              yangcatalog.org", draft-clacla-netmod-model-catalog-03

              (work in progress), April 2018.

   [I-D.claise-semver]

              Claise, B., Barnes, R., and J. Clarke, "Semantic

              Versioning and Structure for IETF Specifications", draft-

              claise-semver-02 (work in progress), January 2018.

   [I-D.openconfig-netmod-model-catalog]

              Shaikh, A., Shakir, R., and K. D'Souza, "Catalog and

              registry for YANG models", draft-openconfig-netmod-model-

              catalog-02 (work in progress), March 2017.

   [openconfigsemver]

              "Semantic Versioning for Openconfig Models",

              <http://www.openconfig.net/docs/semver/>.

   [semver]   "Semantic Versioning 2.0.0", <https://www.semver.org>.

   [yangcatalog]

              "YANG Catalog", <https://yangcatalog.org>.

I’m thinking that we can probably remove most of these references from this draft.  Do you think that there are any of these that we need to keep?

Thanks,
Rob

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 5 Jun 2019 12:19:05 +0000

From: Reshad Rahman (rrahman)
Sent: 05 June 2019 13:17
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] References

Hi,

[RW]
Yes, seems reasonable.

What were the catalog references for?
[RW]
There were some references in the older drafts, or perhaps the older requirements section.

Thanks,
Rob

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> on behalf of "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, June 5, 2019 at 5:54 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Netmod-ver-dt] References

Next question:

   [I-D.claise-semver]

   [openconfigsemver]

   [yangcatalog]

Thanks,
Rob