Subject: [Netmod-ver-dt] Changes to requirements

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 4 Jun 2019 13:21:22 +0000

As I recall, the change that is needed to be made to the requirements draft is around requirement 1.4.  Right now it differentiates between BC enhancements and NBC bug fixes.  I think the feedback was to simply state that NBC changes should be allowed.  Does that sound right?  The minutes don’t really help me here.  I may have to go to the recording for max clarity, but I was hoping to avoid.

If that sounds right, stating in 1.4 that the solution needs to allow for NBC changes feels weird.  This should be requirement 1.1.  But, if I change the ordering, that will require changes to other documents.  That’s not a problem, but I wanted to sync with the team first.

Joe

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 4 Jun 2019 14:58:06 +0000

I think that the main concern raised by Martin, is that rather that the requirements saying "The solution MUST allow NBC changes", instead the requirement is that "The solution MUST be able to express when NBC changes have occurred".

What that exactly means in term of text changes to the requirements is less clear ... 😊

Thanks,
Rob

-----Original Message-----
From: Netmod-ver-dt <[email-masked]> On Behalf Of Joe Clarke (jclarke)
Sent: 04 June 2019 14:21
To: [email-masked]
Subject: [Netmod-ver-dt] Changes to requirements

Joe
_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 4 Jun 2019 14:59:48 +0000

> On Jun 4, 2019, at 10:58, Rob Wilton (rwilton) <[email-masked]> wrote:
> 
> What that exactly means in term of text changes to the requirements is less clear … 😊

Ah, yes.  That was the other point.  The way it reads is that NBC will happen, but what we need to say is that when NBC happens, we will know it.  I think this solves my dilemma.  I’ll make some changes and push to develop.

Joe

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 4 Jun 2019 17:56:00 +0000

Exactly.  Don't focus on the "allowed to happen".  Focus on the fact that our solution can actually describe & communicate when/if they do happen.

> Sent: Tuesday, June 4, 2019 11:00 AM
> To: Rob Wilton (rwilton) <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Netmod-ver-dt] Changes to requirements
> 
> 
> 
> > I think that the main concern raised by Martin, is that rather that the
> requirements saying "The solution MUST allow NBC changes", instead the
> requirement is that "The solution MUST be able to express when NBC
> changes have occurred".
> >
> Ah, yes.  That was the other point.  The way it reads is that NBC will happen,
> but what we need to say is that when NBC happens, we will know it.  I think
> this solves my dilemma.  I’ll make some changes and push to develop.
> 
> Joe
> 
> >
> > Thanks,
> > Rob
> >
> >
> > As I recall, the change that is needed to be made to the requirements draft
> is around requirement 1.4.  Right now it differentiates between BC
> enhancements and NBC bug fixes.  I think the feedback was to simply state
> that NBC changes should be allowed.  Does that sound right?  The minutes
> don’t really help me here.  I may have to go to the recording for max clarity,
> but I was hoping to avoid.
> >
> > If that sounds right, stating in 1.4 that the solution needs to allow for NBC
> changes feels weird.  This should be requirement 1.1.  But, if I change the
> ordering, that will require changes to other documents.  That’s not a
> problem, but I wanted to sync with the team first.
> >
> > Joe

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 4 Jun 2019 18:01:12 +0000

> On Jun 4, 2019, at 13:56, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]> wrote:
> 

Do you like my new text?

Joe