Subject: Re: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] Status obsolete nodes (#2)

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 4 Jun 2019 17:54:12 +0000

I know we wanted a flag for deprecated nodes.  But was there ever confusion about obsolete nodes?

From: Robert Wilton <[email-masked]>
Sent: Tuesday, June 4, 2019 7:16 AM
To: netmod-wg/yang-ver-dt <[email-masked]>
Cc: Subscribed <[email-masked]>
Subject: Re: [netmod-wg/yang-ver-dt] Status obsolete nodes (#2)

The YANG library changes indicate whether status obsolete nodes are implemented by the server., which I think is as much as we can do in this draft.

Otherwise, this issue can be deferred to YANG.Next. netmod-wg/yang-next#63<https://github.com/netmod-wg/yang-next/issues/63>

—
You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub<https://github.com/netmod-wg/yang-ver-dt/issues/2?email_source=notifications&email_token=AETQE732PFQVVSM5ARRJM5TPYZFHTA5CNFSM4G2RIFNKYY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGODW4HRLQ#issuecomment-498628782>, or mute the thread<https://github.com/notifications/unsubscribe-auth/AETQE7ZX7V35SIKFWU7R3NDPYZFHTANCNFSM4G2RIFNA>.

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 5 Jun 2019 08:45:44 +0000

Yes.  At the moment, a server is allowed to implement obsolete nodes that can break a client.

E.g. if an obsolete config node is mandatory, and it is implemented then the client must provide it, and if it is not implemented then the client must not provide it, and there is no way for a client to determine from the server whether it is implemented.

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]> On Behalf Of Sterne, Jason (Nokia - CA/Ottawa)
Sent: 04 June 2019 18:54
To: [email-masked]
Subject: Re: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] Status obsolete nodes (#2)

From: Robert Wilton <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, June 4, 2019 7:16 AM
To: netmod-wg/yang-ver-dt <[email-masked]<mailto:[email-masked]>>
Cc: Subscribed <[email-masked]<mailto:[email-masked]>>
Subject: Re: [netmod-wg/yang-ver-dt] Status obsolete nodes (#2)

—

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Wed, 5 Jun 2019 13:23:21 +0000

I would have thought that "status obsolete" would trump "mandatory".

It seems a bit odd to provide support for a node marked obsolete. Do we think there are servers out there today that support them?

From: Rob Wilton (rwilton) <[email-masked]>
Sent: Wednesday, June 5, 2019 4:46 AM
To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>; [email-masked]
Subject: RE: [netmod-wg/yang-ver-dt] Status obsolete nodes (#2)

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Sterne, Jason (Nokia - CA/Ottawa)
Sent: 04 June 2019 18:54
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] Status obsolete nodes (#2)

—

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 5 Jun 2019 13:34:16 +0000

From: Netmod-ver-dt <[email-masked]> On Behalf Of Sterne, Jason (Nokia - CA/Ottawa)
Sent: 05 June 2019 14:23
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] Status obsolete nodes (#2)

I would have thought that "status obsolete" would trump "mandatory".
[RW]
Martin’s view was effectively the opposite.  I.e. if the node is implemented then mandatory would take effect.

[RW]
Unclear.

One scenario is a standards based model that is implemented, used by customers, and then some of the configuration gets obsoleted, but the vendor wants to keep supporting it because some of the customers are still using it.

Today, in RFC 7950, obsolete states:
   o  "obsolete" means that the definition is obsolete and SHOULD NOT be
      implemented and/or can be removed from implementations.

Noting the “SHOULD NOT” and “can be removed”, rather than “MUST NOT be implemented and/or MUST be removed …”.

Basically, I think that YANG ends up being slightly broken if obsolete nodes can be implemented, but allows implementations to do this.  I think that this will get fixed in YANG.Next, but that will only help with YANG 1.2 modules.  For everything else, it will still need a flag to report to clients what devices actually do.

Thanks,
Rob

From: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, June 5, 2019 4:46 AM
To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [netmod-wg/yang-ver-dt] Status obsolete nodes (#2)

Thanks,
Rob

—

---

From: Balázs Lengyel <[email-masked]>
Date: Wed, 5 Jun 2019 13:35:00 +0000

Mandatory and status are orthogonal in rfc7950. They do not
effect each other. If the schema node is supported, it is
mandatory to use.

I agree that the specification of obsolete is bad in current
YANG. I wanted to correct it for a long time, but some people
claimed that if it was OK for SNMP it is OK for us too; which is a
good argument if you are discussing preservation of national
monuments, but otherwise it is ...

regards Balazs

On 2019. 06. 05. 15:23, Sterne, Jason
(Nokia - CA/Ottawa) wrote:

I
would have thought that "status obsolete" would trump
"mandatory".

It
seems a bit odd to provide support for a node marked
obsolete. Do we think there are servers out there today that
support them?

From: Rob Wilton (rwilton)
<[email-masked]>

To: Sterne, Jason (Nokia - CA/Ottawa)
<[email-masked]>; [email-masked]

Subject: RE: [netmod-wg/yang-ver-dt] Status
obsolete nodes (#2)

Yes.  At the moment, a server is allowed to
implement obsolete nodes that can break a client.

E.g. if an obsolete config node is mandatory,
and it is implemented then the client must provide it, and
if it is not implemented then the client must not provide
it, and there is no way for a client to determine from the
server whether it is implemented.

Thanks,

Rob

From:
Netmod-ver-dt <[email-masked]>
On Behalf Of Sterne, Jason (Nokia - CA/Ottawa)

Sent: 04 June 2019 18:54

Subject: Re: [Netmod-ver-dt]
[netmod-wg/yang-ver-dt] Status obsolete nodes (#2)

I know we wanted a flag
for deprecated nodes.  But was there ever confusion about
obsolete nodes?

From:
Robert Wilton <[email-masked]>

Subject: Re: [netmod-wg/yang-ver-dt] Status
obsolete nodes (#2)

The YANG library changes
indicate whether status obsolete nodes are implemented by
the server., which I think is as much as we can do in this
draft.

Otherwise, this issue can be
deferred to YANG.Next.
netmod-wg/yang-next#63

—

You are receiving this because you are subscribed to
this thread.

Reply to this email directly,
view it on GitHub, or
mute the thread.

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]