Subject: Re: [Netmod-ver-dt] Tools draft

From: Balázs Lengyel <[email-masked]>
Date: Thu, 15 Aug 2019 16:11:24 +0000

Hello,

I started thinking about what should the tools draft really contain . Its not 
clear to me.

*	Write an algorithm for Yang Module (YAM) comparison?  Pyang already does it 
to 90%. Do we want to reverse engineer pyang?
*	Write requirements? Is a draft/RFC the proper place to write tool 
requirements? Are we trying to write requirements for pyang? Personally I am 
missing:

1.	features supported for old and new YAMs separately
2.	listings of all editorial/bc/nbc changes, not just an error at the first 
NBC

*	Do we want to compare just one module or a module considering its 
deviations, features(missing from pyang), imports as pyang does?
*	Create an extension to manually label the changetype 
unchanged/editorial/bc/nbc and the revision that introduced it? That solution 
will have its limitations:

a.	only works if the newYam has the oldYam in its revision history
b.	only works if all revision steps between the oldYam and newYam are 
labeled/annotated for a specific data node.

So what should be in the tools  draft? Help please!

Regards Balazs

---

From: Balázs Lengyel <[email-masked]>
Date: Thu, 15 Aug 2019 16:15:27 +0000

One more thing  we could have in the tool draft is a list of limitations inherent in a  tool based approach. List some changes that can not be categorized as editorial/bc/nbc by an algorithm.

Still I am not sure we have enough material to even have a draft.

Regards Balazs

From: Balázs Lengyel 
Sent: 2019. augusztus 15., csütörtök 18:11
To: Joe Clarke (jclarke) <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>
Cc: Wubo (lana) <[email-masked]>; [email-masked]
Subject: RE: [Netmod-ver-dt] Tools draft

Hello,

I started thinking about what should the tools draft really contain . Its not clear to me.

*	Write an algorithm for Yang Module (YAM) comparison?  Pyang already does it to 90%. Do we want to reverse engineer pyang?
*	Write requirements? Is a draft/RFC the proper place to write tool requirements? Are we trying to write requirements for pyang? Personally I am missing:

1.	features supported for old and new YAMs separately
2.	listings of all editorial/bc/nbc changes, not just an error at the first NBC

*	Do we want to compare just one module or a module considering its deviations, features(missing from pyang), imports as pyang does?
*	Create an extension to manually label the changetype unchanged/editorial/bc/nbc and the revision that introduced it? That solution will have its limitations: 

a.	only works if the newYam has the oldYam in its revision history
b.	only works if all revision steps between the oldYam and newYam are labeled/annotated for a specific data node. 

Regards Balazs