Subject: [Netmod-ver-dt] Netmod Versioning Design Team Meetings and Update

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 8 Aug 2019 13:33:26 +0000

I don't suggest that we meet today, and I'm away next week.

I've setup the following Doodle poll to try and find the best time for the weekly Netmod versioning design team meetings:

https://doodle.com/poll/53qm72pds8arhgb6

You can select yes, no, maybe for each slot.

As a reminder the proposed work split was:
- Joe - initial spin of the semver draft
- Balazs - tooling comparison draft.
- Reshad - version selection draft.
- Rob - packages draft.

I think that we want to aim to have a full set of drafts available so that we can hopefully seek WG adoption at IETF 106.

Thanks,
Rob

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thu, 8 Aug 2019 13:58:27 +0000

On Aug 8, 2019, at 09:33, Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:

I don’t suggest that we meet today, and I’m away next week.

I’ve setup the following Doodle poll to try and find the best time for the weekly Netmod versioning design team meetings:

Done.

As a reminder the proposed work split was:
- Joe – initial spin of the semver draft

Yes, and I should have something to review by next Thursday.  Do we want to meet then or hold off until the week after?

Joe

Thanks,
Rob

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 8 Aug 2019 14:10:30 +0000

If everyone else is free could meet next week, or otherwise, perhaps hold off until week of 19th August.

Thanks,
Rob

From: Joe Clarke (jclarke)
Sent: 08 August 2019 14:58
To: Rob Wilton (rwilton) <[email-masked]>
Cc: [email-masked]; Wubo (lana) <[email-masked]>
Subject: Re: [Netmod-ver-dt] Netmod Versioning Design Team Meetings and Update

Done.

Joe

Thanks,
Rob

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 8 Aug 2019 14:43:55 +0000

I’d rather wait for Rob to be back.

From: Netmod-ver-dt <[email-masked]> on behalf of "Rob Wilton (rwilton)" <[email-masked]>
Date: Thursday, August 8, 2019 at 10:11 AM
To: "Joe Clarke (jclarke)" <[email-masked]>
Cc: "Wubo (lana)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Netmod-ver-dt] Netmod Versioning Design Team Meetings and Update

Thanks,
Rob

Done.

Joe

Thanks,
Rob

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thu, 15 Aug 2019 14:29:18 +0000

As you probably saw, I committed the first pass at this.  I have a number of open questions listed in the commit:

* Do we need to mention instance data anymore?

* Do we need or want to reflect something in YANG Library?

* Do we need a way to distinguish that a revision-label is using this
scheme?

Comments on this work or thoughts on these questions?

Joe

---

From: Balázs Lengyel <[email-masked]>
Date: Thu, 15 Aug 2019 16:22:25 +0000

From: Netmod-ver-dt <[email-masked]> On Behalf Of Joe Clarke (jclarke)
Sent: 2019. augusztus 15., csütörtök 16:29
To: Rob Wilton (rwilton) <[email-masked]>
Cc: Wubo (lana) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] Netmod Versioning Design Team Meetings and Update

On Aug 8, 2019, at 09:33, Rob Wilton (rwilton) <[email-masked] <mailto:[email-masked]> > wrote:

 <https://doodle.com/poll/53qm72pds8arhgb6> https://doodle.com/poll/53qm72pds8arhgb6

Balazs: It was a requirement, but I don’t insist on it.

BALAZS: the label is already there in our proposal. I hope the label will be self documenting like a URI that starts with a URI scheme, so IMHO no need to do anything more in yang-library. 

BALAZS: I hope the label will be self documenting like a URI that starts with a URI scheme,

Joe

---

From: Balázs Lengyel <[email-masked]>
Date: Thu, 15 Aug 2019 16:24:19 +0000

See below! Balazs

From: Netmod-ver-dt <[email-masked]> On Behalf Of Balázs Lengyel
Sent: 2019. augusztus 15., csütörtök 18:22
To: Joe Clarke (jclarke) <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>
Cc: Wubo (lana) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] Netmod Versioning Design Team Meetings and Update

From: Netmod-ver-dt <[email-masked] <mailto:[email-masked]> > On Behalf Of Joe Clarke (jclarke)
Sent: 2019. augusztus 15., csütörtök 16:29
To: Rob Wilton (rwilton) <[email-masked] <mailto:[email-masked]> >
Cc: Wubo (lana) <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: Re: [Netmod-ver-dt] Netmod Versioning Design Team Meetings and Update

BALAZS: the label is already there in yang-library in our proposal. I hope the label will be self documenting like a URI that starts with a URI scheme, so IMHO no need to do anything more in yang-library. 

Joe

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 16 Aug 2019 07:46:09 +0000

* Do we need to mention instance data anymore?
Balazs: It was a requirement, but I don’t insist on it.
I didn’t know if it still belongs in this draft (which is talking about an overlay) or in the main versioning draft (if at all).  What I wanted to steer away from is adding new versioning requirements to this draft (which at this point should only be describing this revision-label).

* Do we need or want to reflect something in YANG Library?
BALAZS: the label is already there in yang-library in our proposal. I hope the label will be self documenting like a URI that starts with a URI scheme, so IMHO no need to do anything more in yang-library.
Here’s my point.  Right now, the rev:revision-label is a simple semver string (e.g., “3.1.0”).  This is not very self-describing.  One might look at this and think “semver” when the vendor meant their own release versioning scheme.

That is certainly one way of doing it.  Something like urn:ietf:params:yang-version:semver/3.1.0.  That type of self-documenting approach is not part of this draft nor touched on in the main module versioning draft.  We can talk about this next week perhaps.

Joe

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 20 Aug 2019 08:57:35 +0000

Given that everyone seems to be happy with the existing Thursday slot then we will continue with that slot.

Currently 3-4 pm BST (GMT + 1), reverting to 3-4 pm (GMT) on 31 October when summer time ends, and food shortages start.

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob Wilton (rwilton)
Sent: 08 August 2019 14:33
To: [email-masked]; Wubo (lana) <[email-masked]>
Subject: [Netmod-ver-dt] Netmod Versioning Design Team Meetings and Update

Thanks,
Rob

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 22 Aug 2019 09:09:45 +0000

Also, I just want to confirm to everyone that we are meeting today.

I have a doctors appointment before.  It is possible, but hopefully unlikely, that I might be late, in which case please can Joe or Reshad can host the webex.

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob Wilton (rwilton)
Sent: 20 August 2019 09:58
To: [email-masked]; Wubo (lana) <[email-masked]>
Subject: Re: [Netmod-ver-dt] Netmod Versioning Design Team Meetings and Update

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Rob Wilton (rwilton)
Sent: 08 August 2019 14:33
To: [email-masked]<mailto:[email-masked]>; Wubo (lana) <[email-masked]<mailto:[email-masked]>>
Subject: [Netmod-ver-dt] Netmod Versioning Design Team Meetings and Update

Thanks,
Rob

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thu, 22 Aug 2019 12:01:26 +0000

On Aug 22, 2019, at 05:09, Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:

I’m planning to attend.  I will NOT be able to make it next week, however.

Joe

Thanks,
Rob

Thanks,
Rob

Thanks,
Rob

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 22 Aug 2019 11:15:24 -0700

I was planning on attending, but my previous meeting ran over. And then the question was - do I attend meeting, or do I have my breakfast before the next meeting starts? Sorry, the stomach took over! Maybe next time.

Cheers.

> On Aug 22, 2019, at 2:09 AM, Rob Wilton (rwilton) <[email-masked]> wrote:
> 
> From: Netmod-ver-dt <[email-masked] <mailto:[email-masked]>> On Behalf Of Rob Wilton (rwilton)
> To: [email-masked] <mailto:[email-masked]>; Wubo (lana) <[email-masked] <mailto:[email-masked]>>
> From: Netmod-ver-dt <[email-masked] <mailto:[email-masked]>> On Behalf Of Rob Wilton (rwilton)
> To: [email-masked] <mailto:[email-masked]>; Wubo (lana) <[email-masked] <mailto:[email-masked]>>
> https://doodle.com/poll/53qm72pds8arhgb6 <https://doodle.com/poll/53qm72pds8arhgb6>
>  
> [email-masked]

Mahesh Jethanandani
[email-masked]