Subject: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] 7d8c59: Updates to module versioning draft

From: Robert Wilton <[email-masked]>
Date: Wed, 18 Sep 2019 07:06:07 -0700

Branch: refs/heads/develop
  Home:   https://github.com/netmod-wg/yang-ver-dt
  Commit: 7d8c5939c690fd4361d6df7d3f38837033db6a65
      https://github.com/netmod-wg/yang-ver-dt/commit/7d8c5939c690fd4361d6df7d3f38837033db6a65
  Author: rwilton <[email-masked]>
  Date:   2019-09-18 (Wed, 18 Sep 2019)

  Changed paths:
    M yang-mod-ver/draft-verdt-netmod-yang-module-versioning.txt
    M yang-mod-ver/draft-verdt-netmod-yang-module-versioning.xml
    M yang-mod-ver/ietf-yang-revisions.yang
    A yang-mod-ver/[email-masked]
    M yang-mod-ver/ietf-yl-revisions.yang

  Log Message:
  -----------
  Updates to module versioning draft

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 18 Sep 2019 14:29:40 +0000

Hi All,

As promised, some updates to the YANG module versioning draft.  Balazs, does this alleviate some of your concerns regarding scope of the YANG semver draft and its scope?

https://github.com/netmod-wg/yang-ver-dt/commit/7d8c5939c690fd4361d6df7d3f38837033db6a65#diff-0206db30260581b3a629ee924d97c7f8

1. Added the following text to revision label to indicate relationship to YANG semver:

   YANG Semver [XXX verdt-netmod-yang-semver] defines a versioning
   scheme based on Semver 2.0.0 [semver] that can be used as a revision
   label.  All revision labels that match the pattern for the "version"
   typedef in the ietf-yang-semver YANG module MUST be interpreted as
   YANG semantic version numbers.

2. Changes revision label examples to be unquoted strings, e.g. 3.1.0 rather than "3.1.0"
3. Slightly restructured the YANG library section and added a tree diagram for the YL augmentations.
4. Added the following text to the section 7.1, Guidelines:

   All IETF YANG modules MUST include revision-label statements for all
   newly published YANG modules, and all newly published revisions of
   existing YANG modules.  The revision-label MUST take the form of a
   YANG semantic version number [XXX verdt-netmod-yang-versioning].

5. Use RFC6991bis for definition of revision-date rather than redefining it.
6. Fixed module boilerplate text.
7. Changed the typedef definition from "label-string" to "revision-label"

8. Added the following text to "revision label" typedef to explain that if it looks like a YANG semver version then it MUST be treated as a YANG semver version:

          Revision labels that classify as YANG semantic versions,
          as defined by the ietf-yang-semver:version typedef,
          MUST conform to the versioning behaviour defined in
          XXXX [verdt]: YANG Semantic Versioning.";

9. Beefed up the references in the module
10. Added a YANG semver number to ietf-yl-revisions.yang.  I.e. eat your own dog food.  I don't think that we can do this for ietf-yang-revisions.yang because it would be a slightly circular use of an extension.

Everyone happy with these changes?

Thanks,
Rob

-----Original Message-----
From: Netmod-ver-dt <[email-masked]> On Behalf Of Robert Wilton
Sent: 18 September 2019 15:06
To: [email-masked]
Subject: [Netmod-ver-dt] [netmod-wg/yang-ver-dt] 7d8c59: Updates to module versioning draft

  Changed paths:

  Log Message:
  -----------

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt