Subject: [Netmod-ver-dt] draft-verdt-netmod-yang-module-versioning: Name of the “label-string” typedef.

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 9 Sep 2019 10:40:33 +0000

The type of “revision-label” is currently defined as:

  typedef label-string {
    type string {
      length "1..255";
      pattern '[^\s@]+';
      pattern '\d{4}-\d{2}-\d{2}' {
        modifier invert-match;
      }
    }
    description
      "A label associated with a YANG revision.

       Excludes spaces and '@'.  Cannot match revision-date.";
    reference
      "draft-verdt-netmod-yang-module-versioning: Revision label";
  }

  typedef revision-date-or-label {
    type union {
      type revision-identifier;
      type label-string;
    }
    description
      "Represents either a YANG revision date or a revision label";
  }

I think that it might be better to change the name of the typedef “label-string” to “revision-label-string”.

Is this OK?

Thanks,
Rob

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 9 Sep 2019 17:51:27 +0000

On Sep 9, 2019, at 06:40, Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:

  typedef label-string {
    type string {
      length "1..255";
      pattern '[^\s@]+';

Is this OK?

It depends.  I think the prefix will be “rev:” right?  I opted to call the typedef in the server draft “version” simply because it will be always written server:version.

Joe

Thanks,
Rob

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 10 Sep 2019 13:50:53 +0000

From: Joe Clarke (jclarke) <[email-masked]>
Sent: 09 September 2019 18:51
To: Rob Wilton (rwilton) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netmod-ver-dt] draft-verdt-netmod-yang-module-versioning: Name of the “label-string” typedef.

  typedef label-string {
    type string {
      length "1..255";
      pattern '[^\s@]+';

Is this OK?

[RW]

Yes, in the packages draft I have the following leaf defined:
    leaf version {
      type rev:label-string;
      mandatory true;
      description
        "Uniquely identies a particular version of a YANG package.

         Follows the definition for revision labels defined in
         draft-verdt-nemod-yang-module-versioning, section XXX";
    }

Here, it looked like calling the type “rev:revision-label-string” might be cleaner.

This is a very minor issue though!

Thanks.
Rob

Joe

Thanks,
Rob

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 10 Sep 2019 15:26:32 +0000

Is this OK?

Yeah, I see your point.  Even within the rev namespace, you might have a need for a different “label-string”.  I think it’s a good change to make in this context.

Joe

Thanks.
Rob

Joe

Thanks,
Rob