Subject: [Netmod-ver-dt] Version selection for NETCONF

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 19 Sep 2019 02:29:58 +0000

Hi all,

Last week (email + meeting) there seemed to be consensus on the use of “root path” method for RESTCONF.

For NETCONF, we discussed using capabilities. Extending the capabilities to include “schema versions” seems sensible, with 1 top-level schema per schema family where family is e.g. vendor-xxx-native, ietf, OpenConfig.

  1.  An example of schema-versions advertised: vendor-xxx-native_1.2.1, vendor-xxx-native_2.0.0, ietf_2.3.0. We also need an RPC for the client to select which schema-version (among the ones advertised by the server) it wants to use.
  2.  If a client doesn’t call the SetVersion RPC, then the server’s behavior is to resort to default schema version (when multiple versions of schemas are supported).
  3.  If a server doesn’t advertise any schema-versions, client doesn’t call SetVersion RPC and both behave as they do today.

Thoughts on this?

Regards,
Reshad.

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thu, 19 Sep 2019 19:46:55 +0000

Why not advertise in yang library since both RC and NC need this?  Other than that, the RPC flow sounds right.  But what is the default schema?  Does the server flag one as default?

Joe

PGP Key : https://www.marcuscom.com/pgp.asc

On Sep 18, 2019, at 21:30, Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Thoughts on this?

Regards,
Reshad.

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 19 Sep 2019 23:08:52 +0000

Hi Joe,

We discussed YL in today’s meeting and consensus was to have it in both YL and capabilities.

Good question about default schema, this could indeed be handy.

Regards,
Reshad.

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thursday, September 19, 2019 at 3:46 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Netmod-ver-dt] Version selection for NETCONF

Joe

Thoughts on this?

Regards,
Reshad.

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Fri, 20 Sep 2019 14:57:40 +0000

On Sep 19, 2019, at 19:08, Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Joe,

Works for me.

It could simply be an empty or boolean leaf to mark the default.

Joe

Regards,
Reshad.

From: "Joe Clarke (jclarke)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, September 19, 2019 at 3:46 PM
To: "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netmod-ver-dt] Version selection for NETCONF

Joe

Thoughts on this?

Regards,
Reshad.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Sat, 21 Sep 2019 15:41:09 +0000

Hi Joe,

Date: Friday, September 20, 2019 at 10:57 AM

Hi Joe,

Works for me.

It could simply be an empty or boolean leaf to mark the default.
<RR> Makes snse. The leaf would be in YL. We’d need to have the equivalent in capabilities.

Regards,
Reshad.

Joe

Regards,
Reshad.

Joe

Thoughts on this?

Regards,
Reshad.