Subject: Re: [Netmod-ver-dt] Today's meeting

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 17 Oct 2019 12:44:28 +0000

Hi Rob, all,

I’ve started working on yang-ver-selection.  Changes needed (I’ve started on some of those):

  1.  New netconf capability for schemas and new RPC to select schema
  2.  Change section 5, 7 (split into RESTCONF and NETCONF specific sections?)
  3.  Get rid of port number in the YANG model, other changes may be needed.
  4.  Explain how the RESTCONF solution updates 8040
  5.  Provide some examples

I’m confident I’ll have something before the meeting next week.

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]> on behalf of "Rob Wilton (rwilton)" <[email-masked]>
Date: Thursday, October 17, 2019 at 6:18 AM
To: "[email-masked]" <[email-masked]>
Subject: [Netmod-ver-dt] Today's meeting

Sorry for cancelling last weeks meeting at short notice due network issues.

It would be good to meet today, if possible.

Status:
draft-verdt-netmod-yang-semver-01<https://datatracker.ietf.org/doc/draft-verdt-netmod-yang-semver/> – thanks Joe!
draft-verdt-netmod-yang-module-versioning-01<https://datatracker.ietf.org/doc/draft-verdt-netmod-yang-module-versioning/> – published
draft-rwilton-netmod-yang-packages – publish next week hopefully?
draft-wilton-netmod-yang-ver-selection – tbd?
schema-comparison – tbd?

draft-verdt-netmod-yang-solutions-02 – Will probably update and publish on Mon Nov 4th, main change is to update draft references, and remove the requirements, referencing the requirements draft instead.

Thank you all for reviewing the packaging draft.  I’m updating the draft with the various comments as much as possible now, and trying to close the dead issues.  I would like to go try and go through the remaining comments raised today, so hopefully we can get to know what I need to update before publishing.  I think that some issues (e.g. do we have a different structure in the file vs the device we will probably need to get WG input on).

For the second half of the meeting it would be good to try and go over the versioning selection draft to see what updates are required.

I can make next week’s meeting, but then I’m on PTO for a week from 26th Oct -> 2nd Nov, which is right before the IETF deadline on Monday 4th November.  I may still be able to review docs whilst on holiday, I’m not sure.

Thanks,
Rob

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 17 Oct 2019 13:04:45 +0000

Hi Reshad,

I’m also tracking this issue https://github.com/rgwilton/YANG-Packages-Draft/issues/18

I think that the packages structure probably needs to be augmented to indicate whether a particular package is a top level “selectable” package, or there needs to be some mechanism that a client knows which package on a device they are allow to choose as the schema that they wish to use.

Thanks,
Rob

From: Reshad Rahman (rrahman) <[email-masked]>
Sent: 17 October 2019 13:44
To: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] Today's meeting

Hi Rob, all,

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> on behalf of "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 17, 2019 at 6:18 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Netmod-ver-dt] Today's meeting

Status:

Thanks,
Rob