Subject: [Netmod-ver-dt] YANG packages slides

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Sat, 16 Nov 2019 15:08:52 +0000

Packages slides are attached.

Comments welcome.  I'll send this copy to Kent, but I suspect that we can update if required.

Thanks,
Rob

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Sun, 17 Nov 2019 02:55:04 +0000

On Nov 16, 2019, at 10:08, Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:

Comments welcome.  I’ll send this copy to Kent, but I suspect that we can update if required.

Looks good.  Noticed you misspelled bootstrap on slide 10.  Does it make sense to also mention at uber packages at like a module family level (e.g., openconfig, ietf, etc.)?

Joe

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 18 Nov 2019 15:14:37 +0000

Nice slides.

Slide 11: bullet one should say "Same *or* different…"

Overall I suspect we'll have to re-hash some of these open points (e.g. reusing YANG library) once the working group actually adopts this work and people start to really dig into it and understand it in detail. It is hard to give meaningful input based on casual looks at these drafts.

For the YANG library issue, if you get a chance, it might be good to actually illustrate the difference in the two options (i.e. show, at least partially, what ends up on the device and what gets queried in both options.  Although that is hard to fit onto slides…)

Jason

From: Netmod-ver-dt <[email-masked]> On Behalf Of Joe Clarke (jclarke)
Sent: Saturday, November 16, 2019 9:55 PM
To: Rob Wilton (rwilton) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netmod-ver-dt] YANG packages slides

Joe

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 18 Nov 2019 22:46:57 +0000

Thanks both.  I’ve fixed the typos.

For the YANG library issue, I don’t have time to add a diagram now.  But I agree that this could be debated during/after a WG adoption call anyway.  That previous comment probably applies to all the issues that we are highlighting in the solution drafts.  Hopefully I will remember to make that clear during the introduction.

Joe, I’ve added a slide on uber-schema (last but one), please let me know if this is what you meant?

Thanks,
Rob

From: Netmod-ver-dt <[email-masked]> On Behalf Of Sterne, Jason (Nokia - CA/Ottawa)
Sent: 18 November 2019 23:15
To: Joe Clarke (jclarke) <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netmod-ver-dt] YANG packages slides

Nice slides.

Jason

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> On Behalf Of Joe Clarke (jclarke)
Sent: Saturday, November 16, 2019 9:55 PM
To: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Netmod-ver-dt] YANG packages slides

Joe

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 19 Nov 2019 00:51:24 +0000

That slide is exactly what I was thinking about.  It links nicely with Reshad’s version selection, too.  Thanks.

Joe

PGP Key : https://www.marcuscom.com/pgp.asc

On Nov 19, 2019, at 06:46, Rob Wilton (rwilton) <[email-masked]> wrote:

Thanks,
Rob

Nice slides.

Jason

Joe

<ietf-106-verdt-yang-packages.pptx>