Subject: Re: [Netmod-ver-dt] DT Update after IETF 106

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 26 Nov 2019 13:28:41 +0000

OK with me.

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]> on behalf of "Rob Wilton (rwilton)" <[email-masked]>
Date: Monday, November 25, 2019 at 1:07 PM
To: "[email-masked]" <[email-masked]>
Subject: [Netmod-ver-dt] DT Update after IETF 106

Hi,

My interpretation of the NETMOD meeting is:

  *   There seems to be reasonable support for the versioning drafts:
     *   There wasn’t much comment on the module versioning, semver, or packages drafts
     *   There are some open issues listed (e.g.. for the packages draft), but I suspect that these can be resolved after adoption
     *   There was one question on the version comparison draft querying whether the rename allows a data node to be renamed into another module or path.  At the moment it doesn’t allow this, but I think that it probably should.  I will add an issue to track this.
     *   Separately, offline, I was questioned whether renamed-from also needs a revision-date/label of when the rename occurred.  I will include this in the previous issue.
     *   Finally there was a request to add more examples to that draft.  I’ll raise a separate issue for this.
  *   There are some objections to version selection draft, Martin thinks that it is too complex
  *   The WG chairs would still like to ask for WG adoption of the documents as a full set

After some discussion with the chairs, the conclusion was that we should update the version selection draft, with an aim of simplifying it, and then ask WG adoption on the set.  I would probably also make minimal updates to the solution overview draft at the same time.

Hence, I think that it would be useful if the DT meetings for the next month focus on the version selection draft.  Is that OK with everyone else?

Thanks,
Rob

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 26 Nov 2019 14:54:30 +0000

As we discussed in SIN, I’ll be unavailable the next few Thursdays (into 2020).  But I am happy to help with text on VS if needed.

Joe

On Nov 26, 2019, at 08:28, Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:

OK with me.

Regards,
Reshad.

From: Netmod-ver-dt <[email-masked]<mailto:[email-masked]>> on behalf of "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 25, 2019 at 1:07 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Netmod-ver-dt] DT Update after IETF 106

Hi,

Thanks,
Rob
_______________________________________________
Netmod-ver-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 26 Nov 2019 14:56:27 +0000

Sounds good. That seems like a good focus -> get the set of drafts adopted by the WG.

From: Netmod-ver-dt <[email-masked]> On Behalf Of Joe Clarke (jclarke)
Sent: Tuesday, November 26, 2019 9:55 AM
To: Reshad Rahman (rrahman) <[email-masked]>
Cc: Rob Wilton (rwilton) <[email-masked]>; [email-masked]
Subject: Re: [Netmod-ver-dt] DT Update after IETF 106

Joe

OK with me.

Regards,
Reshad.

Hi,

Thanks,
Rob