Subject: Re: [Netmod-ver-dt] [netmod] NETMOD 106 Schedule and Call for Presentations

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 4 Nov 2019 09:49:23 +0000

Hi Lou,

Please can we have a slot to update on the ongoing YANG versioning design team work.  I've requested 80 mins, if there is time available.

1) DT Update overview & status update (10 mins, Rob?):
YANG Module Versioning Requirements
draft-ietf-netmod-yang-versioning-reqs-01

YANG Versioning Solution Overview
draft-verdt-netmod-yang-solutions-02

2) Updated YANG Module Revision Handling (10 mins, tbd?):
draft-verdt-netmod-yang-module-versioning-01

3) YANG Semantic Versioning (10 mins, Joe?)
draft-verdt-netmod-yang-semver-01

4) YANG Packages (25 mins, Rob)
draft-rwilton-netmod-yang-packages-02

5) YANG Schema Version Selection (25 mins, tbd?)
draft-wilton-netmod-yang-ver-selection-01

Thanks,
Rob

-----Original Message-----
From: netmod <[email-masked]> On Behalf Of Lou Berger
Sent: 02 November 2019 14:21
To: [email-masked]
Cc: [email-masked]
Subject: Re: [netmod] NETMOD 106 Schedule and Call for Presentations

WG,
	Just a reminder that it is time to send in your agenda requests.
Please do so by the end of Monday Nov 4th (any TZ).

Thank you!
Lou (Kent and Joel)

As reminder -- requests should go to [email-masked] and include

 - name of the drafts
  - name of presentation (usually the title of the draft)
  - name of the presenter(s)
  - desired time request (in minutes)
  - local or remote

On 10/22/19 1:52 PM, Kent Watsen wrote:
> There is a copy/paste error in the 3rd paragraph:
> - s/netconf-chairs/netmod-chairs/
> 
> Please don't send NETMOD requests to the NETCONF chairs!  ;)
> 
> Kent // nervous chair
> 
> 
>> On Oct 22, 2019, at 11:07 AM, Kent Watsen <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>
>> The preliminary IETF 106 meeting agenda has been posted [1].
>>  - The final agenda will be posted this Friday at the same location.
>>  - NETMOD is currently scheduled to meet twice on Tuesday for a
>>    total of 3-1/2 hours.
>>
>> Authors, per [2], the draft submission cutoff is in about two weeks, 
>> on Monday Nov 4th.  Please update your drafts before then.
>>
>> If you are interested in presenting to the WG, please send your 
>> presentation requests to the "netconf-chairs" alias (CC-ed) with the 
>> following information, for each presentation request, if more than 
>> one:
>>
>>  - name of the drafts (if any)
>>  - name of presentation (usually the title of the draft)
>>  - name of the presenter(s)
>>  - desired time request (in minutes)
>>  - local or remote
>>
>> Presenters, please be advised that, due to issues with the Chromebook 
>> displaying PowerPoint, and issues with chairs converting 
>> presentations to PDF themselves, it is now strongly recommended that 
>> presenters only submit PDF versions of their slides.
>>
>> [1] https://datatracker.ietf.org/meeting/106/agenda.html
>> [2] https://datatracker.ietf.org/meeting/106/important-dates/
>>
>> PS: Please respond to *this* thread (removing the "netconf" alias)
>>    so that it's easier for the chairs to track all the requests.
>>
>> Thanks!
>> Kent (and Lou and Joel)
>>
>>
>>
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
> 

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Lou Berger <[email-masked]>
Date: Tue, 5 Nov 2019 10:10:54 -0500

You're the headliner -- so should have the time ;-)

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 5 Nov 2019 15:49:55 +0000

We might like to ask you (the chairs) to reconsider the discussion as to whether we can do a call for adoption on some of these drafts?

I know that the chairs have previously wanted to adopt the drafts as an entire set to cover the whole solution.  And we are obviously still missing the draft of schema comparison tooling.  Arguably this draft isn't required for the solution, only strongly desirable to have because it is only intending to address requirement 2.2 (which has always been a SHOULD rather than a MUST):

       2.2  A mechanism SHOULD be defined to determine whether data
            nodes between two arbitrary YANG module revisions have (i)
            not changed, (ii) changed in a backwards-compatible way,
            (iii) changed in a non-backwards-compatible way.

Note, there is no intention of dropping this last draft, and we already have some pyang tooling/scripts that perform this task, but I think that it could also realistically follow on a bit after the other drafts.

All the "MUST" requirements are intended to be addressed by the set of drafts below.

Personally, I think that these 4 drafts are all in good enough shape that they could be considered for an WG adoption call:

I think that this draft is also well on its way to be ready for WG adoption:
  draft-wilton-netmod-yang-ver-selection-01

  - IMO, the key bit that we still need to figure out for this draft is exactly how packages are sensibly put together (e.g. for optional feature sets and bugfixes) in a way that doesn't defeat one of the main benefits of packages for clients (i.e. being able to know the exact device schema offline without having to download/check the entirely of YANG library on connection).  But equally I see no reason why that couldn't be figured out after the document as been adopted as a WG item.

Finally, doing an adoption call on these drafts may act as a forcing function to get the WG to discuss/agree whether this solution is on the right path.

Of course, it is your decision.

Thanks,
Rob

> From: Lou Berger <[email-masked]>
> Sent: 05 November 2019 15:11
> To: Rob Wilton (rwilton) <[email-masked]>; NetMod WG Chairs <netmod-
> [email-masked]>
> Cc: [email-masked]

---

From: Lou Berger <[email-masked]>
Date: Tue, 5 Nov 2019 11:34:57 -0500

I'll discuss with my co-chairs. I think this is also fair to raise at 
the meeting...

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 5 Nov 2019 16:43:15 +0000

Ack.  Thanks.

> Sent: 05 November 2019 16:35
> I'll discuss with my co-chairs. I think this is also fair to raise at the
> meeting...
> 
> > We might like to ask you (the chairs) to reconsider the discussion as to
> whether we can do a call for adoption on some of these drafts?
> >
> > I know that the chairs have previously wanted to adopt the drafts as an
> entire set to cover the whole solution.  And we are obviously still
> missing the draft of schema comparison tooling.  Arguably this draft isn't
> required for the solution, only strongly desirable to have because it is
> only intending to address requirement 2.2 (which has always been a SHOULD
> rather than a MUST):
> >
> > Note, there is no intention of dropping this last draft, and we already
> have some pyang tooling/scripts that perform this task, but I think that
> it could also realistically follow on a bit after the other drafts.
> >
> >
> > Personally, I think that these 4 drafts are all in good enough shape
> that they could be considered for an WG adoption call:
> >    - IMO, the key bit that we still need to figure out for this draft is
> exactly how packages are sensibly put together (e.g. for optional feature
> sets and bugfixes) in a way that doesn't defeat one of the main benefits
> of packages for clients (i.e. being able to know the exact device schema
> offline without having to download/check the entirely of YANG library on
> connection).  But equally I see no reason why that couldn't be figured out
> after the document as been adopted as a WG item.
> >
> >
> > Finally, doing an adoption call on these drafts may act as a forcing
> function to get the WG to discuss/agree whether this solution is on the
> right path.
> >
> >> To: Rob Wilton (rwilton) <[email-masked]>; NetMod WG Chairs
> >> <netmod- [email-masked]>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 7 Nov 2019 10:35:32 +0000

Let's please meet today to agree/confirm who is going to present what at IETF 106.

Otherwise I think that we should try and continue the discussions on the version selection draft.

It would also be useful to know who is willing to meet in Singapore to progress the versioning work.  I'm hoping to hold the meetings in the pre meeting morning slot, so that Reshad may be able to dial in to the meetings.

Thanks,
Rob

-----Original Message-----
From: Netmod-ver-dt <[email-masked]> On Behalf Of Rob Wilton (rwilton)
Sent: 04 November 2019 09:49
To: Lou Berger <[email-masked]>; NetMod WG Chairs <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netmod-ver-dt] [netmod] NETMOD 106 Schedule and Call for Presentations

Hi Lou,

Thanks,
Rob

-----Original Message-----
From: netmod <[email-masked]> On Behalf Of Lou Berger
Sent: 02 November 2019 14:21
To: [email-masked]
Cc: [email-masked]
Subject: Re: [netmod] NETMOD 106 Schedule and Call for Presentations

WG,

Thank you!
Lou (Kent and Joel)

 - name of the drafts

_______________________________________________
Netmod-ver-dt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod-ver-dt

---

From: Lou Berger <[email-masked]>
Date: Mon, 11 Nov 2019 11:33:09 -0500

Hi,

We discussed this today.  Our preference would be for a thin/minimal 
draft covering the tooling and the output showing the intended direction 
for the work and for this to be included in the set adoption call.  It 
really doesn't have to be complete /much -- just enough to show intended 
direction.  Hopefully this is minimal enough effort for it to be 
submitted quite rapidly.

Does that work for you?

Thanks,

Lou (Joel and Kent)

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Mon, 11 Nov 2019 18:16:59 +0000

Okay ... I'll see if I can put together a rough draft before next week.  If I manage to do this, then I might request a last minute schedule change to add 15 mins to verbally outline the solution.

Thanks,
Rob

> From: Netmod-ver-dt <[email-masked]> On Behalf Of Lou
> Berger
> Sent: 11 November 2019 16:33
> We discussed this today.  Our preference would be for a thin/minimal draft
> covering the tooling and the output showing the intended direction for the
> work and for this to be included in the set adoption call.  It really
> doesn't have to be complete /much -- just enough to show intended
> direction.  Hopefully this is minimal enough effort for it to be submitted
> quite rapidly.
> 
> Does that work for you?
> 
> Thanks,
> 
> Lou (Joel and Kent)
> 
> >> missing the draft of schema comparison tooling.  Arguably this draft
> >> isn't required for the solution, only strongly desirable to have
> >> because it is only intending to address requirement 2.2 (which has
> >> always been a SHOULD rather than a MUST):
> >> have some pyang tooling/scripts that perform this task, but I think
> >> that it could also realistically follow on a bit after the other
> drafts.
> >>>
> >>> All the "MUST" requirements are intended to be addressed by the set
> >>> of
> >> drafts below.
> >>>
> >> exactly how packages are sensibly put together (e.g. for optional
> >> feature sets and bugfixes) in a way that doesn't defeat one of the
> >> main benefits of packages for clients (i.e. being able to know the
> >> exact device schema offline without having to download/check the
> >> entirely of YANG library on connection).  But equally I see no reason
> >> why that couldn't be figured out after the document as been adopted as
> a WG item.
> >>>
> >> function to get the WG to discuss/agree whether this solution is on
> >> the right path.

---

From: Lou Berger <[email-masked]>
Date: Mon, 11 Nov 2019 13:33:13 -0500

we have plenty of time, so this won't be a problem!

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Sat, 16 Nov 2019 09:19:57 +0000

Hi Lou,

I will post a draft on YANG schema comparison this evening/tomorrow morning.

If time is available, please may I adjust our agenda to:

DT Update overview & status update – Rob Wilton (10 mins)
draft-ietf-netmod-yang-versioning-reqs-01
draft-verdt-netmod-yang-solutions-02

Updated YANG Module Revision Handling –Bo Wu (10 mins)
draft-verdt-netmod-yang-module-versioning-01

YANG Semantic Versioning – Joe Clarke (10 mins)
draft-verdt-netmod-yang-semver-01

YANG Packages – Rob Wilton (25 mins)
draft-rwilton-netmod-yang-packages-02

YANG Schema Version Selection – Joe Clarke (Reshad Rahman) (25 mins)
draft-wilton-netmod-yang-ver-selection-01

YANG Schema Comparison – Rob Wilton (15 mins)
draft-verdt-netmod-yang-schema-comparison-00

Next steps? – Rob Wilton

Thanks,
Rob

-----Original Message-----
From: Netmod-ver-dt <[email-masked]> On Behalf Of Lou Berger
Sent: 12 November 2019 02:33
To: Rob Wilton (rwilton) <[email-masked]>; NetMod WG Chairs <[email-masked]>
Cc: [email-masked]
Subject: Re: [Netmod-ver-dt] [netmod] NETMOD 106 Schedule and Call for Presentations

On 11/11/2019 1:16 PM, Rob Wilton (rwilton) wrote:
>> draft covering the tooling and the output showing the intended 
>> direction for the work and for this to be included in the set 
>> adoption call.  It really doesn't have to be complete /much -- just 
>> enough to show intended direction.  Hopefully this is minimal enough 
>> effort for it to be submitted quite rapidly.
>>
>> Does that work for you?
>>
>> Thanks,
>>
>> Lou (Joel and Kent)
>>
>>>> I'll discuss with my co-chairs. I think this is also fair to raise 
>>>> at the meeting...
>>>>
>>>> missing the draft of schema comparison tooling.  Arguably this 
>>>> draft isn't required for the solution, only strongly desirable to 
>>>> have because it is only intending to address requirement 2.2 (which 
>>>> has always been a SHOULD rather than a MUST):
>>>>>                nodes between two arbitrary YANG module revisions 
>>>>> have
>> (i)
>>>>> All the "MUST" requirements are intended to be addressed by the 
>>>>> set of
>>>> drafts below.
>>>> entirely of YANG library on connection).  But equally I see no 
>>>> reason why that couldn't be figured out after the document as been 
>>>> adopted as
>> a WG item.

---

From: Lou Berger <[email-masked]>
Date: Sat, 16 Nov 2019 20:04:49 -0500

Thanks Rob, updated agenda will be posted shortly